Se han descubierto problemas graves se seguridad en los tres productos principales de Mozilla: FireFox, ThunderBird y el propio Mozilla Navigator. Se trata de múltiples vulnerabilidades que podrían ser aprovechadas por atacantes maliciosos para acceder y modificar información almacenada en el sistema de los usuarios de estos FireFox, ThunderBird y Mozilla Navigator. Los detalles se pueden encontrar como siempre en Secunia, que valora la incidencia como "altamente crítica". La buena noticia de que estos problemas de seguridad no afectan a las últimas versiones de estos productos por lo que es altamente recomendable actualizar. Las versiones no afectadas son: Mozilla 1.7.3, ThunderBird 0.8 y FireFox 1.0 PR, cuyas descargas tienes a continuación.

FireFox 1.0 PR Windows
FireFox 1.0 PR Linux
FireFox 1.0 PR Macintosh

ThunderBird 0.8 Windows
ThunderBird 0.8 Linux
ThunderBird 0.8 Macintosh

Mozilla 1.7.3 Windows
Mozilla 1.7.3 Linux
Mozilla 1.7.3 Macintosh

Estas son las versiones en inglés, acaban de salir y el proyecto Nave aún no las ha traducido.

Fuente: www.error500.net