Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Instalar Drivers Ati Mobile Radeon 4250 en OpenSuSE 12.1 [SOLUCIONADO]
  #1  
Antiguo 16-may-2012, 08:57
Galaners Galaners está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2008
Ubicación: México
Versión: 11.2 con KDE4
Mensajes: 90
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 10
Galaners está en el buen camino
Arrow Instalar Drivers Ati Mobile Radeon 4250 en OpenSuSE 12.1 [SOLUCIONADO]

Recien ahora descargué la versión 12.1 de OpenSuSE 12.1 y pues al parecer marchaba bien, solo que los drivers de video que trae por defecto hacían que el rendimiento del sistema se viera pobre en comparación a como debería ser. Los efectos de escritorio funcionaban bien pero muy lento, y juegos como Warcraft III los corría bastante lento para mi sistema que puede correr StarCraft II sin problemas.

Tengo una laptop de gama baja, una Dell Inspiron m5030.

Microprocesador AMD Athlon II Dual-Core Mobile P320 de 2.1Ghz
Placa de video ATI Mobility Radeon HD4250
Memoria RAM DDR3 de 3Gb
Disco rígido de 320Gb
WiFi Atheros 802.11n

Al buscar los drivers por internet me encontré con varios que ya he probado y ninguno funciona, ocurre que al instalarlos el sistema me corre muchísimo peor que con los controladores que trae por defecto, ya ni siquiera se activan los efectos de escritorio y todo me corre muy lento. El procedimiento que hacía era instalarlos directamente, los bajaba, ya sea de la página oficial de ati para 64 bits y los corría con el comando sh desde el nivel 3 de ejecución, todo se instalaba normal y al terminar utilizaba el comando amdconfig --initial como me recomendaron (también probé sin aplicar ese comando) y el resultado era el mismo en cada uno que bajaba. Leyendo me encontré con que algunos tuvieron el mismo problema, pero no había solución.

Probe luego esta solución:
http://es.opensuse.org/ATI/Resoluci%C3%B3n_de_problemas

E instalé los drivers de nuevo, pero todo fue igual a excepción de que al desinstalarlos y tratar de volver a los drivers originales ya no me permitía entrar al entorno gráfico, por lo que asumo que los desinstaló en alguna parte del proceso.

La forma que hago para desinstalar los drivers que he instalado es entrar al directorio /usr/share/ati
ls
sh uninstall-fglrx...

Para volver a ingresar al entorno gráfico volví a instalar los drivers que había bajado, y al ingresar al directorio mencionado arriba me encuentro un archivo llamado fglrx-install.log.
Dentro esta ésto:
Código:
Uninstalling any previously installed drivers.
Unloading radeon module...
ERROR: Module radeon is in use
Unloading drm module...
ERROR: Module drm is in use by radeon,ttm,drm_kms_helper
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.1.10-1.9-desktop/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: se ingresa al directorio `/usr/src/linux-3.1.10-1.9-obj/x86_64/desktop'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: se sale del directorio `/usr/src/linux-3.1.10-1.9-obj/x86_64/desktop'
build succeeded with return value 0
duplicating results into driver repository...
done.
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
- recreating module dependency list
- trying a sample load of the kernel modules
failed.
[Error] Kernel Module : Reboot required. 
[Reboot] Kernel Module : mkinitrd
Se mencionan algunos errores pero la verdad no entiendo muy buen cual es el problema. Les agradezco cualquier tipo de ayuda.

Última edición por Galaners; 18-may-2012 a las 09:44
Responder Citando
  #2  
Antiguo 16-may-2012, 12:51
Avatar de ariellovera
ariellovera ariellovera está desconectado
Miembro Junior
 
Fecha de Ingreso: 13-julio-2005
Ubicación: Oberá, Misiones, Argentina
Versión: 42.2 64 Bits
Mensajes: 665
Agradecimientos: 20
Agradecido 11 Veces en 10 Mensajes
Poder de Credibilidad: 13
ariellovera está en el buen camino
Enviar un mensaje por ICQ a ariellovera Enviar un mensaje por MSN a ariellovera Enviar un mensaje por Skype™ a ariellovera
tenes instalado los siguientes paquetes: kernel-source, gcc, gcc++, make
yo tengo la mima placa de video en mi notebook, y casi el el mismo cpu (phenom II ) asi que deberia funcionar en la tuya. para instalar lo que hago es bajar el ultimo driver (http://www2.ati.com/drivers/linux/am...x86.x86_64.run) y una vez en la carpeta de descarga ejecutar el siguiente comando como root

sh *.run --buildpkg SuSE/SUSE12.1-AMD64

y se crea un fichero rpm, y despues lo instalo con

zypper in fichero
__________________
“Siempre es levemente siniestro volver a los lugares que han sido testigos de un instante de perfección”
Responder Citando
  #3  
Antiguo 16-may-2012, 17:22
Galaners Galaners está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2008
Ubicación: México
Versión: 11.2 con KDE4
Mensajes: 90
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 10
Galaners está en el buen camino
Cita:
Iniciado por ariellovera Ver Mensaje
tenes instalado los siguientes paquetes: kernel-source, gcc, gcc++, make
yo tengo la mima placa de video en mi notebook, y casi el el mismo cpu (phenom II ) asi que deberia funcionar en la tuya. para instalar lo que hago es bajar el ultimo driver (http://www2.ati.com/drivers/linux/am...x86.x86_64.run) y una vez en la carpeta de descarga ejecutar el siguiente comando como root

sh *.run --buildpkg SuSE/SUSE12.1-AMD64

y se crea un fichero rpm, y despues lo instalo con

zypper in fichero
Ok, gracias por la respuesta más al rato lo voy a probar ya que ando en el trabajo y les platico que fue.
Responder Citando
  #4  
Antiguo 16-may-2012, 17:48
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Pues yo pensaba que le había puesto un título descriptivo al artículo que hice en la Wiki de openSUSE para ésto (SDB:Cómo instalar el controlador gráfico de ATI), pero se ve que no... ¡Y lo mejor es que si falla puedes comentar y dar datos de dónde lo hace y se corrige!

Un saludo.
Responder Citando
  #5  
Antiguo 17-may-2012, 00:03
Galaners Galaners está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2008
Ubicación: México
Versión: 11.2 con KDE4
Mensajes: 90
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 10
Galaners está en el buen camino
Cita:
Iniciado por jcsl Ver Mensaje
Hola.

Pues yo pensaba que le había puesto un título descriptivo al artículo que hice en la Wiki de openSUSE para ésto (SDB:Cómo instalar el controlador gráfico de ATI), pero se ve que no... ¡Y lo mejor es que si falla puedes comentar y dar datos de dónde lo hace y se corrige!

Un saludo.
Ya probé el único método que se puede de los que mencionas (agregar los repositorios de ati mediante zypper e instalarlos mediante yast2), ya que los enlaces que proporcionas están caducados, pero igual sigue pasando lo mismo.

Cita:
tenes instalado los siguientes paquetes: kernel-source, gcc, gcc++, make
yo tengo la mima placa de video en mi notebook, y casi el el mismo cpu (phenom II ) asi que deberia funcionar en la tuya. para instalar lo que hago es bajar el ultimo driver (http://www2.ati.com/drivers/linux/am...x86.x86_64.run) y una vez en la carpeta de descarga ejecutar el siguiente comando como root

sh *.run --buildpkg SuSE/SUSE12.1-AMD64

y se crea un fichero rpm, y despues lo instalo con

zypper in fichero
Formatee el sistema para hacer tu método en limpio todo, y lo realice al parecer todo bien, aquí está el resumen de la instalación:

Código:
 
Galaners@linux-qums:~/Descargas> cd /home/Galaners/Descargas
Galaners@linux-qums:~/Descargas> clear










Galaners@linux-qums:~/Descargas> su
Contraseña: 
linux-qums:/home/Galaners/Descargas # zypper install fglrx64_xpic_SUSE121-8.961-1.x86_64.rpm 
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Resolviendo dependencias...

Los siguientes paquetes NUEVOS van a ser instalados:
  fglrx64_xpic_SUSE121 gcc gcc46 glibc-devel kernel-default-devel kernel-desktop-devel kernel-devel kernel-source kernel-syms kernel-xen-devel linux-glibc-devel patch 

12 nuevos paquetes a instalar.
Tamaño total a descargar: 138,6 MiB. Después de la operación se utilizarán 679,3 MiB adicionales.
¿Desea continuar? [s/n/?] (s): s
Descargando paquete  kernel-devel-3.1.10-1.9.1.noarch (1/12), 7,7 MiB (37,2 MiB desempaquetado)
Obteniendo: kernel-devel-3.1.10-1.9.1.noarch.rpm [hecho (160,6 KiB/s)]
Descargando paquete  kernel-xen-devel-3.1.10-1.9.1.x86_64 (2/12), 2,0 MiB (2,7 MiB desempaquetado)
Obteniendo: kernel-xen-devel-3.1.10-1.9.1.x86_64.rpm [hecho (199,1 KiB/s)]
Descargando paquete  kernel-desktop-devel-3.1.10-1.9.1.x86_64 (3/12), 2,0 MiB (2,7 MiB desempaquetado)
Obteniendo: kernel-desktop-devel-3.1.10-1.9.1.x86_64.rpm [hecho (195,8 KiB/s)]
Descargando paquete  kernel-default-devel-3.1.10-1.9.1.x86_64 (4/12), 2,0 MiB (2,7 MiB desempaquetado)
Obteniendo: kernel-default-devel-3.1.10-1.9.1.x86_64.rpm [hecho (198,8 KiB/s)]
Descargando paquete  kernel-source-3.1.10-1.9.1.noarch (5/12), 61,7 MiB (371,8 MiB desempaquetado)
Obteniendo: kernel-source-3.1.10-1.9.1.noarch.rpm [hecho (194,8 KiB/s)]
Descargando paquete  kernel-syms-3.1.10-1.9.1.x86_64 (6/12), 328,0 KiB (1,0 KiB desempaquetado)
Obteniendo: kernel-syms-3.1.10-1.9.1.x86_64.rpm [hecho (184,3 KiB/s)]
Descargando paquete  linux-glibc-devel-3.1_rc5-7.1.1.noarch (7/12), 778,0 KiB (3,1 MiB desempaquetado)
Obteniendo: linux-glibc-devel-3.1_rc5-7.1.1.noarch.rpm [hecho (176,1 KiB/s)]
Descargando paquete  patch-2.6.1.116-4.1.5.x86_64 (8/12), 81,0 KiB (155,0 KiB desempaquetado)
Obteniendo: patch-2.6.1.116-4.1.5.x86_64.rpm [hecho]
Descargando paquete  glibc-devel-2.14.1-14.27.1.x86_64 (9/12), 612,0 KiB (2,9 MiB desempaquetado)
Obteniendo: glibc-devel-2.14.1-14.27.1.x86_64.rpm [hecho (154,4 KiB/s)]
Descargando paquete  gcc46-4.6.2_20111026-1.1.4.x86_64 (10/12), 5,5 MiB (18,5 MiB desempaquetado)
Obteniendo: gcc46-4.6.2_20111026-1.1.4.x86_64.rpm [hecho (186,8 KiB/s)]
Descargando paquete  gcc-4.6-15.1.3.x86_64 (11/12), 4,0 KiB (0 B desempaquetado)
Obteniendo: gcc-4.6-15.1.3.x86_64.rpm [hecho (6,2 KiB/s)]
Descargando paquete  fglrx64_xpic_SUSE121-8.961-1.x86_64 (12/12), 55,9 MiB (237,5 MiB desempaquetado)
Instalando kernel-devel-3.1.10-1.9.1 [hecho]
Instalando kernel-xen-devel-3.1.10-1.9.1 [hecho]
Instalando kernel-desktop-devel-3.1.10-1.9.1 [hecho]
Instalando kernel-default-devel-3.1.10-1.9.1 [hecho]
Instalando kernel-source-3.1.10-1.9.1 [hecho]
Instalando kernel-syms-3.1.10-1.9.1 [hecho]
Instalando linux-glibc-devel-3.1_rc5-7.1.1 [hecho]
Instalando patch-2.6.1.116-4.1.5 [hecho]
Instalando glibc-devel-2.14.1-14.27.1 [hecho]
Instalando gcc46-4.6.2_20111026-1.1.4 [hecho]
Instalando gcc-4.6-15.1.3 [hecho]
Descargando paquete  fglrx64_xpic_SUSE121-8.961-1.x86_64 (1/12), 55,9 MiB (237,5 MiB desempaquetado)
Instalando fglrx64_xpic_SUSE121-8.961-1 [hecho]
Salida adicional del rpm:
Updating /etc/sysconfig/fglrxconfig...
/usr/src/kernel-modules/fglrx /
Apply some patches ...
ati-CONFIG_SMP.patch applied successfully.
ati-2.6.27-build-fix-1.patch applied successfully.
ati-2.6.36-compat_alloc_user_space.patch applied successfully.
amd-3.2.9-no-constant-TS_USEDFPU.patch applied successfully.
amd-3.3.0-new_thread_structure.patch applied successfully.
/

Used CPUs/Cores for compilation  =>  [ 2 ]


********************************************************************************
*                                                                              *
*   Kernel:    3.1.10-1.9-desktop                                              *
*   Source:    /lib/modules/3.1.10-1.9-desktop/build                           *
*   Include:   /lib/modules/3.1.10-1.9-desktop/source/include                  *
*                                                                              *
********************************************************************************



file /lib/modules/3.1.10-1.9-desktop/source/include/../arch/x86/include/asm/compat.h says:COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space
/usr/src/kernel-modules/fglrx/2.6.x /
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make: Entering directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/desktop'
  LD      /usr/src/kernel-modules/fglrx/2.6.x/built-in.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.o
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetInitKerPte':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2357:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2358:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2359:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetPageTableByVirtAddr':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2404:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2407:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2408:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_TestAndClearPageDirtyFlag':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2582:5: warning: return makes integer from pointer without a cast [enabled by default]
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_agp.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_debug.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_ioctl.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_io.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_pci.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_str.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_iommu.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl.o
  CC [M]  /usr/src/kernel-modules/fglrx/2.6.x/kcl_wait.o
  LD [M]  /usr/src/kernel-modules/fglrx/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /usr/src/kernel-modules/fglrx/2.6.x/fglrx.mod.o
  LD [M]  /usr/src/kernel-modules/fglrx/2.6.x/fglrx.ko
make: Leaving directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/desktop'
make: Entering directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/desktop'
  INSTALL /usr/src/kernel-modules/fglrx/2.6.x/fglrx.ko
  DEPMOD  3.1.10-1.9-desktop
make: Leaving directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/desktop'
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
/
Calling 'depmod -a 3.1.10-1.9-desktop' this may take a while...


Summary report:
================================================================================

   Kernel     => 3.1.10-1.9-desktop
   Detected   => RPM package
   Build      => [ OK ]
   Install    => [ OK ]

*************************************************************
Please read "/usr/share/doc/packages/fglrx/README.SuSE" for
configuration details when using SaX2.
*************************************************************

Disable KMS to prevent driver issue:

Kernel image:   /boot/vmlinuz-3.1.10-1.9-desktop
Initrd image:   /boot/initrd-3.1.10-1.9-desktop
Root device:    /dev/disk/by-id/ata-WDC_WD3200BEVT-75A23T0_WD-WXC1A90C3134-part6 (/dev/sda6) (mounted on / as ext4)
Resume device:  /dev/disk/by-id/ata-WDC_WD3200BEVT-75A23T0_WD-WXC1A90C3134-part5 (/dev/sda5)
Kernel Modules: thermal_sys thermal processor fan pata_atiixp ata_generic 
Features:       acpi block usb resume.userspace resume.kernel
Bootsplash:     openSUSE (1024x768)
Check: No fglrx section.
Uninitialised file found, configuring.
Switch to AMD
Switch to AMD


linux-qums:/home/Galaners/Descargas #
Lo extraño de todo es que tengo catalyst instalado y puedo acceder a él y a su configuración. El problema sigue siendo el mismo. El sistema está peor de como empezó después de la instalación de éste. Es como si los drivers si estuviesen instalados pero el rendimiento 3d fuese pobre, apenas puedo bajar el scroll de las páginas en firefox ya que se mueve realmente lento, las pantallas no puedo arrastrarlas fluidamente y ni siquiera tengo activados los efectos de escritorio.

Aquí están los datos de Xorg.conf:

Código:
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Y los de Xorg.conf.fglrx-o

Código:
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Los de Xorg.conf.install

Código:
Section "Device"
  Identifier "vboxvideo"
  Driver  "vboxvideo"
EndSection

Section "Screen"
  Identifier "vboxvideo"
  Device "vboxvideo"
EndSection


Section "Device"
  Identifier "vmware"
  Driver  "vmware"
EndSection

Section "Screen"
  Identifier "vmware"
  Device "vmware"
EndSection


Section "Device"
  Identifier "cirrus"
  Driver  "cirrus"
EndSection
Section "Screen"
  Identifier "cirrus"
  Device "cirrus"
EndSection


Section "Device"
  Identifier "fbdev"
  Driver  "fbdev"
EndSection
Section "Screen"
  Identifier "fbdev"
  Device "fbdev"
EndSection


Section "Device"
  Identifier "vesa"
  Driver  "vesa"
EndSection

Section "Screen"
  Identifier "vesa"
  Device "vesa"
EndSection


Section "ServerLayout"
  Identifier "Layout"
  Screen  "vboxvideo"
  Screen  "vmware"
  Screen  "cirrus"
  Screen  "fbdev"
  Screen  "vesa"
EndSection


Información de la pantalla
Fabricante: ATI Technologies Inc
Modelo: ATI Mobility Radeon HD Graphics
Controlador 2D: fglrx

Y la información del hardware:




De nuevo les agradecería su ayuda.
Responder Citando
  #6  
Antiguo 17-may-2012, 01:58
Avatar de ariellovera
ariellovera ariellovera está desconectado
Miembro Junior
 
Fecha de Ingreso: 13-julio-2005
Ubicación: Oberá, Misiones, Argentina
Versión: 42.2 64 Bits
Mensajes: 665
Agradecimientos: 20
Agradecido 11 Veces en 10 Mensajes
Poder de Credibilidad: 13
ariellovera está en el buen camino
Enviar un mensaje por ICQ a ariellovera Enviar un mensaje por MSN a ariellovera Enviar un mensaje por Skype™ a ariellovera
lo que podes intentar hacer es ejecutar el siguiente comando como root
#aticonfig --initial

y despues reiniciar la pc
para saber si tenes aceleracion tenes que ejecutar el siguiente comando

#glxinfo | grep direct

y te tiene que tirar algo asi

direct rendering: Yes
GL_AMD_multi_draw_indirect, GL_AMD_name_gen_delete,
GL_ARB_draw_indirect, GL_ARB_draw_instanced,
GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access,
__________________
“Siempre es levemente siniestro volver a los lugares que han sido testigos de un instante de perfección”
Responder Citando
  #7  
Antiguo 17-may-2012, 03:43
Galaners Galaners está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2008
Ubicación: México
Versión: 11.2 con KDE4
Mensajes: 90
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 10
Galaners está en el buen camino
Cita:
Iniciado por ariellovera Ver Mensaje
lo que podes intentar hacer es ejecutar el siguiente comando como root
#aticonfig --initial

y despues reiniciar la pc
para saber si tenes aceleracion tenes que ejecutar el siguiente comando

#glxinfo | grep direct

y te tiene que tirar algo asi

direct rendering: Yes
GL_AMD_multi_draw_indirect, GL_AMD_name_gen_delete,
GL_ARB_draw_indirect, GL_ARB_draw_instanced,
GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access,
Ya lo intenté y nada, el comando me arroja esto:

Código:
linux-qums:/home/Galaners # glxinfo | grep direct
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13
linux-qums:/home/Galaners #
Responder Citando
  #8  
Antiguo 17-may-2012, 09:02
Galaners Galaners está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2008
Ubicación: México
Versión: 11.2 con KDE4
Mensajes: 90
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 10
Galaners está en el buen camino
Bueno, después de probar con bastantes soluciones encontré una que me sirvió un poco.
http://en.opensuse.org/SDB:Radeon
Lo que hice fue modificar el archivo xorg.conf y agregarle:

Código:
Section "DRI"
   Group      "video"
   Mode       0660
EndSection
Sección que no poseía y a la sección:

Código:
Section "Device"
  BoardName    "R420 JI"
  Driver       "radeon"
  Identifier   "Device[0]"
  VendorName   "ATI"
EndSection
Le modifiqué los parámetros por los de arriba. Al reiniciar el sistema me arrancó muy rápidamente y muchísimo más fluido, el problema es que aún no he podido iniciar los efectos y el comando glxinfo | grep me sigue arrojando lo mismo.

También "reinicie" la base de datos de los paquetes y utilicé el comando:

Código:
zypper dup
zypper up
El comando zypper up no me deja actualizar los paquetes, me sale una lista enorme de paquetes que no pueden ser actualizados sin razón aparente.

Otra cosa es que en el resumen del sistema "sysinfo" en vez de salir:

Código:
Información de la pantalla
Fabricante: ATI Technologies Inc
Modelo: ATI Mobility Radeon HD Graphics
Controlador 2D: fglrx
Cambia el controlador 2D por:

Código:
Controlador 2D: radeon

Ahora mismo no me encuentro en mi computadora por lo que no puedo dar más información, igual si tienen alguna pista sobre la solución al problema la comparten, por favor.
Responder Citando
  #9  
Antiguo 17-may-2012, 11:33
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Cita:
Iniciado por Galaners Ver Mensaje
Ya probé el único método que se puede de los que mencionas (agregar los repositorios de ati mediante zypper e instalarlos mediante yast2), ya que los enlaces que proporcionas están caducados, pero igual sigue pasando lo mismo.
Ya está arreglado el 1-click install. Si vuelve a fallar lo comentas y mientras tanto miras en la versión inglesa que puede estar más actualizada (el enlace está en la parte izquierda de la página, en el cuadro con título Otros idiomas). Además del método con zypper y YaST también se explica cómo instalar el controlador manualmente, ¿no lo has visto?

Formatee el sistema para hacer tu método en limpio todo, y lo realice al parecer todo bien, aquí está el resumen de la instalación:

Cita:
Iniciado por Galaners Ver Mensaje
Código:
linux-qums:/home/Galaners/Descargas # zypper install fglrx64_xpic_SUSE121-8.961-1.x86_64.rpm 
...
Uninitialised file found, configuring.
Switch to AMD
La compilación e instalación se hace bien. No hace falta que ejecutes después aticonfig --initial porque se hace durante la instalación.

Cita:
Iniciado por Galaners Ver Mensaje
Y los de Xorg.conf.fglrx-o
Ese debe ser una copia de seguridad de alguno anterior, no sirve para nada.

Cita:
Iniciado por Galaners Ver Mensaje
Los de Xorg.conf.install
Y ese es una copia del que se usa durante la instalación, que tampoco sirve para nada. Los únicos archivos que sirven son xorg.conf (si existe) y los que están en /etc/X11/xorg.conf.d.

Cita:
Iniciado por Galaners Ver Mensaje
Información de la pantalla
Fabricante: ATI Technologies Inc
Modelo: ATI Mobility Radeon HD Graphics
Controlador 2D: fglrx
Quizás sea que el controlador de ATI funciona fatal con tu tarjeta gráfica. ¿Te funcionaba bien antes?

Cita:
Iniciado por Galaners Ver Mensaje
Bueno, después de probar con bastantes soluciones encontré una que me sirvió un poco.
http://en.opensuse.org/SDB:Radeon
Lo que hice fue modificar el archivo xorg.conf y agregarle:

Código:
Información de la pantalla
Fabricante: ATI Technologies Inc
Modelo: ATI Mobility Radeon HD Graphics
Controlador 2D: fglrx
Cambia el controlador 2D por:

Código:
Controlador 2D: radeon
No me queda claro cuál es el contenido actual del fichero xorg.conf, pero parece que estas usando el controlador radeon que es que se debería usar por defecto si no instalas el de ATI. Si ya tienes instalado el controlador de ATI fglrx, renombra xorg.conf y ejecuta aticonfig --initial para crear uno nuevo. Para ver qué controlador estás usando ejecuta:
lsmod | egrep "radeon|fglrx"
En principio no tendrías que tocar para nada los archivos de configuración porque no es necesario. Cuando probé el controlador de ATI la configuración se hizo al instalar el rpm, y cuando uso el controlador por defecto no tengo que modificar nada y no uso xorg.conf.

Un saludo.

Última edición por jcsl; 17-may-2012 a las 12:03
Responder Citando
  #10  
Antiguo 17-may-2012, 21:48
Galaners Galaners está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2008
Ubicación: México
Versión: 11.2 con KDE4
Mensajes: 90
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 10
Galaners está en el buen camino
Cita:
Iniciado por jcsl Ver Mensaje
Hola.



Ya está arreglado el 1-click install. Si vuelve a fallar lo comentas y mientras tanto miras en la versión inglesa que puede estar más actualizada (el enlace está en la parte izquierda de la página, en el cuadro con título Otros idiomas). Además del método con zypper y YaST también se explica cómo instalar el controlador manualmente, ¿no lo has visto?

Formatee el sistema para hacer tu método en limpio todo, y lo realice al parecer todo bien, aquí está el resumen de la instalación:



La compilación e instalación se hace bien. No hace falta que ejecutes después aticonfig --initial porque se hace durante la instalación.



Ese debe ser una copia de seguridad de alguno anterior, no sirve para nada.



Y ese es una copia del que se usa durante la instalación, que tampoco sirve para nada. Los únicos archivos que sirven son xorg.conf (si existe) y los que están en /etc/X11/xorg.conf.d.



Quizás sea que el controlador de ATI funciona fatal con tu tarjeta gráfica. ¿Te funcionaba bien antes?



No me queda claro cuál es el contenido actual del fichero xorg.conf, pero parece que estas usando el controlador radeon que es que se debería usar por defecto si no instalas el de ATI. Si ya tienes instalado el controlador de ATI fglrx, renombra xorg.conf y ejecuta aticonfig --initial para crear uno nuevo. Para ver qué controlador estás usando ejecuta:
lsmod | egrep "radeon|fglrx"
En principio no tendrías que tocar para nada los archivos de configuración porque no es necesario. Cuando probé el controlador de ATI la configuración se hizo al instalar el rpm, y cuando uso el controlador por defecto no tengo que modificar nada y no uso xorg.conf.

Un saludo.
Gracias por la respuesta, mira, ya renombré el archivo xorg.conf y eliminé los drivers que había instalado hasta ahora e instalé los que recomendaste, pero sigue igual, se ve todo muy lento y no tengo activada la aceleración 3D.
El archivo xorg.conf creado a partir de la instalación contiene esto:

Código:
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Comparado con el viejo que le cambié el nombre y que fue el que modifiqué (llamado xorg.conf(modificado)):

Código:
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	BoardName    "R420 JI"
        Driver       "radeon"
        Identifier   "Device[0]"
        VendorName   "ATI"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
   Group      "video"
   Mode       0660
EndSection
El controlador no lo he usado anteriormente, solo he manejado Windows, así que no sabría decirte si funciona o no con el de mi laptop. Aunque la versión 12.4 de Catalyst ya la he usado en Windows y funciona muy bien.

Al ejecutar lsmod | egrep "radeon|fglrx" en la consola no me aparece nada ni como usuario ni como root.

De nuevo gracias por la respuesta y si tienen alguna otra idea es bienvenida, mientras tanto, como dices, voy a revisar la versión inglesa haber que tal.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
instalar opensuse 12.1 con raid1 por hardware mmalexp Instalación y Actualizaciones 11 04-abr-2012 22:00
Opensuse 11.4 en portatil con tarjetas Intel i3 y Ati Mobile HD 5470 Mariner_I Portátiles y otros Dispositivos 4 09-jun-2011 16:37
Instalación de openSuse 11.4 manteniendo 11.3 jncruces Instalación y Actualizaciones 0 29-abr-2011 19:48
Después de instalar suse 11.2 no funciona red local amungar Internet, Redes y Wireless 15 21-nov-2009 08:52
Guía de Instalación de OpenSuSE 10.3 DiabloRojo Instalación y Actualizaciones 5 11-feb-2008 10:41



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 08:17.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba