Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Escritorios: KDE, Gnome, otros...


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas para iniciar sesión gráfica
  #1  
Antiguo 15-abr-2012, 02:56
Avatar de RGB
RGB RGB está desconectado
Miembro Senior
 
Fecha de Ingreso: 25-enero-2005
Ubicación: Lombardía, cerca de una copa de vino tinto de la Toscana
Versión: 42.2 x86_64
Mensajes: 1.116
Agradecimientos: 7
Agradecido 191 Veces en 100 Mensajes
Poder de Credibilidad: 14
RGB está en el buen camino
Problemas para iniciar sesión gráfica

Hoy he tenido un problema con openSUSE 11.4, 64 bits: en un momento se ha caído el servidor gráfico y ya no puedo entrar nuevamente.

Entrando como root, si hago startx me dice

Call to lnusertemp failed (temporary directory full?) check your installation

Les cuento que problemas de espacio no tengo ya que tengo configurado cron para borrar /tmp y /var/tmp en forma periódica.

En las varias pruebas que he hecho, he visto los siguientes mensajes

cannot move /var/log/Xorg.0.lot to /var/log/Xorg.0.log.old

Lo he movido manualmente y nada.

También he visto

xinit failed /usr/bin/Xorg is not setuid, maibe that's the reason? If so use the display manager or adjust /etc/permissions.local

El «Display manager» no puedo usarlo y el mentado archivo permissions está todo comentado. Supongo que tendría que descomentar la última línea del mismo...

# setuid bit on Xorg is only needed if no display manager, ie startx
# is used. Beware of CVE-2010-2240.
#
#/usr/bin/Xorg root:root 4711

¿Alguna idea?

Desde ya, muchas gracias
__________________
Existen dos clases de personas: las que dicen que hay dos clases de personas y las que no.



Mi blog sobre fotografía digital, arte, software libre,
matemática, física y otros delirios
Responder Citando
  #2  
Antiguo 15-abr-2012, 03:26
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
Cita:
... Supongo que tendría que descomentar la última línea del mismo...
Ummm ... no debiera ser eso. El /etc/permisisions.local de mi 11.4x64 está exactamente igual que el que muestras (comentado)

Por lo del bit suid, estos son los permisos en mi caso

oS114:~> la /usr/bin/Xorg
-rwxr-xr-x 1 root root 1970760 Feb 7 17:34 /usr/bin/Xorg

oS114:~> la /var/log/Xorg.0.log*
-rw-r--r-- 1 root root 45014 Abr 15 02:08 /var/log/Xorg.0.log
-rw-r--r-- 1 root root 45150 Abr 15 01:46 /var/log/Xorg.0.log.old
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
Responder Citando
  #3  
Antiguo 15-abr-2012, 03:33
Avatar de RGB
RGB RGB está desconectado
Miembro Senior
 
Fecha de Ingreso: 25-enero-2005
Ubicación: Lombardía, cerca de una copa de vino tinto de la Toscana
Versión: 42.2 x86_64
Mensajes: 1.116
Agradecimientos: 7
Agradecido 191 Veces en 100 Mensajes
Poder de Credibilidad: 14
RGB está en el buen camino
Cita:
Iniciado por XisEme Ver Mensaje
Ummm ... no debiera ser eso. El /etc/permisisions.local de mi 11.4x64 está exactamente igual que el que muestras (comentado)

Por lo del bit suid, estos son los permisos en mi caso

oS114:~> la /usr/bin/Xorg
-rwxr-xr-x 1 root root 1970760 Feb 7 17:34 /usr/bin/Xorg

oS114:~> la /var/log/Xorg.0.log*
-rw-r--r-- 1 root root 45014 Abr 15 02:08 /var/log/Xorg.0.log
-rw-r--r-- 1 root root 45150 Abr 15 01:46 /var/log/Xorg.0.log.old
Pues los tengo igual...
__________________
Existen dos clases de personas: las que dicen que hay dos clases de personas y las que no.



Mi blog sobre fotografía digital, arte, software libre,
matemática, física y otros delirios
Responder Citando
  #4  
Antiguo 15-abr-2012, 03:34
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
En este hilo me parece que se habla del mismo error.
Aún no lo he revisado.

Editado: Como ya habrás visto, hay comentarios de solucionado modificando permisos y algunos otros.

Si necesitaras algún dato para comparar con mi sistema (11.4x64 kde-4.8.2 ati), ni que decir tiene que no tienes más que decirlo.
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

Última edición por XisEme; 15-abr-2012 a las 03:54
Responder Citando
  #5  
Antiguo 15-abr-2012, 04:57
Avatar de RGB
RGB RGB está desconectado
Miembro Senior
 
Fecha de Ingreso: 25-enero-2005
Ubicación: Lombardía, cerca de una copa de vino tinto de la Toscana
Versión: 42.2 x86_64
Mensajes: 1.116
Agradecimientos: 7
Agradecido 191 Veces en 100 Mensajes
Poder de Credibilidad: 14
RGB está en el buen camino
Gracias, XisEme,

Probé lo comentado en ese hilo pero nada funcionó, por lo que simplemente apliqué la clásica solución del desesperado: reinstalé 11.4 y ahora estoy descargando las 362 actualizaciones...

Y es que tengo un trabajo que terminar para el martes...

En fin, que quedará el misterio de qué sucedió. Al menos ahora funciona.

De cualquier forma, muchas gracias

Saludos
__________________
Existen dos clases de personas: las que dicen que hay dos clases de personas y las que no.



Mi blog sobre fotografía digital, arte, software libre,
matemática, física y otros delirios
Responder Citando
  #6  
Antiguo 15-abr-2012, 12:33
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.591
Agradecimientos: 570
Agradecido 2.476 Veces en 1.674 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Tienes espacio de sobra en la particion raiz /, sino activa el borrado de temporales. La otra cosa era eliminar manualmente los archivos /var/log/Xorg.0.log* y reinicializar
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Problemas con Yast2 e instalacion de paquetes en opensuse 11.3 ejdvc656 General OpenSUSE 28 01-oct-2010 03:40
Manual zypper para 11.1 (Traducción al español) tranzorx FAQs, Manuales y Tutoriales 11 22-ene-2010 00:21
Ares en Linux sin emular willicl Software 18 11-ago-2009 22:11
hacer que la pc nos hable al iniciar sesion (KDE3) Defton FAQs, Manuales y Tutoriales 3 01-jul-2009 21:30
Bienvenido a GNU/Linux (I) karlggest FAQs, Manuales y Tutoriales 9 09-sep-2008 13:04



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 15:10.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba