Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Error Repositorios 12.1
  #1  
Antiguo 01-feb-2012, 17:49
joseminoz joseminoz está desconectado
Aforado
 
Fecha de Ingreso: 01-febrero-2012
Versión: 12.1
Mensajes: 6
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joseminoz está en el buen camino
Error Repositorios 12.1

Buenas.
Quería consultar en el foro porque llevo muchas horas googleando y no le encuentro solución al tema.

Es la tercera vez en el mes que instalo opensuse 12.1 x64 desde el dvd (para ver si fue algún error en la instalación o algo por el estilo) y tengo siempre (en todo día y horario) el mismo problema.

A la hora de actualizar repositorios salta este mensaje de error:

"Error en la descarga (curl) de 'http://download.opensuse.org/distribution/12.1/repo/non-oss/repodata/repomd.xml':
Código de error: Connection failed
Mensaje de error: Resolving host timed out: download.opensuse.org "

Me lo hace con todas las lineas de repositorios que tengo.
Ya probé limpiando caché, desactivando ipv6, de todo, pero no hay solución.
Lo peor es que el mismo dvd lo use para instalar en otra maquina amd y agarro todo a la perfección, motivo por el cual mas bronca tengo ...
El equipo tiene la conexión a internet en perfecto estado, banda ancha, etc., inclusive estoy escribiendo desde el mismo opensuse; por lo que el problema es únicamente con los repositorios.

Este es el error después de omitir cada linea linea de repositorio porque no lee ninguna...

"Error en la inicialización del repositorio.
[|] No se han encontrado metadatos válidos en la(s) URL(s) especificada(s)
Historial:
- Error desconocido leyendo desde 'http://download.opensuse.org/distribution/12.1/repo/oss/'
- SKIP request: User-requested skipping of a file
- Error en la descarga (curl) de 'http://download.opensuse.org/distribution/12.1/repo/oss/repodata/repomd.xml':
Código de error: Connection failed
Mensaje de error: Resolving host timed out: download.opensuse.org"

Espero alguien me sepa dar las respuestas a este dolor de cabeza que tengo ya que no puedo instalar actualizaciones de seguridad ni paquete de software alguno, y ya estoy evaluando pasarme a otra distribución pero no quiero porque esta me gusto bastante salvo por ese temita.

Gracias.
Responder Citando
  #2  
Antiguo 02-feb-2012, 00:14
Avatar de sieg84
sieg84 sieg84 está desconectado
Miembro Junior
 
Fecha de Ingreso: 18-diciembre-2009
Ubicación: México
Versión: 13.1
Mensajes: 470
Agradecimientos: 36
Agradecido 88 Veces en 77 Mensajes
Poder de Credibilidad: 5
sieg84 está en el buen camino
Tal vez te funcione desde konsole:
zypper cc -a && zypper ref && zypper up

Eso me paso a mi cuando recien instale opensuse, creo que lo que hice fue lo anterior.
__________________
Responder Citando
  #3  
Antiguo 02-feb-2012, 01:09
joseminoz joseminoz está desconectado
Aforado
 
Fecha de Ingreso: 01-febrero-2012
Versión: 12.1
Mensajes: 6
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joseminoz está en el buen camino
linux-ouuq:~ # zypper cc -a && zypper ref && zypper up
All repositories have been cleaned up.
Retrieving repository 'Actualizaciones para openSUSE 12.1 12.1-1.4' metadata [\]
Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml':
Error code: Connection failed
Error message: Resolving host timed out: download.opensuse.org

Abort, retry, ignore? [a/r/i/?] (a):
Responder Citando
  #4  
Antiguo 02-feb-2012, 02:33
Avatar de sieg84
sieg84 sieg84 está desconectado
Miembro Junior
 
Fecha de Ingreso: 18-diciembre-2009
Ubicación: México
Versión: 13.1
Mensajes: 470
Agradecimientos: 36
Agradecido 88 Veces en 77 Mensajes
Poder de Credibilidad: 5
sieg84 está en el buen camino
podrías intentar con algún espejo
http://mirrors.opensuse.org/

o tal vez este configurado con algun proxy ¿?
http://forums.opensuse.org/english/g...ml#post2250995
__________________
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a sieg84 Por Este Mensaje:
joseminoz (02-feb-2012)
  #5  
Antiguo 02-feb-2012, 04:39
Avatar de julioeep
julioeep julioeep está desconectado
Miembro Junior
 
Fecha de Ingreso: 19-diciembre-2008
Ubicación: Villavicencio, Colombia
Versión: OpenSuSE 12.3, 13.1, Tumbleweed 64 bits
Mensajes: 625
Agradecimientos: 69
Agradecido 103 Veces en 94 Mensajes
Poder de Credibilidad: 6
julioeep está en el buen camino
Yo tuve un problema similar y era por culpa del proxy, afortunadamente como yo era el administrador del proxy pues hice que todo url que contuviera "download.opensuse.org" no fuera cacheado, sera ese tu caso??

Puede probar con alguna de las url y colocarlas en el navegador o en una consola copiar "wget http://
download.opensuse.org/update/12.1/repodata/
repomd.xml" sin las comillas y ver si se descarga el archivo, no se me ocurre mas por ahora, pero si nos proxy, debería ser zypper.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a julioeep Por Este Mensaje:
joseminoz (02-feb-2012)
  #6  
Antiguo 02-feb-2012, 17:28
joseminoz joseminoz está desconectado
Aforado
 
Fecha de Ingreso: 01-febrero-2012
Versión: 12.1
Mensajes: 6
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joseminoz está en el buen camino
Cita:
Iniciado por sieg84 Ver Mensaje
podrías intentar con algún espejo
http://mirrors.opensuse.org/

o tal vez este configurado con algun proxy ¿?
http://forums.opensuse.org/english/g...ml#post2250995
no me da resultados con otro repositorios, el mismo mensaje de error...

#julioeep
por medio del navegador entra perfecto al fichero oss y non-oss y/o a cualquier otro repo, asi que no es problema de proxy.

Para despistarme mas aun, cuando desconecto el router y conecto la pc directamente a internet al modem no ingresa a internet de ninguna manera, no conecta (apague y volvi a prender el modem, y desde mocosoft entraba). Ya no se que pensar...

Encima tengo un intel i3-2100 sandy bridge y debian stable (squeeze 6.0.4) me anda medio medio porque no me toma bien el hard por el kernel (2.6.35), necesito alguna distro que tenga kernel de 3.0 para arriba, y no me queda otra que arreglar esto o esperar a que salga ubuntu kde 12.4 porque necesito algo estable porque es mi maquina de laburo!!! (y no quiero irme a slackware ni nada por el estilo porque no quiero dolores de cabeza, me tiene que ser algo rápido y productivo).. Sino lo único que me queda es ubuntu kde 11.10 (unity me es asqueroso al igual que gnome3) pero tiene un bug en kwin (al igual que debian testing) que me tiene las pel... inchadas.

El Hardware de red lo detecta a la perfección.
Responder Citando
  #7  
Antiguo 02-feb-2012, 17:31
joseminoz joseminoz está desconectado
Aforado
 
Fecha de Ingreso: 01-febrero-2012
Versión: 12.1
Mensajes: 6
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joseminoz está en el buen camino
Hay algún fichero configuración que pueda ser que zypper este trabajando en ipv6? para probar pasándolo a ipv4
Responder Citando
  #8  
Antiguo 02-feb-2012, 18:10
joseminoz joseminoz está desconectado
Aforado
 
Fecha de Ingreso: 01-febrero-2012
Versión: 12.1
Mensajes: 6
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joseminoz está en el buen camino
Estoy viendo que packagekit tiene alguna clase de conflicto

inteli3:/home/jose # zypper clean
PackageKit está bloqueando la ejecución de zypper. Esto sucede si tiene un applet de actualización u otro administrador de software utilizando PackageKit.
¿Solicitar a PackageKit interrumpir el proceso y salir? [si/no] (no): s
PackageKit se encuentra en ejecución (probablemente ocupado).
¿Reintentar? [si/no] (no): s
PackageKit se encuentra en ejecución (probablemente ocupado).
¿Reintentar? [si/no] (no): ^C

inteli3:/home/jose # top



top - 14:09:20 up 17 min, 3 users, load average: 0.06, 0.28, 0.30
Tasks: 149 total, 2 running, 147 sleeping, 0 stopped, 0 zombie
Cpu(s): 0.2%us, 0.2%sy, 0.0%ni, 99.6%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 3772640k total, 1629908k used, 2142732k free, 49124k buffers
Swap: 2104316k total, 0k used, 2104316k free, 927912k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
8149 root 20 0 124m 21m 5772 S 1 0.6 0:13.38 Xorg
26939 jose 20 0 402m 26m 16m R 1 0.7 0:01.23 konsole
248 root 20 0 0 0 0 S 0 0.0 0:00.05 usb-storage
17176 jose 20 0 488m 103m 32m S 0 2.8 0:07.34 kwin
1 root 20 0 37316 4464 2008 S 0 0.1 0:00.91 systemd
2 root 20 0 0 0 0 S 0 0.0 0:00.00 kthreadd
3 root 20 0 0 0 0 S 0 0.0 0:00.00 ksoftirqd/0
6 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/0
7 root -2 19 0 0 0 S 0 0.0 0:00.20 rcuc0
8 root RT 0 0 0 0 S 0 0.0 0:00.00 rcun0
9 root -2 0 0 0 0 S 0 0.0 0:00.00 rcub0
10 root RT 0 0 0 0 S 0 0.0 0:00.00 rcun1
11 root -2 0 0 0 0 S 0 0.0 0:00.00 rcub1
12 root RT 0 0 0 0 S 0 0.0 0:00.00 watchdog/0
13 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/1
15 root -2 19 0 0 0 S 0 0.0 0:00.10 rcuc1
16 root 20 0 0 0 0 S 0 0.0 0:00.00 ksoftirqd/1
17 root 20 0 0 0 0 S 0 0.0 0:00.32 kworker/0:1
18 root RT 0 0 0 0 S 0 0.0 0:00.00 watchdog/1
19 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/2
20 root 20 0 0 0 0 S 0 0.0 0:00.58 kworker/2:0
21 root -2 19 0 0 0 S 0 0.0 0:00.11 rcuc2
22 root 20 0 0 0 0 S 0 0.0 0:00.00 ksoftirqd/2
23 root RT 0 0 0 0 S 0 0.0 0:00.00 watchdog/2
24 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/3
26 root -2 19 0 0 0 S 0 0.0 0:00.09 rcuc3
27 root 20 0 0 0 0 S 0 0.0 0:00.00 ksoftirqd/3
28 root RT 0 0 0 0 S 0 0.0 0:00.00 watchdog/3
29 root 0 -20 0 0 0 S 0 0.0 0:00.00 cpuset
30 root 0 -20 0 0 0 S 0 0.0 0:00.00 khelper


donde esta packagekit funcionando?? ?)
Responder Citando
  #9  
Antiguo 02-feb-2012, 18:25
joseminoz joseminoz está desconectado
Aforado
 
Fecha de Ingreso: 01-febrero-2012
Versión: 12.1
Mensajes: 6
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joseminoz está en el buen camino
mate packagekit y sigue el problema...
Responder Citando
  #10  
Antiguo 03-feb-2012, 12:24
Avatar de xisco
xisco xisco está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 23-marzo-2006
Ubicación: Sector Horchata
Versión: La ultima estable
Mensajes: 1.649
Agradecimientos: 25
Agradecido 143 Veces en 115 Mensajes
Poder de Credibilidad: 10
xisco está en el buen camino
hola,
desinstala packagekit y se acabaran tus problemas

Salu2
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
acer aspire se bloquea al iniciar opensuse 12.1 annubis Hardware 7 05-abr-2012 20:13
Formas de instalar opensuse, 12.1 moralejo Instalación y Actualizaciones 29 01-dic-2011 00:30
Como creo una Imagen del sistema Opensuse 12.1 para luego clonar a otro Disco Duro? Jonathan Miguel General OpenSUSE 3 23-nov-2011 23:12
Primera beta de suse 12.1 va a retrasar un poco Holmes Noticias 1 25-sep-2011 04:19
Cronograma versión openSUSE 12.1 Holmes General OpenSUSE 1 10-may-2011 19:55



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 02:20.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba