ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   General OpenSUSE (http://www.forosuse.org/forosuse/forumdisplay.php?f=23)
-   -   Flash player en chromium y packman (http://www.forosuse.org/forosuse/showthread.php?t=34347)

Wonder 08-nov-2017 00:30

Flash player en chromium y packman
 
Hola.
Hace poco que he instalado opensuse en portátil, para depurar dudas y luego cambiar pc a opensuse.

El otro día, una de las primeras cosas que hice, a consejo vuestro, añadir el repositorio packman con prioridad 70, el repositorio añadido fue este:
http://packman.inode.at/suse/openSUSE_Tumbleweed/
Sacado de aquí.
Tras ello, cambié los paquetes a este repositorio.

Instalé chromium, que como bien es sabido, no trae flash.

Me fui a Yast, busqué flash-player, localizado e instalé, todo seguía igual.

Busqué por internet, y antes de instalar pepper quise probar otras opciones que encontré.
Y la primera que vi funcionó pero...no vi la diferencia o el porque funcionó y a mi la instalación no me hizo nada, me explico:
La que encontré y quise probar de primeras, fue su instalación con 1 click install, localizada aquí, ví que me añadía el repositorio packman también, y seguí adelante porque queria probar.
Me instaló 3 paquetes, flash-player, flash-player-gnome y flash-player-ppapi (este último es la única diferencia a cuando yo busqué flash-player, que no aparecia).
Entiendo/deduzco (corregidme si me equivoco) que ambos repositorios packman (el que yo añadí y el que se añadió con este 1 click install) es lo mismo (espejos distintos), por ello, porque me funcionó con esta última opción?

Gracias de antemano.

Saludos!

Edito: Yo mismo pude ver el motivo, firefox usa flash-player, pero chromium usa flash-player-ppapi, al instalar solo flash-player por eso no me funcionó en chromium, pero no se porque en la búsqueda no me apareció. Ahora con zypper lo instalé sin problemas.

DanielVE 08-nov-2017 11:01

No sigo el hilo debidamente y si resuelve algo te digo que PPAPI es para navegadores basados en Chromium y NPAPI para los basados en Netscape, y que todos los paquetes flash-player* pertenecen al repositorio Packman luego deberían aparecer una vez añadido este.

Wonder 08-nov-2017 13:39

Thanks DanielVE,
Si, por algún motivo que desconozco, al instalar la primera vez flash-player luego no me aparecía PPAPI.
Como tuve que hacer una reinstalación, al hacer todo de 0, si, ya apareció.
Gracias por la aclaración :)

Saludos.

Rusk0 09-nov-2017 16:39

Hola, yo iba a abrir un hilo sobre este tema. Resulta que lo necesito para unas clases a distancia y por algún motivo no funciona. Según dices, reinstalaste el sistema y funciono?

Enviado desde mi HUAWEI GRA-L09 mediante Tapatalk

Wonder 09-nov-2017 16:56

Cita:

Iniciado por Rusk0 (Mensaje 197775)
Hola, yo iba a abrir un hilo sobre este tema. Resulta que lo necesito para unas clases a distancia y por algún motivo no funciona. Según dices, reinstalaste el sistema y funciono?

Enviado desde mi HUAWEI GRA-L09 mediante Tapatalk

Cuento mejor:
En la primera instalación de flash-player, no me apreció flash-player-PPAPI, ya no me dió tiempo a buscar mucho, pues tuve que formatear y reinstalar opensuse (por unos problemas de compatibilidad de mi portátil).

En la siguiente vez, tras añadir repositorio packman y cambiar paquetes a el, si, al ir a buscar flash-player, ya me apareció también PPAPI y lo instalé y todo perfecto, sin problemas.

Saludos.

DiabloRojo 10-nov-2017 11:10

Cita:

Iniciado por Rusk0 (Mensaje 197775)
Hola, yo iba a abrir un hilo sobre este tema. Resulta que lo necesito para unas clases a distancia y por algún motivo no funciona. Según dices, reinstalaste el sistema y funciono?

Bienvenido al foro @Rusk0, vemos que es tu 1er. mensaje en el foro. Estamos encantados de que te hayas dado de alta, como queremos ayudarte en tu desempeño en el foro tenemos unas normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar, etc... Es como una guía o navaja suiza para los novatos. Para evitarte futuros problemas en el foro fíjate lo que dice resaltado y en negrita la norma 5 sobre el objetivo primordial del foro y, sobre todo, la norma 7 de escribir claro y nítido para entendernos.

Como eres nuevo, preséntate en la sección de Presentaciones y si tienes tiempo libre, acuérdate de leer las normas.
http://images2.hiboox.com/images/061...a01a15fff2.gif

Wonder 12-nov-2017 01:56

Cita:

Iniciado por DanielVE (Mensaje 197749)
No sigo el hilo debidamente y si resuelve algo te digo que PPAPI es para navegadores basados en Chromium y NPAPI para los basados en Netscape, y que todos los paquetes flash-player* pertenecen al repositorio Packman luego deberían aparecer una vez añadido este.

Siguiendo el hilo, ayer me puse a trabajar con Firefox, ya que, durante estos días, usé Chromium (Chrome trae por defecto flash y demás...).
Me di cuenta que Firefox no me muestra componentes flash, pero tampoco me aparece el "dibujito" dónde aparece, complemento no compatible, o clicka aquí para activar flash.
Aunque para Firefox supongo no sería necesario, probé instalando NPAPI, que como tal, vi, entre distintos paquetes, instalé estos dos:
freshplayerplugin y npapi-sdk (el primero me desinstaló el flash-player y el PPAPI del mismo).
Pero no funcionó...y no se por dónde proseguir...

Saludos!!

DiabloRojo 12-nov-2017 12:07

Cita:

Iniciado por Wonder (Mensaje 197825)
instalé estos dos:
freshplayerplugin y npapi-sdk (el primero me desinstaló el flash-player y el PPAPI del mismo).!

El 1º es el que tengo instalado. Hace tiempo que no uso el flash de Adobe si el de Packman.

Usando Leap 42.2, te informo de los paquetes que tengo y, ojo, al final de cada linea de que repo procede, es importante. Por cierto, tengo instalado Chrome de Google usando su repo de Linux, merece la pena tenerlo por las librerías que instala y que usara Chromium.

Código:

zypper se -si chromium
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre                      | Tipo      | Versión              | Arquitectura | Repositorio                 
---+-----------------------------+------------+-----------------------+--------------+------------------------------
i+ | Chromium                    | aplicación |                      | noarch      | openSUSE-Leap-42.2-Update-Oss
i+ | chromium                    | paquete    | 62.0.3202.89-104.38.1 | x86_64      | openSUSE-Leap-42.2-Update-Oss
i+ | chromium-ffmpeg-extra      | paquete    | 61.0.3163.100-1.1    | x86_64      | Packman Repository         
i+ | chromium-plugin-widevinecdm | paquete    | 1.4.8.1029-1.1        | x86_64      | Packman Repository

zypper se -si mozilla
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre                            | Tipo    | Versión        | Arquitectura | Repositorio                 
---+------------------------------------+---------+----------------+--------------+------------------------------
i+ | MozillaFirefox                    | paquete | 52.4.0-57.18.2 | x86_64      | openSUSE-Leap-42.2-Update-Oss
i+ | MozillaFirefox-branding-upstream  | paquete | 52.4.0-57.18.2 | x86_64      | openSUSE-Leap-42.2-Update-Oss
i+ | MozillaFirefox-translations-common | paquete | 52.4.0-57.18.2 | x86_64      | openSUSE-Leap-42.2-Update-Oss                                                                           
i+ | ca-certificates-mozilla            | paquete | 2.7-8.1        | noarch      | openSUSE-Leap-42.2-Oss                                                                                 
i+ | mozilla-kde4-integration          | paquete | 0.6.4-8.3      | x86_64      | openSUSE-Leap-42.2-Oss                                                                                 
i+ | mozilla-nspr                      | paquete | 4.13.1-13.1    | x86_64      | openSUSE-Leap-42.2-Update-Oss                                                                           
i+ | mozilla-nspr-32bit                | paquete | 4.13.1-13.1    | x86_64      | openSUSE-Leap-42.2-Update-Oss                                                                           
i+ | mozilla-nss                        | paquete | 3.28.6-40.10.1 | x86_64      | openSUSE-Leap-42.2-Update-Oss                                                                           
i+ | mozilla-nss-32bit                  | paquete | 3.28.6-40.10.1 | x86_64      | openSUSE-Leap-42.2-Update-Oss                                                                           
i+ | mozilla-nss-certs                  | paquete | 3.28.6-40.10.1 | x86_64      | openSUSE-Leap-42.2-Update-Oss                                                                           
i+ | mozilla-nss-certs-32bit            | paquete | 3.28.6-40.10.1 | x86_64      | openSUSE-Leap-42.2-Update-Oss

zypper se -si papi
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre            | Tipo    | Versión        | Arquitectura | Repositorio     
---+--------------------+---------+----------------+--------------+-------------------
i+ | flash-player-ppapi | paquete | 27.0.0.170-2.1 | x86_64      | Packman Repository

zypper se -si freshplayer
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre            | Tipo    | Versión  | Arquitectura | Repositorio     
---+-------------------+---------+-----------+--------------+-------------------
i+ | freshplayerplugin | paquete | 0.3.5-4.4 | x86_64      | Packman Repository

zypper se -si flash
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre            | Tipo    | Versión        | Arquitectura | Repositorio     
---+--------------------+---------+----------------+--------------+-------------------
i+ | flash-player-ppapi | paquete | 27.0.0.170-2.1 | x86_64      | Packman Repository


Wonder 12-nov-2017 12:50

Cita:

Iniciado por DiabloRojo (Mensaje 197829)
El 1º es el que tengo instalado. Hace tiempo que no uso el flash de Adobe si el de Packman.

Ayer tras postear la duda hice el cambio, quité el flash-player y puse el mencionado (te leí en un post que flash-player no iba muy bien con firefox...).
Pero una duda, comentas que no usas el flash de Adobe si el de packman.
Yo el flash, aunque de adobe, lo instalé de packman...

Cita:

Usando Leap 42.2, te informo de los paquetes que tengo y, ojo, al final de cada linea de que repo procede, es importante. Por cierto, tengo instalado Chrome de Google usando su repo de Linux, merece la pena tenerlo por las librerías que instala y que usara Chromium.
Gracias por la info, yo instalé Chrome, pero descargando el archivo que proporciona google para la instalación de Chrome, no a través de su repo, pero ahora mismo lo hago, desinstalo chrome, añadiré su repo y lo instalaré, lo dicho, gracias.

Código:

zypper se -si chromium
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre  | Tipo      | Versión          | Arquitectura | Repositorio           
---+----------+------------+------------------+--------------+------------------------
i+ | Chromium | aplicación |                  | noarch      | (Paquetes del sistema)
i+ | chromium | paquete    | 62.0.3202.89-1.1 | x86_64      | openSUSE-Tumbleweed-Oss

zypper se -si mozilla
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre                                | Tipo    | Versión    | Arquitectura | Repositorio           
---+----------------------------------------+---------+------------+--------------+------------------------
i+ | MozillaFirefox                        | paquete | 56.0-1.1  | x86_64      | openSUSE-Tumbleweed-Oss
i+ | MozillaFirefox-branding-openSUSE      | paquete | 45-3.2    | x86_64      | openSUSE-Tumbleweed-Oss
i+ | MozillaFirefox-translations-common    | paquete | 56.0-1.1  | x86_64      | openSUSE-Tumbleweed-Oss
i+ | MozillaThunderbird                    | paquete | 52.4.0-1.7 | x86_64      | openSUSE-Tumbleweed-Oss
i+ | MozillaThunderbird-translations-common | paquete | 52.4.0-1.7 | x86_64      | openSUSE-Tumbleweed-Oss
i+ | MozillaThunderbird-translations-other  | paquete | 52.4.0-1.7 | x86_64      | openSUSE-Tumbleweed-Oss
i+ | ca-certificates-mozilla                | paquete | 2.11-2.1  | noarch      | openSUSE-Tumbleweed-Oss
i+ | kmozillahelper                        | paquete | 5.0.1-1.4  | x86_64      | openSUSE-Tumbleweed-Oss
i+ | mozilla-nspr                          | paquete | 4.17-1.1  | x86_64      | openSUSE-Tumbleweed-Oss
i+ | mozilla-nss                            | paquete | 3.33-1.2  | x86_64      | openSUSE-Tumbleweed-Oss
i+ | mozilla-nss-certs                      | paquete | 3.33-1.2  | x86_64      | openSUSE-Tumbleweed-Oss

zypper se -si papi
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre            | Tipo    | Versión        | Arquitectura | Repositorio   
---+--------------------+---------+----------------+--------------+-----------------
i+ | flash-player-ppapi | paquete | 27.0.0.170-2.3 | x86_64      | Packman Completo

zypper se -si freshplayer
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre            | Tipo    | Versión  | Arquitectura | Repositorio   
---+-------------------+---------+-----------+--------------+-----------------
i+ | freshplayerplugin | paquete | 0.3.7-3.6 | x86_64      | Packman Completo

zypper se -si flash
Cargando datos del repositorio...
Leyendo los paquetes instalados...

E  | Nombre            | Tipo    | Versión        | Arquitectura | Repositorio   
---+--------------------+---------+----------------+--------------+-----------------
i+ | flash-player-ppapi | paquete | 27.0.0.170-2.3 | x86_64      | Packman Completo

Esos son mis datos, y por algún motivo que no logro ver ni encontrar, sigo sin flash en firefox.
Por cierto, el nombre de mi repositorio packman, es que lo añadí yo a través de url, y le puse ese nombre (vi en la página de opensuse dónde aparecía que había 3 tipos, y añadí el completo :))

Un saludo!!!

DanielVE 12-nov-2017 13:41

Wrapper
 
DiabloRojo está utilizando un wrapper (freshplayerplugin) para proporcionar Flash de Chrome en Firefox, que supongo es el que goza de más salud —tengo entendido que sobrevive en el navegador gracias a ellos—. Valida que realmente lo tienes instalado.

Antiguamente había jaleo entre las aplicaciones de 64bit y las librerías y complementos de 32bit. Había que crear un enlace de /usr/lib/browser-plugins/libflashplayer.so a /usr/lib64/browser-plugins/libflashplayer.so para que FF 64-bit detectara Flash de 32-bit. Lo revisaría si estás utilizando un sistema multiarch pero es poco probable que sea tu caso.

Mira la web de soporte de Mozilla, parece interesante.

¿Puede estar bloqueado por Ad-Block?
¿Ves el complemento cargado desde about:addons?

Y para terminar:

¿No está planificado eliminar la compatibilidad con Flash para la v.57?


La franja horaria es GMT +2. Ahora son las 13:48.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!