ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   El Contubernio (http://www.forosuse.org/forosuse/forumdisplay.php?f=17)
-   -   Disponible KDE 4.10.5 en el repositorio estándar (http://www.forosuse.org/forosuse/showthread.php?t=30168)

jcsl 16-jul-2013 22:51

Disponible KDE 4.10.5 en el repositorio estándar
 
Hola.

Ya han añadido la versión 4.10.5 al repositorio de estándar de actualizaciones, así que ya no es necesario usar el repositorio extra para tener KDE a la última.

Un saludo.

LUKE10 17-jul-2013 00:20

Me di cuenta ayer, que tenia problemas con dependencias en ciertos paquetes de kde con los del repositorio estándar, y ayer quedaron solucionadas las dependencias entre kde y el estándar.

Código:

wyrms@linux-3bn4:~> sudo zypper up
root's password:
Obteniendo los metadatos del repositorio 'google-chrome' ............................................................................................................................[hecho]
Construyendo el caché del repositorio 'google-chrome' ...............................................................................................................................[hecho]
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

Las siguientes actualizaciones NO serán instaladas:
  k3b k3b-lang libmlt5-modules qt4-qtscript

No hay nada que hacer.

los paquetes k3b y k3b-lang, están desactualizados por que uso los de packman por los codec k3b-codec.

el paquete libmlt5-modules esta desactualizado por que uso un programa que usa una versión anterior.

Y qt4-qtscriptes el que realmente tengo problemas de dependencias al actualizarlo.

edit:
la pregunta es..
¿seguirán actualizando a partir de ahora en el repo estándar a la ultima de kde o solo fue una actualización del estándar?
lo digo por quitar el repo de kde o mantenerlo para seguir teniendo actualizaciones del mismo.

un saludo.

arag 17-jul-2013 01:49

@jcsl entiendo que ya el repo core no es necesario pero el repo extra tiene alguna aplicaciones que no están en el oss si no me equivoco

jcsl 17-jul-2013 03:42

Hola.

Cita:

Iniciado por LUKE10 (Mensaje 165853)
Me di cuenta ayer, que tenia problemas con dependencias en ciertos paquetes de kde con los del repositorio estándar, y ayer quedaron solucionadas las dependencias entre kde y el estándar.

Código:

wyrms@linux-3bn4:~> sudo zypper up
root's password:
Obteniendo los metadatos del repositorio 'google-chrome' ............................................................................................................................[hecho]
Construyendo el caché del repositorio 'google-chrome' ...............................................................................................................................[hecho]
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

Las siguientes actualizaciones NO serán instaladas:
  k3b k3b-lang libmlt5-modules qt4-qtscript

No hay nada que hacer.

los paquetes k3b y k3b-lang, están desactualizados por que uso los de packman por los codec k3b-codec.

el paquete libmlt5-modules esta desactualizado por que uso un programa que usa una versión anterior.

Y qt4-qtscriptes el que realmente tengo problemas de dependencias al actualizarlo.

edit:
la pregunta es..
¿seguirán actualizando a partir de ahora en el repo estándar a la ultima de kde o solo fue una actualización del estándar?
lo digo por quitar el repo de kde o mantenerlo para seguir teniendo actualizaciones del mismo.

un saludo.

Supongo que puedes forzar la instalación de qt4-qtscript siempre que no haya problemas de dependencias, y si las hay entonces tendrás que decidir lo que hacer en función de lo que te proponga zypper o YaST. Si han añadido KDE supongo que seguirán añadiendo actualizaciones. En principio creo que ya no será necesario. Lo que no creo que vayan a hacer es incluir 4.11.x en el futuro al repositorio estándar.

Cita:

Iniciado por arag (Mensaje 165855)
@jcsl entiendo que ya el repo core no es necesario pero el repo extra tiene alguna aplicaciones que no están en el oss si no me equivoco

Esto no lo sé a ciencia cierta, pero es de suponer que si han añadido 4.10.5 al repositorio de actualizaciones también incluirán las actualizaciones que ahora hay en el KDE:Extra del repositorio para 4.10.5 al KDE:Extra de los repositorios de la comunidad. Es decir, que desactivando todo lo de KDE 4.10.5 y añadiendo los repositorios UpdatedApps y KDE:Extra desde YaST -> Repositorios de software -> Repositorios de la comunidad se tendría que estar a la última.

Un saludo.

LUKE10 17-jul-2013 05:02

Es decir que hasta la versión 4.11 podemos desactivar los repos de kde no?

sobre los conflictos son estos los que me dan:

Código:

#### YaST2 conflicts list - generated 2013-07-17 05:09:43 ####

qt4-qtscript-0.2.0-6.1.1.x86_64 requiere libqt4 = 4.8.4, pero este requisito no puede cumplirse
proveedores no instalables: libqt4-4.8.4-3.3.1.i586[openSUSE-12.3-1.7]
                  libqt4-4.8.4-3.3.1.x86_64[openSUSE-12.3-1.7]
                  libqt4-4.8.4-3.6.1.i586[repo-update]
                  libqt4-4.8.4-3.6.1.x86_64[repo-update]
    [ ] romper qt4-qtscript-0.2.0-6.1.1.x86_64 ignorando algunas de sus dependencias

    [ ] no instalar qt4-qtscript-0.2.0-6.1.1.x86_64

    [ ] Se realizarán las siguientes acciones:
desactualización de libqt4-4.8.5-321.1.x86_64 a libqt4-4.8.4-3.6.1.x86_64
instalar libqt4-4.8.4-3.6.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
desactualización de libqt4-qt3support-4.8.5-321.1.x86_64 a libqt4-qt3support-4.8.4-3.6.1.x86_64
instalar libqt4-qt3support-4.8.4-3.6.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
desactualización de libqt4-sql-4.8.5-321.1.x86_64 a libqt4-sql-4.8.4-3.6.1.x86_64
instalar libqt4-sql-4.8.4-3.6.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
desactualización de libqt4-x11-4.8.5-321.1.x86_64 a libqt4-x11-4.8.4-3.6.1.x86_64
instalar libqt4-x11-4.8.4-3.6.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
desactualización de libqca2-2.0.3-28.5.x86_64 a libqca2-2.0.3-10.1.1.x86_64
instalar libqca2-2.0.3-10.1.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
desactualización de libqt4-sql-mysql-4.8.5-323.1.x86_64 a libqt4-sql-mysql-4.8.4-3.6.1.x86_64
instalar libqt4-sql-mysql-4.8.4-3.6.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
desactualización de libQtWebKit4-4.8.5+2.3.1-72.1.x86_64 a libQtWebKit4-4.8.4+2.2.0-3.2.1.x86_64
instalar libQtWebKit4-4.8.4+2.2.0-3.2.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
desactualización de libdbusmenu-qt2-0.9.2-22.30.x86_64 a libdbusmenu-qt2-0.9.2-4.1.1.x86_64
instalar libdbusmenu-qt2-0.9.2-4.1.1.x86_64 (con cambio de proveedor)
  obs://build.opensuse.org/KDE -->  openSUSE
    [ ] no instalar qt4-qtscript-0.2.0-6.1.1.x86_64



#### YaST2 conflicts list END ###

demasiados paquetes a desactualizar por 1....

un saludo.

jcsl 17-jul-2013 13:24

Hola.

Cita:

Iniciado por LUKE10 (Mensaje 165858)
Es decir que hasta la versión 4.11 podemos desactivar los repos de kde no?

Supongo que sí.

Cita:

Iniciado por LUKE10 (Mensaje 165858)
sobre los conflictos son estos los que me dan:

demasiados paquetes a desactualizar por 1....

un saludo.

No tengo problemas con el paquete qt4-qtscript-0.2.0-6.1.1.x86_64. Lo he instalado para probar y no produce ningún error ni necesita desactualizar nada (claro que lo he instalado después de hacer el cambio de repositorios y de actualizar el sistema, así que ya estarían los paquetes en la versión que necesita). Debe ser algo relacionado con los repositorios que tienes o con el paquete ese que mantienes en una versión más antigua, algo propio de tu configuración en fin. Al cambiar del repositorio KDE 4.10 al de actualizaciones he usado YaST porque había muchos cambios que hacer y con la interfaz gráfica se aprecia mejor. ¿Habrás desactivado los repositorios de KDE 4.10 antes de nada, no? De todas formas, si es mucho lío hacer el cambio puedes seguir usando los repositorios que tengas ahora. Los paquetes del repositorio KDE 4.10 están un pelín más actualizados, pero supongo que los del repositorio de actualizaciones estarán un pelín más probados.

Un saludo.

sieg84 17-jul-2013 22:12

algo me decía que era mejor esperar...
los conflictos @LUKE10 supongo que son porque en los repos KR410 aun contienen paquetes mas actualizados que los del repositorio estándar

karlggest 17-jul-2013 22:58

Hola.

Desde que publicaron 12.3, las actualizaciones ¿mensuales? de KDE han sido incorporadas al repositorio de actualizaciones, con la notable salvedad de KDE 4.10.4.

Eso quiere decir que la diferencia entre el repositorio de KDE y el de actualización de la distro puede consistir, como mucho y si acaso, en que en el repositorio haya algún paquete que no se haya incluido en la rama de openSUSE. En este momento, por ejemplo, parece más actual el contenido de updates (versión posterior empaquetada).

4.11 se anunció como una LTS; así que no es fácil especular con lo que harán los de openSUSE.

Salud!!

mikrios 18-jul-2013 12:24

Esto se parece un poco a un cruce de caminos.

No me supone ningún sacrificio mantener ambos rpm , siempre puedo cambiar las prioridades o tomar una decisión ,cuando exista alguna dependencia ( y a último remedio zypper dup y a lo que salga cara o cruz).

Siempre teniendo en cuenta que no comprometa la estabilidad del sistema (actualizaciones criticas o fallos de seguridad) .

Con Packman lo tengo claro , aquí lo que mas pesa no es la versión si no la funcionalidad .
Prefiero una aplicación con todos sus codecs ,aunque sea una versión inferior , que una incompleta (por eso le subo la prioridad a Packman y cambio de proveedor ) .

La 4.11 esta anunciada para el 14 de agosto (o a mediados de ese mes) , que la incluyan en la 12.3 sera cuestión de ver .

Por lo pronto si aparece como beta en la 13.1 :

http://news.opensuse.org/2013/07/16/...e-milestone-3/

Como está entre paréntesis , me supongo que empezaran por la beta y terminaran por la estable ,para ir conformando lo que sera la futura 13.1

Saludos


La franja horaria es GMT +2. Ahora son las 13:51.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!