ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   General OpenSUSE (http://www.forosuse.org/forosuse/forumdisplay.php?f=23)
-   -   Problema al iniciar demonios en el arranque (http://www.forosuse.org/forosuse/showthread.php?t=23737)

fbon 31-mar-2010 17:07

Problema al iniciar demonios en el arranque
 
Estoy con Suse 11 y me ocurrio lo siguiente:
Instale PostgreSQL 8.3 en el servidor. Luego de las configuraciones basicas y de asegurarme que estaba funcionando correctamente, verifique si el servicio levantaba al iniciar el servidor.
Lo que descubrí es que si bien existia el script /etc/init.d/postgresql este no estaba correctamente configurado (solucionado sin problemas ) y ademas no existian los links correspondientes en rc3.d y rc5.d (que es lo que a mi me interesaba).

Creo los links con el comando ln, obteniendo un resultado similar al de otros servicios que si estaban levantando.
hice : ln -s ../postgresql S12postgresql y no pude hacerlo funcionar.
Si funcionó cuando utilice el comando chkconfig. Este comando me creo los links S07postgresql y K01postgresql.

Mi pregunta especificamente es :
1) porque ambos metodos no son equivalentes ?
2) que mas hace el chkconfig ?
3) La documentacion encontrada me indico que el numero siguiente a la S o la K del link es simplemente para establecer el "orden" de encendido o apagado del servicio. Entonces, ¿ en base a que es chkconfig elabora dichos indices ?

Muchas gracias por sus aportes.


La franja horaria es GMT +2. Ahora son las 19:38.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!