Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 9 de 9

Tema: apt para suse

  1. #1
    Bres Invitado

    apt para suse

    Buenas, este es mi primer mensaje en este foro, aunque ya llevo un par de semanitas visitandolo.

    Aunque nuestra SuSE ya lleva el YaST para manejo de paquetes, y va muy bien, alguna vez he hechado en falta algun repositorio con paquetes como los codecs para xvid, ultimas versiones del firefox y algunas cosillas útiles. Buscando por internet encontré hace un tiempo el apt4rpm que es la herramienta apt-get de debian adaptada para las distribuciones que usan RPMs.

    En esa web hay un enlace a apt for suse donde explican todo lo que hay que hacer para tener la herramienta lista. Yo soy muy novato y la he sabido instalar y utilizar, así que no es complicado.

    Saludos.

  2. #2
    benysar Invitado
    Bienvenido.

    Pues no...no es complicado, y creo que la gran mayoria de los intengrantes del foro la utilizamos . Pero como todo...has de tener cuidado con los repositorios que utilizas, así como con aquello que actualizas...puede quedar un verdadero desastre

  3. #3
    geeko Invitado
    Pues yo o no entiendo para que se utiliza o no sé usarlo o lo tengo mal instalado/configurado.

    Segun tengo entendido es para instalar/actualizar paquetes pero cada vez que pongo

    apt-get install cualquiercosa

    me aparece:

    Leyendo listas de paquetes... Done
    Construyendo árbol de dependencias... Done
    E: No se encontró el paquete cualquiercosa


    y ultimamente, despues de instalar los paquetes necesarios para ver divx con el xine-kaffeine me aparece este error:

    Leyendo listas de paquetes... Done
    Construyendo árbol de dependencias... Done
    Tal vez quiera ejecutar `apt-get -f install' para corregirlos:
    The following packages have unmet dependencies:
    w32codec-all: Obsoletes: w32codec
    E: Dependencias no resueltas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).


    A ver si me podeis explicar un poco para que sirve y como se utiliza para "mentes lentas" con algun ejempl .... (será cosa de la resaca )

  4. #4
    benysar Invitado
    Para mentes "lentas" aconsejo el synaptic (por propia experiencia xDD ) . Es simplemente una "gui" para el apt...te hace la vida mucho mas comoda. Despues de instalado seria bueno que comprobaras la lista de repositorios (servidores donde se encuentran los paquetes) y a funcionar . Yo(ahora estoy trasteando con la 9.2 nuevecita) estoy haciendo pruebas como loco (instalando paquetes y demás) y funciona bastante bién.
    P.D yo también hice lo mismo que tú (lo del kaffeine) y sin ningún problema

  5. #5
    geeko Invitado
    Prefiero usar la consola

    Tengo SuSE 9.0 y el problema que tengo es que no me encuatra nada, incluso haciendo antes un apt-get update (que ésto sí que funciona). Siempre me pone que no encuentra lo que le pido, por eso no sé si lo utilizo mal o lo tengo mal configurado..... por ejemplo:

    linux:/home/unai # apt-get install amule
    Leyendo listas de paquetes... Done
    Construyendo árbol de dependencias... Done
    E: No se encontró el paquete amule


    ¿No tendria que buscarme el amule?

  6. #6
    benysar Invitado
    Cita Iniciado por geeko
    Prefiero usar la consola

    Tengo SuSE 9.0 y el problema que tengo es que no me encuatra nada, incluso haciendo antes un apt-get update (que ésto sí que funciona). Siempre me pone que no encuentra lo que le pido, por eso no sé si lo utilizo mal o lo tengo mal configurado..... por ejemplo:

    linux:/home/unai # apt-get install amule
    Leyendo listas de paquetes... Done
    Construyendo árbol de dependencias... Done
    E: No se encontró el paquete amule


    ¿No tendria que buscarme el amule?
    que repositorios tienes?
    lo puedes encontrar en el fichero sources.list, dentro de etc/apt

  7. #7
    geeko Invitado
    parece ser que solo tengo dos ftp:

    # Uncomment the line below, in case you want to use SuSE's patch rpms.
    # Read the information about patch rpms at http://linux01.gwdg.de/apt4rpm

    # rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/9.0-i386 update-prpm security-prpm

    # A very basic sources.list line. Fastest repository first.
    # Remove "base" in case you are behind a
    # slow connection. Fastest repository first.
    # Visit the server to determine which apt components are provided.
    rpm ftp://mirrors.mathematik.uni-bielefe...inux/suse/apt/ SuSE/9.0-i386 update security
    rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/9.0-i386 update security

    # The list with all available components can be found at:
    # http://linix01.gwdg.de/apt4rpm
    # Some components provide experimental software, select wisely!
    # http://ftp.gwdg.de/pub/linux/suse/ap...urces.list.FTP

    # Consult the link above if you want to include uri's for src rpms


    poco, ¿verdad? buscaré más y hare pruebas, no sabia esto, gracias

  8. #8
    benysar Invitado
    Cita Iniciado por geeko
    poco, ¿verdad? buscaré más y hare pruebas, no sabia esto, gracias
    De nada
    P.D aqui tiens el "estandar" para suse 9:

    http://ftp.gwdg.de/pub/linux/suse/ap...rces.list.HTTP
    Copialo, renombralo por sources.list y cambialo por el que tienes. Peeeeeeero yo quitaria los correspondientes a suse-people y kde-unenstable (como poco)

  9. #9
    geeko Invitado
    Gracias, parece que todo va bien menos que hay veces que me pide que elimine el w32codec continuamente

    w32codec-all: Obsoletes: w32codec
    E: Dependencias no resueltas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).


    y si lo hago me pide borrerlo... ¿puede que necesite instalar algun paquete más?

    EDITO: Al final lo he borra (si lo necesito más adelante lo volveré a instalar) pero al hacer por ejemplo

    apt-get install gimp

    despues de aparentemente descargar todo aparece este error:

    Checking GPG signatures...
    Unknown signature /var/cache/apt/archives/gxmhtml_1.4.2-0.ximian.8.8_i586.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#fd4fe9e9)
    Unknown signature /var/cache/apt/archives/gimp_1%3a1.2.5-43.ximian.8.3_i586.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#fd4fe9e9)
    E: Error(s) while checking package signatures:
    0 unsigned package(s)
    2 package(s) with unknown signatures
    0 package(s) with illegal/corrupted signatures
    linux:/home/unai # gimp
    bash: gimp: command not found


    y no tengo ni idea de que se trata, parece un error en las firmas de los paqutes...

    REEDITO: El problema de las firmas ya está solucionado, que mania tengo de preguntar antes de buscar....
    Última edición por geeko; 07-ene-2005 a las 12:35

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Fuentes apt para SuSE 9.2
    By Mdk in forum Software
    Respuestas: 25
    Último mensaje: 21-abr-2008, 18:44
  2. ¿Qué SuSE es mejor para un AMD 64?
    By Clufis in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 14-dic-2004, 09:38
  3. KDE 3.3.1 disponible para SuSE 9.2
    By riven in forum Noticias
    Respuestas: 0
    Último mensaje: 15-nov-2004, 01:59
  4. Nada para SuSE Standard/Professional 9.2
    By mabs in forum Noticias
    Respuestas: 5
    Último mensaje: 07-oct-2004, 09:12
  5. Aviso de seguridad
    By Kunael in forum Internet, Redes y Wireless
    Respuestas: 1
    Último mensaje: 05-ago-2004, 22:35

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •