Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 6 123 ... ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 54

Tema: Error con el traydock del amsn

  1. #1
    kabukiman Invitado

    Error con el traydock del amsn

    Hola!

    Es lo primero que intento instalar y ya estoy preguntando...

    A ver, me he bajado el amsn, lo he descomprimido y funciona perfectamente. El problema está al intentar compilar el traydock. Tengo instalado lo que pide, tcl, tk e imlib, éste último es el que dá el error.

    Me dice que no lo detecta y pide una versión 1.8.2 o superior, cuando el que tengo instalado es 1.9.14-176.

    Por lo que he visto en el sr. google es bastante habitual, pero no doy con la solución

    A ver si me podéis ayudar.

    Un saludo

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Buenas

    Qué paquetes tienes exactamente instalados??

    Yo tengo estos 3 relativos al imlib:



    y no me da ningún fallo al compilar el plugin:

    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    Fecha de Ingreso
    16-julio-2004
    Ubicación
    /home/riven
    Mensajes
    930
    Post Thanks / Like
    Poder de Credibilidad
    10
    Pues mira en este hilo ya los discutimos con Mdk , pues tenia el mismo problema; la verdad es que no he continuado con la labor,ahora es muy tarde, pero mañana, si antes no lo hemos sacado en claro, lo miramos.
    Nunca olvido una cara pero con la suya voy a hacer una excepción.
    Estos son mis principios. Si no le gustan tengo otros.


  4. #4
    kabukiman Invitado
    Los paquetes que tengo instalados son esos tres...

    Y el error es el que tenían Mdk y riven:

    Código:
    checking for Tcl configuration... found /usr/lib/tclConfig.sh
    checking for Tk configuration... found /usr/lib/tkConfig.sh
    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking for imlib-config... /opt/gnome/bin/imlib-config
    checking for IMLIB - version >= 1.8.2... no
    *** Could not run IMLIB test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means IMLIB was incorrectly installed
    *** or that you have moved IMLIB since it was installed. In the latter case, you
    *** may want to edit the imlib-config script: /opt/gnome/bin/imlib-config
    ERROR: Needs a system with Imlib 1.8.2 or higher
    You can obtain it from:
    ftp://ftp.enlightenment.org/pub/enlightenment/
    ftp://www.rasterman.com/pub/enlightenment/
    ftp://ftp.labs.redhat.com/pub/imlib/
    configure: error: Fatal Error: no Imlib detected.
    Y ninguno de los tres enlaces para obtenerlo funciona.

    Un saludo

  5. #5
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Pues es raro ... yo no recuerdo que me diera ningún problema cuando lo hice

    Has mirado el fichero config.log que te pone a ver si explica algo más??
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  6. #6
    kabukiman Invitado
    Yo no entiendo ni papa en el config.log, lo que si veo es que se repite un montón de veces algo que debería estar en otro directorio, tal que así:

    Código:
    /opt/gnome/include/Imlib_types.h:88: warning: data definition has no type or storage class
    /opt/gnome/include/Imlib_types.h:92: error: parse error before '*' token
    /opt/gnome/include/Imlib_types.h:92: warning: data definition has no type or storage class
    /opt/gnome/include/Imlib_types.h:93: error: parse error before '*' token
    He mirado en /opt/gnome/include y sólo hay 6 archivos...


  7. #7
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Prueba a ejecutar esto en lugar del configure:

    ./configure --with-imlib-prefix=/opt/gnome/

    De esa forma le pasas como parámetro la ruta correspondiente, a ver si así la encontrara

    Cita Iniciado por kabukiman
    He mirado en /opt/gnome/include y sólo hay 6 archivos...
    Estos 3 al menos sí deberías tenerlos:

    /opt/gnome/include/Imlib.h
    /opt/gnome/include/Imlib_types.h
    /opt/gnome/include/Imlib_private.h
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  8. #8
    kabukiman Invitado
    Me da exactamente el mismo error salvo una linea que añade una /, no sé si tendrá importancia...

    checking for imlib-config... /opt/gnome//bin/imlib-config


  9. #9
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Pues sobra una barra entonces

    Prueba con esto:

    ./configure --with-imlib-prefix=/opt/gnome
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  10. #10
    Fecha de Ingreso
    16-julio-2004
    Ubicación
    /home/riven
    Mensajes
    930
    Post Thanks / Like
    Poder de Credibilidad
    10
    vamos aprobar una cosa, haznos un favor chuzo teclea esto:
    Código:
    riven@linux:~> rpm -qa | grep imlib
    y dime que librerias dice que tienes.
    Nunca olvido una cara pero con la suya voy a hacer una excepción.
    Estos son mis principios. Si no le gustan tengo otros.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problema con amsn
    By Phoenix_uy in forum Software
    Respuestas: 9
    Último mensaje: 27-sep-2008, 15:53
  2. Problema con AMSN
    By Richard in forum Software
    Respuestas: 8
    Último mensaje: 30-oct-2007, 04:28
  3. No puedo instalar amsn
    By Moi in forum Software
    Respuestas: 24
    Último mensaje: 24-sep-2006, 05:59
  4. Borrar configuracion aMSN
    By CHILETUX in forum Software
    Respuestas: 2
    Último mensaje: 16-ago-2006, 22:28
  5. amsn cvs
    By clanescu in forum Software
    Respuestas: 3
    Último mensaje: 14-jun-2005, 07:15

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •