Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 7 de 7

Tema: No puedo instalar el Firefox

  1. #1
    zhonnetiks Invitado

    No puedo instalar el Firefox

    Como era de esperar, ya estoy aki con otro problema, resumo:
    Tras la satisfactoria instalacion del KDE, todo me iba de maravilla, hasta que vi que el Gimp 2.0 andaba suelto por la red, como no lo tenía instalado, pues me puse manos a la obra. Me lo bajé y con ello las últimas versiones de los paquetes que necesitaba (Glib, gtk, atk, pango...). Instalé todos excepto el pango que me daba un error. Total, que lo dejé marginao porque después me di cuenta que para lo que iba a hacer, mejor estarse quieto.
    A lo que ibamos, yo estaba navegando con mi Firefox, y quise cambiarle el skin, lo cambié y se quedó el programa "pillado". Maté la tarea y desde ahí no me volvió a arrancar. Como no se desinstalar programas instalados desde un .tar.gz pues lo que hice fue borrar la carpeta donde estaba instalado.
    He intentado volver a instalar el Firefox, pero ahora me dice lo siguiente:

    Cita Iniciado por Terminal
    zhonnetiks@linux:~/Programas/firefox-installer> ./firefox-installer

    (firefox-installer-bin:4700): GLib-GObject-WARNING **: specified class size for type `PangoXftFontMap' is smaller than the parent type's `PangoFontMap' class size

    (firefox-installer-bin:4700): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
    ./firefox-installer: line 56: 4700 Violación de segmento ./${BINNAME}-bin $@
    zhonnetiks@linux:~/Programas/firefox-installer> ./firefox-installer-bin
    Supongo que eso que me dice del Glib es a raíz de lo que yo hice, lo que he hecho es volver a instalar el Glib que me venía con los cd's, pero me pasa lo mismo.

    A ver si hay alguna solución posible a esto

    Muxas gracias

    Saludos

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Y no has probado a instalarlo usando el rpm??

    El único "problema" de hacerlo así sería que el programa está en inglés, aunque se puede traducir luego sin problemas en el caso que te interese tenerlo en español
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    zhonnetiks Invitado
    Yo el que tenía instalado lo hice a traves del .tar.gz, y me iba de perlas. He visto en un hilo que está en rpm, me lo estoy bajando, cuando lo instale comento ok??

  4. #4
    zhonnetiks Invitado
    Weno chuzo, te cuento: no puedo instalar los rpm por el yast porque me faltará alguna libreria que haga eso (eso me lleva pasando desde que actualicé el KDE supongo), bueno, que le tiro por el terminal y se instala correctamente porque la barra termina bien y no me dice ningun fallo, pero lo que pasa es que busco el ejecutable y está en /usr/bin, por lo que lo voy a lanzar y no me hace nada.

    Yo creo que el fallo está en lo que instalé del Glib y Pango (concretamente este ultimo)

  5. #5
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Pero ejecutalo también desde la consola, así puedes ver el fallo exacto que da, y si es el mismo que te daba antes ...

    Sí parece que pueda ser un problema de librerías, pero a ver si puedes poner la salida al ejecutarlo por la consola y así es más fácil intentar ver el posible fallo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  6. #6
    zhonnetiks Invitado
    Ya toy aki, esto es lo que me dice, me sale al principio eso de Gecko que antes no me salía (he comprobado que tras hacerlo varias veces el número que aparace despues de Gecko varía)

    Cita Iniciado por Terminal
    zhonnetiks@linux:/usr/bin> firefox

    (Gecko:13985): GLib-GObject-WARNING **: specified class size for type `PangoXftFontMap' is smaller than the parent type's `PangoFontMap' class size

    (Gecko:13985): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
    Violación de segmento

  7. #7
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    El problema parece estar en la librería pango, si dices que esa también la actualizaste, eso por lo que se ve en el error, luego igual es otra, estas cosas son complicadas

    Podrías intentar volver a la versión antigua que tenías de esta librería a ver si se solucionara ...

    Es un poco lo bueno de usar apt para todas estas actualizaciones, se suelen evitar estos problemas
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. no puedo instalar paquetes con yast
    By francesc in forum Software
    Respuestas: 6
    Último mensaje: 07-dic-2007, 09:02
  2. No puedo instalar amsn
    By Moi in forum Software
    Respuestas: 24
    Último mensaje: 24-sep-2006, 05:59
  3. Como Instalar SuSe 9.2 Profesional???
    By Kensai in forum Instalación y Actualizaciones
    Respuestas: 8
    Último mensaje: 18-ago-2006, 09:39
  4. Operación "array sort" infinita causa DoS en Firefox
    By chuzo in forum Internet, Redes y Wireless
    Respuestas: 0
    Último mensaje: 29-nov-2004, 11:26
  5. Las fechas de FireFox 1.0
    By chuzo in forum Noticias
    Respuestas: 8
    Último mensaje: 21-sep-2004, 13:28

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •