Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 5 de 5

Tema: Dependencias de librerias antiguas

  1. #1
    Killrazor Invitado

    Dependencias de librerias antiguas

    Hola, aqui estamos otra vez yo y mis problemas con las dependencias (vengo de windows, y todo lo que no venga masticadito....). Me intente instalar el snort, pero el rpm me pide una librerias libpcap-0.6. Yo intento instalarlas con apt (apt-get install libpcap) y me dice que las librerias que yo tengo instaladas son bastante mas nuevas (las 0.8). Que soluciones me quedan?

    Gracias

  2. #2
    Fecha de Ingreso
    28-julio-2004
    Ubicación
    Europa
    Mensajes
    1.195
    Post Thanks / Like
    Poder de Credibilidad
    18
    * ¿Y porqué no instalas directamente snort a partir de apt?
    PGP id 0xC5ABA76A #http://pgp.mit.edu/
    FSF Associate Member id 4281 #http://www.fsf.org

  3. #3
    Killrazor Invitado
    Ya lo instento pero me da esto:

    Código:
    linux:~ # apt-get -f install snort
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following NEW packages will be installed:
      snort
    0 upgraded, 1 newly installed, 0 removed and 173 not upgraded.
    Need to get 0B/360kB of archives.
    After unpacking 2730kB of additional disk space will be used.
            snort = 2.1.1-34 is needed by snort-2.1.1-37.3
    E: Transaction set check failed
    La gente habla maravillas del apt pero a mi no me va muy bien. Si le hago apt-get install snort me reponde que no puede porque necesito la libreria 0.6 de libpcap.
    Siii, lo que explicaba era con apt. Si le hago apt-get -f install me pide una version anterior de snort. Acaso tengo mal instalado el apt?
    La verdad es que no entiendo nada.

    Gracias

  4. #4
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Hola Killrazor

    Primero ten en cuenta que ningún sistema es perfecto, el funcionamiento de apt puede ser muy bueno, pero ya depende los paquetes exactos que haya en los repositorios y la configuración de tu fichero sources.list ...

    En este caso es muy raro que para instalar un determinado paquete necesites una versión anterior. Lo único que se me ocurre es que realmente el paquete que hay corresponda a una especie de actualización de la versión anterior

    Puedes probar el comando apt showpkg snort para ver las versiones disponibles que hay del paquete en los diferentes repositorios que tengas definidos, si estuviera la versión antigua que necesitas siempre podrías probar a instalar esa

    Un saludo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  5. #5
    Fecha de Ingreso
    28-julio-2004
    Ubicación
    Europa
    Mensajes
    1.195
    Post Thanks / Like
    Poder de Credibilidad
    18
    * Si mal no recuerdo ese paquete (snort) está incoporado en SuSE. Déjate de apt si te da problemas y prueba con un simple YaST, que va a las mil maravillas con lo propio.
    PGP id 0xC5ABA76A #http://pgp.mit.edu/
    FSF Associate Member id 4281 #http://www.fsf.org

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problemas con APT y dependencias
    By Dudu678 in forum Software
    Respuestas: 4
    Último mensaje: 03-sep-2004, 00:43
  2. Respuestas: 13
    Último mensaje: 29-ago-2004, 23:21

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •