Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 3 123 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 29

Tema: Aiss que torpe soy con el KDE xD

  1. #1
    zhonnetiks Invitado

    Aiss que torpe soy con el KDE xD

    Weno, ha llegado la hora definitiva de actualizar el kde, pero como siempre, hay un problema vaya donde vaya.

    La primera vez que fui a instalarlo por el terminal, hice una comprobación para ver las dependencias, y me salia lo siguiente:

    Cita Iniciado por Terminal
    linux:/home/zhonnetiks/kde # rpm -i *.rpm --test
    error: Failed dependencies:
    ladspa is needed by kalsatools-1.5.0-347
    libsfftw.so.2 is needed by kalsatools-1.5.0-347
    libsrfftw.so.2 is needed by kalsatools-1.5.0-347
    kdebase3-SuSE <= 9.0 conflicts with kdebase3-3.3.1-6
    arts-devel is needed by kdelibs3-devel-3.3.1-10
    libxslt-devel is needed by kdelibs3-devel-3.3.1-10
    libxml2-devel is needed by kdelibs3-devel-3.3.1-10
    libFLAC.so.4 is needed by kdemultimedia3-3.3.1-3
    libOggFLAC.so.1 is needed by kdemultimedia3-3.3.1-3
    He leido por ahi que no hacen mucha falta los devel, (que son los que mas errores me dan para actualizar el KDE) y he optado por quitar algunos. Weno, centrandonos en el problema central,

    Código:
    kdebase3-SuSE <= 9.0 conflicts with kdebase3-3.3.1-6
    ¿Que hago yo para satisfacer eso?

    Otra cosita, no se a que puñetas habré tocado, que ahora el yast2 no se me abre, bueno, se me abre, pero cuando pincho en "Instalar/Desinstalar software" se me queda cargando la nueva ventana, pero se cierra y no puedo hacer nada en cuanto a manipular las librerias que tengo instaladas.

    Alguna sugerencia?????

    Muxas gracias y a ver si consigo poner el KDE !!

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Cita Iniciado por zhonnetiks
    Weno, centrandonos en el problema central,

    Código:
    kdebase3-SuSE <= 9.0 conflicts with kdebase3-3.3.1-6
    ¿Que hago yo para satisfacer eso?
    Desinstala el paquete kdebase3-SuSE y ese problema ya no debe aparecer, aunque por los demás parece que te faltan algunos paquetes ...
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    zhonnetiks Invitado
    Wenas chuzo, ya e arreglado el sistema para que no me pida esos archivos, hasta el punto de dejar solo el error del paquete "kdebase3-SuSE".

    Como ya dije, el yast no me funciona (no se porq) y si tengo q tocar algo de los rpm's, tengo que acerlo a traves del terminal. Aki dejo una captura para que veais como voy:

    Cita Iniciado por Terminal
    linux:/home/zhonnetiks/kde # rpm -i *.rpm --test
    error: Failed dependencies:
    kdebase3-SuSE <= 9.0 conflicts with kdebase3-3.3.1-6
    linux:/home/zhonnetiks/kde # rpm -e kdebase3-SuSE
    error: Failed dependencies:
    suse_help_viewer is needed by (installed) susehelp-2003.08.21-38
    linux:/home/zhonnetiks/kde # rpm -e susehelp-2003.08.21-38
    error: Failed dependencies:
    susehelp is needed by (installed) susehelp_es-2003.08.21-29
    Y me podria tirar así todo el dia porq no tendría fin

    Alguna sugerencia?

    Muxas gracias

    Saludos

  4. #4
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Pues intenta ir eliminando también los que hagan falta para poder borrar ese (por los que salen de momento serían susehelp_es y susehelp)

    Normalmente de todos los que desinstales siempre deberías tener versiones nuevas también por lo que no habría problema

    Yo esto siempre lo hago usando apt, y es más fácil porque te resuelve directamente las dependencias y los paquetes que tiene que cambiar

    Un saludo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  5. #5
    zhonnetiks Invitado
    Nop, no se quiere desisntalar, es que como tambien se me a fastidiao el Yast, pos no lo puedo hacer por ahí y tengo que hacerlo desde el terminal

    Cita Iniciado por Terminal
    zhonnetiks@linux:~> rpm -e susehelp
    error: Failed dependencies:
    susehelp is needed by (installed) susehelp_es-2003.08.21-29
    zhonnetiks@linux:~> rpm -e susehelp_es-2003.08.21-29
    error: Failed dependencies:
    susehelp_lang is needed by (installed) susehelp-2003.08.21-38
    zhonnetiks@linux:~> rpm -e susehelp_lang
    error: package susehelp_lang is not installed
    zhonnetiks@linux:~> rpm -e susehelp-2003.08.21-38
    error: Failed dependencies:
    susehelp is needed by (installed) susehelp_es-2003.08.21-29
    Me lleva a un pasillo sin fondo

  6. #6
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    El hacerlo desde Yast te daría igual .. porque las dependencias al final serían las mismas

    Prueba a desinstalar los 2 paquetes de una vez, a ver si así los eliminara:

    rpm -e susehelp susehelp_es

    Otra opción sería usar el parámetro --force en el comando rpm, que te permite ignorar los fallos de dependencias y poder instalar o desinstalar los paquetes, aunque no es muy recomendable pues puedes dejar el sistema inconsistente
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  7. #7
    zhonnetiks Invitado
    Muxas gracias chuzo, el comando que me has pasao a funcionado, pero vamos.... que me a servido de poco, cuento:

    Tras haber hecho lo que me has dixo, he comprobado dependencias, y estaba todo correcto, y decidido e ido a instalar,¿que a pasao?, pues que me e quedao con poco espacio en el disco duro y se a quedado a medio instalar, y consigo, se an quedado los paquetes a medias.

    ¿Ahora que? Pues que se me ha quedado esto "en cueros", todo desordenado (el yast sigue sin funcionar). Y cada vez que quiero terminar de instalarlo me dice lo siguiente:

    Cita Iniciado por Terminal
    file (opt/kde3/share/doc/HTML/en/kinfocenter/blockdevices/index.docbook from install of kdeutils3-3.3.1-3 conflicts with file from package kdeutils3-3.1.4-24
    (He cogido ese trozo como podia haber cogido cualquier otro, porque el error que me da es mas o menos el mismo, lo único que cambia es el nombre del paquete)

    Alguna solucion ante tal fracaso?

    Saludos

  8. #8
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    La opción de Actualización del sistema de Yast sí te funciona??

    Porque si te funciona puedes lo siguiente:

    En Yast/Software/Cambiar fuente de instalación pulsas en Añadir y en la opción FTP. En nombre del servidor pones ftp.rediris.es y en directorio del servidor: /sites/ftp.suse.com/pub/suse/i386/supplementary/KDE/update_for_9.1/yast-source

    y dejas esa nueva fuente en primer lugar (debajo saldrá el cd/dvd que ya salía antes) y eliges la opción de Actualizar el sistema que te comentaba, ahí te debería detectar las nuevas versiones de KDE (y posiblemente de algún otro paquete también, aunque puedes elegir cuáles quieres actualizar) y debería intentar arreglar las dependencias ...

    Yo también probaría a actualizar los paquetes correspondientes a Yast, a ver si así solucionas lo otro también

    A ver que tal
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  9. #9
    zhonnetiks Invitado
    Perdona chuzo por tardar tanto en responder, pero es que he tenido que formatear todo el disco duro entero para reestructurar todo el PC, a lo que vamos, que instalé de nuevo el SuSE ayer, y arreglé todas las dependencias con el comando
    Código:
    rpm -i *.rpm --test
    A lo que el unico paquete conflictivo era el Kdebase-SuSE, lo desinstalé con el comando
    Código:
    rpm -e kdebase-SuSE
    y se quitó bien, ya con todo arreglado me decidí a actualizar el KDE con el comando
    Código:
    rpm -Uvh *.rpm
    y comenzó a trabajar con la barra de progreso, pero al empezar el segundo paquete comenzó a "rayarse" el terminal escribiendo un puñao de rutas...
    Hice un Ctrl+C porque eso no me parecia nada normal, y volví a instalar el paquete Kdebase-SuSE para restaurarlo todo como estaba.


    Dejemosno de tanto rollo y a explicar.

    La opción que me distes chuzo sería la buena si disponiese de una buena conexión porque lo que tengo....
    A lo que me dijo Goltnor de instalar paquete a paquete, es una buena opción?? es que me aprece muy coñazo...

    Enga, que me haria muxa ilusion tener el KDE en condiciones

    Muxas gracias a todos por soportarme tanto....


  10. #10
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Cita Iniciado por zhonnetiks
    ya con todo arreglado me decidí a actualizar el KDE con el comando
    Código:
    rpm -Uvh *.rpm
    y comenzó a trabajar con la barra de progreso, pero al empezar el segundo paquete comenzó a "rayarse" el terminal escribiendo un puñao de rutas...
    Hice un Ctrl+C porque eso no me parecia nada normal, y volví a instalar el paquete Kdebase-SuSE para restaurarlo todo como estaba.
    Pues tuviste suerte que luego todo siguiera normal ... eso de cortar la instalación de los paquetes con Ctrl+C (y más si son los paquetes de KDE) no suele dar buenos resultados, y en muchas ocasiones el resultado es que luego no se inicia KDE

    Instalar todo con el rpm no debe dar problemas, puede tardar más o menos ya dependiendo de los paquetes en sí, pero debería hacerlo bien. Podrías poner los paquetes exactos que bajastes y estás intentando instalar con el rpm *.rpm

    Cita Iniciado por zhonnetiks
    A lo que me dijo Goltnor de instalar paquete a paquete, es una buena opción?? es que me aprece muy coñazo...
    Qué te dijo exactamente??
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •