El pasado día 17 la X.org Foundation puso a disposición de los usuarios un parche que corrige un problema de seguridad que afecta al sistema X Window y que fue dado a conocer el pasado 15 de septiembre.

Las vulnerabilidades en cuestión afectan a libXpm y permite que puedan ser explotadas por usuarios maliciosos para provocar denegaciones de servicio (DoS) o comprometer un sistema afectado.

Los problemas se deben a diversos errores, entre los que se encuentran desbordamientos de entero, accesos a zonas de memoria inadecuadas o errores de validación de entradas, y se han confirmado en las versiones 6.8.1 y anteriores de la librería en cuestión.

Se recomienda actualizar a la mayor brevedad posible.

Fuente: Hispasec

Más Información: X.Org Foundation Security Advisory For The X Window System

Un saludo