Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 17

Tema: Problema al hacer el ./configure

  1. #1
    zhonnetiks Invitado

    Problema al hacer el ./configure

    Como he dicho en el Off-topic, ya estoy de vuelta.

    Amos a ver, resulta que me e bajado el KShutdown; me lo bajo, lo descomprimo, y cuando le ago el configure por el terminal, me salta con esto:

    Cita Iniciado por Terminal
    checking for libz... configure: error: not found.
    Possibly configure picks up an outdated version
    installed by XFree86. Remove it from your system.

    Check your installation and look into config.log
    Hay que actulizarlo o alo por el estilo??

    Muxas gracias y un saludo!

  2. #2
    benysar Invitado
    Cita Iniciado por zhonnetiks
    Como he dicho en el Off-topic, ya estoy de vuelta.

    Amos a ver, resulta que me e bajado el KShutdown; me lo bajo, lo descomprimo, y cuando le ago el configure por el terminal, me salta con esto:



    Hay que actulizarlo o alo por el estilo??

    Muxas gracias y un saludo!
    te dice (en principio) que no encuentra "libz". Seguramente lo tendrás en un paquete de tus cdś.....zlib es el nombre (si te sigue dando el mismo error despues de instalarlo, entonces prueba con zlib-devel)

  3. #3
    zhonnetiks Invitado
    Bueno como no hay 2 sin 3, aki traigo el siguiente problema:
    He instalado el zlib-devel que me dijo Benysar, y si, rula de PM.
    A continuación me pidió las cabeceras del Qt, y se las di.
    Pero ahora me salta con lo siguiente:

    Cita Iniciado por Terminal
    checking for KDE... configure: error:
    in the prefix, you've chosen, are no KDE headers installed. This will fail.
    So, check this please and use another prefix!
    Que hago yo ahora?

    Muxas gracias benysar por responder

    Un saludo

  4. #4
    benysar Invitado
    te dice que, efectivamente necesitas las devel de kde...seguro que las tienes instaladas? también puedes probar (si las tienes instaladas) a reiniciar kde, a ver si asi....

  5. #5
    zhonnetiks Invitado
    Tonto de mí por no haber mirado eso, es que me creia que la libreria KDE no iba a tener un devel de esos. Bueno, Resulta que el configure ya lo hace bien, y como a mí no me sale nada perfecto, pues el siguiente problema me lo da al terminar el "make".

    Cita Iniciado por Terminal
    miscutils.cpp: En static member function `static bool
    MiscUtils::runCommandWithPause(const QString&, int)':
    miscutils.cpp:153: error: `wait' undeclared (first use this function)
    miscutils.cpp:153: error: (Each undeclared identifier is reported only once for
    each function it appears in.)
    make[2]: *** [miscutils.o] Error 1
    make[2]: Leaving directory `/home/zhonnetiks/Programas/kshutdown-0.4.0/kshutdown'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/zhonnetiks/Programas/kshutdown-0.4.0'
    make: *** [all] Error 2
    Acto seguido, hago el "make install" y me termine de la misma forma, y he buscado dentro de esta carpeta el archivo ejecutable, pero no aparece.

    Alguna solucion??

    Muxas gracias........

  6. #6
    benysar Invitado
    Esto ya no me dice nada

    A ver si alguien que sepa mas que yo

  7. #7
    zhonnetiks Invitado
    Benysar, el caso es que ese problema me lo ha hecho ya con unos cuantos programas...

  8. #8
    benysar Invitado
    Aqui tienes un rpm para la SuSE 9.1:
    http://rpmpoint.hp.infoseek.co.jp/

  9. #9
    zhonnetiks Invitado
    Gracias por molestarte en buscarmelo Benysar, pero no me funciona bien, es decir, lo instalo a traves del terminal con el comando "rpm -Uvh <nombredelarchivo.rpm>" y me dice que todo OK, a lo que ejecuto lo que es el programa ya instalado pero se me queda cargando, con el simbolillo del programa tras el raton, y en la barra de tareas, el nombre del programa con un reloj de arena y no se me llega a abrir el programa.

    Uso suse 9.0 y kde 3.1.4, influyo esto?? (fijo que si pero bueno )

  10. #10
    benysar Invitado
    Pues si...no siempre que instalas un programa 9.1 en 9 funciona...mas cuando el kernel ha cambiado.
    No se que decirte...yo acabo de compilarlo desde las fuentes (en una 9.1) y no he tenido problema.....pero la verdad...casi lo mismo lo puedes hacer desde linea de comandos y sin complicarte demasiado la vida

    Es la 4 la versión que intentas compilar?..es que es la ultima

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •