Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 19

Tema: No se instalar lmule

  1. #1
    Thor Invitado

    No se instalar lmule

    ¡Hola!

    Lo primero de todo es reconocer lo poco suelto que estoy en linux, asi que aparte de "novato" en el foro, también lo soy con SuSE. He bajado de internet lmule, una vez descomprimido, el archivo de instalación (si es que se puede llamar asi) dice lo siguiente:

    Código:
    INSTALL
    -------
    
    You will need glib/gtk-1.2.10 (package names like glib and glibdev or
    glib-devel, gtk and gtkdev or gtk-devel) and libexpat (package name should be
    expat) to compile LMule.  Also wxWindows-2.4.0 or greater, linked against
    glib/gtk-1.2.10 is needed (package names wxGTK and wxGTK-devel).
    
    I have used GCC 2.95.2, 3.2, and 3.3 to compile LMule, older GCC's probably
    can't handle Microsoft C++ well enough.
    
    You do not need to patch wxWindows anymore. You can do it, but most of the patch
    stuff is already moved into the LMule itself so you will not get much benefits
    from patching. So just grab the prebuilt library for your distribution, install
    it and start compiling the LMule :) (Un-Thesis> You must patch wxWindows'
    src/generic/listctrl.cpp and include/listctrl.h before you can statically link
    it to LMule)
    
    Anyway, if you want to patch, here are the instructions:
    
    
    PATCH INSTRUCTIONS (OPTIONAL)
    -----------------------------
    Applying the wx-patch:
    cd wxGTK-2.4.0 (or wherever you have extracted wxWindows sources)
    patch -p0 < wx-patch

    HOW TO COMPILE WXWINDOWS
    ------------------------
    Only GTK1 is supported. Don't try GTK2 anymore. wxWindows isn't ready for it.

    For GTK1:
    ./configure --prefix=/usr --disable-gtk2 --enable-timedate --enable-gui
    --enable-protocol --enable-http --enable-ftp --enable-resources
    --enable-prologio --disable-debug --enable-final --enable-timer --with-gtk
    --disable-profile

    After wxwindows has compiled and you have installed it, you can compile LMule.
    do "./configure && make" as usual. If for some reason, wx-config cannot be
    found, use ./configure --with-wx-config=/path/wx-config. Sometimes it will be
    named wxgtk-2.4-config.

    To install it as root type "make install". (You don't have to install if you
    don't like to. It will run fine from the source directory too)

    Note: If you are using CVS version, you will have to run ./autogen.sh to
    generate configure script. Automake > 1.5, Autoconf >= 2.57 and Gettext are
    required and the only versions we will support.

    And if you want to remote-administer it, you should definitely try VNC (or
    TightVNC). You probably won't get disappointed
    http://www.realvnc.org/ http://www.tightvnc.org/

    If you change the chart colors and want to select a custom color.. be sure to
    press "Add to custom color"-button and select the color from there. Otherwise
    color will not change .

    Código:
    ADVANCED OPTIONS
    ----------------
    There are new configure options:
    	--enable-optimise
    	--enable-profile
    
    With --enable-optimise, -O flag will be added to the compilation options. If not
    given, no optimization will occur. It is currently preferable not to optimise,
    because if LMule crashes, the optimised code will not produce usable stack
    trace.  -O2 is reported to work fine, -O3 will totally crash on start up, don't
    waste your time as of now.
    
    With --enable-profile, -pg flag will be added to the compilation options. LMule
    will then record profiling data in gmon.out, from which one can see where LMule
    spends its time. You probably do not want to turn this on, unless you want to
    help the devs figure out where your CPU time is going :P
    A ver si me podeis decir qué es lo que tengo que hacer porque no sé por donde empezar. Mi versión de SuSE es la 9.

    Gracias
    Última edición por Thor; 30-oct-2004 a las 01:41

  2. #2
    benysar Invitado
    Pues lo primero es no instalar lmule. Es mejor y mas reciente el "amule".
    Vete a este pagina y te lo descargas:
    http://www.amule.org/files/download.php?file=12
    también has de descargar los paquetes que hay a la izquierda de la pagina...:wxGTK y wxBase.
    Los tres paquetes los metes en una carpeta vacia, abres una consola y como root tecleas (dentro del directorio):
    rpm -ivh *.rpm
    eso hará que se instalen los tres paquetes...Si te saliera algún mensaje de error, postealo aquí

  3. #3
    Thor Invitado
    ¡Qué rapidez benysar!

    He creado una carpeta llamada amule en /home/amule y contiene:
    1-aMule-2.0.0rc7-1.i586-SuSE_9.rpm
    2-wxBase-2.4.2.tar.gz
    3-wxGTK-2.4.2.tar.gz

    He ejecutado en la terminal como superusuario:
    linux:/home/amule # rpm -ivh *.rpm

    Y me da el siguiente error:

    Código:
    error: Failed dependencies:
            wxBase >= 2.4.0 is needed by aMule-2.0.0rc7-1
            libwx_base-2.4.so is needed by aMule-2.0.0rc7-1
            libwx_base-2.4.so(WXBASE_2.4) is needed by aMule-2.0.0rc7-1
    Gracias

  4. #4
    benysar Invitado
    Has de bajarte los paquetes .rpm para poder instalarlos asi. Los tar.bz/gz se hace de otra manera mas complicada.
    Ya sabes...del mismo sitio que te bajaste esos paquetes, puedes descargarlos en .rpm

  5. #5
    Thor Invitado
    Creo que ya tengo lo que debo, pero me aparece lo siguiente:

    linux:/home/amule # rpm -ivh *.rpm
    Preparing... ########################################### [100%]
    file /usr/lib/libwx_gtk-2.4.so.0 from install of wxGTK-2.4.2-1 conflicts with file from package wxGTK-2.4.1.2-43
    linux:/home/amule #

  6. #6
    benysar Invitado
    Lo que te dice es que al instalar las GTK te crea un conflicto con las GTK que ya tienes instalados. Solución....desinstalalas (wxGTK-2.4.1.2-43) y esperemos que no dependa de algo importante xDD (te lo avisaria)

  7. #7
    Fecha de Ingreso
    16-julio-2004
    Ubicación
    /home/riven
    Mensajes
    930
    Post Thanks / Like
    Poder de Credibilidad
    10
    como bien dice el apañero beny, desinstala los paquetes wx (y tambien el amule para empezar de cero); ahora dirigete a la pagine de amule.org y desde alli bajate los paquetes .rpm de la librerias wx (wxBase, wxGTK, wxGTK-devel), estas son algo disitintas a las que vienen con nuestra distro y no te daran problemas al compilar el amule; una vez instaladas, solo deberias tener que instalar el amule y ejecutarlo sin mayores problemas.

    Nunca olvido una cara pero con la suya voy a hacer una excepción.
    Estos son mis principios. Si no le gustan tengo otros.


  8. #8
    Thor Invitado
    ¡Hola de nuevo!

    Lo primero agradeceros la ayuda ya que ya me funciona amule , he desinstalado el paquete antiguo que tenía y he instalado los nuevos.

    Ahora me pregunto una cosa, ¿puedo compartir las mismas carpetas "incoming" y "temp" para emule (windows) y amule? Lo digo porque de momento voy usando los dos sistemas operativos, todavía me falta mucho para olvidar al malo de la película (windows).


  9. #9
    Fecha de Ingreso
    16-julio-2004
    Ubicación
    /home/riven
    Mensajes
    930
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por Thor
    Ahora me pregunto una cosa, ¿puedo compartir las mismas carpetas "incoming" y "temp" para emule (windows) y amule?
    no hay problema, pero estas carpetas deberan estar en una particion con un sistema de archivos en FAT32, este es el unico requisito; Linux puede escribir en FAT32 sin problemas, pero no asi sobre NTFS, y los OS de Redmon solo "ven" sistemas de archivos "propios" como FAT32,

    un saludo.
    Nunca olvido una cara pero con la suya voy a hacer una excepción.
    Estos son mis principios. Si no le gustan tengo otros.


  10. #10
    Thor Invitado
    Gracias por la aclaración riven. Ha habido suerte y tengo XP en una partición FAT32. De momento he puesto en amule que la carpeta temporal sea la "temp" del emule y la cosa va bien, excepto que ha aparecido un archivo que ya estaba descargado, pero eso no es problema. Lo curioso es que al volver a windows, emule ha vuelto a codificar todos los archivos temporales para poder ser compartidos, supongo que también será normal.

    Gracias por todo, este foro es una caña

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •