Gracias Gracias:  2
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: Librerias Python 3 para Pysol leap 15.2

  1. #1
    Fecha de Ingreso
    08-noviembre-2018
    Mensajes
    62
    Post Thanks / Like
    Poder de Credibilidad
    3

    Librerias Python 3 para Pysol leap 15.2

    Hola a todos!
    Hace ya un par de meses instalé leap 15.2 en el PC de mi pareja (Intel NUC i5-7260U 8Gb, sin problemas. Tan solo tuve que recurrir a la guia no oficial de victorhck para instalar los Codecs VLC y a Wine para instalar la version última (2.10) win de Pysol FC, al no conseguirlo via Opensuse... y esto último quedó pendiente, como reto.

    Para instalar el juego activé el repositorio games y para mi sorpresa apareció disponible Pysol FC y sus barajas. Pero tan solo marcar la aplicación en Yast apareció el mensaje:
    python3-requirementslib para pysolFC-2.8.0-lp152.1.1.nonarch
    con opción de ignorar petición o romper dependencias.

    Busqué en Yast el susodicho python3 y no aparece. Activé en Yast-Ver el paquete python3 y lo instalé. Pero al marcar de nuevo la instalación del juego, el mensaje se repite. Por la red encontré el instalador one-click Ymp, que me llevó al mismo resultado.

    Buscando python3-requirementslib ha aparecido un rpm asociado a TW, Parece una tabla de equivalencias de enlace. No se, no es mi mundo.
    https://opensuse.pkgs.org/tumbleweed...oarch.rpm.html
    pero no a leap15.2 oficial, También encontré
    https://software.opensuse.org/packag...equirementslib

    ... Y, de aquí no me he atrevido a pasar, al no estar en los repositorios de leap15.2. ¿Mejor olvidarlo? o es válida la de TW? o la particular de un miembro de la comunidad del 2º link?... Con wine, ya funciona aceptablemente, aunque el reto de correr mejor en opensuse sigue en pié.

    Saludos y gracias por alguna sugerencia.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.728
    Post Thanks / Like
    Poder de Credibilidad
    10
    En tu ultimo enlace, que es este: https://software.opensuse.org/packag...equirementslib

    Tienes el paquete para todas las versiones, incluido Leap 15.2, solo tienes que hacer clic en los botones amarillos y rojos de la versión 15.2, aparecen 3 experimentales y 3 comunitarios. En principio, deberías añadir el repo devel:languages: python, actualizar ese repo y pasaras a usar la ultima versión de python 3 incluida ese paquete.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. Gracias toni_usuario ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    08-noviembre-2018
    Mensajes
    62
    Post Thanks / Like
    Poder de Credibilidad
    3
    Hola,
    He tenido un par de oportunidades para entrar en su máquina y he probado secuencialmente las 3 soluciones comunitarias indicadas. Ya no aparece el error citado pero, o no arranca nada o reclama idéntico archivo, ahora para Python, a secas.

    Desisto. No sé suficiente y no la quiero liar. Creo haber ensuciado demasiado esa máquina, a pesar de que todo sigue funcionado. Ya tiene Python, Python2 y todo el Python3, cuando en términos prácticos, se lo he resolví con Wine.

    Desde el derecho al pataleo del ignorante, me pregunto porqué no estará disponible este archivo dentro de la oferta opensuse para ser descargado e instalado complementariamente al solicitar un juego que si está disponible. Bien..., miraré de limpiar lo que entienda, cuando me deje entrar de nuevo. Y probablemente acuda también al hilo donde ayudas a limpiar repositorios.

    De cualquier modo, gracias por tu interés y tus sugerencias.
    Saludos.

  5. #4
    Fecha de Ingreso
    19-junio-2020
    Ubicación
    Mallorca (Illes Balears).
    Mensajes
    108
    Post Thanks / Like
    Poder de Credibilidad
    1
    Hola, eso es porque el rpm python-requirementslib si te fijas esta unresolvable (irresoluble) en los repositorios para 15.2 excepto para TW del repo devel:languagesython.

    https://build.opensuse.org/package/s...equirementslib.

    Por eso no te funciona.

    Saludos.

  6. Gracias toni_usuario ha agradecido este mensaje
  7. #5
    Fecha de Ingreso
    19-junio-2020
    Ubicación
    Mallorca (Illes Balears).
    Mensajes
    108
    Post Thanks / Like
    Poder de Credibilidad
    1
    Hola, este se me paso por alto si hay un python3-requirementslib https://software.opensuse.org/packag...equirementslib del repo Cloud:OpenStack:Master, lo que no se si te funcionara con PysolFC?
    Saludos.

  8. #6
    Fecha de Ingreso
    08-noviembre-2018
    Mensajes
    62
    Post Thanks / Like
    Poder de Credibilidad
    3
    Muchas gracias, pero... he tirado la toalla para más probaturas. No sé lo suficiente. Ya le va Pysol con la version exe en Wine.
    Ahora estoy intentando desandar lo andado en Python y además tengo un problema derivado, con el cortafuegos y Samba debido a los inventos...

    (Si se no hay pista definitiva, abriría hilo en Subforo redes Samba.)

    No todo sigue funcionando correctamente en la máquina. Activando Yast-Samba para nuestra red local doméstica, -que parece pasar por abrir firewall para samba-, me salen 6 errores relativos a "gi" que parecen bloquear su trabajo, del tipo

    File "/usr/bin/firewall-cmd", line 24, in <module>
    from gi.repository import GObject
    Buscando, he encontrado ese error reportado y su reparación en el siguiente hilo, relacionado directamente con Python y languages
    https://www.linuxquestions.org/quest...-a-4175648559/

    Con Yast-instalar/desinstalar Sw... /buscar programas y /ver paquetes huerfanos e innecesarios, he ido desistalando python's, para intentar volver a la configuración por defecto de Python en leap 15.2. Al activar Samba, Los 6 errores firewall ahora apuntan a ( ...en get zones, zones, services, etc)

    Ejecución del comando "[["firewall-offline-cmd", "--get-zones"]]" fallida.
    Código de salida: 127
    Salida de error: No existe el fichero o el directorio - firewall-offline-cmd
    Ahora Samba ya muestra sus pestañas, aunque el cortafuegos sigue inactivo, con los errores mencionados y sin mostrar zonas . Pero no se ven los directorios declarados compartidos de las 2 máquinas (Quizás por no incluir la zona samba...)

    Siguiendo una indicacion www, probé,- tras desinstalar e instalar samba y firewall-

    montse@192:~> firewall-cmd --complete-reload
    bash: /usr/bin/firewall-cmd: /usr/bin/python3: intérprete erróneo: No existe el fichero o el directorio
    montse@192:~>

    Todo funciona bien, menos el cortafuegos y Samba...
    ¿Me falta desinstalar o reinstalar algo más de Python, para normalizar la instalacion?

    Gracias y saludos

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Respuestas: 5
    Último mensaje: 16-nov-2018, 10:21
  2. Manual para programar Python
    By DiabloRojo in forum Programación y Scripts
    Respuestas: 29
    Último mensaje: 27-mar-2013, 21:21
  3. Interprete de Python para Opensuse 12.1
    By fran248 in forum Programación y Scripts
    Respuestas: 2
    Último mensaje: 14-ago-2012, 16:24
  4. Librerias *.h para Kdevelop
    By Lord_Scarl in forum Programación y Scripts
    Respuestas: 5
    Último mensaje: 10-oct-2007, 22:13
  5. Librerias para multimedia
    By CrazhMeM in forum General OpenSUSE
    Respuestas: 1
    Último mensaje: 30-dic-2005, 21:00

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •