Gracias Gracias:  2
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  1
Mostrando resultados del 1 al 10 de 10

Tema: Gimp no se abre en leap 15.2

  1. #1
    Fecha de Ingreso
    01-junio-2016
    Mensajes
    33
    Post Thanks / Like
    Poder de Credibilidad
    0

    Gimp no se abre en leap 15.2

    La aplicación GIMP para manejo de imágenes es tiene opciones que no tiene Krita. Por ejemplo, exporta a PDF y sobre todo resulta más intuitiva y manejable. Se instala, pero no funciona. Según como la instales te da violación de segmento o bien un mensaje en el que te dice que ha sido compilado usando bibliotecas de versiones más recientes. Me he pasado cinco días buscando en foros en español e inglés y no he visto ninguna solución al problema. El problema persiste incluso en las versiones que pueden obtenerse de repositorios comunitarios.
    ¿Hay alguna solución al problema?
    Gracias anticipadas por cualquier respuesta.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.684
    Post Thanks / Like
    Poder de Credibilidad
    10
    Parece un problema del tema GTK que utilizas, si usas Plasma cambia de tema de GTK.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. Gracias Facior ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    01-junio-2016
    Mensajes
    33
    Post Thanks / Like
    Poder de Credibilidad
    0
    Gracias por tu pronta respuesta.
    Eso mismo he pensado y he probado a instalar el escritorio Gnome ya que Gimp es un programa de ese escritorio y ocurre los mismo. En los foros en inglés hay hilos que informan de ese mismo problema sin resolverlo.

  5. #4
    Fecha de Ingreso
    01-junio-2016
    Mensajes
    33
    Post Thanks / Like
    Poder de Credibilidad
    0
    Después de muchos intentos, creo que una posible solución consiste en instalarlo a través de flatpak de Fedora o snap de Canonical. Sin embargo, es una solución que no gusta a todo el mundo. Tanto flatpak como snap instalan bibliotecas aspciadas con cada aplicación y suelen ralentizar el inicio. Creo más sensato dedicar tiempo a aprender a manejar Krita con su excesiva complejidad.

  6. No me Gusta mickey no le ha gustado este mensaje
  7. #5
    Fecha de Ingreso
    19-junio-2020
    Ubicación
    Mallorca (Illes Balears).
    Mensajes
    79
    Post Thanks / Like
    Poder de Credibilidad
    1
    Hola.
    Podrías decirnos que versión estas instalando, porque a mi me funciona perfectamente.
    Según como la instales te da violación de segmento o bien un mensaje en el que te dice que ha sido compilado usando bibliotecas de versiones más recientes. Me he pasado cinco días buscando en foros en español e inglés y no he visto ninguna solución al problema.
    Código:
    zypper se -si gimp
    Cargando datos del repositorio...
    Leyendo los paquetes instalados...
    
    E  | Nombre              | Tipo    | Versión            | Arquitectura | Repositorio
    ---+---------------------+---------+--------------------+--------------+----------------------
    i+ | gimp                | paquete | 2.10.12-lp152.1.12 | x86_64       | Repositorio principal
    i  | gimp-lang           | paquete | 2.10.12-lp152.1.12 | noarch       | Repositorio principal
    i  | gimp-plugin-aa      | paquete | 2.10.12-lp152.1.12 | x86_64       | Repositorio principal
    i  | gimp-plugins-python | paquete | 2.10.12-lp152.1.12 | x86_64       | Repositorio principal
    i  | libgimp-2_0-0       | paquete | 2.10.12-lp152.1.12 | x86_64       | Repositorio principal
    i  | libgimpui-2_0-0     | paquete | 2.10.12-lp152.1.12 | x86_64       | Repositorio principal
    Saludos.
    Última edición por mickey; 07-oct-2020 a las 01:32

  8. #6
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.179
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:


    Me extraña, uso los dos y funciona perfectamente :



    Código:
    HP-OMEN:~ # zypper se -si gimp
    Loading repository data...
    Reading installed packages...
    
    S | Name                | Type    | Version            | Arch   | Repository
    --+---------------------+---------+--------------------+--------+----------------------
    i | gimp                | package | 2.10.12-lp152.1.12 | x86_64 | openSUSE-Leap-15.2-1
    i | gimp                | package | 2.10.12-lp152.1.12 | x86_64 | Repositorio principal
    i | gimp-help           | package | 2.8.2-lp152.4.1    | noarch | openSUSE-Leap-15.2-1
    i | gimp-help           | package | 2.8.2-lp152.4.1    | noarch | Repositorio principal
    i | gimp-help-es        | package | 2.8.2-lp152.4.1    | noarch | openSUSE-Leap-15.2-1
    i | gimp-help-es        | package | 2.8.2-lp152.4.1    | noarch | Repositorio principal
    i | gimp-lang           | package | 2.10.12-lp152.1.12 | noarch | openSUSE-Leap-15.2-1
    i | gimp-lang           | package | 2.10.12-lp152.1.12 | noarch | Repositorio principal
    i | gimp-plugin-aa      | package | 2.10.12-lp152.1.12 | x86_64 | openSUSE-Leap-15.2-1
    i | gimp-plugin-aa      | package | 2.10.12-lp152.1.12 | x86_64 | Repositorio principal
    i | gimp-plugins-python | package | 2.10.12-lp152.1.12 | x86_64 | openSUSE-Leap-15.2-1
    i | gimp-plugins-python | package | 2.10.12-lp152.1.12 | x86_64 | Repositorio principal
    i | libgimp-2_0-0       | package | 2.10.12-lp152.1.12 | x86_64 | openSUSE-Leap-15.2-1
    i | libgimp-2_0-0       | package | 2.10.12-lp152.1.12 | x86_64 | Repositorio principal
    i | libgimpui-2_0-0     | package | 2.10.12-lp152.1.12 | x86_64 | openSUSE-Leap-15.2-1
    i | libgimpui-2_0-0     | package | 2.10.12-lp152.1.12 | x86_64 | Repositorio principal
    Código:
    HP-OMEN:~ # zypper se -si krita
    Loading repository data...
    Reading installed packages...
    
    S  | Name              | Type    | Version           | Arch   | Repository
    ---+-------------------+---------+-------------------+--------+------------------------------
    i+ | krita             | package | 4.3.0-lp152.126.1 | x86_64 | KDE:/Extra/openSUSE_Leap_15.2
    i  | krita-lang        | package | 4.3.0-lp152.126.1 | noarch | KDE:/Extra/openSUSE_Leap_15.2
    i+ | krita-plugin-gmic | package | 2.9.2-lp152.28.1  | x86_64 | graphics-SUSE_Leap_15.2
    Código:
    HP-OMEN:~ # inxi -xxxSMGz
    System:    Kernel: 5.3.18-lp152.44-default x86_64 bits: 64 compiler: gcc v: 7.5.0 Console: tty 1 wm: kwin_x11 DM: SDDM 
               Distro: openSUSE Leap 15.2 
    Machine:   Type: Laptop System: HP product: OMEN by HP Laptop 15-dc0xxx v: N/A serial: <filter> Chassis: type: 10 serial: N/A 
               Mobo: HP model: 84DA v: 93.24 serial: <filter> UEFI: AMI v: F.12 date: 03/23/2020 
    Graphics:  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
               Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard driver: nouveau v: kernel bus ID: 01:00.0 
               chip ID: 10de:1c8d 
               Device-3: Quanta type: USB driver: uvcvideo bus ID: 1-6:4 chip ID: 0408:5300 serial: <filter> 
               Display: server: X.Org 1.20.3 compositor: kwin_x11 driver: modesetting,nouveau unloaded: fbdev,vesa 
               alternate: intel,nv,nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz s-dpi: 96 
               OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 
               direct render: Yes
    En otro equipo la mayoría de los programas funcionan ok, aunque gimp en ese otro equipo, aún no lo he probado .

    Mira de reinstalarlo y renombra el archivo ~/.config/GIMP .

    Saludos cordiales

  9. #7
    Fecha de Ingreso
    01-junio-2016
    Mensajes
    33
    Post Thanks / Like
    Poder de Credibilidad
    0
    Por si tenía las configuraciones dañadas por tanto intento, he borrado el disco duro y he re-instalado el sistema. Trabajo con Leap 15.2. Instalando Gimp desde yast aparece la versión 2.10.22. No da error al instalar. Sin embargo, al lanzar la aplicación me aparece un cuadro de dialogo con este mensaje.
    Liblcms2 version mismatch!

    GIMP was compiled against LittleCMS version 2.0, but the
    LittleCMS version found at runtime is only 2.9.

    Somehow you or your software packager managed
    to install a LittleCMS that is older than what GIMP was
    built against.

    Please make sure that the installed LittleCMS version
    is at least 2.0 and that headers and library match.

    NO hay violación de segmento; pero si esta incompatibilidad.

    Posteriormente instalo con yast libcms2 versión 2.11. El problema sigue igual, si bien veo que también sigue instalado libcms 2.9. Si trato de desintestinar esta versión 2.9 me dice que se desintalará libreoffice calc, que uso más que Gimp, por lo que desisto.
    Última edición por Facior; 08-oct-2020 a las 17:12

  10. #8
    Fecha de Ingreso
    01-junio-2016
    Mensajes
    33
    Post Thanks / Like
    Poder de Credibilidad
    0
    Gracias a todos por la información al respecto.
    Creo que he descubierto el problema. El Ordenador que uso ahora lleva un Intel i7-10700 y una placa base MSI z490 con Ethernet Realtek 8125. El driver de esta Ethernet lo obtengo del repositorio home:Sauerland. No sé si se puede obtener de otra forma. EN este repositorio hay una versión posterior de GImp que es la que se instala. He probado a desactivar el repositorio y Gimp e instalarlo del repositorio principal. Ya no aparece el mensaje de error de antes. Ahora tampoco arranca; pero un cuadro de dialogo me dice esto.
    GEGL operation missing!

    GIMP requires the GEGL operation "gegl:alien-map".
    This operation cannot be found. Check your
    GEGL install and ensure it has been compiled
    with any dependencies required for GIMP.

    ¿Alguna idea?

    P.D.
    Si el driver r8125 estuviera disponible del repositorio oficial lo preferiría; pero no lo he averiguado.

  11. #9
    Fecha de Ingreso
    26-octubre-2005
    Mensajes
    126
    Post Thanks / Like
    Poder de Credibilidad
    0

  12. Gracias Facior ha agradecido este mensaje
  13. #10
    Fecha de Ingreso
    01-junio-2016
    Mensajes
    33
    Post Thanks / Like
    Poder de Credibilidad
    0
    SOLUCIONADO.
    Por fin he podido resolver el problema. La clave está en instalar Gimp antes de añadir ningún repositorio no oficial que contenga alguna versión. En mi caso, el driver para la Ethernet Realek 8125 solo se encuentra en el repositorio home:Saunders. He instalado el sistema desde una wifi usb solo con los repositorio oficiales. De esta modo todo funciona perfectamente. Una vez instalado, añado Packman y home:Saunders para poder instalar multimedia y driver de Realtek. Creo que es un consejo útil para todos. Software en repositorios no oficiales hay que instalarlo al final.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. gimp 2.8?
    By azavenom in forum Software
    Respuestas: 6
    Último mensaje: 14-abr-2012, 18:28
  2. gimp 2.8?
    By azavenom in forum La cafetería
    Respuestas: 5
    Último mensaje: 14-abr-2012, 04:18
  3. Respuestas: 4
    Último mensaje: 02-mar-2012, 23:12
  4. Problema con el Gimp
    By galois in forum Software
    Respuestas: 6
    Último mensaje: 27-mar-2006, 20:08

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •