Gracias Gracias:  1
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 7 de 7

Tema: el controlador de NVIDIA no funciona en Leap 15.2

  1. #1
    Fecha de Ingreso
    03-septiembre-2020
    Mensajes
    3
    Post Thanks / Like
    Poder de Credibilidad
    0

    el controlador de NVIDIA no funciona en Leap 15.2

    hola
    acabo de instalar Leap 15.2 y todo bien, pero cuando instalo el controlador para la tarjeta nvidia Geforce 9500 GT, se instala sin problemas, reinicio y nada, solo pantalla negra
    he instalado (bloquenado el nouveau) el G04, G03 desde yast y lo mismo, lo instale via hardway y tampoco,
    nunca habia tenido problemas de este tipo con esta tarjeta en las versiones anteriores.

    ¿cual creen que sea el problema?


    System:
    Kernel: 5.3.18-lp152.36-default x86_64 bits: 64 compiler: gcc v: 7.5.0
    Desktop: IceWM 1.4.2 dm: SDDM Distro: openSUSE Leap 15.2
    Graphics:
    Device-1: NVIDIA G96C [GeForce 9500 GT] vendor: Micro-Star MSI
    driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:0640
    Display: x11 server: X.Org 1.20.3 driver: nouveau
    unloaded: fbdev,modesetting,vesa alternate: nv,nvidia
    resolution: 1440x900~60Hz s-dpi: 96
    OpenGL: renderer: NV96 v: 3.3 Mesa 19.3.4 direct render: Yes

  2. #2
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.167
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:

    No soy muy experto en este tema (vamos que si lo hago, es con chuleta en mano) ; pero si es conveniente para que otros te ayuden, el aportar datos.

    Uno de ellos son :

    Código:
    frank@Z87-DELUX:~> inxi -xxxG
    Graphics:  Device-1: NVIDIA GK106 [GeForce GTX 660] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 01:00.0 
               chip ID: 10de:11c0 
               Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: nouveau unloaded: fbdev,modesetting,vesa 
               alternate: nv,nvidia resolution: 1600x900~60Hz s-dpi: 96 
               OpenGL: renderer: NVE6 v: 4.3 Mesa 18.3.2 direct render: Yes
    Si hablas de G04 y G03 Entiendo que usas los drivers, ya precopilados y con el kernel en uso, si es así comenta que los usas y tienes añadidos los repositorios.

    En caso contrario, hay que descargar : por un lado los drivers y por otro los kernels y utilidades para compilar lo ( me refiero a los privativos) .

    Para ser de ayuda, la persona que sabe del tema, es interesante que le facilites las cosas .

    Por ejemplo un : inxi -xxxFz

    Código:
    frank@Z87-DELUX:~> inxi -xxxFz
    System:    Kernel: 4.12.14-lp151.28.63-default x86_64 bits: 64 compiler: gcc v: 7.5.0 Desktop: KDE Plasma 5.12.8 
               tk: Qt 5.9.7 wm: kwin_x11 dm: SDDM Distro: openSUSE Leap 15.1 
    Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
               Mobo: ASUSTeK model: Z87-DELUXE v: Rev 1.xx serial: <filter> UEFI: American Megatrends v: 2103 
               date: 08/15/2014 
    CPU:       Topology: Quad Core model: Intel Core i7-4770S bits: 64 type: MT MCP arch: Haswell rev: 3 
               L2 cache: 8192 KiB 
               flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 49489 
               Speed: 3093 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3093 2: 3131 3: 3093 4: 3095 5: 3094 6: 3094 
               7: 3094 8: 3094 
    Graphics:  Device-1: NVIDIA GK106 [GeForce GTX 660] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 01:00.0 
               chip ID: 10de:11c0 
               Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: nouveau unloaded: fbdev,modesetting,vesa 
               alternate: nv,nvidia resolution: 1600x900~60Hz s-dpi: 96 
               OpenGL: renderer: NVE6 v: 4.3 Mesa 18.3.2 direct render: Yes 
    Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
               bus ID: 00:1b.0 chip ID: 8086:8c20 
               Device-2: NVIDIA GK106 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
               chip ID: 10de:0e0b 
               Sound Server: ALSA v: k4.12.14-lp151.28.63-default 
    Network:   Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
               chip ID: 8086:153b 
               IF: eth1 state: down mac: <filter> 
               Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 
               v: 2.3LK-NAPI port: c000 bus ID: 09:00.0 chip ID: 10ec:8168 
               IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
    Drives:    Local Storage: total: 9.32 TiB used: 742.69 GiB (7.8%) 
               ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS250G2X0C-00L350 size: 232.89 GiB speed: 31.6 Gb/s 
               lanes: 4 serial: <filter> rev: 101110WD scheme: GPT 
               ID-2: /dev/nvme1n1 vendor: Western Digital model: WDS100T3X0C-00SJG0 size: 931.51 GiB speed: 31.6 Gb/s 
               lanes: 4 serial: <filter> rev: 102000WD scheme: GPT 
               ID-3: /dev/sda vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB speed: 6.0 Gb/s 
               rotation: 7200 rpm serial: <filter> rev: CC4H 
               ID-4: /dev/sdb vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB speed: 6.0 Gb/s rotation: 5425 rpm 
               serial: <filter> rev: 0001 scheme: GPT 
               ID-5: /dev/sdc vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB speed: 6.0 Gb/s 
               rotation: 7200 rpm serial: <filter> rev: CC47 scheme: GPT 
               ID-6: /dev/sdd vendor: Western Digital model: WD20EFRX-68EUZN0 size: 1.82 TiB speed: 6.0 Gb/s 
               rotation: 5400 rpm serial: <filter> rev: 0A80 scheme: GPT 
               ID-7: /dev/sde vendor: Western Digital model: WD20EFRX-68EUZN0 size: 1.82 TiB speed: 6.0 Gb/s 
               rotation: 5400 rpm serial: <filter> rev: 0A82 scheme: GPT 
    Partition: ID-1: / size: 60.00 GiB used: 31.67 GiB (52.8%) fs: btrfs dev: /dev/sdc2 
               ID-2: /home size: 871.22 GiB used: 711.02 GiB (81.6%) fs: btrfs dev: /dev/sdc3 
               ID-3: /opt size: 60.00 GiB used: 31.67 GiB (52.8%) fs: btrfs dev: /dev/sdc2 
               ID-4: /tmp size: 60.00 GiB used: 31.67 GiB (52.8%) fs: btrfs dev: /dev/sdc2 
               ID-5: /var size: 60.00 GiB used: 31.67 GiB (52.8%) fs: btrfs dev: /dev/sdc2 
    Swap:      Alert: No Swap data was found. 
    Sensors:   System Temperatures: cpu: 32.5 C mobo: 30.0 C gpu: nouveau temp: 31 C 
               Fan Speeds (RPM): cpu: 693 fan-1: 889 fan-3: 878 fan-4: 439 fan-5: 1127 fan-6: 0 gpu: nouveau fan: 1080 
               Voltages: 12v: N/A 5v: N/A 3.3v: 3.42 vbat: 3.38 
    Info:      Processes: 275 Uptime: 6h 59m Memory: 31.35 GiB used: 1.67 GiB (5.3%) Init: systemd v: 234 runlevel: 5 
               target: graphical.target Compilers: gcc: 7.5.0 alt: 7 Shell: bash v: 4.4.23 running in: konsole 
               inxi: 3.1.00
    Saludos cordiales .

  3. #3
    Fecha de Ingreso
    26-octubre-2005
    Mensajes
    126
    Post Thanks / Like
    Poder de Credibilidad
    0
    Opensuse 15.2 ya no da soporte en sus repositorios de nvidia a esa tarjeta, por antigua.
    Tendrás que usar el driver nouveau o bien instalar el driver nvidia via "hard way", o bien cambiar la gráfica por otra mas actual

  4. #4
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    Cita Iniciado por cuqui Ver Mensaje
    Opensuse 15.2 ya no da soporte en sus repositorios de nvidia a esa tarjeta, por antigua.
    Tendrás que usar el driver nouveau o bien instalar el driver nvidia via "hard way", o bien cambiar la gráfica por otra mas actual
    Tiene razón. Según la web de Nvidia te corresponde el driver 340.108 de 23 de Diciembre de 2019. Y en el repo de Nvidia el driver más viejo es el 390.138 de 24 de Junio de 2020 con soporte para de Geforce 400 series hasta Geforce 1000 series.

    Sólo te queda bajar el driver a mano de aquí: https://www.nvidia.es/Download/drive...aspx/156194/es

    e instalarlo a mano. Por ejemplo con mi chuleta:

    Cita Iniciado por Krovikan
    CONSEJO: Leer todo antes de hacer nada. Aunque se vea mucha letra es porque pongo muchas notas. Es más fácil de lo que parece.

    La opción manual que es la mia (ya que siempre voy con drivers Beta no disponibles en el repo):


    IMPORTANTE: Hace falta tener instalado kernel-default, kernel-default-devel, kernel-devel y kernel-macros (los 4 paquetes de la misma versión). En tu caso han de tener todos la versión 5.3.18-lp152.36

    Bajar el driver Nvidia desde su página web en el enlace que puse más arriba.


    1º Omitir Noveau:


    Con permisos de root escribir:

    Código:
    sudo echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf
    Ir a Yast y desinstalar: Mesa-dri-nouveau y ponerlo como tabú. Después hacer:

    Código:
    sudo dracut --force
    IMPORTANTE: Reiniciar antes de instalar los drivers NVIDIA tras los pasos anteriores.


    Ahora el proceso de instalación de los drivers propietarios a mano:


    Tras cargar Linux el escritorio saldrá negro. Cambiar a una terminal con Ctrl+Alt+F1.

    Iniciar sesión root y pasar al runlevel 3 (con lo que el gestor de ventanas se muere) tecleando:

    Código:
    init 3
    OPCIONAL MEDIO AVANZADO: Para hacer el proceso anterior de inicio del sistema en runlevel 3 (desde el arranque) también puedes darle a la tecla "e" en la pantalla del Grub y bajar con la tecla de la flecha hacia abajo hasta la línea que comienza con linux.

    Dale a la tecla "Fin" para llegar al final de los parámetros (una o dos líneas por debajo) y escribe un espacio y un 3.
    Quedaría algo así como "quiet 3" (puede acabar en un parámetro distinto en lugar de quiet).

    Con eso el servidor gráfico ya no se inicia y vas directamente a la pantalla negra con petición de usuario y contraseña.

    FIN del OPCIONAL MEDIO AVANZADO


    Instalar el driver:

    NOTA: Asegúrate de estar en runlevel 3 tal y como he mencionado en los códigos anteriores. Para comprobarlo, escribe el comando "runlevel" (sin comillas).
    El resultado tendría que ser similar a N 3 (si sale otro número has de hacer init 3 de nuevo o reiniciar con el medio avanzado descrito encima).

    Localízalo en su directorio y teclear:

    Código:
    sh NVIDIA-Linux-x86_64-340.108.run
    Elige todas las opciones por defecto que te pregunte.

    Verás que te compila el módulo para el kernel e instala el driver junto con las librerías necesarias.


    Tras acabar, teclear:

    Código:
    init 5
    para iniciar el gestor de ventanas (en este caso Plasma).


    NOTA:

    Tendrás que repetir el proceso de instalación siempre que actualices el kernel.
    A veces, actualizar el servidor gráfico de versión puede hacer que acabe el arranque en la consola (pantalla negra). En ese caso también tendrás que repetir la instalación del driver.
    Para ello tan fácil como:

    Ctrl+Alt+F1 cuando ves la pantalla en negro tras cargar el sistema, iniciar sesión root, init 3, sh NVIDIA-Linux-x86_64-340.108.run (desde el directorio que lo tengas) e init 5.


    OPCIONAL: Se puede instalar la aplicación nvdock (el paquete se llama igual) que te pone un icono en la barra inferior de la pantalla que te da acceso al panel de opciones de Nvidia.

    Allí en la sección OpenGL Settings desactivar la casilla "Allow Flipping". Apenas te quita algo de rendimiento y te permite grabar vídeo y audio de forma correcta en juegos con un programa como Vokoscreen, SimpleScreenRecorder o similares.

    Saludos

  5. Gracias mikrios ha agradecido este mensaje
  6. #5
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.673
    Post Thanks / Like
    Poder de Credibilidad
    10
    Bienvenido al foro @chuchov, vemos que es tu 1er. mensaje en el foro. Estamos encantados de que te hayas dado de alta, como queremos ayudarte en tu desempeño en el foro tenemos unas normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar, etc... Es como una guía o navaja suiza para los novatos. Para evitarte futuros problemas en el foro fíjate lo que dice resaltado y en negrita la norma 5 sobre el objetivo primordial del foro y, sobre todo, la norma 7 de escribir claro y nítido para entendernos.

    La mejor opción es hacer lo que te comenta el compañero @Krovikan.

    Como eres nuevo, preséntate en la sección de Presentaciones y si tienes tiempo libre, acuérdate de leer las normas.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  7. #6
    Fecha de Ingreso
    03-septiembre-2020
    Mensajes
    3
    Post Thanks / Like
    Poder de Credibilidad
    0
    gracias Krovikan

    generalmete instalo el controlador a mano, aunque no de esta manera, lo intente asi como dices y cuando reicinio el sistema no encunetra el servidor X11 que se desinstala con el Mesa-dri-nouveau por lo cual me aparece "failed to start Xdispay manager".
    Buscanado en Yast instale el controlador "x11-video-nvidiaG03-340.108-lp151.24.1.x86_64.rpm" a que no estaba instalado, eta vez cuando reinicio se queda suspendido el sistema cuando intenta cargar el controlador "starting Locale Service" pero ahora veo que con el X11 se reinstalo el controlador "mesa-dri-nouveau" lo cual creo que causa el conflicto.

    buscaré como deshabilitar el controlador de mesa para ver si asi funciona.
    Última edición por chuchov; 06-sep-2020 a las 02:21

  8. #7
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    El

    sudo echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf

    que comento en uno de los pasos es para deshabilitar Nouveau (Nouveau está dentro de Mesa) y lo de desinstalar Mesa-dri-noveau y ponerlo como tabú es para que jamás te lo vuelva a instalar (ese paquete y Nvidia se llevan muy mal).


    Saludos

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Nuevo controlador 325.15 de NVIDIA
    By LUKE10 in forum Portal de ForoSUSE
    Respuestas: 4
    Último mensaje: 26-sep-2013, 05:33
  2. Nuevo controlador 325.15 de NVIDIA
    By LUKE10 in forum Noticias
    Respuestas: 0
    Último mensaje: 13-ago-2013, 13:22
  3. controlador NVIDIA 310.14
    By LUKE10 in forum Noticias
    Respuestas: 5
    Último mensaje: 17-nov-2012, 17:16
  4. Controlador NVIDIA 180.60 ya disponible.
    By jcsl in forum Portal de ForoSUSE
    Respuestas: 1
    Último mensaje: 04-jun-2009, 14:15
  5. Controlador NVIDIA 180.60 ya disponible.
    By jcsl in forum Noticias
    Respuestas: 1
    Último mensaje: 04-jun-2009, 14:15

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •