Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 11

Tema: Configuración HTTP/2

  1. #1
    Fecha de Ingreso
    01-septiembre-2020
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0

    Configuración HTTP/2

    Buenas familia, ando bastante corto de administración y en mi nuevo trabajo me han pedido habilitar HTTP/2, he estado mirando varios manuales pero no consigo echarlo a andar. Os cuento un poco, la versión que tienen montada es Linux version 4.12.14-197.34-default (geeko@buildhost) (gcc version 7.5.0 (SUSE Linux), tengo habilitado los módulos de http2, proxy y proxy-fcgi, he deshabilitado prefork y he habilitado event. Cuando lo tengo todo habilitado me da este error al iniciar apache:

    httpd-prefork: Syntax error in -C/-c directive: Syntax error on line 28 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot load /usr/lib64
    /apache2-prefork/mod_proxy_fcgi.so into server: /usr/lib64/apache2-prefork/mod_proxy_fcgi.so: undefined symbol: proxy_module


    Aquí todos los modulos que tengo habilitados:

    a2enmod -l
    actions alias auth_basic authn_core authn_file authz_host authz_groupfile authz_core authz_user autoindex cgi dir env expires include log_config mime negotiation setenvif ssl socache_shmcb userdir reqtimeout rewrite php7_module http2 mod_gzip mpm_event mod_http2 php7-fpm proxy_fcgi proxy


    Me he dado cuenta que si deshabilito proxy_fcgi apache inicia sin problemas. Lo que me tiene bastante mosqueado es porque despues de deshabilitar prefork y habilitar event, entiendo que por el error que aún sigue apuntando a prefork, ¿hay que modificar algo de configuración?

    Este es el fichero donde se indican los modulos:

    more /etc/apache2/sysconfig.d/loadmodule.conf
    # File generated from /etc/sysconfig/apache2, do not edit. Edit the sysconfig file instead.
    LoadModule actions_module /usr/lib64/apache2-prefork/mod_actions.so
    LoadModule alias_module /usr/lib64/apache2-prefork/mod_alias.so
    LoadModule auth_basic_module /usr/lib64/apache2-prefork/mod_auth_basic.so
    LoadModule authn_core_module /usr/lib64/apache2-prefork/mod_authn_core.so
    LoadModule authn_file_module /usr/lib64/apache2-prefork/mod_authn_file.so
    LoadModule authz_host_module /usr/lib64/apache2-prefork/mod_authz_host.so
    LoadModule authz_groupfile_module /usr/lib64/apache2-prefork/mod_authz_groupfile.so
    LoadModule authz_core_module /usr/lib64/apache2-prefork/mod_authz_core.so
    LoadModule authz_user_module /usr/lib64/apache2-prefork/mod_authz_user.so
    LoadModule autoindex_module /usr/lib64/apache2-prefork/mod_autoindex.so
    LoadModule cgi_module /usr/lib64/apache2-prefork/mod_cgi.so
    LoadModule dir_module /usr/lib64/apache2-prefork/mod_dir.so
    LoadModule env_module /usr/lib64/apache2-prefork/mod_env.so
    LoadModule expires_module /usr/lib64/apache2-prefork/mod_expires.so
    LoadModule include_module /usr/lib64/apache2-prefork/mod_include.so
    LoadModule log_config_module /usr/lib64/apache2-prefork/mod_log_config.so
    LoadModule mime_module /usr/lib64/apache2-prefork/mod_mime.so
    LoadModule negotiation_module /usr/lib64/apache2-prefork/mod_negotiation.so
    LoadModule setenvif_module /usr/lib64/apache2-prefork/mod_setenvif.so
    LoadModule ssl_module /usr/lib64/apache2-prefork/mod_ssl.so
    LoadModule socache_shmcb_module /usr/lib64/apache2-prefork/mod_socache_shmcb.so
    LoadModule userdir_module /usr/lib64/apache2-prefork/mod_userdir.so
    LoadModule reqtimeout_module /usr/lib64/apache2-prefork/mod_reqtimeout.so
    LoadModule rewrite_module /usr/lib64/apache2-prefork/mod_rewrite.so
    LoadModule http2_module /usr/lib64/apache2-prefork/mod_http2.so
    LoadModule http2_module /usr/lib64/apache2-prefork/mod_http2.so
    LoadModule proxy_fcgi_module /usr/lib64/apache2-prefork/mod_proxy_fcgi.so
    LoadModule proxy_module /usr/lib64/apache2-prefork/mod_proxy.so


    A ver si habeis tenido el mismo problema o sabeis como va el tema.

    Muchas gracias de antemano!!!!!

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.684
    Post Thanks / Like
    Poder de Credibilidad
    10
    Antes que nada, ¿como estas configurado apache?. Te lo digo porque desde Yast -> Servicios de red se debe hacer, es decir, que hay pocos archivos de configuración se puede editar "a mano".
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    01-septiembre-2020
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Buenas Diablorojo, pues el tema es que no es entorno grafico, yast por lo que veo es un programa para esas configuraciones pero en modo grafico no??

  4. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.684
    Post Thanks / Like
    Poder de Credibilidad
    10
    Yast es una GUI para configurar servicios y editar los archivos de configuración de dichos servicios en openSUSE.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  5. #5
    Fecha de Ingreso
    01-septiembre-2020
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Buenas, no se muy bien de que va ese GUI, no la he utilizado. Buscando por google he visto un artículo donde hablan de como arreglar el error que me da:
    https://http2.co/how-to-fix-ah10034-...-by-mod_http2/

    Lo he realizado y aún así sigue funcionando con prefork:

    apachectl -V | grep -i mpm
    Server MPM: prefork


    Alguna idea??? Me trae loco...

  6. #6
    Fecha de Ingreso
    03-abril-2007
    Ubicación
    Mexico/SanLuisPotosi
    Mensajes
    910
    Post Thanks / Like
    Poder de Credibilidad
    14
    Yast también tiene interfaz para terminal o consola, no es necesario tener entorno gráfico para poder usarlo.
    Saludos.
    __________________________________________________

    Mi Blog:
    http://elblogdedarkspark.blogspot.mx/
    Canales de Youtube:
    http://www.youtube.com/user/DarkSpark2099
    http://www.youtube.com/user/defton En des-uso

  7. #7
    Fecha de Ingreso
    01-septiembre-2020
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Buenas compañeros, ya lo solucione, por lo que veo event no estaba instalado asi que lo instale y a su misma vez me pidio que actualizara apache, tenia la version 2.4.33 y me actualizó a 2.4.46.
    Ahora me ha surgido otro error que seguramente sera mas facil de lo que parece pero no encuentro nada, es compilar php, este es el error:

    Sep 03 12:19:03 preaedweb01 start_apache2[108087]: [Thu Sep 03 12:19:03.355077 2020] [php7:crit] [pid 108087:tid 140590917802240] Apache is running a threaded MPM, but your PHP Module is not compil
    ed to be threadsafe. You need to recompile PHP.

    Sabeis algo sobre esto?

    Gracias!!!!!

  8. #8
    Fecha de Ingreso
    01-septiembre-2020
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Ya parece ser que lo logre echar a andar. He desinstalado php y lo he vuelto a instalar. Ahora apache esta levantado pero no logro configurarlo para que funcione con php-fpm, pondre algun avance cuando lo solucione ya que los manuales que he visto no me han solucionado nada...

  9. #9
    Fecha de Ingreso
    01-septiembre-2020
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Buenas, ya h evisto el error, al parecer el servicio FPM no estaba levantado por falta de una libreria que no la encuentro por ningún lado, a ver si os suena, os paso el error:

    php-fpm[15920]: /usr/sbin/php-fpm: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory

    Saludos.

  10. #10
    Fecha de Ingreso
    27-julio-2005
    Ubicación
    Atlántida
    Mensajes
    960
    Post Thanks / Like
    Poder de Credibilidad
    16
    Cita Iniciado por fjgata Ver Mensaje
    Buenas, ya h evisto el error, al parecer el servicio FPM no estaba levantado por falta de una libreria que no la encuentro por ningún lado, a ver si os suena, os paso el error:

    php-fpm[15920]: /usr/sbin/php-fpm: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory

    Saludos.
    buscador de paquetes?? --> https://rpmfind.net/linux/rpm2html/s....so.0()(64bit)
    --
    hkp://subkeys.pgp.net
    GNU/Linux Opensuse Tumbleweed x86_64

    Linux Registered User #391410


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Sesión VNC a través de HTTP
    By </MR> in forum Internet, Redes y Wireless
    Respuestas: 8
    Último mensaje: 04-sep-2008, 00:18
  2. wget y http://www.almaguitar.com/
    By juliandojal in forum Software
    Respuestas: 0
    Último mensaje: 04-jun-2008, 20:37
  3. Y el servidor http en opensuse 10.2??
    By arxus in forum General OpenSUSE
    Respuestas: 2
    Último mensaje: 20-oct-2007, 21:17
  4. server http
    By tempano in forum Internet, Redes y Wireless
    Respuestas: 1
    Último mensaje: 03-jul-2005, 12:03
  5. Actualizacion Suse 9.3 por FTP o HTTP
    By asellus2001 in forum Instalación y Actualizaciones
    Respuestas: 0
    Último mensaje: 26-abr-2005, 11:24

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •