Hola:

Este fallo lo que provocaba, es que la mayoría de los programas y sistema de plasma, apareciese en Ingles, mezclado con algunas cosas en español.

Reviso casi todo lo relacionado, con perl y configuraciones locales en la raíz "/" (idioma, lenguaje, zona, etc) y mas o menos no aprecio nada.

Pero al ejecutar desde konsole de la sesión de usuario, si da muestra de ello :

Código:
           frank@HP-OMEN:~> inxi -Fz
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "es:en_US",
        LC_ALL = (unset),
        LC_MEASUREMENT = "es_ES.UTF-8",
        LC_MONETARY = "es_ES.UTF-8",
        LC_COLLATE = "es_ES.UTF-8",
        LC_NUMERIC = "es_ES.UTF-8",
        LC_TIME = "es_IC.UTF-8",
        LANG = "es_ES.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("es_ES.UTF-8").
Lo que me lleva a revisar, la configuraciones Locales, de preferencias del sistema (de plasma) , localizando el archivo de configuración del mismo y que se encuentra en ; /home/frank/.config/ (o sea en ~/.config/plasma-localrc) ; El cual el contenido, mas o menos esta ok :

Código:
plasma-localrc = 

Esto es lo que contiene el archivo :

[Formats]
LANG=es_ES.UTF-8
LC_COLLATE=es_ES.UTF-8
LC_MEASUREMENT=es_ES.UTF-8
LC_MONETARY=es_ES.UTF-8
LC_NUMERIC=es_ES.UTF-8
LC_TIME=es_ES.UTF-8
useDetailed=true

[Translations]
LANGUAGE=es:en_US
Donde antes en LC_TIME contenía en su configuración esto :

Código:
LC_TIME = "es_IC.UTF-8",
Que indica que la localización es españa Islas Canarias , Eso no está mal, lo que si puede que el archivo, si lo esté, o bien puede que otro; para el caso, al cambiar la Zona horaria por españa España, todo volvió a pasar a español, incluido el sistema y sus programas, quedando el problema solucionado, pero con ese archivo dudoso y pendiente de revisar ( como eso es nuevo, no se si de otros países hubiese alguno que hiciese lo mismo) .

Esto se suele configurar en preferencias del sistema ---> Preferencias regionales -----> Formato ( como curiosidad , en la misma Zona, en Fecha y hora ----> Zona horaria : poniendo Atlántico Islas Canarias, no se produce el problema ; por lo que todo queda en sospecha del archivo LC_TIME correspondiente a esa Zona) .

Observaciones : por un lado el problema queda solucionado, pero por otro lado, como las configuración y lo de poner Islas Canarias, sería lo correcto, de ahí si hay un error, del cual espero que corrijan el mismo y se solucione esto.

Gracias y un saludo cordial.