Gracias Gracias:  1
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 17

Tema: Error al actualizar software automáticamente.

  1. #1
    Fecha de Ingreso
    15-julio-2020
    Ubicación
    Madrid
    Mensajes
    4
    Post Thanks / Like
    Poder de Credibilidad
    0

    Error al actualizar software automáticamente.

    Hola.
    He instalado Leap 15.2 hace unos días y lo actualizo manualmente porque la actualización automática siempre da error, pero si pincho el icono de "Actualizaciones de software" en el panel y luego pincho el botón "Comprobar Actualizaciones" funciona perfectamente.
    También va bien si lo hago con zypper.

    ¿Alguna pista o donde puedo mirar a ver que ocurre?

    Gracias.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.674
    Post Thanks / Like
    Poder de Credibilidad
    10
    Bienvenido al foro @juanPerez, vemos que es tu 1er. mensaje en el foro. Estamos encantados de que te hayas dado de alta, como queremos ayudarte en tu desempeño en el foro tenemos unas normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar, etc... Es como una guía o navaja suiza para los novatos. Para evitarte futuros problemas en el foro fíjate lo que dice resaltado y en negrita la norma 5 sobre el objetivo primordial del foro y, sobre todo, la norma 7 de escribir claro y nítido para entendernos.

    No tengo todavía Leap 15.2, espero que algún compañero que se lo haya instalado o actualizado te pueda ayudar a informar si tiene el mismo error, seria un bug, o si le funciona. A mi nunca me ha funciona la Actualización automática, siempre he tenido que hacerlo a mano.

    Como eres nuevo, preséntate en la sección de Presentaciones y si tienes tiempo libre, acuérdate de leer las normas.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    Cita Iniciado por juanPerez Ver Mensaje
    la actualización automática siempre da error, pero si pincho el icono de "Actualizaciones de software" en el panel y luego pincho el botón "Comprobar Actualizaciones" funciona perfectamente.
    Eso hace siglos que me pasa a mi. Me pasa en Leap 15.2, 15.1, 15.0 y posiblemente ya pasara en 42.x.

    Y lo único que he podido deducir (no he buscado en Internet porque no es muy molesto ese fallo) es que está puesto para actualizarse 1 vez al día, es decir, cada 24h.

    En algo que me he fijado es que si un día actulizas con pk-updates (el nombre del plasmoide al cual haces referencia) a las 11:36 (por ejemplo), ya no te lo comprueba hasta las 11:36 clavadas del día siguiente. Si enciendes el ordenador antes (10:45 por ejemplo) te sale el error que mencionas. Pero si te pones a hacer cosas, al llegar a las 11:36, sin darle al comprobar, a las 11:36 te hace el solito la comprobación de forma correcta.

    El ¿por qué?. Lo desconozco salvo ese periodo de las opciones (click derecho en el plasmoide de las actualizaciones y verás las opciones de intérvalo de actualizaciones).

    Un error bastante raro pero muy salvable y poco molesto en mi opinión.


    Saludos
    Última edición por Krovikan; 15-jul-2020 a las 19:10 Razón: Añadir sistema

  4. #4
    Fecha de Ingreso
    15-julio-2020
    Ubicación
    Madrid
    Mensajes
    4
    Post Thanks / Like
    Poder de Credibilidad
    0
    Me fijaré a ver a que hora se actualiza.
    Muchas gracias.

  5. #5
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.169
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:

    Aunque de un solo fallo, el proceso de packagekit falla ( ya sea un programa con dependencias, ya sea la cache, ya sea uno de los repos) .

    Como actuar, si se conoce el fallo; pues desmarcar ese y actualizar lo demás .

    Si el fallo es temporal por el repositorio, pues hay que esperar a que quede bien y actualizar .

    En caso que no se conozca, ir a KsysGuard (monitor del sistema) , poner en búsqueda packagekit y cerrar o matar ese proceso, a continuación, abrir consola super usuario y ejecutar zypper refs , zypper ref y zypper up ; ahí es mas fácil ver lo que falla, si es un repo se puede des activar temporalmente, si es otra cosa se puede bloquear.

    También se puede esperar a que se solucione y actualizar después .

    En caso que haya fallado un repo, por que está mal o ha cambiado, muy fácilmente desde yast, se pueden borrar y volverlos a cargar (no olvidarse poner las prioridades, nº menor, mayor prioridad) , si es packman el que falla, se puede añadir otro de los mirror, con lo cual , siempre tendrá una reserva.

    Otra es cuando hay un fallo en las caches del usuario (ya el moderador a dado soluciones a esto, como no recuerdo donde lo indico por si lo buscan) .

    Y Por último, recordar añadir en yast, las opciones lo de limpiar al borrar paquetes y lo de cambio de proveedor, eso en yast instalador y desinstalador de software, también recordar las utilidades de esa aplicación, etc y recordar que si se quita packagekit, se tiene un actalizador en linea desde yast .

    Si algún paquete da fallos y no deja actualizar, se puede bloquear el mismo y actualizar lo demás, eso con el comando zypper; ver todos las utilidades del mismo en la wiki, ademas tiene bastantes ejemplos de como utilizar lo .

    Gracias y un saludo cordial .

  6. #6
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    Yo al menos hablaba de cuando el error no es de conflictos (algún parche de opensuse para Mozilla) ni de que hace falta la versión X de otro paquete ni de que no puede actualizar un repo (normalmente porque falta aceptar la firma o el repo está caido). No, nada de eso.

    Simplemente falla por que sí al arrancar el sistema. De hecho me pone "Última comprobación: hace 23h 53min" (ningún mensaje adicional en forma de ventana emergente). Y si al momento (o más tarde) le das a Comprobar actualizaciones, funciona.

    No vale la pena matar el proceso si con darle a Comprobar actualizaciones, va bien.


    He estado mirando en Google y ME ESTOY MEANDO DE RISA.

    En https://en.opensuse.org/System_Updates ponen textualmente:
    Disable KDE update checking

    KDE update widget will check online updates every time you login. This often fails and throw annoying error notifications. If you don't want to use it

    a partir de ahí te dicen que lo desintales ya que en el futuro será sustituido por Discover.


    Por cierto, me ha hecho él solito la comprobación a la misma hora de ayer 11:36 (si le hubiera dado antes a Comprobar actualizaciones, esa hora cambiaría a la de cuando yo le hubiera dado al botoncito).


    Saludos

  7. #7
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.169
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:

    https://es.opensuse.org/Zypper

    Kde tenía antes una aplicación para actualizar, en preferencias del sistema (por lo menos a mi me gustaba) , ahora con esa nueva, pues no se a donde ira a parar, a lo mejor , mejora y se queda como una favorita, vete tu a saber

    El tema y sobre todo al principio, hay veces que packagekit se hace algo pesado y no deja ni usar zypper , ni yast ( por eso o se acaba el proceso, o se hace un kill, o se espera a que termine) .

    El bloqueo : zypper al 'PackageKit*' y para listar la lista de bloqueados : zypper ll y para quitar el bloqueo : zypper rl PackageKit-browser-plugin

    Sin contar las chuletas de zypper, esta de la wiki es una de las mejores, ademas hecha por un compañero del foro.

    Saludos cordiales

  8. #8
    Fecha de Ingreso
    15-julio-2020
    Ubicación
    Madrid
    Mensajes
    4
    Post Thanks / Like
    Poder de Credibilidad
    0
    Cita Iniciado por Krovikan Ver Mensaje
    Eso hace siglos que me pasa a mi. Me pasa en Leap 15.2, 15.1, 15.0 y posiblemente ya pasara en 42.x.

    Y lo único que he podido deducir (no he buscado en Internet porque no es muy molesto ese fallo) es que está puesto para actualizarse 1 vez al día, es decir, cada 24h.

    En algo que me he fijado es que si un día actulizas con pk-updates (el nombre del plasmoide al cual haces referencia) a las 11:36 (por ejemplo), ya no te lo comprueba hasta las 11:36 clavadas del día siguiente. Si enciendes el ordenador antes (10:45 por ejemplo) te sale el error que mencionas. Pero si te pones a hacer cosas, al llegar a las 11:36, sin darle al comprobar, a las 11:36 te hace el solito la comprobación de forma correcta.

    El ¿por qué?. Lo desconozco salvo ese periodo de las opciones (click derecho en el plasmoide de las actualizaciones y verás las opciones de intérvalo de actualizaciones).

    Un error bastante raro pero muy salvable y poco molesto en mi opinión.


    Saludos
    Comprobado y ocurre como dices así que para mi está solucionado.
    Saludos.

  9. #9
    Fecha de Ingreso
    10-marzo-2011
    Mensajes
    9
    Post Thanks / Like
    Poder de Credibilidad
    0
    Hola qué tal:

    A veces pasa con la versión 15.2. Así que puedes revisar manualmente los repositorios (es decir, en un navegador escribe la url del repositorio problemático) para ver si está temporalmente caído. Yo prefiero la actualización manual desde la consola en el siguiente orden:

    1. Actualizar la lista de paquetes:

    Código:
    zypper ref
    2. Buscar parches para el sistema:

    Código:
    zypper patch

    3. Buscar actualizaciones:

    Código:
    zypper up
    Suele ser más rápido que desde el gestor gráfico de actualizaciones y también te permite ver si hay algún problema con los repositorios. Si ves que alguno tarda más de lo debido en responder (aprox. más de 3 minutos) presiona CTRL+SHIFT+C (estando en la consola, por supuesto) para cancelar la operación, y verás cuál es la falla.

    Finalmente, puedes probar reiniciar tu equipo. Puede sonar tonto e ilógico, pero una vez me funcionó.

    Saludos.

  10. #10
    Fecha de Ingreso
    25-agosto-2008
    Ubicación
    Bogotá D.C, Colombia
    Mensajes
    369
    Post Thanks / Like
    Poder de Credibilidad
    13
    A mi me está comenzando a ocurrir algo raro: Es capaz de encontrar las actualizaciones, pero al darle actualizar, en el plasmoide, genera el error The PackageKit daemon has crashed, y vuelve a buscar y mostrar las actualizaciones, por lo que recurro a la consola para actualizar.

    Lo que no entiendo es por qué siguen insistiendo con Discover. Es una jungla de bugs, tanto, que los Aburami pueden encontrar fácilmente al Bikochu en Discover. Yo lo desinstalo apenas instalo openSUSE porque sencillamente no sirve para nada.

    Se supone que fue hecho para reemplazar a PackageKit pero depende de PackageKit y si este falla, no sirve Discover y si Discover falla, simplemente queda Zypper.

    EDITO: Incluso un miembro de desarrollo de KDE en Reddit aconseja desinstalarlo :v

    https://www.reddit.com/r/openSUSE/co...eb2x&context=3
    Última edición por NestorAcevedo; 02-oct-2020 a las 21:56

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problema con Actualizar e instalar software/repositorios
    By barto667 in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 25-may-2016, 16:59
  2. Actualizar software mediante repos
    By amdasus in forum Software
    Respuestas: 2
    Último mensaje: 05-jul-2011, 23:23
  3. Respuestas: 11
    Último mensaje: 23-ago-2010, 13:24
  4. software update - error
    By guicho in forum Internet, Redes y Wireless
    Respuestas: 1
    Último mensaje: 28-oct-2007, 23:19
  5. Actualizar Software
    By Zerg in forum Software
    Respuestas: 2
    Último mensaje: 15-abr-2005, 13:07

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •