Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 2 de 2 PrimeroPrimero 12
Mostrando resultados del 11 al 16 de 16

Tema: Problemas con adb para hacer funcionar DroidCam desde USB en mi computador

  1. #11
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.600
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por fabioonier Ver Mensaje
    Creé ese enlace simbólico y me salió este error
    Código:
    fabioonier@linux-53z1:/usr/lib64> adb services
    adb: symbol lookup error: adb: undefined symbol: EVP_EncodedLength
    Ese error es porque la versión de tu librería libcrypto no tiene implantada esa función, puede ser porque la tuya es muy antigua.

    Para buscar archivos del una libreria, uso el comando zypper con la opción wp
    sudo zypper wp libcrypto.so.1
    Última edición por DiabloRojo; 08-may-2020 a las 09:37
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  2. #12
    Fecha de Ingreso
    22-octubre-2012
    Mensajes
    66
    Post Thanks / Like
    Poder de Credibilidad
    8
    Cita Iniciado por Krovikan Ver Mensaje
    En yast2-->Instalar/desinstalar tienes unas casillas debajo del campo de búsqueda.

    Una de ellas es Proporciona. Entonces si en el campo de búsqueda escribo libcrypto.so.1 y marco la casilla de Proporciona, me salen todos los paquetes (instalados o no) que proporcionen lo que has escrito en el campo de búsqueda.

    No hagas ningún enlace y borra el que creastes. Instala el paquete de openssl1_0_0 y ya dices qué tal.


    Saludos
    Lamentablemente sigue sin funcionar. Instalé la librería que me sugeriste, borré el enlace simbólico y adb sigue pidiento libcrypto.so.1 de manera específica.

    Código:
    fabioonier@linux-53z1:/usr/lib64> sudo zypper se openssl1
    Cargando datos del repositorio...
    Advertencia: Parece que el repositorio 'Repositorio principal de actualizaciones' no está actualizado. Se recomienda usar una réplica o servidor distintos.
    Leyendo los paquetes instalados...
    
    E  | Nombre                      | Resumen                                                                      | Tipo   
    ---+-----------------------------+------------------------------------------------------------------------------+--------
    i+ | libopenssl1_0_0             | Secure Sockets and Transport Layer Security                                  | paquete
       | libopenssl1_0_0-32bit       | Secure Sockets and Transport Layer Security                                  | paquete
       | libopenssl1_0_0-hmac        | HMAC files for FIPS-140-2 integrity checking of the openssl shared libraries | paquete
       | libopenssl1_0_0-hmac-32bit  | HMAC files for FIPS-140-2 integrity checking of the openssl shared libraries | paquete
       | libopenssl1_0_0-steam       | Secure Sockets and Transport Layer Security for steam                        | paquete
       | libopenssl1_0_0-steam-32bit | Secure Sockets and Transport Layer Security for steam                        | paquete
    i+ | libopenssl1_1               | Secure Sockets and Transport Layer Security                                  | paquete
    i+ | libopenssl1_1-32bit         | Secure Sockets and Transport Layer Security                                  | paquete
       | libopenssl1_1-hmac          | HMAC files for FIPS-140-2 integrity checking of the openssl shared libraries | paquete
       | libopenssl1_1-hmac-32bit    | HMAC files for FIPS-140-2 integrity checking of the openssl shared libraries | paquete
       | libxmlsec1-openssl1         | OpenSSL crypto plugin for XML Security Library                               | paquete
    fabioonier@linux-53z1:/usr/lib64> adb services
    adb: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory
    fabioonier@linux-53z1:/usr/lib64>

    En la imagen anterior se puede ver que android-tools requiere, específicamente, libcrypto.so.1, aunque muestra libcrypto.so.1()(64 bit). No se qué sifnigica eso.

    Esta pensando en si habría alguna manera de saber cuál es el archivo en el cual el programa adb llama a esa librería, editarlo con vi y cambiar el nombre libcrypto.so.1 por libcrypto.so.1.0.0 de tal manera que adb llame a la librería que sí tengo instalada en mi computador.
    ¿Será posible?

  3. #13
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    992
    Post Thanks / Like
    Poder de Credibilidad
    11
    adb: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

    adb: erro cargando librerías compartidas: libcrypto.so.1: no se puede abrir el fichero objeto compartido: No existe el fichero o el directorio


    Es como si la estuviera buscando en un sitio distinto a donde la tengas (siempre que la que tengas sea la correcta).

    Cuando hacía C en el 2003 recuerdo que mirando el código fuente podía usar un depurador creo que era, que te ejecutaba línea a línea el código. No tengo conocimientos para ello pero sin saber qué hace exactamente el programa, dónde busca y qué busca, estamos dando palos de ciego.

    A mi no se me ocurren más cosas. Salen muchos resultados en Google poniendo en la búsqueda:

    adb: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

    Es cuestión de leer y encontrar una fórmula mágica. Siento no poder ayudar más.

    EDIT: lo de (64 bit) es que la versión del paquete a usar es el que no lleva la coletilla -32bit de coletilla.


    Saludos

  4. #14
    Fecha de Ingreso
    03-abril-2007
    Ubicación
    Mexico/SanLuisPotosi
    Mensajes
    904
    Post Thanks / Like
    Poder de Credibilidad
    14
    Yo te recomiendo mejor bajar Android Studio que es la SDK oficial y agregarla al PATH y así mantenerla actualizada.

    Código:
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> ldd adb
            linux-vdso.so.1 (0x00007ffcfdbde000)
            libdl.so.2 => /lib64/libdl.so.2 (0x00007f0423db4000)
            libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0423b95000)
            libm.so.6 => /lib64/libm.so.6 (0x00007f042385d000)
            librt.so.1 => /lib64/librt.so.1 (0x00007f0423655000)
            libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f042343d000)
            libc.so.6 => /lib64/libc.so.6 (0x00007f0423082000)
            /lib64/ld-linux-x86-64.so.2 (0x00007f04241fe000)
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> adb devices
    * daemon not running; starting now at tcp:5037
    * daemon started successfully
    List of devices attached
    
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> ls -la /usr/lib64/ | grep libcrypto
    lrwxrwxrwx   1 root root        19 dic 17  2018 libcrypto.so -> libcrypto.so.43.0.1
    -r-xr-xr-x   1 root root   2520456 ene 10 05:13 libcrypto.so.1.0.0
    -rwxr-xr-x   1 root root   2681240 ene 10 06:01 libcrypto.so.1.1
    lrwxrwxrwx   1 root root        19 dic 17  2018 libcrypto.so.43 -> libcrypto.so.43.0.1
    -rwxr-xr-x   1 root root   1934176 dic 17  2018 libcrypto.so.43.0.1
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> adb  
    Android Debug Bridge version 1.0.41
    Version 29.0.1-5644136
    Installed as /home/darkspark/Android/Sdk/platform-tools/adb
    
    global options:
    
    .....
    .....
    
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> sudo zypper search --provides libcrypto.so.1
    Cargando datos del repositorio...
    Leyendo los paquetes instalados...
    
    E  | Nombre                | Resumen                                     | Tipo    
    ---+-----------------------+---------------------------------------------+--------
    i+ | libopenssl1_0_0       | Secure Sockets and Transport Layer Security | paquete
       | libopenssl1_0_0-32bit | Secure Sockets and Transport Layer Security | paquete
    i+ | libopenssl1_1         | Secure Sockets and Transport Layer Security | paquete
    i+ | libopenssl1_1-32bit   | Secure Sockets and Transport Layer Security | paquete
    


    Saludos.
    __________________________________________________

    Mi Blog:
    http://elblogdedarkspark.blogspot.mx/
    Canales de Youtube:
    http://www.youtube.com/user/DarkSpark2099
    http://www.youtube.com/user/defton En des-uso

  5. #15
    Fecha de Ingreso
    22-octubre-2012
    Mensajes
    66
    Post Thanks / Like
    Poder de Credibilidad
    8
    Cita Iniciado por Defton Ver Mensaje
    Yo te recomiendo mejor bajar Android Studio que es la SDK oficial y agregarla al PATH y así mantenerla actualizada.

    Código:
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> ldd adb
            linux-vdso.so.1 (0x00007ffcfdbde000)
            libdl.so.2 => /lib64/libdl.so.2 (0x00007f0423db4000)
            libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0423b95000)
            libm.so.6 => /lib64/libm.so.6 (0x00007f042385d000)
            librt.so.1 => /lib64/librt.so.1 (0x00007f0423655000)
            libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f042343d000)
            libc.so.6 => /lib64/libc.so.6 (0x00007f0423082000)
            /lib64/ld-linux-x86-64.so.2 (0x00007f04241fe000)
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> adb devices
    * daemon not running; starting now at tcp:5037
    * daemon started successfully
    List of devices attached
    
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> ls -la /usr/lib64/ | grep libcrypto
    lrwxrwxrwx   1 root root        19 dic 17  2018 libcrypto.so -> libcrypto.so.43.0.1
    -r-xr-xr-x   1 root root   2520456 ene 10 05:13 libcrypto.so.1.0.0
    -rwxr-xr-x   1 root root   2681240 ene 10 06:01 libcrypto.so.1.1
    lrwxrwxrwx   1 root root        19 dic 17  2018 libcrypto.so.43 -> libcrypto.so.43.0.1
    -rwxr-xr-x   1 root root   1934176 dic 17  2018 libcrypto.so.43.0.1
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> adb  
    Android Debug Bridge version 1.0.41
    Version 29.0.1-5644136
    Installed as /home/darkspark/Android/Sdk/platform-tools/adb
    
    global options:
    
    .....
    .....
    
    darkspark@linux-xdah:~/Android/Sdk/platform-tools> sudo zypper search --provides libcrypto.so.1
    Cargando datos del repositorio...
    Leyendo los paquetes instalados...
    
    E  | Nombre                | Resumen                                     | Tipo    
    ---+-----------------------+---------------------------------------------+--------
    i+ | libopenssl1_0_0       | Secure Sockets and Transport Layer Security | paquete
       | libopenssl1_0_0-32bit | Secure Sockets and Transport Layer Security | paquete
    i+ | libopenssl1_1         | Secure Sockets and Transport Layer Security | paquete
    i+ | libopenssl1_1-32bit   | Secure Sockets and Transport Layer Security | paquete
    


    Saludos.
    Hola, Defton. Gracias por tu sugerencia y te tengo una pregunta: ¿El Android Studio no es un SDK y además muy pesado? Lo que pasa es que, aunque se cosas de programación no soy un desarrollador, y menos de aplicaciones para Android.
    En otras palabras, ¿será necesario instalar un SDK tan pesado para conseguir que DroidCam me permita conectar con mi smartphone via USB?

  6. #16
    Fecha de Ingreso
    03-abril-2007
    Ubicación
    Mexico/SanLuisPotosi
    Mensajes
    904
    Post Thanks / Like
    Poder de Credibilidad
    14
    Efectivamente android estudio es el SDK oficial, adb,fastboot,etc forman parte de el, y si, puede considerarse pesado (alrededor de 800Mb la descarga y 1,4Gb ya extraido) pero a mi manera de ver tiene algunas ventajas, pues te permite indicar la ruta donde quieres guardar el "driver" (el directorio plataform-tools solo pesa 30Mb) por lo que puedes borrar android studio después de bajar lo que necesitas, aparte te descarga la versión mas reciente de los archivos, y puedes seguir actualizándolos con android studio (si no lo borras claro jeje).
    Otra ventaja que yo veo, es que al estar los archivos en la partición /home, al momento de actualizar opensuse, simplemente se vuelve a agregar al path y listo, ya esta "instalado" otra vez.

    Creo que tu problema es la versión de adb que tienes instalada, y esta buscando las librerías de las dependencias con nombres y/o versiones diferentes.
    ¿Como instalaste el paquete? pues a mi no me aparece en los repositorios que tengo configurados, ni aqui.
    Última edición por Defton; 10-may-2020 a las 17:10
    __________________________________________________

    Mi Blog:
    http://elblogdedarkspark.blogspot.mx/
    Canales de Youtube:
    http://www.youtube.com/user/DarkSpark2099
    http://www.youtube.com/user/defton En des-uso

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ¿Se puede hacer funcionar suse desde un pendrive?
    By Miguel Machado in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 31-dic-2017, 00:43
  2. Respuestas: 0
    Último mensaje: 25-dic-2008, 20:49
  3. Problemas para hacer funcionar https
    By cosmic in forum Internet, Redes y Wireless
    Respuestas: 0
    Último mensaje: 01-may-2007, 18:36
  4. Problemas para hacer funcionar https
    By cosmic in forum Instalación y Actualizaciones
    Respuestas: 0
    Último mensaje: 01-may-2007, 18:36
  5. Pasos para hacer funcionar xgl con gnome y kde
    By josem in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 4
    Último mensaje: 13-sep-2006, 02:20

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •