Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 20

Tema: Problemas con adb para hacer funcionar DroidCam desde USB en mi computador

  1. #1
    Fecha de Ingreso
    22-octubre-2012
    Mensajes
    79
    Post Thanks / Like
    Poder de Credibilidad
    9

    Problemas con adb para hacer funcionar DroidCam desde USB en mi computador

    Hola a todos.
    Estoy tratando de usar mi celular como cámara web para las hacer mis clases sincrónicas con mis estudiantes del colegio. Para ello he usado Ipwebcam en mi celular pero la conexión la hace por Wifi y tiene muchísima latencia.
    La otra opción que he encontrado ha sido usar DroidCam que tiene las opciones de conectar por Wifi (con le problema de la latencia) o de hacer conexión via USB y con una latencia muuuuuuy baja.
    Para ello he seguido las instrucciones de esta página web
    https://technibuzz.com/how-to-instal...inux-manually/

    y de este video
    https://www.youtube.com/watch?v=9ucoOy4uu5c

    pero aún no logro la conexión por USB entre mi celular y mi computadora usando DroidCam. Me sale el siguiente error cada que lo intento
    Captura de pantalla de 2020-05-06 12-56-31.jpg

    Y cuando uso la terminal para buscar los dispositivos conectados a mi computadora me sale ésto:
    Código:
    fabioonier@linux-53z1:~> adb services
    adb: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory
    fabioonier@linux-53z1:~>
    y no logro encontrar dónde descargar esa librería libcrypto.so.1

    Tengo Opensuse Leap 15.1, escritorio GNOME

    ¿Qué más puedo hacer?

  2. #2
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    Aquí tienes la librería:

    Código:
    krovikan@linux:~/Descargas> zypper se -v libcrypto
    
    E | Nombre                 | Tipo        | Versión           | Arquitectura | Repositorio                         
    --+------------------------+-------------+-------------------+--------------+-------------------------------------
      | libcrypto43            | paquete     | 2.8.0-lp151.1.3   | x86_64       | Repositorio principal (OSS)         
        name: libcrypto43
      | libcrypto43-32bit      | paquete     | 2.8.0-lp151.1.3   | x86_64       | Repositorio principal (OSS)         
        name: libcrypto43-32bit
      | libcryptopp            | paquete src | 5.6.5-lp151.3.3.1 | noarch       | Repositorio de actualizaciones (OSS)
        name: libcryptopp
      | libcryptopp-devel      | paquete     | 5.6.5-lp151.2.3   | x86_64       | Repositorio principal (OSS)         
        name: libcryptopp-devel
      | libcryptopp-devel      | paquete     | 5.6.5-lp151.3.3.1 | i586         | Repositorio de actualizaciones (OSS)
        name: libcryptopp-devel
      | libcryptopp-devel      | paquete     | 5.6.5-lp151.3.3.1 | x86_64       | Repositorio de actualizaciones (OSS)
        name: libcryptopp-devel
      | libcryptopp5_6_5       | paquete     | 5.6.5-lp151.2.3   | x86_64       | Repositorio principal (OSS)         
        name: libcryptopp5_6_5
      | libcryptopp5_6_5       | paquete     | 5.6.5-lp151.3.3.1 | i586         | Repositorio de actualizaciones (OSS)
        name: libcryptopp5_6_5
      | libcryptopp5_6_5       | paquete     | 5.6.5-lp151.3.3.1 | x86_64       | Repositorio de actualizaciones (OSS)
        name: libcryptopp5_6_5
      | libcryptopp5_6_5-32bit | paquete     | 5.6.5-lp151.2.3   | x86_64       | Repositorio principal (OSS)         
        name: libcryptopp5_6_5-32bit
      | libcryptopp5_6_5-32bit | paquete     | 5.6.5-lp151.3.3.1 | x86_64       | Repositorio de actualizaciones (OSS)
        name: libcryptopp5_6_5-32bit
    Has de instalar el paquete libcrypto43 con

    Código:
    sudo zypper in libcrypto43
    o desde yast.


    Saludos

  3. #3
    Fecha de Ingreso
    22-octubre-2012
    Mensajes
    79
    Post Thanks / Like
    Poder de Credibilidad
    9
    Hola, Krovikan. Muchas gracias por responder.
    Te cuento que esa librería ya la tengo instalada y al parecer no contiene ese archivo en particular.
    Código:
    fabioonier@linux-53z1:~> sudo zypper se libcrypto43
    [sudo] password for root: 
    Cargando datos del repositorio...
    Advertencia: Parece que el repositorio 'Repositorio principal de actualizaciones' no está actualizado. Se recomienda usar una réplica o servidor distintos.
    Leyendo los paquetes instalados...
    
    E  | Nombre            | Resumen                            | Tipo   
    ---+-------------------+------------------------------------+--------
    i+ | libcrypto43       | An SSL/TLS protocol implementation | paquete
       | libcrypto43-32bit | An SSL/TLS protocol implementation | paquete
    fabioonier@linux-53z1:~>
    Tengo algunos archivos con nombres similares, pero no el que me pide adb. Por ejemplo, tengo uno que se llama libcrypto.so.1.1 pero el que se necesita es libcrypto.so.1

    ¿Qué otra cosa puedo intentar?

  4. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.673
    Post Thanks / Like
    Poder de Credibilidad
    10
    Puedes crear un enlace simbólico con el comando ln -s origen destino
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  5. #5
    Fecha de Ingreso
    22-octubre-2012
    Mensajes
    79
    Post Thanks / Like
    Poder de Credibilidad
    9
    Hola, DiabloRojo.
    Hasta donde tengo entendido un enlace simbólico se hace con archivos que ya tengo en el sistema. ¿Cómo hago uno a un archivo que no tengo instalado?

  6. #6
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    Se refiere a que crees un enlace simbólico a esa librería con el nombre que pide adb. En este caso (las rutas son las que tengas tú):

    sudo ln -s /lib64/libcrypto.so.1.1 /lib64/libcrypto.so.1

    La primera ruta es el nombre de la librería que tienes y la segunda ruta es el nombre del fichero virtual que creas (que apunta a la primera ruta).

    Eso te genera un fichero virtual, el librcrypto.so.1 que apunta a libcrypto.so.1.1. El sistema encuentra su fichero aunque realmente está accediendo a otro. Por ejemplo:

    En mi /lib64 puedo ver un fichero virtual llamado libutil.so.1 pero al señalarlo se puede ver que abajo te muestra a donde apunta, en mi caso a libutil-2.26.so.

    Esto es muy útil para que el sistema acceda a nuevas versiones de una librería a través del mismo nombre siempre.


    Saludos

  7. #7
    Fecha de Ingreso
    22-octubre-2012
    Mensajes
    79
    Post Thanks / Like
    Poder de Credibilidad
    9
    Cita Iniciado por Krovikan Ver Mensaje
    Se refiere a que crees un enlace simbólico a esa librería con el nombre que pide adb. En este caso (las rutas son las que tengas tú):

    sudo ln -s /lib64/libcrypto.so.1.1 /lib64/libcrypto.so.1

    La primera ruta es el nombre de la librería que tienes y la segunda ruta es el nombre del fichero virtual que creas (que apunta a la primera ruta).

    Eso te genera un fichero virtual, el librcrypto.so.1 que apunta a libcrypto.so.1.1. El sistema encuentra su fichero aunque realmente está accediendo a otro. Por ejemplo:

    En mi /lib64 puedo ver un fichero virtual llamado libutil.so.1 pero al señalarlo se puede ver que abajo te muestra a donde apunta, en mi caso a libutil-2.26.so.

    Esto es muy útil para que el sistema acceda a nuevas versiones de una librería a través del mismo nombre siempre.


    Saludos
    Creé ese enlace simbólico y me salió este error
    Código:
    fabioonier@linux-53z1:/usr/lib64> adb services
    adb: symbol lookup error: adb: undefined symbol: EVP_EncodedLength
    Supongo que eso significa que libcrypto.so.1.1 no es una actualización de libcrypto.so.1 y, por tanto, contiene información que no es útil para el funcionamiento de adb.

    No encuentro en ninguna página web información acerca de lo que contiene el archivo libcrypto.so.1 de tal manera que pueda reconstruirlo o adaptarlo para Opensuse LEap 15.1

    ¿Qué otra cosa puedo intentar?
    Última edición por fabioonier; 07-may-2020 a las 19:53

  8. #8
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    He mirado en mi Yast y ese archivo lo proporciona sólo:

    libopenssl1_0_0

    Mi versión es la 1.0.2p-lp151.5.13.1


    Saludos

  9. #9
    Fecha de Ingreso
    22-octubre-2012
    Mensajes
    79
    Post Thanks / Like
    Poder de Credibilidad
    9
    Cita Iniciado por Krovikan Ver Mensaje
    He mirado en mi Yast y ese archivo lo proporciona sólo:

    libopenssl1_0_0

    Mi versión es la 1.0.2p-lp151.5.13.1


    Saludos
    Antes de proseguir, vale la pena decir que no solamente quiero solucionar el problema sino que también quiero aprender de linux y Opensuse.
    ¿Qué buscaste y cómo lo buscaste? En otras palabras, ¿cómo supiste qué buscar?
    Y, con respecto a la solución del problema, ¿sugieres que cree un enlace simbólico al archivo que encontraste?

  10. #10
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    En yast2-->Instalar/desinstalar tienes unas casillas debajo del campo de búsqueda.

    Una de ellas es Proporciona. Entonces si en el campo de búsqueda escribo libcrypto.so.1 y marco la casilla de Proporciona, me salen todos los paquetes (instalados o no) que proporcionen lo que has escrito en el campo de búsqueda.

    No hagas ningún enlace y borra el que creastes. Instala el paquete de openssl1_0_0 y ya dices qué tal.


    Saludos

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ¿Se puede hacer funcionar suse desde un pendrive?
    By Miguel Machado in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 30-dic-2017, 23:43
  2. Respuestas: 0
    Último mensaje: 25-dic-2008, 19:49
  3. Problemas para hacer funcionar https
    By cosmic in forum Internet, Redes y Wireless
    Respuestas: 0
    Último mensaje: 01-may-2007, 18:36
  4. Problemas para hacer funcionar https
    By cosmic in forum Instalación y Actualizaciones
    Respuestas: 0
    Último mensaje: 01-may-2007, 18:36
  5. Pasos para hacer funcionar xgl con gnome y kde
    By josem in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 4
    Último mensaje: 13-sep-2006, 02:20

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •