Gracias Gracias:  7
Me Gusta Me Gusta:  1
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 16

Tema: ¿Cómo resolver actualización? SOLUCIONADO

  1. #1
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    965
    Post Thanks / Like
    Poder de Credibilidad
    11

    Question ¿Cómo resolver actualización? SOLUCIONADO

    Hola:

    Hace semanas, de hecho más de 1 mes, tengo disponible siempre en el plasmoide pk-updates de Plasma 5 una actualización que no sé resolver.

    El pk-updates no sabe hacerlo y viendo el paquete en el Yast, tampoco sé qué hacer.

    Como una imagen vale más que 1000 palabras he compuesto una imagen a partir de 2 distintas. En la derecha Actualización en Línea y en la izquierda Yast.

    Yast me dice que tengo instalada la versión 7.3.1 (y parece que tambien la 6.2) de dicha librería.

    Actualización en Línea parece que me diga que tengo la 6.2 y quiere borrar algo.

    En fin, la imagen (siento no reducirla pero igual no se leería lo que arregla):



    Código:
    krovikan@linux:~/Descargas> zypper se -iv libgio-2*
    Cargando datos del repositorio...
    Leyendo los paquetes instalados...
    
    E  | Nombre             | Tipo    | Versión            | Arquitectura | Repositorio                         
    ---+--------------------+---------+--------------------+--------------+-------------------------------------
    i+ | libgio-2_0-0       | paquete | 2.54.3-lp151.6.2   | x86_64       | Repositorio principal (OSS)         
        name: libgio-2_0-0
    i+ | libgio-2_0-0       | paquete | 2.54.3-lp151.7.3.1 | x86_64       | Repositorio de actualizaciones (OSS)
        name: libgio-2_0-0
    i+ | libgio-2_0-0-32bit | paquete | 2.54.3-lp151.7.3.1 | x86_64       | Repositorio de actualizaciones (OSS)
        name: libgio-2_0-0-32bit
    SOLUCIÓN: Teclear los siguientes comandos

    Código:
    sudo rpm --rebuilddb
    sudo zypper clean -a

    Saludos
    Última edición por Krovikan; 25-feb-2020 a las 12:34 Razón: Resolución

  2. #2
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.778
    Post Thanks / Like
    Poder de Credibilidad
    24
    Hola.

    ¿Por qué lo tienes marcado para desinstalar? Prueba a marcarlo para actualizar o con la opción --force en zypper.

    salud!!

  3. Gracias Krovikan ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    965
    Post Thanks / Like
    Poder de Credibilidad
    11
    Cita Iniciado por karlggest Ver Mensaje
    ¿Por qué lo tienes marcado para desinstalar?
    Me lo marcó él solito.

    Respecto a zypper no lo uso. Sé alguna cosa pero casi nada. Y no sé qué quieres que teclee delante del --force.


    Saludos

  5. #4
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    332
    Post Thanks / Like
    Poder de Credibilidad
    2
    Y si pruebas a ver si es lo mismo que me pasó a mi?
    Código:
    sudo zypper up --allow-vendor-change

  6. Gracias Krovikan ha agradecido este mensaje
  7. #5
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    965
    Post Thanks / Like
    Poder de Credibilidad
    11
    Eso no sirve. Es más, en la lista ni aparece libgio-2_0-0.

    Sólo aparece en Actualización en línea, y en pk_updates como openSUSE-2020-25(1).

    Tengo 11 aplicaciones bloquedas (aunque el número de paquetes sea 27) pero ninguna relacionada:

    Los 27 elementos siguientes están bloqueados y no cambiarán con ninguna acción:
    Disponible:
    brltty brltty-driver-at-spi2 brltty-driver-brlapi brltty-driver-xwindow brltty-lang hugin kcm_tablet kcm_tablet-lang kleopatra
    kleopatra-lang kpat kpat-lang kreversi kreversi-lang ksudoku ksudoku-lang marble marble-data marble-doc marble-kde marble-lang
    Mesa-dri-nouveau mutt mutt-doc mutt-lang postfix xbrlapi


    Saludos

  8. #6
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    332
    Post Thanks / Like
    Poder de Credibilidad
    2
    Y con...
    Código:
    sudo zypper patch
    o...
    Código:
    sudo zypper patch --allow-vendor-change
    Creo que "actualización en línea" aplica los parches, no es una actualización normal:

    https://es.opensuse.org/M%C3%B3dulo_..._en_l%C3%ADnea

  9. Gracias Krovikan ha agradecido este mensaje
  10. #7
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    965
    Post Thanks / Like
    Poder de Credibilidad
    11
    Ahora sí sale la actualización.

    Tanto con --allow-vendor-change como sin él sale:

    krovikan@linux:~/Descargas> sudo zypper patch --allow-vendor-change
    Cargando datos del repositorio...
    Leyendo los paquetes instalados...
    Resolviendo dependencias de paquete...

    Los 27 elementos siguientes están bloqueados y no cambiarán con ninguna acción:
    Disponible:
    brltty brltty-driver-at-spi2 brltty-driver-brlapi brltty-driver-xwindow brltty-lang hugin kcm_tablet kcm_tablet-lang kleopatra
    kleopatra-lang kpat kpat-lang kreversi kreversi-lang ksudoku ksudoku-lang marble marble-data marble-doc marble-kde marble-lang
    Mesa-dri-nouveau mutt mutt-doc mutt-lang postfix xbrlapi

    El siguiente parche NUEVO va a ser instalado:
    openSUSE-2020-25

    El siguiente paquete va a ser ELIMINADO:
    libgio-2_0-0

    1 paquete a quitar.
    Después de la operación, se liberarán 1,6 MiB.
    ¿Desea continuar? [s/n/v/...? mostrar todas las opciones] (s): s

    Buscando conflictos de archivos: .................................................. ...............................................[terminado]
    (1/1) Eliminando libgio-2_0-0-2.54.3-lp151.6.2.x86_64 .................................................. ..............................[error]
    Error al eliminar (58457)libgio-2_0-0-2.54.3-lp151.6.2.x86_64(@System):
    Error: Subprocess failed. Error: RPM fallido: La señal 11 (Violación de segmento) ha interrumpido el comando
    .
    ¿Cancelar, reintentar o ignorar? [a/r/i] (a): a
    Problema durante la instalación o la eliminación de paquetes:
    La instalación se ha cancelado siguiendo las indicaciones.

    Consulte el mensaje de error anterior para obtener sugerencias.


    Saludos

  11. Me Gusta Jordi4321 le ha gustado este mensaje
  12. #8
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    332
    Post Thanks / Like
    Poder de Credibilidad
    2
    La violación de segmento ni idea, ya tendrá que aparecer algún pro. Igual aquí entra la opción "force" pero no tengo ni idea.
    Prueba esto:
    https://forums.opensuse.org/showthre...85#post2865785
    sudo rpm --rebuilddb
    sudo zypper clean -a
    Y re-ejecutar el zypper patch.

    En tu caso, si no funciona, según dicen ahí sería algo así:
    Código:
    sudo zypper remove -f libgio-2_0-0
    Y reintentar instalar los parches.
    Aunque espera a que aparezca alguien más para esto último, no se si puedes forzar algo así a la ligera.
    Última edición por Jordi4321; 24-feb-2020 a las 18:21

  13. Gracias Krovikan ha agradecido este mensaje
  14. #9
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    965
    Post Thanks / Like
    Poder de Credibilidad
    11
    Antes de probar tu sugerencia, la que sí he probado es la del --force pero especificando la versión:

    NOTA: No pruebes a teclear el contenido de tu segundo code (sin versión) pues te dirá que te va a desinstalar medio sistema (480 paquetes)

    Código:
    krovikan@linux:~/Descargas> sudo zypper remove --force libgio-2_0-0-2.54.3-lp151.6.2.x86_64
    Cargando datos del repositorio...
    Advertencia: No hay repositorios definidos. Se trabajará solo con las resoluciones instaladas. No se puede instalar nada.
    Leyendo los paquetes instalados...
    Resolviendo dependencias de paquete...
    
    El siguiente paquete va a ser ELIMINADO:
      libgio-2_0-0
    
    1 paquete a quitar.
    Después de la operación, se liberarán 1,6 MiB.
    ¿Desea continuar? [s/n/v/...? mostrar todas las opciones] (s): s
    (1/1) Eliminando libgio-2_0-0-2.54.3-lp151.6.2.x86_64 ................................................................................[error]
    Error al eliminar (1320)libgio-2_0-0-2.54.3-lp151.6.2.x86_64(@System):
    Error: Subprocess failed. Error: RPM fallido: La señal 11 (Violación de segmento) ha interrumpido el comando.                                
    ¿Cancelar, reintentar o ignorar? [a/r/i] (a): a
    Problema durante la instalación o la eliminación de paquetes:
    La instalación se ha cancelado siguiendo las indicaciones.                                                                                   
    Consulte el mensaje de error anterior para obtener sugerencias.

    Saludos

  15. #10
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    332
    Post Thanks / Like
    Poder de Credibilidad
    2
    Son solo apuntes xD
    Ya te digo que no tengo ni idea de que está pasando, pero creo que el asunto está bien encaminado. A ver si DR o alguien que sabe más te da la solución.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Respuestas: 3
    Último mensaje: 04-ene-2016, 03:49
  2. Error actualización skanlite-doc ( SOLUCIONADO )
    By mikrios in forum General OpenSUSE
    Respuestas: 0
    Último mensaje: 10-jun-2014, 17:44
  3. Actualización KDE 4.8 [solucionado]
    By manolobarea in forum General OpenSUSE
    Respuestas: 13
    Último mensaje: 01-feb-2012, 02:01
  4. Actualizacion de 11.2 a 11.3 por Red [solucionado]
    By CromoRed in forum Instalación y Actualizaciones
    Respuestas: 8
    Último mensaje: 13-ene-2011, 17:34
  5. Actualizacion de XFCE estropeo mi sistema!!! [SOLUCIONADO]
    By chester08 in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 7
    Último mensaje: 22-ago-2009, 18:51

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •