Gracias Gracias:  15
Me Gusta Me Gusta:  20
No me Gusta No me Gusta:  1
Página 1 de 3 123 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 27

Tema: Como actualizar 490 paquetes con zypper dup aceptando o cancelando algunos

  1. #1
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    527
    Post Thanks / Like
    Poder de Credibilidad
    10

    Como actualizar 490 paquetes con zypper dup aceptando o cancelando algunos Solucionad

    Hola a todos.
    Después de un tiempo inactivo por enfermedad me encuentro con 490 actualizaciones que no puedo instalar,lamento este bloqueo mental pero no se como aceptar o cancelar algunos de
    estos paquetes.
    Agradeceré vuestra inestimable ayuda.
    (Feu servir Intro o la tecla d'espai per visualitzar el text per línies o per pàgines.)

    Per poder instal·lar el paquet Mesa-dri-nouveau, heu d'acceptar els termes de la llicència:

    WARNING: Nouveau DRI/3D driver selected.

    This driver is considered experimental and is known to have issues with
    applications that use certain 3D acceleration features of modern
    NVIDIA hardware.

    Symptoms include application crashes or lockups & crashes of your system's
    graphical environment. Older Hardware and less demanding applications may work
    just fine and do benefit from the Hardware acceleration features this driver
    offers over software emulation.

    Use of this driver is especially not recommended for use with the KDE Desktop
    Environment or Qt-based Applications.

    The hardware vendor potentially offers alternative drivers.

    Please click "Accept" if you accept the risks that may come with the
    installation of this driver. Choose "Cancel" to prevent installation
    of the driver and use software emulation instead.


    (Premeu "q" per sortir del paginador.)
    ~
    Última edición por catlib; 07-feb-2020 a las 19:26 Razón: Solucionado

  2. #2
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    312
    Post Thanks / Like
    Poder de Credibilidad
    2
    Buenas!

    Esto que te dice es que vas a instalar el driver Nouveau.
    Si usas los propietarios de Nvidia puedes poner este paquete como tabú en yast para que no se actualice, y ya no aparece ese mensaje.
    Si no quieres hacer eso, tienes que bajar ese texto hasta el final y escribir Yes o Si, y enter. Para bajar usa la barra espaciadora, con el enter cuando llegas al final tienes problemas.
    Después de aceptar esto o bloquearlo ya podrás actualizar.

    Salu2!

  3. Gracias catlib ha agradecido este mensaje
    Me Gusta Archrysler, catlib le ha gustado este mensaje
  4. #3
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    527
    Post Thanks / Like
    Poder de Credibilidad
    10
    Hola jordi4321
    E quita do nvidia de los repositorios de programari y no consigo hacer la instalación,por favor os agradeceré un poco de paciencia y ayuda lo mas explicita posible.

  5. #4
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    312
    Post Thanks / Like
    Poder de Credibilidad
    2
    Tranquilo...
    A ver lo que haría yo primero antes de quitar nada en los repos es ver que driver estás usando. Hay 2 posibilidades normalmente, uno es el libre (nouveau) y otro es el propietario (nvidia). Entonces, para saber cual estás usando:
    Vas a Yast -> Información del hardware.
    Cuando cargue la info, abres Pantalla -> TuTarjetaGráfica y miras que pone en "Controlador", y nos lo dices.

    Cuando sepamos esto, seguimos ;-)

  6. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib le ha gustado este mensaje
  7. #5
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    527
    Post Thanks / Like
    Poder de Credibilidad
    10

  8. #6
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    312
    Post Thanks / Like
    Poder de Credibilidad
    2
    Vale, estás usando el Nouveau.

    Para tu tarjeta habría que usar los drivers 340 en caso de querer usar los propietarios, y no están en los repos oficiales que vienen en OpenSuse, así que habría que instalar desde la web de Nvidia a mano. Resumiendo, opción no válida :S

    Lo que tienes que hacer es:
    1- sudo zypper dup
    2- Lo he desbloqueado en el mío para poder escribirlo bien. Te aparecerá lo que escribiste en el primer mensaje, entonces aprietas la tecla espacio, a veces hay que apretar varias veces. Luego, te pregunta esto:
    Código:
    ¿Acepta los términos de la licencia? [si/no] (no):
    En català seguramente si estás usando català en el sistema. Aqui escribes si y aprietas la tecla enter.

    Y ya está, continuará la actualización.
    Si te aparecen otros mensajes similares, que pasa a veces, tendrás que hacer los mismos pasos.

    Sabiendo esto debería actualizarse sin demasiados problemas....

    Pd. El repo de Nvidia puedes dejarlo deshabilitado, no te sirve para mucho....

    Salu2!

  9. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib le ha gustado este mensaje
  10. #7
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    948
    Post Thanks / Like
    Poder de Credibilidad
    11
    Cita Iniciado por Jordi4321 Ver Mensaje
    1- sudo zypper dup
    @catlib, antes de hacer el punto 1 dinos que openSUSE tienes. Porque si tienes openSUSE Leap 15.1 el comando es sudo zypper up y si tienes openSUSE Thumbleweed (o TW como se le suele llamar) el comando es el que dice jordi, sudo zypper dup.

    Saludos

  11. Gracias catlib ha agradecido este mensaje
    Me Gusta Jordi4321, catlib le ha gustado este mensaje
  12. #8
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    312
    Post Thanks / Like
    Poder de Credibilidad
    2
    dinos que openSUSE tienes
    Cierto, yo he dado por hecho que tiene TW, al escribir en el primer mensaje "dup"....

  13. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib le ha gustado este mensaje
  14. #9
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    527
    Post Thanks / Like
    Poder de Credibilidad
    10
    Tengo Tumbleweed y jordi le doy a la tecla espacio y nada

  15. #10
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    312
    Post Thanks / Like
    Poder de Credibilidad
    2
    A mi me dice esto:
    Código:
    El siguiente paquete va a ser actualizado:
      Mesa-dri-nouveau
    
    1 paquete a actualizar.
    Tamaño total de descarga: 8,9 MiB. Ya en caché: 0 B. Después de la operación, se
    liberarán 4,1 KiB.
    ¿Desea continuar? [s/n/v/...? mostrar todas las opciones] (s): s
    (Utilice las teclas de dirección o Av Pág/Re Pág para desplazarse por el texto l
    ínea a línea o página a página.)
    
    Para poder instalar 'Mesa-dri-nouveau', debe aceptar los términos del siguiente 
    acuerdo de licencia:
    
    (...)
    Utilice las teclas de dirección o Av Pág/Re Pág para desplazarse por el texto línea a línea o página a página.

    Aunque le doy al espacio y funciona perfecto.
    Lee bien todo lo que te pregunta, igual te dejas la parte de..."desea continuar?", ahí tienes que escribir s y enter.

  16. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib le ha gustado este mensaje

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Actualizar con zypper dup o zypper up en openSUSE Tumbleweed [solucionado]
    By ylarguex in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 23-mar-2018, 01:46
  2. Respuestas: 3
    Último mensaje: 04-ene-2016, 03:49
  3. Duda con zypper y la reintalación de paquetes
    By jony127 in forum General OpenSUSE
    Respuestas: 9
    Último mensaje: 30-nov-2010, 23:20
  4. Error, La instalación de Algunos Paquetes ha fallado
    By Lophophora in forum Instalación y Actualizaciones
    Respuestas: 5
    Último mensaje: 26-jun-2008, 07:28
  5. La instalación de algunos paquetes ha fallado
    By latestanswerer in forum Instalación y Actualizaciones
    Respuestas: 3
    Último mensaje: 16-mar-2006, 19:19

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •