Gracias Gracias:  1
Me Gusta Me Gusta:  1
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 1 de 1

Tema: Configurar compositor Picom / Compton en Lxde

  1. #1
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    412
    Post Thanks / Like
    Poder de Credibilidad
    3

    Configurar compositor Picom / Compton en Lxde

    Lxde no lleva de serie un compositor, esto hace que si no instalas uno el sistema haga cosas extrañas, como por ejemplo algunos que he visto son: programas que dibujan mal el contenido, youtube con vídeos con rayas o entrecortados, menús con comportamientos "erráticos", etc.
    Bueno, siempre he usado Compton pero ahora lo están "mudando" a Picom. hay más opciones, pero por la info que tengo, esta es la mejor opción.
    En OpenSuse co-existen los 2 en los repos, pero parece que ahora funciona bien instalar solamente Picom. Instalé Compton y hay ciertos programas que se quedaban bloqueados al cerrarlos por ejemplo. Hay una gui para configurar, "compton-conf", que aparentemente funciona, pero si ejecuto "picom" desde la teminal aparecen un montón de errores con las opciones que escribe, que parece están en proceso de desaparición, así que hay que configurar el asunto a mano de momento.
    Aquí como he conseguido configurar Picom solamente en TW y Lxde:
    1- Instalamos el paquete picom:
    Código:
    sudo zypper in picom
    2- Creamos el archivo de configuración en /home/usuario/.config/picom.conf.
    3- Hay muchas opciones para configurar. La única info detallada que he encontrado es la wiki de Arch:
    https://wiki.archlinux.org/index.php/Picom
    Y desde ahí:
    https://jlk.fjfi.cvut.cz/arch/manpages/man/picom.1
    Entonces, según esa wiki hay un archivo picom.conf por defecto en /etc/xdg/picom.conf, para copiarlo a /.config y modificarlo, que no he encontrado en OpenSuse, entonces he probado varias opciones a mi aire, pero no ha funcionado. Es delicado ese archivo parece. Bueno, lo que he hecho:
    https://github.com/yshui/picom/blob/...om.sample.conf
    He copiado este contenido al picom.conf, y lo he ajustado a mis necesidades, entonces sí he podido añadir algo y trastear. No me gustan mucho los efectos, así que solo he dejado cierto "desvanecimiento", las sombras (no descarto quitarlas), y configurado la parte de OpenGL:
    Código:
    # Shadow
    shadow = true;
    shadow-radius = 7;
    shadow-offset-x = -7;
    shadow-offset-y = -7;
    # shadow-opacity = 0.7;
    # shadow-red = 0.0;
    # shadow-green = 0.0;
    # shadow-blue = 0.0;
    shadow-exclude = [
    	"name = 'Notification'",
    	"class_g = 'Conky'",
    	"class_g ?= 'Notify-osd'",
    	"class_g = 'Cairo-clock'",
    	"_GTK_FRAME_EXTENTS@:c"
    ];
    # shadow-exclude = "n:e:Notification";
    # shadow-exclude-reg = "x10+0+0";
    # xinerama-shadow-crop = true;
    
    # Opacity
    inactive-opacity = 1;
    active-opacity = 1;
    frame-opacity = 1;
    inactive-opacity-override = false;
    # inactive-dim = 0.2;
    # inactive-dim-fixed = true;
    # blur-background = true;
    # blur-background-frame = true;
    # blur-kern = "3x3box";
    # blur-kern = "5,5,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1";
    # blur-background-fixed = true;
    # blur-background-exclude = [
    #	"window_type = 'dock'",
    #	"window_type = 'desktop'",
    #	"_GTK_FRAME_EXTENTS@:c"
    #];
    # opacity-rule = [ "80:class_g = 'URxvt'" ];
    
    # max-brightness = 0.66
    
    # Fading
    fading = true;
    #fade-delta = 4;
    fade-in-step = 0.09;
    fade-out-step = 0.09;
    # no-fading-openclose = true;
    # no-fading-destroyed-argb = true;
    # fade-exclude = [ ];
    
    # Other
    backend = "glx";
    mark-wmwin-focused = true;
    mark-ovredir-focused = true;
    # use-ewmh-active-win = true;
    detect-rounded-corners = true;
    detect-client-opacity = true;
    refresh-rate = 0;
    vsync = true;
    # sw-opti = true;
    # unredir-if-possible = true;
    # unredir-if-possible-delay = 5000;
    # unredir-if-possible-exclude = [ ];
    focus-exclude = [ "class_g = 'Cairo-clock'" ];
    detect-transient = true;
    detect-client-leader = true;
    # invert-color-include = [ ];
    # resize-damage = 1;
    
    # GLX backend
    glx-no-stencil = true;
    glx-no-rebind-pixmap = true;
    xrender-sync-fence = true;
    use-damage = true;
    
    # Window type settings
    wintypes:
    {
      tooltip = { fade = true; shadow = true; opacity = 1; focus = true; full-shadow = false; };
      dock = { shadow = false; }
      dnd = { shadow = false; }
      popup_menu = { opacity = 1; }
      dropdown_menu = { opacity = 1; }
    };
    Esto me ha funcionado perfecto para mi Nvidia 710. Cada uno debería jugar con estos ajustes para que funcione en su caso.
    4- Ir a Menú inicio -> Sistema -> Preferencias -> Administrador de la configuración de Openbox -> Desmarcar: "Las ventanas(...)sin decorar" y Animar(...)
    5- Para que arranque al inicio de la sesión: Menú inicio -> Sistema -> Preferencias -> Aplicaciones predeterminadas para LXsession -> Inicio automático -> Añadir:
    Código:
    @picom -b
    Con esto (si no me he dejado nada) solo queda cerrar sesión y volver a entrar. Listo.
    Ahora todo funciona correctamente.
    No me gustan para nada las configuraciones "a mano", hay que leer y leer comandos y funciones y luego escoger las que más te gusten, y si no te equivocas al escribirlas puede que funcionen, mejor las GUI siempre, pero no parece que haya otra forma de hacer esto por ahora.
    Si alguien puede añadir algo a esto, genial, ya digo, no he encontrado mucha info por ahí de este asunto.

    Nota: cada vez que entras al archivo de configuración el "daemon" (proceso) picom se para, y deja de funcionar el compositor. Para arrancarlo de nuevo basta con abrir la terminal y escribir:
    Código:
    picom -b
    O cerrar sesión y volver a entrar.


    Salu2!
    Última edición por Jordi4321; 25-ene-2020 a las 15:34 Razón: Cambio detalles incoherentes xD

  2. Gracias DiabloRojo ha agradecido este mensaje
    Me Gusta Archrysler le ha gustado este mensaje

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. tumbleweed y lxde
    By benito in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 5
    Último mensaje: 02-dic-2018, 22:19
  2. LXDE en openSUSE 13.1
    By jcsl in forum FAQs, Manuales y Tutoriales
    Respuestas: 6
    Último mensaje: 07-sep-2016, 22:32
  3. Portal:LXDE
    By jcsl in forum Colaboración wiki opensuse
    Respuestas: 9
    Último mensaje: 26-ago-2014, 01:40
  4. Cambiar de KDE a Lxde
    By alarmero in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 3
    Último mensaje: 30-nov-2013, 07:17
  5. Escritorio LXDE
    By ptrvio in forum Software
    Respuestas: 6
    Último mensaje: 14-jul-2008, 17:36

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •