Gracias Gracias:  1
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: openSUSE TW - No hay adaptadores bluetooth disponibles

  1. #1
    Fecha de Ingreso
    25-agosto-2008
    Ubicación
    Bogotá D.C, Colombia
    Mensajes
    320
    Post Thanks / Like
    Poder de Credibilidad
    12

    openSUSE TW - No hay adaptadores bluetooth disponibles

    Hola a todos.

    Recién me acaba de ocurrir el problema descrito en el título. En este punto, el adaptador bluetooth es el integrado del equipo.

    Hasta ayer estaba funcionando en mi Asus X570zd, pero hoy no. Y no he actualizado desde el lunes. He reiniciado varias veces y el problema ya es persistente.

    Al buscar en el diario de registro encuentro esto:
    Código:
    nov 14 11:44:15 neoacevedo kdeinit5[2139]: bluedevil: Bluetooth operational changed false
    nov 14 11:44:15 neoacevedo kdeinit5[2139]: bluedevil: Bluetooth operational changed true
    nov 14 11:44:16 neoacevedo plasmashell[2186]: org.kde.plasma: invalid metadata "/usr/lib64/qt5/plugins/kio_bluetooth.so"
    nov 14 11:46:19 neoacevedo systemsettings5[3397]: kf5.kconfigwidgets: A widget named ' "kcfg_enableGlobalBluetooth" ' was found but there is no setting named ' "enableGlobalBluetooth" '
    ¿cómo puedo levantar el controlador del bluetooth?
    Última edición por NestorAcevedo; 14-nov-2019 a las 18:57 Razón: Añadir más información.

  2. #2
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.959
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    Aunque este no es TW, puedes mirar si los tienes :

    Código:
    Z87-DELUX:~ # zypper se -si blue*
    Loading repository data...
    Reading installed packages...
    
    S | Name             | Type    | Version          | Arch   | Repository                              
    --+------------------+---------+------------------+--------+-----------------------------------------
    i | bluedevil5       | package | 5.12.8-lp151.1.2 | x86_64 | Repositorio principal                   
    i | bluedevil5-lang  | package | 5.12.8-lp151.1.2 | noarch | Repositorio principal                   
    i | bluez            | package | 5.48-lp151.8.3.1 | x86_64 | Repositorio principal de actualizaciones
    i | bluez-qt-imports | package | 5.55.0-lp151.1.1 | x86_64 | Repositorio principal                   
    i | bluez-qt-udev    | package | 5.55.0-lp151.1.1 | x86_64 | Repositorio principal                   
    Z87-DELUX:~ #
    Lo mismo puedes hacerlo desde yast2 y buscarlos, si alguno pueda estar mal, marca lo en el instalador de software y vuelve lo a reinstalar .

    En el mismo programa, tienes history y puedes ver si se ha instalado algo que le pudiese aceptar, o bien verlo en : /var/log/zypp/history .

    Si ves que en esas fechas Ayer por ejemplo hubo alguna actualización (kernel, firmware, etc, que pudiese aceptar, pues prueba a reinstalar, idem buscar en el instalador y volver a reinstalar; por si hubiese la posibilidad, de que alguno este corrupto.

    Saludos cordiales

  3. Gracias fonfonete ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    25-agosto-2008
    Ubicación
    Bogotá D.C, Colombia
    Mensajes
    320
    Post Thanks / Like
    Poder de Credibilidad
    12
    Hola @mikrios, ya verifiqué y todo está en regla, incluso, he actualizado y no se por qué, pero está pasando ahora, que el adaptador no se encuentra cuando el equipo se encuentra funcionando solo con la batería, pero eso también es al azar.

  5. #4
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.959
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola :

    Al principio marca false y después true , puede que los añadidos este alguno mal (mirar en yast soft) y en todo caso refrescar los módulos con dracut --force.

    Si sale lo del principio, también es indicativo que en la bios está marcada ( no se si es alguna pequeña placa, como en wifi, lo digo por sacarla y limpiar sus contactos) , pero miraría 1º lo del kernel, que esté ok, forzar a crear de nuevo los módulos con dracut --force

    Y mirar si falta algo de los añadidos,plug ins etc y volver a reinstalar (me suena a un conflicto), también puedes probar a des activarlo de la bios, reiniciar, volver a entrar de nuevo y volver activarlo ( uno lo quita y la 2ª vez lo vuelve a reponer) .

    Fijate que los dos primeros y más importantes están ok, pero en
    Código:
    nov 14 11:44:16 neoacevedo plasmashell[2186]: org.kde.plasma: invalid metadata "/usr/lib64/qt5/plugins/kio_bluetooth.so"
    nov 14 11:46:19 neoacevedo systemsettings5[3397]: kf5.kconfigwidgets: A widget named ' "kcfg_enableGlobalBluetooth" ' was found but there is no setting named ' "enableGlobalBluetooth" '
    Marca los fallos , si están disponibles en software de yast, mira de reinstalarlos y si hay que reiniciarlos en ~/.config o ~/.kde o en ./local un archivo que acabe en rc, le cambias el nombre para obligar a que ponga de la raíz uno nuevo. en config : bluedevilglobalrc, bluedevilreceiverrc, mirar en otros ocultos si hay algo en /.kde4/share/config /kdeglobals (en los otros no veo nada,pero si instalaste algo, vuelve hacerlo, por si cambio algo , al actualizar (kernel, lib, etc) .

    Saludos cordiales.

  6. #5
    Fecha de Ingreso
    25-agosto-2008
    Ubicación
    Bogotá D.C, Colombia
    Mensajes
    320
    Post Thanks / Like
    Poder de Credibilidad
    12
    Bueno, ahora es con la inalámbrica, pero el último log, el de ayer, lo que dice es que renombró la conexión. Pero hoy no se detecta para nada la inalámbrica.

  7. #6
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.959
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola :

    Creo que merece hacer unas pruebas con un usb live , para ver sin hacer instalación te da los mismos errores (cuando se hace una instalación se usa con el equipo conectado a la red eléctrica, ya que una interrupción por baterías bajas , puede dar al traste con la instalación) .

    Si tienes algún medio de comprobar el equipo antes de instalar, hazlo (merece la pena, ya que descartas, memoria, HD. y otros dispositivos, suele haber por la web, algunos live, que chekean el equipo y si no verifica, con algunas utilidades que vienen en la iso, o bien instalar en memoria un live y desde él instalar las utilidades necesarias para hacer la comprobación) .

    Comprueba si lo que tienes instalado, cumple todas las dependencias, con : sudo zypper ve
    También yast, al fondo de todo tienes de forma grafica el journal de systemd (donde ya incluye los filtros necesarios para ir delimitando los errores .

    A mi hijo, se le cortaba la wifi cuando encendía el micro ondas, pero bluetooth, su frecuencia, es muy próxima a la de wifi, por lo que hay que observar, si no hay algún otro dispositivo, que pueda interferir con los del equipo ( en mi casa uso analizadores de espectros, para medir esas señales, estos cubren de 6 Ghz y 8 Ghz, y tienen programas especiales para medir wifi ( solo la a/b) , pero si aparece algo raro, se ve perfectamente ahí .

    ya contaras como van las pruebas, saludos cordiales

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Bluetooth en Opensuse 12.1
    By gonzalorezk in forum Internet, Redes y Wireless
    Respuestas: 1
    Último mensaje: 04-dic-2011, 21:21
  2. Bluetooth en openSUSE 11.4
    By UnderUp in forum Internet, Redes y Wireless
    Respuestas: 12
    Último mensaje: 22-sep-2011, 00:44
  3. habilitar bluetooth en linux opensuse 11.1
    By ashidalgov in forum Software
    Respuestas: 0
    Último mensaje: 30-abr-2009, 19:01
  4. Respuestas: 1
    Último mensaje: 19-feb-2009, 00:53
  5. Bluetooth USB Adapter run on OpenSUSE?
    By drakolive in forum Hardware
    Respuestas: 3
    Último mensaje: 03-oct-2008, 04:35

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •