Gracias Gracias:  40
Me Gusta Me Gusta:  3
No me Gusta No me Gusta:  0
Página 1 de 8 123 ... ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 77

Tema: Inicio de openSUSE Leap 15.10 con pantalla verde SOLUCIONADO

  1. #1
    Fecha de Ingreso
    13-junio-2014
    Ubicación
    Veracruz, Ver.
    Mensajes
    595
    Post Thanks / Like
    Poder de Credibilidad
    6

    Question Inicio de openSUSE Leap 15.10 con pantalla verde SOLUCIONADO

    Qué tal, amigos!
    Acabo de instalar Leap 15.10, junto con Windows 7, en una partición diferente. Después de realizados los ajustes previos a la instalación en Yast, y antes de comenzar la instalación, me apareció un mensaje de advertencia con los drivers Mesa-noveau, creo que decía algo con respecto a que podrían haber problemas con esos controladores. En fin, acepté de todos modos e instalé. Al reiniciarse la máquina, después del bootmenu, la pantalla se queda en verde.

    Mi pantalla es de 32 pulgadas y tengo una tarjeta Nvidia Geforce GTX 1050 (Cuándo se dignarán a dar soporte completo de video a Linux estas empresas, y no sólo hacerlo con Windows?).

    Parece ser que es problema con los controladores de video, sin embargo, no sé cómo solucionar esto. Podrían echarme la mano los que saben del tema, por favor?
    Saludines,
    Isabel.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.464
    Post Thanks / Like
    Poder de Credibilidad
    10
    Hola @susemex

    ¡Cuanto tiempo sin verte por el foro!

    Hay una chuleta del compañero @Krovikan en el foro publicado en varios temas sobre los drivers de Nvidia, búscalo y sigue las instrucciones.

    Saludos.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. Gracias susemex ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    189
    Post Thanks / Like
    Poder de Credibilidad
    1
    Hola!
    A mi me ha pasado alguna vez algo por el estilo con mi Nvidia 710. Primero hay que asegurar la jugada viendo donde está el fallo al arrancar, apretando "esc" justo después del menú del grub ves el proceso de arranque y los posibles errores. Cuando está seguro que es la tarjeta, siempre me funcionó arrancar con "nomodeset". Luego con el sistema en marcha cambiaba los drivers y demás. También está el chroot para hacer cosas. Te paso links por si te interesa:
    https://en.opensuse.org/SDB:Configur..._things_to_try
    https://imgur.com/a/3o1n2
    https://www.suse.com/support/kb/doc/?id=7018126

    Salu2!
    Última edición por Jordi4321; 10-nov-2019 a las 16:58 Razón: Quitar comentario innecesario

  5. Gracias susemex ha agradecido este mensaje
  6. #4
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    914
    Post Thanks / Like
    Poder de Credibilidad
    10
    Tienes la opción cómoda aquí:

    https://www.forosuse.org/forosuse/sh...374#post203374


    Y la opción manual que es la mia aquí:


    IMPORTANTE: Hace falta tener instalado kernel-default, kernel-default-devel, kernel-devel y kernel-macros (los 4 paquetes de la misma versión).

    Bajar el driver Nvidia desde su página web.


    Para omitir Noveau:


    Con permisos de root escribir:

    Código:
    echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf
    Desinstalar: Mesa-dri-nouveau y ponerlo como tabú en Yast.

    Código:
    dracut --force
    IMPORTANTE: Reiniciar antes de instalar los drivers NVIDIA.


    Ahora el proceso de instalación de los drivers propietarios a mano (existen repos pero no los uso):


    Tras cargar Linux el escritorio saldrá negro. Cambiar a una terminal con Ctrl+Alt+F1.

    Iniciar sesión root y pasar al runlevel 3 (con lo que el gestor de ventanas se muere) tecleando:

    Código:
    init 3
    Instalar el driver. Localízalo en su directorio y tecelar:

    Código:
    sh NVIDIA-Linux-x86_64-435.27.02.run -q
    (la numeración varía dependiendo de cuál hayas bajado)

    Verás que te compila el módulo para el kernel e instala el driver.

    Tras acabar, teclear:

    Código:
    init 5
    para iniciar el gestor de ventanas (en este caso Plasma).



    Tendrás que repetir el proceso de instalación siempre que actualices el kernel o el servidor gráfico. Tan fácil como:

    Ctrl+Alt+F1 cuando ves la pantalla en negro tras cargar el sistema, iniciar sesión root, init 3, sh NVIDIA-Linux-x86_64-435.27.02.run -q (desde el directorio que lo tengas) e init 5.

    Recuerda que la versión del driver puede variar respecto a la que bajes.


    OPCIONAL: Se puede instalar la aplicación nvdock (el paquete se llama igual) que te pone un icono en la barra inferior de la pantalla que te da acceso al panel de opciones de Nvidia.

    Allí en la sección OpenGL Settings desactivar la casilla "Allow Flipping". Apenas te quita algo de rendimiento y te permite grabar vídeo y audio de forma correcta en juegos con un programa como Vokoscreen, SimpleScreenRecorder o similares.

    NOTA: La versión del driver que uso es la versión Beta con Soporte para Vulkan. Se puede hallar en este enlace. Funciona este driver a partir de la familia 600 de tarjetas.


    Saludos

  7. Gracias susemex ha agradecido este mensaje
  8. #5
    Fecha de Ingreso
    13-junio-2014
    Ubicación
    Veracruz, Ver.
    Mensajes
    595
    Post Thanks / Like
    Poder de Credibilidad
    6
    Cita Iniciado por DiabloRojo Ver Mensaje
    Hola @susemex

    ¡Cuanto tiempo sin verte por el foro!

    Hay una chuleta del compañero @Krovikan en el foro publicado en varios temas sobre los drivers de Nvidia, búscalo y sigue las instrucciones.

    Saludos.
    Gracias, DR! Y sí, había estado ausente por un tiempo debido a asuntos del trabajo.

    Cita Iniciado por Jordi4321 Ver Mensaje
    Hola!
    A mi me ha pasado alguna vez algo por el estilo con mi Nvidia 710. Primero hay que asegurar la jugada viendo donde está el fallo al arrancar, apretando "esc" justo después del menú del grub ves el proceso de arranque y los posibles errores. Cuando está seguro que es la tarjeta, siempre me funcionó arrancar con "nomodeset". Luego con el sistema en marcha cambiaba los drivers y demás. También está el chroot para hacer cosas. Te paso links por si te interesa:
    https://en.opensuse.org/SDB:Configur..._things_to_try
    https://imgur.com/a/3o1n2
    https://www.suse.com/support/kb/doc/?id=7018126

    Salu2!
    Gracias, amigo! No recuerdo en qué línea específicamente se coloca el 'nomodeset'.

    Cita Iniciado por Krovikan Ver Mensaje
    Tienes la opción cómoda aquí:

    https://www.forosuse.org/forosuse/sh...374#post203374


    Y la opción manual que es la mia aquí:


    IMPORTANTE: Hace falta tener instalado kernel-default, kernel-default-devel, kernel-devel y kernel-macros (los 4 paquetes de la misma versión).

    Bajar el driver Nvidia desde su página web.


    Para omitir Noveau:


    Con permisos de root escribir:

    Código:
    echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf
    Desinstalar: Mesa-dri-nouveau y ponerlo como tabú en Yast.

    Código:
    dracut --force
    IMPORTANTE: Reiniciar antes de instalar los drivers NVIDIA.


    Ahora el proceso de instalación de los drivers propietarios a mano (existen repos pero no los uso):


    Tras cargar Linux el escritorio saldrá negro. Cambiar a una terminal con Ctrl+Alt+F1.

    Iniciar sesión root y pasar al runlevel 3 (con lo que el gestor de ventanas se muere) tecleando:

    Código:
    init 3
    Instalar el driver. Localízalo en su directorio y teclear:

    Código:
    sh NVIDIA-Linux-x86_64-435.27.02.run -q
    (la numeración varía dependiendo de cuál hayas bajado)

    Verás que te compila el módulo para el kernel e instala el driver.

    Tras acabar, teclear:

    Código:
    init 5
    para iniciar el gestor de ventanas (en este caso Plasma).



    Tendrás que repetir el proceso de instalación siempre que actualices el kernel o el servidor gráfico. Tan fácil como:

    Ctrl+Alt+F1 cuando ves la pantalla en negro tras cargar el sistema, iniciar sesión root, init 3, sh NVIDIA-Linux-x86_64-435.27.02.run -q (desde el directorio que lo tengas) e init 5.

    Recuerda que la versión del driver puede variar respecto a la que bajes.


    OPCIONAL: Se puede instalar la aplicación nvdock (el paquete se llama igual) que te pone un icono en la barra inferior de la pantalla que te da acceso al panel de opciones de Nvidia.

    Allí en la sección OpenGL Settings desactivar la casilla "Allow Flipping". Apenas te quita algo de rendimiento y te permite grabar vídeo y audio de forma correcta en juegos con un programa como Vokoscreen, SimpleScreenRecorder o similares.

    NOTA: La versión del driver que uso es la versión Beta con Soporte para Vulkan. Se puede hallar en este enlace. Funciona este driver a partir de la familia 600 de tarjetas.


    Saludos
    Creo haber seguido alguna vez una guía de este tipo aquí, pero no recuerdo si era la tuya. No es primera vez que me pasa esto debido a los controladores de Nvidia. Seguiré tus pasos, como bien recomienda también DR, pero primero es pasar de esa pantalla verde que no me deja avanzar. Y con respecto al programa nvdock, le echaré un vistazo; si me deja grabar juegos, lo podría usar; suelo jugar Subsistence, a través de Steam.
    Saludines,
    Isabel.

  9. #6
    Fecha de Ingreso
    13-junio-2014
    Ubicación
    Veracruz, Ver.
    Mensajes
    595
    Post Thanks / Like
    Poder de Credibilidad
    6
    Seguí los pasos de Krovikan y sí pude instalar los drivers de Nvidia; antes de concluír, me aparecieron dos mensajes:

    mensaje 1.jpg

    mensaje 2.jpg

    Luego de reiniciar la máquina, ahora me apareció otro problema... todo se ve demasiado pequeño!!! No puedo modificar resolución ni nada porque no se alcanzan a leer los textos.
    Saludines,
    Isabel.

  10. #7
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    914
    Post Thanks / Like
    Poder de Credibilidad
    10
    Es normal el mensaje. Siempre me lo pone cuando quiere instalar las librerías openGL 32 bits. Las instala de todas formas.

    ¡Felicidades! Has completado la instalación manual.

    Lo de que no se vea todo bien es como si no tuvieras configurado x.org.

    Igual te ayuda ejecutar creo que era --> nvidia-xconfig (es para configurar x.org).

    Al final de la instalación del driver te da la opción de configurar X.org. Por defecto está en No (si quieres ver la opción, la próxima vez no escribas el modificador -q en la línea de instalación del driver que comienza con sh) y nunca le doy a Sí porque siempre arrastro el mismo /home.


    Saludos

  11. Gracias susemex ha agradecido este mensaje
  12. #8
    Fecha de Ingreso
    13-junio-2014
    Ubicación
    Veracruz, Ver.
    Mensajes
    595
    Post Thanks / Like
    Poder de Credibilidad
    6
    Necesito actualizar el archivo xorg.conf como apareció en el mensaje, pero con lo diminuto de la letra me es imposible ver bien. Existe alguna opción para iniciar el sistema en una resolución baja para poder ver lo que hago?
    Saludines,
    Isabel.

  13. #9
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    189
    Post Thanks / Like
    Poder de Credibilidad
    1
    Creo que es lo que dice @krovikan
    Igual te ayuda ejecutar creo que era --> nvidia-xconfig (es para configurar x.org).
    Esto lo puedes hacer desde la consola (Ctrl+Alt+F4).
    Para volver Ctrl+Alt+F7.

    Yo sigo pensando que si no hay más opción que usar la instalación manual está bien, pero es un poco rollo a la hora de actualizar el sistema, veo más cómodo usar los repos.
    Última edición por Jordi4321; 11-nov-2019 a las 10:13

  14. Gracias susemex ha agradecido este mensaje
  15. #10
    Fecha de Ingreso
    13-junio-2014
    Ubicación
    Veracruz, Ver.
    Mensajes
    595
    Post Thanks / Like
    Poder de Credibilidad
    6
    Ejecuté el comando nvidia-xconfig y me apareció lo siguiente:
    WARNING: Unable to locate/open X configuration file.

    Package xorg-server was not found in the pkg-config search path.

    Perhaps you should add the directory containing 'xorg-server.pc' to the PKG_CONFIG_PATH environment variable.
    No package 'xorg-server' found.

    ERROR: Unable to write to directory '/etc/X11'.
    Si me sigue dando lata, creo que usaré los drivers de los repos. Será muy notoria la diferencia de rendimiento entre los controladores oficiales y los del repositorio de openSUSE?
    Saludines,
    Isabel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Respuestas: 49
    Último mensaje: 16-ene-2019, 11:37
  2. inicio de sesion fallido opensuse Leap 42.1
    By Leinad in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 21-may-2016, 11:10
  3. Cambiar pantalla de inicio y apagado en opensuse 13.2
    By annubis in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 11
    Último mensaje: 06-feb-2015, 00:27
  4. Openupdater(Icono en la barra de Inicio) de Color Verde
    By Wasin in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 4
    Último mensaje: 23-oct-2008, 16:10
  5. Respuestas: 1
    Último mensaje: 21-feb-2008, 22:35

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •