Gracias Gracias:  5
Me Gusta Me Gusta:  1
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: Evitar que el proceso de actualizacion instale un paquete

  1. #1
    Fecha de Ingreso
    15-enero-2019
    Mensajes
    190
    Post Thanks / Like
    Poder de Credibilidad
    1

    Evitar que el proceso de actualizacion instale un paquete

    Hola gente,
    Utilizo OpenSuse Tumbleweed, y desinstale el paquete postfix porque no lo necesito y me hace lento el inicio del sistema.

    Ese paquete es un servidor de correos, del cual no termino de entender bien su utilidad en un entorno de escritorio, pero bueno.
    No posee dependencias.

    La cuestión es que cada vez que actualizo el sistema, me vuelve a instalar ese paquete, como puede verse en la imagen:


    Pregunta: ¿existe alguna forma de indicarle al sistema que no instale ese paquete?, es decir, bloquearlo para siempre del proceso de actualización.

    Sldos.

  2. #2
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    907
    Post Thanks / Like
    Poder de Credibilidad
    10
    Muy buena pregunta de la que desconozco la respuesta.

    Lo de buena pregunta es porque hace un tiempo borré algunas cosas que encuentro supérfluas como Kpatience, Ksudoku, Kreversi, Marble y habrán más cosas. Pero...

    siempre que había una actualización gorda (creo que era con esas) como actualización de versión de Plasma o del Framework o recompilación con nueva versión de Qt, me los volvía a instalar siempre. Puede que por culpa de los patrones que siempre "actualizaba". Que si patterns-este, patterns-el otro, etc.

    Pero no tengo nada clara la solución a esto que digo.

    Bueno, quizás una solución es bloquear postifx o marcarlo tabú (en el Yast seleccionas el paquete y puedes bloquearlo o marcarlo tabú en lugar de actualizar, desinstalar, etc). Pero creo que a zypper no le haría mucha gracia si tiende a instalarlo siempre. Lo mismo me pregunto qué podría hacer yo para poder quitar morralla innecesaria como la nombrada más arriba.


    Saludos

  3. Me Gusta Tux83 le ha gustado este mensaje
  4. #3
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.685
    Post Thanks / Like
    Poder de Credibilidad
    22

  5. Gracias Tux83 ha agradecido este mensaje
  6. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.449
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por karlggest Ver Mensaje
    Hola.

    Márcalo como tabú.

    Salud!!
    +1

    Ojo, se hace desde Yast->Software->Instalar/desinstalar ..., selecciona el paquete, botón derecho->Todos los de la lista-> Tabú

    También se puede hacer desde la consola
    sudo zypper al postfix
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  7. Gracias Tux83, enae ha agradecido este mensaje
  8. #5
    Fecha de Ingreso
    15-enero-2019
    Mensajes
    190
    Post Thanks / Like
    Poder de Credibilidad
    1
    Gracias, no sabia que se podía hacer eso.

    Solucionado!

  9. #6
    Fecha de Ingreso
    06-agosto-2013
    Ubicación
    / Home
    Mensajes
    264
    Post Thanks / Like
    Poder de Credibilidad
    7
    Hola, si lo desinstalas, luego:
    Código:
    zypper al 'postfix*'
    salu2.
    fuente:https://es.opensuse.org/Zypper
    edito:en mi caso:
    linux-4rua:~ # zypper info postfix
    Loading repository data...
    Reading installed packages...


    Information for package postfix:
    --------------------------------
    Repository : openSUSE-Tumbleweed-Oss
    Name : postfix
    Version : 3.4.6-4.1
    Arch : x86_64
    Vendor : openSUSE
    Installed Size : 3.5 MiB
    Installed : No
    Status : not installed
    Source package : postfix-3.4.6-4.1.src
    Summary : A fast, secure, and flexible mailer
    Description :
    Postfix aims to be an alternative to the widely-used sendmail program.
    Última edición por enae; 24-sep-2019 a las 02:27

  10. Gracias Tux83, DiabloRojo ha agradecido este mensaje

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Respuestas: 10
    Último mensaje: 27-nov-2017, 17:12
  2. Cómo puedo deshabilitar x actualización de paquete?
    By susemex in forum Instalación y Actualizaciones
    Respuestas: 5
    Último mensaje: 20-feb-2016, 01:37
  3. Proceso de instalación o se completa
    By DiAlejandro in forum Instalación y Actualizaciones
    Respuestas: 4
    Último mensaje: 29-oct-2014, 01:59
  4. Proceso mandb
    By Rekeb in forum Software
    Respuestas: 2
    Último mensaje: 12-mar-2007, 02:05
  5. proceso & tarea
    By dudoso in forum General OpenSUSE
    Respuestas: 9
    Último mensaje: 20-ene-2006, 20:10

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •