Gracias Gracias:  3
Me Gusta Me Gusta:  1
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 14

Tema: Dependencias para compilar wine-tkg

  1. #1
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    134
    Post Thanks / Like
    Poder de Credibilidad
    1

    Dependencias para compilar wine-tkg

    Hola!
    En Arch estaba usando wine-tkg (https://github.com/Tk-Glitch/PKGBUIL...r/wine-tkg-git), que funcionaba muy bien. Ahora hay un script para usarlo en otras distros y funciona hasta que salta un error:

    Código:
    gstreamer-1.0 base plugins 32-bit development files not found
    Tengo instalado el paquete gstreamer-plugins-base-devel-32bit, por lo visto no es el que necesita.
    Estoy buscando este paquete gstreamer-1.0 y no lo encuentro para opensuse....
    Me quedare con las ganas de probar este wine en Opensuse?
    Por cierto, se confirma lo que vi ya desde un inicio, compilando se nota muchísimo que va más rápido el sistema que Arch, es una bala!

    Salu2.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.430
    Post Thanks / Like
    Poder de Credibilidad
    10
    Es el paquete gstreamer-devel para la libreria en general y el paquete gstreamer-plugins-base-devel-32bit para el plugin de 32 bits. Lee las descripciones, tienes mas información con el comando
    zypper info gstreamer-plugins-base-devel-32bit

    Código:
    ~> zypper se gstreamer | grep  devel   
       | gstreamer-devel                             | Include Files and Libraries mandatory for Development                         | paquete     
       | gstreamer-editing-services-devel            | GStreamer Editing Services - Development files                                | paquete     
       | gstreamer-plugins-bad-devel                 | GStreamer Streaming-Media Framework Plug-Ins                                  | paquete     
       | gstreamer-plugins-base-devel                | Include files and librs mandatory for development with gstreamer-plugins-base | paquete     
       | gstreamer-plugins-base-devel-32bit          | Include files and librs mandatory for development with gstreamer-plugins-base | paquete     
       | gstreamer-plugins-qt-devel                  | Include files and libraries mandatory for development                         | paquete     
       | gstreamer-plugins-qt5-devel                 | Include files and libraries mandatory for development                         | paquete     
       | gstreamer-rtsp-server-devel                 | Development files for the GStreamer-based RTSP server library                 | paquete     
       | gstreamer-transcoder-devel                  | Development files for the GStreamer Transcoding API                           | paquete     
       | gstreamer-validate-devel                    | Validate GStreamer Pipelines -- Developer's files                             | paquete     
       | gstreamermm-devel                           | C++ bindings for the GStreamer streaming multimedia library                   | paquete     
       | mingw32-gstreamer-0_10-devel                | Streaming-Media Framework Runtime (development files)                         | paquete     
       | mingw32-gstreamer-devel                     | Streaming-Media Framework Runtime (development files)                         | paquete     
       | mingw64-gstreamer-0_10-devel                | Streaming-Media Framework Runtime (development files)                         | paquete     
       | mingw64-gstreamer-devel                     | Streaming-Media Framework Runtime (development files)                         | paquete 
    
    
    ~> zypper info gstreamer-plugins-base-devel-32bit  
    Leyendo los paquetes instalados...
    
    Información para paquete gstreamer-plugins-base-devel-32bit:
    ------------------------------------------------------------
    Repositorio           : openSUSE-Leap-15.0-Oss                                                        
    Nombre                : gstreamer-plugins-base-devel-32bit                                            
    Versión               : 1.12.5-lp150.1.1                                                              
    Arquitectura          : x86_64                                                                        
    Proveedor             : openSUSE                                                                      
    Tamaño de instalación : 0 B                                                                           
    Instalado             : No                                                                            
    Estado                : no se ha instalado                                                            
    Paquete de fuentes    : gstreamer-plugins-base-1.12.5-lp150.1.1.src                                   
    Resumen               : Include files and librs mandatory for development with gstreamer-plugins-base
    Descripción           :                                                                               
        This package contains all necessary include files and libraries needed
        to compile and link applications that use gstreamer-plugins-base.
    
    
    Última edición por DiabloRojo; 28-ago-2019 a las 09:19
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    134
    Post Thanks / Like
    Poder de Credibilidad
    1
    El problema es que ese paquete que mencionas está instalado, y me da ese error.

    Código:
    jordi@localhost:~> zypper info gstreamer-plugins-base-devel-32bit
    Cargando datos del repositorio...
    Leyendo los paquetes instalados...
    
    
    Información para paquete gstreamer-plugins-base-devel-32bit:
    ------------------------------------------------------------
    Repositorio           : Repositorio principal (OSS)                                                  
    Nombre                : gstreamer-plugins-base-devel-32bit                                           
    Versión               : 1.16.0-2.1                                                                   
    Arquitectura          : x86_64                                                                       
    Proveedor             : openSUSE                                                                     
    Tamaño de instalación : 0 B                                                                          
    Instalado             : Sí                                                                           
    Estado                : actualizado                                                                  
    Paquete de fuentes    : gstreamer-plugins-base-1.16.0-2.1.src                                        
    Resumen               : Include files and librs mandatory for development with gstreamer-plugins-base
    Descripción           :                                                                              
        This package contains all necessary include files and libraries needed
        to compile and link applications that use gstreamer-plugins-base.

  4. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.430
    Post Thanks / Like
    Poder de Credibilidad
    10
    Veo en ese script forma parte de un bloque mayor: https://github.com/Tk-Glitch/PKGBUILDS

    Orientado a una distribución diferente Bedrock Linux que puede tener otro nombre para su paquete gstreamer-plugins de 32 bits, no se como lo intentas instalar, dame las instrucciones.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  5. #5
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    134
    Post Thanks / Like
    Poder de Credibilidad
    1
    Ese repo git está enfocado a Arch y derivados. Se construyen las cosas con PKGBUILD, pero ahora su creador ha hecho un script para otras distros, las dependencias están casi todas (me faltó alguna, espero que de un error luego, si no lo da ya está).
    Exactamente el paquete que no encuentro es este:

    'lib32-gst-plugins-base-libs'

    que aparece en los repos de ArchLinux.

    Yo solo he instalado el paquete que indicas más arriba, nada más (y las demás dependencias).

    Si te fijas ofrecen diferentes cosas:

    https://opensuse.pkgs.org/15.0/opens...86_64.rpm.html
    https://archlinux.pkgs.org/rolling/a...kg.tar.xz.html
    Última edición por Jordi4321; 28-ago-2019 a las 12:14

  6. #6
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.430
    Post Thanks / Like
    Poder de Credibilidad
    10
    Me parece que el problema viene de la falta de esta carpeta /usr/lib32/girepository-1.0/ y su contenido según el error que te aparece.

    Para saber que paquete proporciona una dependencia, se usa el comando
    zypper wp libgstaudioconvert.so
    Última edición por DiabloRojo; 28-ago-2019 a las 13:10
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  7. #7
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    134
    Post Thanks / Like
    Poder de Credibilidad
    1
    La carpeta /usr/lib32 directamente no existe. Esta lib y lib64. Si hago una busqueda con la primera cosa que instala el paquete de Arch

    zypper wp libgstallocators-1.0.so

    me dice que no hay nada que tenga eso.

    Me ha pasado por la cabeza usar un programilla que se llama fpm para convertir el paquete de arch a rpm. Como pasa muchas veces no hay instrucciones para Opensuse, y no puedo instalarlo. Lo probare en una maquina virtual con ubuntu.

    https://fpm.readthedocs.io/en/latest/installing.html

  8. #8
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.430
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cuando tenga un rato intentare instalar el script.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  9. #9
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    134
    Post Thanks / Like
    Poder de Credibilidad
    1
    Ya he conseguido compilarlo. Estoy a tope con los de github intentando hacerlo funcionar todo. Ya pondré aquí lo que hay que hacer cuando esté todo listo.
    Es un pequeño gran lío de dependencias más que otra cosa.
    Para mi es demasiado complicado hacerlo, además he tenido que reinstalar porque se volvió el sistema inestable con tanta prueba. Ahora está todo bien, menos un error en el arranque que ha aparecido al instalar las dependencias para compilar:

    Código:
    systemd[1]: /usr/lib/systemd/system/isdn.service:3: Failed to add dependency on hylafax-hfaxd, ignoring: Invalid argument
    La verdad es que ese wine funciona muy bien, los juegos se notan más fluidos, al menos en Arch, porque yo tengo una tarjeta gráfica malísima.
    Última edición por Jordi4321; 29-ago-2019 a las 18:37

  10. Gracias DiabloRojo ha agradecido este mensaje
  11. #10
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    134
    Post Thanks / Like
    Poder de Credibilidad
    1
    Bueno finalmente no ha podido ser. No arranca la compilación en OpenSuse Tw. Por lo visto no hay problema compilar en Ubuntu y usarlo donde sea, pero compilando en OpenSuse da un error de versiones al arrancar.
    A la espera que se solucione.

    Ya he solucionado el error: he editado /usr/lib/systemd/system/isdn.service, borrando la entrada hylafax-hfaxd en Before=. No se lo que es, algo relacionado con el fax, que no tengo, por lo tanto fuera. Ya no sale el error.
    Última edición por Jordi4321; 30-ago-2019 a las 13:28

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Temas Similares

  1. Dependencias para ATI
    By faco84 in forum Hardware
    Respuestas: 16
    Último mensaje: 07-abr-2009, 00:52
  2. Error al compilar wine 0.9.23
    By balrog in forum Software
    Respuestas: 1
    Último mensaje: 17-oct-2006, 12:45
  3. Ayuda para solucionar dependencias
    By luis in forum Software
    Respuestas: 0
    Último mensaje: 07-mar-2006, 09:47
  4. Ayuda para solucionar dependencias
    By luis in forum Instalación y Actualizaciones
    Respuestas: 0
    Último mensaje: 07-mar-2006, 09:45
  5. dependencias para k9copy
    By pelicos in forum Software
    Respuestas: 3
    Último mensaje: 24-jun-2005, 21:16

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •