Gracias Gracias:  4
Me Gusta Me Gusta:  2
No me Gusta No me Gusta:  0
Página 3 de 3 PrimeroPrimero 123
Mostrando resultados del 21 al 28 de 28

Tema: Dependencias para compilar wine-tkg

  1. #21
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    317
    Post Thanks / Like
    Poder de Credibilidad
    2
    Buf, por lo visto hay mil formas de intentar hacer esto xD

    A ver, no paso ningún argumento ni nada, solo toco algo de la configuración en el archivo customization.

    También estuve en github hablando con ellos y me pasaron un listado de deps de la web de winehq, como si este listado que has usado tu no sirviese para nada xD.

    He conseguido compilar sin problema con lo que he estado trasteando yo, pero luego a la hora de usar el wine creado me sale en Lutris "version mismatch", y no arranca.

    Entiendo que a ti si que te ha funcionado, así que reinstalaré el sistema y probaré tu forma, a ver que tal.

    Has mirado los logs en /PKGBUILDS/wine-tkg-git/src/wine-tkg-staging-fsync-git-32-build y PKGBUILDS/wine-tkg-git/src/wine-tkg-staging-fsync-git-64-build, si aparece algún error o fallo?

    Mis logs están a rebosar de fallos xD

    Bueno, sea como sea, eres un makina!!

    --EDIT--

    Estoy haciendo una mezcla entre lo que ya llevo instalado yo y lo que has escrito y instala solo en 64 bits 230 paquetes nuevos xDD Y yo estoy siguiendo cosas que han conseguido compilar wine de antemano (web de winehq incluida)

    --EDIT--

    Sigue dando los mismos fallos:
    Código:
    configure: libhal 32-bit development files not found, no legacy dynamic device support.
    configure: GTK3 32-bit development files not found, GTK themes won't be supported.
    configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
    Recompilando, a ver si funciona.

    --EDIT2--

    Código:
    -> Removed BIG_UGLY_FROGMINER - Ribbit
     -> Removed Proton-tkg token - Valve Ribbit
     -> exit cleanup done
     -> Compilation time for 64-bit wine: 
    
    real	4m17,271s
    user	5m7,611s
    sys	2m42,908s
    
     -> Compilation time for 32-bit wine: 
    
    real	4m18,015s
    user	5m10,952s
    sys	2m46,726s
    Compilar ok, pero luego, en Lutris:
    Código:
    Running /home/jordi/.local/share/lutris/runners/wine/wine-tkg-staging-fsync-git-5.0rc6.r1.g9dc9c57b/bin/wine /mnt/24900711-3d8d-4042-bbe3-7762ddf28edb/.Playonlinux/wineprefix/Steam/drive_c/Program Files (x86)/Steam/Steam.exe -no-browser
    esync: up and running.
    wine client error:0: version mismatch 597/596.
    Your wine binary was not upgraded correctly,
    or you have an older one somewhere in your PATH.
    Or maybe the wrong wineserver is still running?
    Waiting on children
    All children gone
    Exit with returncode 1
    Última edición por Jordi4321; 19-ene-2020 a las 20:40

  2. #22
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    317
    Post Thanks / Like
    Poder de Credibilidad
    2
    Estoy recompilando usando la misma versión de staging que el sistema. Por lo visto el mismatch es eso.
    A ver si hay suerte.
    El fallo de hal se soluciona instalando hal-devel y hal-devel-32bit de un repo no oficial, los tengo apuntados pero no se cual de los 2 es xD
    Me intriga mucho el de GTK3, el de OSS ya me dijeron que no era importante si no recuerdo mal.

    --EDIT--

    No hay suficiente con cambiar el "staging", ahora otra vez con "plain_version", en este caso tenemos instalada la versión 5.0-rc5.

    --EDIT2--

    Misma versión en los 2 sitios, sigue igual. Ultima prueba poner la 5.0-rc4. Si también falla abandono.
    Última edición por Jordi4321; 19-ene-2020 a las 21:22

  3. #23
    Fecha de Ingreso
    20-noviembre-2017
    Ubicación
    Limpio - Paraguay
    Mensajes
    93
    Post Thanks / Like
    Poder de Credibilidad
    3

    Red face No te dees por vencido, más cuando el final esta cerca!....

    Compilar ok, pero luego, en Lutris:
    Código:
    Running /home/jordi/.local/share/lutris/runners/wine/wine-tkg-staging-fsync-git-5.0rc6.r1.g9dc9c57b/bin/wine /mnt/24900711-3d8d-4042-bbe3-7762ddf28edb/.Playonlinux/wineprefix/Steam/drive_c/Program Files (x86)/Steam/Steam.exe -no-browser
    esync: up and running.
    wine client error:0: version mismatch 597/596.
    Your wine binary was not upgraded correctly,
    or you have an older one somewhere in your PATH.
    Or maybe the wrong wineserver is still running?
    Waiting on children
    All children gone
    Exit with returncode 1
    Yo voy a abandonar, el "jefe" tkg dice que lo probará y ya dirá algo, a ver si lo consigue él.
    Yo reinstalaré OST y usaré Arch en el pen para hacer esto como ya hice alguna vez, me retiro, ya he perdido demasiado tiempo con esto xD.
    Lol, lo de las dependencias que te salta no se me reproduce, no obstante el mensaje "configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported." es porque lo estas compilando en una maquina virtual, estoy casi seguro!...

    En cuanto al error de "Versión mismath" ocurre porque lutris intente utilizar sus propias librerías en vez de las que compilamos... para que te funcione basta con que le des clic derecho sobre el lanzador (en tu caso por lo que veo es steam) -> configure (opción del menú contextual) -> System options (pestaña) -> Disable lutris runtime (asegurar de que el swith quede en enable).
    Screenshot_20200119_153622.jpgScreenshot_20200119_152522.jpg
    Saludos!

  4. #24
    Fecha de Ingreso
    20-noviembre-2017
    Ubicación
    Limpio - Paraguay
    Mensajes
    93
    Post Thanks / Like
    Poder de Credibilidad
    3
    Ya te he respondido.... pero esta pendiente de revisión... resumiendo... Deshabilita para que lutris use sus librerias "Disable lutris runtime", en la pestaña System options
    Saludos

  5. #25
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    317
    Post Thanks / Like
    Poder de Credibilidad
    2
    Deshabilita para que lutris use sus librerias "Disable lutris runtime"
    Nada, ni habilitado ni deshabilitado. Por defecto está deshabilitado. A ver con la rc4, que con mi superPc tarda una eternidad en compilar...
    A este fallo en git me dijeron que es que se compila mal, y puede ser.
    Se crea un archivo lastbuild por ahí que lo abro y busco "error" y hay un montón, muchos "fatal", la palabra "fatal" suena mu chunga XD
    Hay alguna que parece algún bug de prgramación, ahora no recuerdo bien que era, pero era una orden "algo -V" que debería ser "algo -v", y dice orden no encontrada por ejemplo.

    --AÑADO--

    Nada, es virtualmente imposible para mí de que funcione. Otro día que me pille con ganas instalare Arch en el pen y probaré a construirlo desde ahí, a ver que pasa. Si así funciona ya me va bien. De momento dejo este tema aparcado otra vez...

    Yo no entiendo nada pero fíjate en este error por ejemplo:
    Código:
    configure:4673: ccache gcc -V >&5
    gcc: error: unrecognized command line option '-V'
    gcc: fatal error: no input files
    compilation terminated.
    Si haces gcc --help dice que debería ser -v, que es:
    -v Muestra los programas invocados por el compilador.
    Y tiene su lógica, recoge los programas invocados y luego hace algo, por eso dice "fatal error", no hay listado nada xD
    Veré este log en Arch, a ver si es diferente. De hecho en la página de git ya dice que es un experimento esto que intentamos hacer. Las indicaciones para compilar en Ubuntu son super raras por ejemplo.

    --SALGO DE DUDAS--

    Vale vale, esos errores no cuentan, estoy viendo el script "configure" y simplemente hace una comprobación ahí:
    Código:
    for ac_option in --version -v -V -qversion; do
    Bueno no se, da igual xD
    Ve tu a saber si no son esos dos fallos de GTK y OSS los que dan problemas....
    Última edición por Jordi4321; 19-ene-2020 a las 23:27

  6. #26
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    317
    Post Thanks / Like
    Poder de Credibilidad
    2
    Bueno, me autorespondo porque añadir esto al mensaje anterior...no se.
    Ya tengo el wine-tkg construido desde Manjaro y funcionando en OpenSuse TW, con algún error de "fontconfig" pero creo que eso es solucionable.
    Como no me gusta quedarme con dudas, he estado un momento (o no tan momento xD) "estudiando" los logs, y creo que es "serio" el problema que tiene en TW con Gtk3, y las librerías de 32 bits en general, no se por que me da la sensación que es algo importante...lo dejo aquí por si alguien entiende de gcc y demás:
    Esto es lo que hace Manjaro:
    Código:
    configure:14561: gtk+-3.0 cflags: -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/lib32/libffi-3.2.1/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib32/dbus-1.0/include -pthread 
    configure:14562: gtk+-3.0 libs: -L/usr/lib32 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 
    configure:14567: checking gtk/gtk.h usability
    configure:14567: ccache gcc -m32 -c -pipe -O2 -ftree-vectorize  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/lib32/libffi-3.2.1/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib32/dbus-1.0/include -pthread  conftest.c >&5
    configure:14567: $? = 0
    configure:14567: result: yes
    configure:14567: checking gtk/gtk.h presence
    configure:14567: ccache gcc -m32 -E  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/lib32/libffi-3.2.1/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib32/dbus-1.0/include -pthread  conftest.c
    configure:14567: $? = 0
    configure:14567: result: yes
    configure:14567: checking for gtk/gtk.h
    configure:14567: result: yes
    configure:14579: checking for -lgobject-2.0
    configure:14604: ccache gcc -m32 -o conftest -pipe -O2 -ftree-vectorize  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/lib32/libffi-3.2.1/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib32/dbus-1.0/include -pthread  -pipe -O2 -ftree-vectorize conftest.c -lgobject-2.0 -L/usr/lib32 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0   >&5
    configure:14604: $? = 0
    configure:14625: result: libgobject-2.0.so.0
    configure:14632: checking for -lcairo
    configure:14657: ccache gcc -m32 -o conftest -pipe -O2 -ftree-vectorize  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/lib32/libffi-3.2.1/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib32/dbus-1.0/include -pthread  -pipe -O2 -ftree-vectorize conftest.c -lcairo   >&5
    configure:14657: $? = 0
    configure:14678: result: libcairo.so.2
    configure:14685: checking for -lgtk-3
    configure:14710: ccache gcc -m32 -o conftest -pipe -O2 -ftree-vectorize  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/lib32/libffi-3.2.1/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib32/dbus-1.0/include -pthread  -pipe -O2 -ftree-vectorize conftest.c -lgtk-3   >&5
    configure:14710: $? = 0
    configure:14731: result: libgtk-3.so.0
    (..)
    Va comprobando las librerías de 32 bits y las va encontrando. Vale, ahora a TW:
    Código:
    configure:14592: gtk+-3.0 cflags: -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/wayland -I/usr/include/libxkbcommon -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -pthread 
    configure:14593: gtk+-3.0 libs: -lgtk-3 -lgdk-3 -L/usr/lib -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 
    configure:14598: checking gtk/gtk.h usability
    configure:14598: ccache gcc -m32 -c -pipe -O2 -ftree-vectorize  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/wayland -I/usr/include/libxkbcommon -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -pthread  conftest.c >&5
    configure:14598: $? = 0
    configure:14598: result: yes
    configure:14598: checking gtk/gtk.h presence
    configure:14598: ccache gcc -m32 -E  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/wayland -I/usr/include/libxkbcommon -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -pthread  conftest.c
    configure:14598: $? = 0
    configure:14598: result: yes
    configure:14598: checking for gtk/gtk.h
    configure:14598: result: yes
    configure:14610: checking for -lgobject-2.0
    configure:14635: ccache gcc -m32 -o conftest -pipe -O2 -ftree-vectorize  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 -I/usr/include/wayland -I/usr/include/libxkbcommon -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -pthread  -pipe -O2 -ftree-vectorize conftest.c -lgobject-2.0 -lgtk-3 -lgdk-3 -L/usr/lib -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0   >&5
    /usr/lib64/gcc/x86_64-suse-linux/9/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib64/gcc/x86_64-suse-linux/9/../../../libharfbuzz.so when searching for -lharfbuzz
    /usr/lib64/gcc/x86_64-suse-linux/9/../../../../x86_64-suse-linux/bin/ld: cannot find -lharfbuzz
    collect2: error: ld returned 1 exit status
    Como veis, es la misma operación pero en TW hace algo curioso y es que si no entiendo mal salta a las librerías de 64 bits, cuando debería buscar en las de 32, lanza un error y "pasa de todo".
    Puedo llegar a entender que ahí está el fallo, pero ni entiendo qué hace y mucho menos como se soluciona, supera mis conocimientos de esto xD

    Sea como sea, me falta construir Proton-tkg para probarlo en Steam a ver que tal, y si funciona o no, tengo que reinstalar el sistema, como siempre está inestable y leeento, aunque me esperaré a ver si al final puedo quitar ese error de GTK3, si me indicáis algo.

    Salu2!

    ---EDIT--
    Madre mia, a veces las cosas son más sencillas de lo que parece....no conocía el comando "locate", usándolo me he dado cuenta que ese archivo que busca no está en /usr/lib, o sea, que al final si que busca en la ruta correcta. La solución:
    Código:
    cd /usr/lib
    sudo ln -s libharfbuzz.so.0 libharfbuzz.so
    Listo, Gtk3 en marcha. Recompilando.

    --EDIT2--
    Todo sigue igual, ahora hay unos logs con los mínimos "not found", solo libhal y OSS, en Manjaro aparecen incluso más, sigue con el version mismatch.
    Hasta aquí he llegado.
    Reinstalo el sistema y a otra cosa. Si alguien lo consigue ya lo contará xD
    Última edición por Jordi4321; 20-ene-2020 a las 20:14

  7. #27
    Fecha de Ingreso
    20-noviembre-2017
    Ubicación
    Limpio - Paraguay
    Mensajes
    93
    Post Thanks / Like
    Poder de Credibilidad
    3

    Creo que tienes problemas de dependencias

    Para comprobar las dependencias tienes disponible
    Para 64bit

    ./non-makepkg-build.sh --deps64

    Para 32bit
    ./non-makepkg-build.sh --deps32

    En mi caso para ambos check me devuelve

    configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported. (Curiosamente solo me salta en la maquina virtual).
    configure: libvulkan and libMoltenVK 32-bit development files not found, Vulkan won't be supported. (como no pienso utilizar en MAC no me afecta).

    Usando ese parámetro me ayudo a instalar todas las dependencias... En tu caso me imagino que te ha de listar unos cuantos!...
    Saludos

  8. #28
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    317
    Post Thanks / Like
    Poder de Credibilidad
    2
    Voy a hacer un reset a la máquina, reinstalar todo siguiendo tus pasos y tiene que funcionar si o si. Ahora he visto tu mensaje que estaba pendiente de aprobación y ya veo que te funciona sin problemas, así que a mí también me tiene que funcionar.
    Puede que después de tanto trasteo tenga algún conflicto entre cosas que instalé, porque el sistema se vuelve como inestable, va lento y al arrancar salen mensajes que no salían antes.
    Si acaba funcionando será genial, estuvimos en github con otra persona también intentándolo y no hubo manera.
    Luego comento.

    --AÑADO--

    Bueno, a ver, sistema instalado desde 0, esta vez con Lxqt. Varias cosas después de seguir todo tu "tuto"...por cierto, los trasteos anteriores ya eran en la máquina real:
    unixODBC-devel-32bit -> no lo encuentra en los repos. Solución forzada, no encuentro la misma versión que lleva el sistema en ninguna parte:
    aahttp://rpm.pbone.net/index.php3/stat/4/idpl/23999255/dir/opensuse_tumbleweed/com/unixODBC-devel-32bit-2.3.1-367.1.x86_64.rpm.html
    aahttp://rpm.pbone.net/index.php3/stat/4/idpl/23996681/dir/opensuse/com/unixODBC-32bit-2.3.1-365.1.x86_64.rpm.html
    Son versiones más antiguas, tabú en yast.
    Otro detalle que he apuntado y no se cuando ha pasado:
    Código:
    Los siguientes 2 paquetes NUEVOS van a ser instalados:
      libopenssl-1_1-devel libopenssl-devel
    
    El siguiente paquete va a ser ELIMINADO:
      libressl-devel
    Entonces:
    Código:
    --deps64  
    configure: MinGW compiler not found, cross-compiling PE files won't be supported.
    configure: libhal 64-bit development files not found, no legacy dynamic device support.
    configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
    Elimino los mingw-gcc e instalo (no me preguntes por que instalo justamente esto):
    mingw32-cross-gcc
    mingw64-cross-gcc
    Hal no está en los repos oficiales, entonces añado este repo:
    aahttps://software.opensuse.org/download/package?package=hal-devel-32bit&project=home%3Abelphegor_belbel%3AKDE3
    E instalo:
    hal-devel -> desinstala libhal1
    hal-devel-32bit
    Código:
    --deps64
    configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
    64 listo.
    Ahora lo chungo:
    Código:
    --deps32
    configure: libGLU 32-bit development files not found, GLU won't be supported.
    configure: libhal 32-bit development files not found, no legacy dynamic device support.
    configure: gstreamer-1.0 base plugins 32-bit development files not found, GStreamer won't be supported.
    configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
    configure: libcapi20 32-bit development files not found, ISDN won't be supported.
    configure: libvulkan and libMoltenVK 32-bit development files not found, Vulkan won't be supported.
    Si te fijas, libhal 32bit devel not found....y más arriba escribo "e instalo hal-devel-32bit", es lo que más me saca de mis casillas xD

    Aquí me he quedado porque ya no se ni que instalar. No se como te ha salido tan fácil...no se si será el escritorio, los drivers de vídeo, el pc...me parece muy muy raro que a ti te funcione perfecto a la primera y yo tenga tantos problemas xD

    Espero a ver que me comentas, sino reinstalo otra vez, ya que esto son cerca de 1000 paquetes "extra" (que me parece una burrada). Ya estoy bien con Lutris y los wine oficiales xD (estoy un poco harto)

    --EDIT2--

    Por las capturas parece que usas KDE, verdad? A ver si KDE llevará una configuración diferente a Lxde o Lxqt. Yo instalo con "escritorio genérico" y luego selecciono Lxde o Lxqt en este caso, y 4 cosillas básicas, lo mínimo que uso. Dime como instalas tu TW y haré lo mismo, a ver si descubro que es lo que hago yo diferente, me da mucha rabia :S

    --EDIT3--

    He reinstalado con la primera opción que aparece en el instalador con KDE, nada de configuraciones adicionales, ni nada, tal cual se instala lo he probado. Pasa lo mismo. Ya no he hecho el --deps32.
    Reinstalo Lxde (Lxqt es terrible xD) y fin del trasteo, ya no pierdo ni 1 minuto más con esto. De hecho los juegos funcionan bien con todo de serie, así que ya está.
    Ya que esto acaba aquí, hago un pequeño "offtopic": cuando arranco la primera vez con los drivers nouveau, aparece el nombre tumbleweed y encima la imagen que veo cuando arrranca la bios xD:
    https://linustechtips.com/main/uploa...dec95bb9c2.png
    Al apagar igual. Luego cuando instalo los drivers Nvidia ya va todo normal, es super curioso.
    Si leyera este hilo sin ser yo, pensaría que Jordi4321 se lo está inventando todo, pero no ...
    Sea como sea, gracias por vuestro tiempo!
    Última edición por Jordi4321; 21-ene-2020 a las 17:35

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Dependencias para ATI
    By faco84 in forum Hardware
    Respuestas: 16
    Último mensaje: 07-abr-2009, 00:52
  2. Error al compilar wine 0.9.23
    By balrog in forum Software
    Respuestas: 1
    Último mensaje: 17-oct-2006, 12:45
  3. Ayuda para solucionar dependencias
    By luis in forum Software
    Respuestas: 0
    Último mensaje: 07-mar-2006, 09:47
  4. Ayuda para solucionar dependencias
    By luis in forum Instalación y Actualizaciones
    Respuestas: 0
    Último mensaje: 07-mar-2006, 09:45
  5. dependencias para k9copy
    By pelicos in forum Software
    Respuestas: 3
    Último mensaje: 24-jun-2005, 21:16

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •