Gracias Gracias:  8
Me Gusta Me Gusta:  9
No me Gusta No me Gusta:  1
Página 1 de 5 123 ... ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 47

Tema: Velocidad de arranque e inicio de aplicaciones

  1. #1
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    181
    Post Thanks / Like
    Poder de Credibilidad
    1

    Velocidad de arranque e inicio de aplicaciones

    Hola gente,
    Creo este tema para consultarles, ¿existe manera de mejorar la velocidad de arranque y de carga de aplicaciones?, ya que se toma su buen tiempo en iniciar.
    Utilizo OpenSuse Tumbleweed, con disco HDD (ext4) y 12 Gb de Ram (de los cuales consume solo 0,5 el sistema).




    Quiero que consuma mas RAM para obtener mayor velocidad de respuesta, pero luego de buscar no encuentré la manera.
    Busqué aplicaciones para mejorar eso, como e4rat, prelink o preload, pero no existen para OpenSuse, o capaz tengan otro nombre, no se...

    Ustedes conocen alguna manera de mejorar los tiempos?

  2. #2
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    75
    Post Thanks / Like
    Poder de Credibilidad
    1
    Hola!
    Mira, justamente a mi me pasaba lo mismo con el arranque, era lentísimo. He buscado por ahí y encontré algo. Para empezar deberías mirar que es lo que ralentiza el arranque, con un
    Código:
     systemd-analyze blame
    .
    En mi caso ha mejorado muchísimo configurando en Yast NTP a manual, desactivar ipv6 y desactivando chronyd-wait.service, que se hace con un
    Código:
    sudo systemctl disable chronyd-wait.service
    .
    Aun así, noto como si se quedara semiclavado en el inicio del arranque, además aparece un error:
    Código:
    Couldn't get size: 0x800000000000000e
    [    2.259426] MODSIGN: Couldn't get UEFI db list
    [    2.259531] Couldn't get size: 0x800000000000000e
    [    2.259546] Couldn't get UEFI MokListRT
    [    2.259623] Couldn't get size: 0x800000000000000e
    [    2.259637] Couldn't get UEFI dbx list
    que no consigo averiguar que es lo que significa.
    La otra parte de la pregunta, aquí dicen algo interesante:
    https://forums.opensuse.org/showthre...y-slow-to-load
    Lo acabo de probar y parece más ágil al cargar páginas y abrir las aplicaciones.
    Esto no lo se seguro, pero diria que el consumo de RAM no tiene nada que ver con que cargue más rápido o más lento las aplicaciones. Yo siempre prefiero usar lo que menos RAM consuma, en este caso LXDE, cuanta mas chatarra (efectos visuales, etc) tenga el sistema tiene mas trabajo para moverlo, al final a mi me interesa más la agilidad general que los efectos visuales.
    Me está ocupando unos 450Mb de Ram arrancado sin nada abierto, y las aplicaciones se cargan bastante rápido (con disco SSD).

    Salu2!
    Última edición por Jordi4321; 19-ago-2019 a las 07:13

  3. Gracias Tux83 ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.643
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola.

    @Tux83 empieza por aquí:

    https://lizards.opensuse.org/2012/07...2-second-boot/

    Naturalmente, hay muchas cosas que han cambiado en el arranque y tendrás que ir de una en una.

    Salud!!

  5. Gracias Tux83 ha agradecido este mensaje
  6. #4
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    181
    Post Thanks / Like
    Poder de Credibilidad
    1
    Gracias a ambos!
    Empecemos por los servicios:

    Código:
    ~> systemd-analyze blame
             14.217s postfix.service
             11.122s btrfsmaintenance-refresh.service
              8.215s firewalld.service
              6.649s apparmor.service
              5.917s ModemManager.service
              4.777s initrd-switch-root.service
              4.211s avahi-daemon.service
              3.862s rsyslog.service
              3.816s smartd.service
              2.699s display-manager.service
              2.653s systemd-udevd.service
              2.298s systemd-logind.service
              2.084s plymouth-quit-wait.service
              1.954s mcelog.service
              1.950s sound-extra.service
              1.941s alsa-restore.service
              1.940s kbdsettings.service
              1.905s vboxdrv.service
              1.856s nscd.service
              1.636s upower.service
              1.192s udisks2.service
              1.096s auditd.service
              1.076s systemd-tmpfiles-setup.service
              1.057s documentos.mount
              ...
    Deshabilite: postfix, btrfsmaintenance (ya que solo uso ext4), firewalld, apparmor, ModemManager.
    Antes el sistema demoraba en iniciar 80s, ahora demora 70s.

    Antes:
    Código:
    ~> systemd-analyze
    Startup finished in 3.084s (kernel) + 3.337s (initrd) + 34.158s (userspace) = 40.579s 
    graphical.target reached after 34.143s in userspace
    Despues:
    Código:
    ~> systemd-analyze
    Startup finished in 3.092s (kernel) + 3.265s (initrd) + 16.728s (userspace) = 23.087s 
    graphical.target reached after 16.713s in userspace
    No entiendo bien esos valores, ya que solo gané 10s y pareciera que hubiera ganado mucho mas, pero bueno, es irrelevante...
    Solo configuré esos servicios porque estoy seguro que no son importante, no quiero sacrificar nada importante ahora.

    --------------------------------------

    Sobre internet, utilizo una configuración fija por cable, y ya había deshabilitado el IPv6. Cité la lentitud del Firefox porque es lo que mas utilizo, pero no creo que sea por la conexión.

    --------------------------------------

    Sobre arranque de aplicaciones, ustedes utilizan disco SSD por lo cual no necesitan precargar nada (también llamado cacheo). En mi caso que uso HDD me seria muy útil que el sistema cargue las aplicaciones que mas uso en RAM, mientras este esté inactivo, para así acelerar la primer ejecución.
    Esto lo hacía un programa llamado preloader, que no logro ubicar en esta distribución.

    En KDE, Menu inicio -> Preferencias del sistema -> Arranque y apagado -> Sesión de escritorio , existen estas 3 opciones:
    1° Restaurar sesión previa
    2° Restaurar sesión guardada manualmente
    3° Comenzar una sesión vacía


    Yo tengo seleccionada la ultima.

    Pregunta: si selecciono la 1° o la 2°, al iniciar la sesión carga todo el cache de lo que se utilizó o solo carga lo que se dejó abierto al momento de salir?.
    Si cargase todo, funcionaría como el "preloader".

    Sldos.

  7. Gracias Krovikan ha agradecido este mensaje
  8. #5
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.643
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola.

    La segunda parte del artículo es: https://lizards.opensuse.org/2012/07...d-boot-part-2/

    En general, es buena idea sacar un gráfico del arranque para ver qué procesos pueden estar obligando a otros a esperar antes de ejecutarse. De todas formas, el arranque del sistema suele responder a las características de la distribución y no tener, por tanto, mucho margen de maniobra: openSUSE tradicionalmente ha tenido un arranque bastante lento en comparación a otras distribuciones.

    Salud!!

  9. #6
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    870
    Post Thanks / Like
    Poder de Credibilidad
    9
    He estado siguiendo vuestros comentarios y, tras verificar (en mi desconocimiento) las implicaciones reales de postfix, lo he desactivado y desinstalado.

    No he hecho ninguna actualización (ni de seguridad) para ver el antes y el después.

    Antes (arranque matutino del 20/08/2019):

    Código:
    krovikan@linux:~> systemd-analyze
    Startup finished in 11.414s (firmware) + 10.367s (loader) + 1.750s (kernel) + 1.861s (initrd) + 23.860s (userspace) = 49.254s
    krovikan@linux:~> systemd-analyze blame
             12.216s postfix.service
             10.765s btrfsmaintenance-refresh.service
              9.692s wicked.service
               725ms display-manager.service
               535ms apparmor.service
    Después (arranque matutino del 21/08/2019):

    Código:
    krovikan@linux:~> systemd-analyze
    Startup finished in 11.404s (firmware) + 10.367s (loader) + 1.737s (kernel) + 1.723s (initrd) + 11.696s (userspace) = 36.929s
    krovikan@linux:~> systemd-analyze blame
              9.912s btrfsmaintenance-refresh.service
              8.968s wicked.service
               770ms display-manager.service
               620ms lvm2-monitor.service
               543ms vboxdrv.service
               540ms apparmor.service
               533ms copias.mount
               447ms plymouth-quit-wait.service
    Una ganancia de 13 segundazos. De los cuales 12 en el espacio de usuario.

    Yo sí uso BtrFS así que ahí dejo el servicio correspondiente.


    Saludos

  10. Me Gusta Tux83 le ha gustado este mensaje
  11. #7
    Fecha de Ingreso
    16-agosto-2019
    Mensajes
    75
    Post Thanks / Like
    Poder de Credibilidad
    1
    Hombre, has pasado de un arranque en 40 segundos a 23, has recortado 17 segundos, no está nada mal.
    En el link que pasa el compañero hay muchas cosas que yo no tengo en mi sistema, así que también probé lo que pone pero a medias, no se si he recortado unos pocos segundos con todo. Aun así el arranque en un SSD es lentísimo comparado de donde vengo (Arch / Antergos), personalmente seguiré investigando a ver si hay algo mas para "tunear".
    Tema Firefox, a mi me va rapidísimo...aquí tienes unos trucos https://norfipc.com/utiles/10-medida...lve-lento.html y aquí también ha y algo, en la sección "speedup" https://en.opensuse.org/Firefox Yo uso firefox con adblockplus, se nota.
    El resto de preguntas no puedo ayudar, además estoy en Lxde.

    --EDIT--
    Fijate si es lento mi arranque:
    Código:
    Startup finished in 8.840s (firmware) + 798ms (loader) + 2.755s (kernel) + 2.292s (initrd) + 10.800s (userspace) = 25.487s 
    graphical.target reached after 10.760s in userspace
    Marca más tiempo que el tuyo, ahora probaré los ajustes que mencionas.

    --EDIT2--

    Nada, deshabilitando lo mismo que mencionas tarda 1 segundo más. Bueno da igual, no tengo prisa para que arranque. Ya está bien así.
    Última edición por Jordi4321; 21-ago-2019 a las 13:57

  12. Me Gusta Tux83 le ha gustado este mensaje
  13. #8
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.643
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola,
    arranque.jpgVisualizar gráficamente el arranque (systemd analyze plot > arranque.svg) de un sistema es interesante para detectar que un proceso en arranque pueda impedir con su retraso que se inicien otros, para así poder tomar decisiones.

    Salud!!

  14. Me Gusta Tux83 le ha gustado este mensaje
  15. #9
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    870
    Post Thanks / Like
    Poder de Credibilidad
    9
    Lo visualizo pero no sé detectar que un proceso esté ralentizando a otro. Más bien me parece que no lo hay.Arranque.jpg


    Saludos

  16. Me Gusta Tux83 le ha gustado este mensaje
  17. #10
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    181
    Post Thanks / Like
    Poder de Credibilidad
    1
    Hay servicios que se ejecutan todos juntos y hay otros que deben esperar a que sus anteriores estén activos antes de ejecutarse. Por eso existen esos gráficos.
    No es una suma directa de tiempos.

    Cita Iniciado por Jordi4321 Ver Mensaje
    Hombre, has pasado de un arranque en 40 segundos a 23, has recortado 17 segundos, no está nada mal.
    No me quejo, pero no es real eso. Optimicé 10 segundos en realidad, lo controlé con el cronometro del celular, desde que bootea hasta que carga el escritorio (tengo autologin).

    ----------

    El tiempo del boot no me interesa demasiado, me gustaría optimizar el uso de RAM, que precargue las aplicaciones que mas uso para obtener mejor velocidad en la primer ejecución.
    Alguien conoce como hacer eso?.

    Sldos.

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Temas Similares

  1. inicio de aplicaciones lentísimo
    By yoenforosuse in forum Instalación y Actualizaciones
    Respuestas: 3
    Último mensaje: 20-dic-2016, 19:33
  2. Posponer arranque de aplicaciones
    By Orugario in forum General OpenSUSE
    Respuestas: 2
    Último mensaje: 07-sep-2014, 22:00
  3. Respuestas: 0
    Último mensaje: 06-abr-2014, 22:12
  4. Aplicaciones de Inicio
    By Universe in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 4
    Último mensaje: 02-abr-2011, 19:28
  5. Respuestas: 2
    Último mensaje: 16-mar-2007, 00:13

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •