Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: LibreOffice no encuentra sus librerías

  1. #1
    Fecha de Ingreso
    05-agosto-2019
    Mensajes
    3
    Post Thanks / Like
    Poder de Credibilidad
    0

    Question LibreOffice no encuentra sus librerías

    cuando intento ejecutar LibreOffice 6.3.0.4 30(Build:4) me dice que:

    no se puede encontrar /usr/lib64/clang/8.0.1/lib/linux/libclang_rt.builtins-x86_64.a: No existe el fichero o el directorio
    error: linker command failed with exit code 1
    Final linking of kernel DynamicKernel failed

    mi primer impulso ha sido reinstalar, pero me gustaría saber si existe alguna forma de verificar la integridad de los programas desde yast y así me ahorro el tiempo de estar reinstalando programas y sus dependencias, un saludo por adelantado.

    ----------EDIT-------------
    Reinstalar el programa desde yast no solucionó el problema, parece que me voy a divertir, ahora voy a intentar instalando desde consola como me indica Tux83 mas abajo a ver si es un problema de la ultima actualización o es solo mío

    zypper remove --clean-deps libreoffice
    zypper install libreoffice

    ---------EDIT2-----------
    Luego de que se completen los comandos obtuve una hermosa lista de errores
    ** (soffice:15218): CRITICAL **: 15:22:38.636: void g_lo_menu_insert_section(GLOMenu*, gint, const gchar*, GMenuModel*): assertion 'G_IS_LO_MENU (menu)' failed

    (ELIPSIS DE ERRORES SUCESIVOS)

    no se puede encontrar /usr/lib64/clang/8.0.1/lib/linux/libclang_rt.builtins-x86_64.a: No existe el fichero o el directorio
    error: linker command failed with exit code 1 (use -v to see invocation)
    Final linking of kernel DynamicKernel failed.

    con ese nuevo dato conseguí llegar a un hilo de github que puede tener relación o no, al parecer por estar usando XFCE, el libreOffice está intentando usar unas referencias a un paquete programado en ASM que puede que lo necesite o no, de lo que estoy seguro es que en portátil LibreOffice funciona perfectamente y en la PC de escritorio me sigue lanzando la advertencia, seguiré informando, esto puede ser un error de actualización, alguna librería mal linkeada o un error causado por algún apagón eléctrico.

    ----SOLUCIÓN----
    Parece que libreoffice espera que estén instaladas ciertas librerías por defecto y sea por mi versión como por algún problema en la instalación, no tenía todas las librerías, acabo de instalar el paquete python3-Clang y sus dependencias, por alguna razón libreOffice necesita esa librería de python pero el error, como se puede ver, solo dice que falta una librería que no concuerda del todo, esto es por que va a buscar el fichero a una localización que no existe, al instalar el paquete Python3-Clang se colocan sucesivamente los componentes de lib y share, en mi caso solo tenía los ficheros de include de clang, así que doy este tema por cerrado.

    Gracias a todos por la ayuda.
    Última edición por anubarakdesu; 18-ago-2019 a las 17:43 Razón: solucionado
    "A veces es mejor encender un lanzallamas que maldecir a la oscuridad" - Terry Pratchett

  2. #2
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    177
    Post Thanks / Like
    Poder de Credibilidad
    1
    Tengo la misma versión y no me pide ese paquete, es mas, ni siquiera lo tengo instalado.

    Seguí nomás tu primer instinto, con:
    sudo zypper -rm --clean-deps libreoffice
    sudo zypper in libreoffice


    Sldos.

  3. #3
    Fecha de Ingreso
    05-agosto-2019
    Mensajes
    3
    Post Thanks / Like
    Poder de Credibilidad
    0
    Acabo de terminar la instalación nueva y sigue igual, parece que es algún problema mas grande, voy a probar desde consola a como me indica y actualizo el tema
    "A veces es mejor encender un lanzallamas que maldecir a la oscuridad" - Terry Pratchett

  4. #4
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    177
    Post Thanks / Like
    Poder de Credibilidad
    1
    No sabia que usabas Xfce, que versión de OpenSuse tenes?

    Parece un problema de repositorios, podrías comentarnos que te devuelve este comando?: zypper lr -d

  5. #5
    Fecha de Ingreso
    25-enero-2005
    Ubicación
    Lombardía, entre lagos y montañas mientras corro al trabajo
    Mensajes
    1.134
    Post Thanks / Like
    Poder de Credibilidad
    16
    Prueba lo siguiente: desinstala, abre un terminal y escribe

    whereis libreoffice

    Si el comando te da resultados (archivos y/o carpetas) es porque algo te ha quedado de una instalación anterior que no se borra al desinstalar: estas cosas pueden pasar cuando cambias repositorios. Tienes que borrar esos archivos manualmente antes de reinstalar.

    Si el comando no te da resultados... pues ni idea. Revisa que no tengas un conflicto de repositorios.
    Existen dos clases de personas: las que dicen que hay dos clases de personas y las que no.



    Mi blog sobre fotografía digital, arte, software libre,
    matemática, física y otros delirios

  6. #6
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    177
    Post Thanks / Like
    Poder de Credibilidad
    1
    Cita Iniciado por anubarakdesu Ver Mensaje
    ----SOLUCIÓN----
    Parece que libreoffice espera que estén instaladas ciertas librerías por defecto y sea por mi versión como por algún problema en la instalación, no tenía todas las librerías, acabo de instalar el paquete python3-Clang y sus dependencias, por alguna razón libreOffice necesita esa librería de python pero el error, como se puede ver, solo dice que falta una librería que no concuerda del todo, esto es por que va a buscar el fichero a una localización que no existe, al instalar el paquete Python3-Clang se colocan sucesivamente los componentes de lib y share, en mi caso solo tenía los ficheros de include de clang, así que doy este tema por cerrado.

    Gracias a todos por la ayuda.
    En mi caso, tengo KDE, no tengo instalada esa librería y el LibreOffice funciona sin problemas.
    Eso me hace pensar que en realidad esa librería está asociada al entorno Xfce, mas que al LibreOffice en sí.

    Me alegro que este solucionado!
    Saludos.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. librerias
    By alvaro in forum General OpenSUSE
    Respuestas: 5
    Último mensaje: 22-nov-2011, 23:48
  2. Librerias
    By rocker_rose in forum General OpenSUSE
    Respuestas: 0
    Último mensaje: 14-nov-2006, 15:53
  3. Librerias...
    By KaLPo in forum Software
    Respuestas: 7
    Último mensaje: 07-jul-2006, 17:58
  4. librerias
    By patry in forum Programación y Scripts
    Respuestas: 2
    Último mensaje: 24-dic-2005, 18:09
  5. librerias de apt
    By jelius in forum Software
    Respuestas: 8
    Último mensaje: 20-oct-2005, 11:29

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •