Gracias Gracias:  3
Me Gusta Me Gusta:  1
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: Paquetes oficiales y GLIBC

  1. #1
    Fecha de Ingreso
    08-noviembre-2018
    Mensajes
    46
    Post Thanks / Like
    Poder de Credibilidad
    0

    Paquetes oficiales y GLIBC

    Hola foro. En la progresiva reinstalación de Sw sobre Leap15.1, me he encontrado con 2 dificultades leves:

    El 1º corresponde al PysolFC (Soy un adicto a su Freecell semiautomático, para desconectar). Aun cuando existe instalador para 15.1,
    https://software.opensuse.org/downlo...ackage=PySolFC
    el icono botó la primera vez y aquí acabó su acción. La 2ª vez, ni eso.

    Después de seguir buscando encontré otra entrada donde indica que aún no existe paquete oficial para la 15.1
    https://software.opensuse.org/package/PySolFC
    ¿La solución será esperar el paquete oficial?... Llegará, ¿no?... Entretanto la tengo sobre Wine.
    ---------------------
    El 2º se refiere a un requerimiento del complemento del addon de Firefox Video Downloader Helper, perfecto hasta la LP15.0: Al ejecutarse da error por no encontrar la libreria GNU C GLIBC-2.27. Leap15.1 solo llega a la 2.26

    Encuentro glibc-2.29-lp151.504.1.x86_64.rpm para Leap 15.1 en http://rpm.pbone.net/index.php3/stat...%29%2864bit%29
    , que supera a la 2.27 requerida.

    Y al instalarla con Yast me propone 836 cambios, entre ellos al propio Yast... Desistí. Mucho cambio, y el primero en el propio Yast. Si va bien, pues bien. pero si no, igual me quedo sin sistema, sin Yast, y se va todo al traste... ¿Es recomendable esta instalación para la Lp15.1, con los 836 cambios?
    toni@192:~> inxi -C
    CPU: Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-HT-MCP-) cache: 2048 KB
    Saludos.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.361
    Post Thanks / Like
    Poder de Credibilidad
    10
    Te contesto los puntos:

    1.- Es una aplicación Python, mira las librerías si te falta alguna o una version mas actual. Basta con ejecutarlo en consola para que aparezca el error.

    2.- Tienes alternativas a Video Downloader Helper pero me extraña que no funcione ya que yo lo uso en Leap 15.0 sin problemas, y no creo que deberia haber problemas con el Leap 15.1 por esa libreria, yo la tengo mas vieja que tu.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. Gracias toni_usuario ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    08-noviembre-2018
    Mensajes
    46
    Post Thanks / Like
    Poder de Credibilidad
    0
    Gracias, DR.

    En relación al complemento del Video Dowloader Helper, lo solventé al recordar que esa libreria vieja que citas también se la instalé a mi pareja, que sigue usando L15.0: En sus Descargas estaba la versión 1.2.4, anterior a la actual 1.30 oficial, y que no reclama la GLIBC 2.27, aún no incorporada por Leap 15.1.

    Instalado y funcionando. Mientras, va reclamando actualizar a 1.30, que no habría que aceptar, en tanto Leap 15.1 no actualice su Libreria C... De ahí mis preguntas sobre la conveniencia o no a instalar la GLibC 2.29 encontrada, con más de 800 cambios anunciados.

    En relación al Pysol, igual. Bien en la 15.0 y mal en la 15.1. Me sorprende la divergencia de los 2 links opensuse citados: Mientras el primero ofrece un rpm para L15.1, el segundo declara la No Existencia de paquete oficial para L15.1... y lleva razón.
    toni@192:~> pysol
    Traceback (most recent call last):
    File "/usr/bin/pysol", line 28, in <module>
    init()
    File "/usr/lib/python2.7/site-packages/pysollib/init.py", line 91, in init
    from six.moves import tkinter
    ImportError: No module named six.moves
    toni@192:~>
    ¿?
    Me tendré que contentar con la versión Win en Wine, con una dinámica extraña. Saludos.

  5. #4
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.603
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola.

    Desarrollar con intérpretes y particularmente con python tiene muchas ventajas pero también un porrón de inconvenientes. En particular, tienes que conseguir incorporar todas las dependencias etc.

    Tienes instalado, seguramente, python3, y lo que necesitas es python2.

    Código:
    sudo zypper in python2-pip
    Aunque luego al ejecutarlo dice que no encuentra el "cardset" y solo puedes cerrar.

    Supuestamente, si funciona como creo, si tienes la carpeta de instalación en Windows, deberías poder ejecutarlo directamente sin wine, pero no tengo wine en esta máquina así que no puedo probar para ver cómo está instalado.

    https://sourceforge.net/projects/pys...PySolFC-2.6.4/

    Salud!!

  6. Gracias toni_usuario ha agradecido este mensaje
    Me Gusta toni_usuario le ha gustado este mensaje
  7. #5
    Fecha de Ingreso
    08-noviembre-2018
    Mensajes
    46
    Post Thanks / Like
    Poder de Credibilidad
    0
    Gracias !
    Resuelto a la primera! ... El Cardset ya lo tenia instalado por probaturas anteriores.

  8. #6
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.361
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por toni_usuario Ver Mensaje
    Instalado y funcionando. Mientras, va reclamando actualizar a 1.30, que no habría que aceptar, en tanto Leap 15.1 no actualice su Libreria C... De ahí mis preguntas sobre la conveniencia o no a instalar la GLibC 2.29 encontrada, con más de 800 cambios anunciados.
    Ni se te ocurra, igual rompes openSUSE y te toca reinstalarlo de nuevo, ya que es una librería esencial del kernel.

    Saludos.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  9. Gracias toni_usuario ha agradecido este mensaje

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problema con Glibc 2.4
    By Redan in forum Software
    Respuestas: 1
    Último mensaje: 19-jun-2007, 12:39
  2. ¿Actualizar Glibc?
    By Mikage in forum El Contubernio
    Respuestas: 0
    Último mensaje: 07-mar-2007, 12:59
  3. glibc 2.3.2 en suse 10.1
    By Maky in forum General OpenSUSE
    Respuestas: 0
    Último mensaje: 16-oct-2006, 22:51
  4. Glibc
    By gualas in forum Software
    Respuestas: 1
    Último mensaje: 26-sep-2006, 20:18
  5. Repositorios oficiales.
    By frippado in forum Software
    Respuestas: 2
    Último mensaje: 08-abr-2006, 02:02

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •