Gracias Gracias:  1
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 9 de 9

Tema: Montaje de particiones NTFS ha dejado de hacerse desde fstab

  1. #1
    Fecha de Ingreso
    20-noviembre-2014
    Mensajes
    13
    Post Thanks / Like
    Poder de Credibilidad
    0

    Montaje de particiones NTFS ha dejado de hacerse desde fstab

    Hola a todos, a ver si alguien puede echarme una mano...

    Tengo en mi equipo un disco duro con un par de particiones con formato NTFS. Hasta hace unas tres semanas iba todo perfectamente con el driver ntfs-3g y con esta configuración del fstab:

    Código:
    UUID=2AF83C65F82F51AD                      /mnt/intercambio        ntfs   defaults                      0  0
    UUID=9A503D58593C3D87                      /mnt/fotografias        ntfs   defaults                      0  0
    El caso es que de un tiempo a esta parte, cuando arranca el sistema no se montan estas dos particiones al inicio, sin que haya hecho ningún cambio en el fstab ni en los discos. De hecho, si abro Dolphin e intengo acceder a alguna de ellas, me pide la contraseña de root y a partir de ahí funciona todo perfectamente en esa particion.

    ¿Alguien sabe lo que puede estar pasando o puede darme alguna pista?


    Un saludo y gracias.

  2. #2
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.905
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    No se si pudo haber, un cambio en la politica del sistema, en cuanto seguridad (mira si hay cambios en fstab o si tienes copia) .

    Añade que los monte en el inicio, desde preferencias del sistema.

    I algún programa o carpeta varío (bueno es lo del principio)

    Por comodidad. desde yast2, puedes poner los en autofs (para que monte dispositivos bajo demanda, ya sean en el equipo o en red) .

    Puedes repetir la operación, no lleva mucho tiempo y es fácil hacer lo, recordar que aplique cambios en permisos y directorios.

    Si hubo alguna actualización cuando empezó a dar el fallo (hay que tener en cuenta que lo has montado en la / , a mi por lo general, solo lo tengo para acceder a el (y con hacerlo a uno me sirve para todos, lo tengo así por preferencia, ya que no los monto si no lo necesito, para eso uso el autofs) ,

    Código:
    -
    ├─sdc1  vfat               6368-A204                                       ├─sdc1    300M root  disk  brw-rw----
    ├─sdc2  btrfs              6239e5be-ef0b-449b-a571-e827de64245a            ├─sdc2     60G root  disk  brw-rw----
    └─sdc3  btrfs              05947e18-5f48-4efe-a36e-3f735c594d40            └─sdc3  871.2G root  disk  brw-rw----
    sdd                                                                        sdd       1.8T root  disk  brw-rw----
    └─sdd1  btrfs   RED-DATA1  98bdd06d-a857-4e0c-91ef-3dff8915f827            └─sdd1    1.8T root  disk  brw-rw----
    sde                                                                        sde       1.8T root  disk  brw-rw----
    └─sde1  btrfs   RED-DATA2  8768b8d4-56d8-4a5c-9a68-1d61eeb94e61            └─sde1    1.8T root  disk  brw-rw----
    sr0     iso9660 ISOIMAGE   2014-05-16-21-49-37-00               /run/media sr0      10.1M root  cdrom brw-rw----
    nvme1n1                                                                    nvme1n1 465.8G root  disk  brw-rw----
    └─nvme1n1p1
            ntfs               53D39B7442E3F817                     /run/media └─nvme1n1p1
                                                                                       464.8G root  disk  brw-rw----
    nvme0n1                                                                    nvme0n1 232.9G root  disk  brw-rw----
    └─nvme0n1p1
            btrfs   WD-3D-M2-PCIE
                               2735972a-6976-4150-b767-6c2b3fbbc4d8            └─nvme0n1p1
                                                                                       232.9G root  disk  brw-rw----
    z87-delux:~ # clear
    z87-delux:~ # lsblk -fm
    NAME    FSTYPE  LABEL      UUID                                 MOUNTPOINT NAME      SIZE OWNER GROUP MODE
    sda                                                                        sda     931.5G root  disk  brw-rw----
    ├─sda1  vfat               1D81-8EBA                            /boot/efi  ├─sda1    156M root  disk  brw-rw----
    ├─sda2  btrfs              ab0ed9b0-7705-46e5-8af5-323a194123b5 /          ├─sda2     40G root  disk  brw-rw----
    ├─sda3  btrfs              0892a0a2-e4c0-492e-b8a9-86b249e424fa /home      ├─sda3  885.8G root  disk  brw-rw----
    └─sda4  swap               d4bc9a05-07a7-4d3d-ae00-2424460474d3 [SWAP]     └─sda4      2G root  disk  brw-rw----
    sdb                                                                        sdb       3.7T root  disk  brw-rw----
    └─sdb1  btrfs   Seagate-4T 3dcf25f9-4ffc-4871-937c-2eee56c9f669 /run/media └─sdb1    3.7T root  disk  brw-rw----
    sdc                                                                        sdc     931.5G root  disk  brw-rw----
    ├─sdc1  vfat               6368-A204                                       ├─sdc1    300M root  disk  brw-rw----
    ├─sdc2  btrfs              6239e5be-ef0b-449b-a571-e827de64245a            ├─sdc2     60G root  disk  brw-rw----
    └─sdc3  btrfs              05947e18-5f48-4efe-a36e-3f735c594d40            └─sdc3  871.2G root  disk  brw-rw----
    sdd                                                                        sdd       1.8T root  disk  brw-rw----
    └─sdd1  btrfs   RED-DATA1  98bdd06d-a857-4e0c-91ef-3dff8915f827            └─sdd1    1.8T root  disk  brw-rw----
    sde                                                                        sde       1.8T root  disk  brw-rw----
    └─sde1  btrfs   RED-DATA2  8768b8d4-56d8-4a5c-9a68-1d61eeb94e61            └─sde1    1.8T root  disk  brw-rw----
    sr0     iso9660 ISOIMAGE   2014-05-16-21-49-37-00               /run/media sr0      10.1M root  cdrom brw-rw----
    nvme1n1                                                                    nvme1n1 465.8G root  disk  brw-rw----
    └─nvme1n1p1
            ntfs               53D39B7442E3F817                     /run/media └─nvme1n1p1
                                                                                       464.8G root  disk  brw-rw----
    nvme0n1                                                                    nvme0n1 232.9G root  disk  brw-rw----
    └─nvme0n1p1
            btrfs   WD-3D-M2-PCIE
                               2735972a-6976-4150-b767-6c2b3fbbc4d8            └─nvme0n1p1
                                                                                       232.9G root  disk  brw-rw----
    z87-delux:~ #
    Estoy con la 42.3 y no tengo problemas (aunque el punto de montaje es el que se usa por defecto ) .

    Comenta tu S.O. y la fecha que sospeches día mas o menos, haz un cat /var/log/zypp/history o ve desde yast en el instalador de programas, en la opción de ver la historia de instalación (sobre la fecha que tengas sospecha, has visto algún cambio relacionado) .

    O sea se puede ver mas cosas, permisos, cambios de propietario,etc...

    Salu2 cordiales

  3. #3
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    139
    Post Thanks / Like
    Poder de Credibilidad
    1
    Cita Iniciado por Viskovitz Ver Mensaje
    ¿Alguien sabe lo que puede estar pasando o puede darme alguna pista?
    Yo poseo la misma configuración del fstab y no tengo problemas.
    Posiblemente no sea problema de montaje, sino de permisos. Prueba con lo siguiente:

    sudo chmod 777 /mnt/intercambio
    sudo chmod 777 /mnt/fotografias


    Sldos.

  4. #4
    Fecha de Ingreso
    06-agosto-2013
    Ubicación
    / Home
    Mensajes
    197
    Post Thanks / Like
    Poder de Credibilidad
    7
    Hola, yo las monto al principio, media/lo que sea,
    Salu2

  5. #5
    Fecha de Ingreso
    20-noviembre-2014
    Mensajes
    13
    Post Thanks / Like
    Poder de Credibilidad
    0
    Hola a todos y gracias por contestar.

    He probado lo que propone mikrios y funciona a medias, ahora cada vez que arranco me pide contraseña para montar las particiones, lo cual es un avance pero no es lo que iba buscando.

    Por otra parte al ir a probar la propuesta de Tux83 he visto que las dos carpetas tienen ya los permisos drwxrwxrwx, aunque parece que están incluidas dentro del grupo root y pertenecen al usuario root. ¿Puede ser que este comportamiento se deba a esto?


    Un saludo y gracias.

  6. #6
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    139
    Post Thanks / Like
    Poder de Credibilidad
    1
    Cita Iniciado por Viskovitz Ver Mensaje
    ya los permisos drwxrwxrwx, aunque parece que están incluidas dentro del grupo root y pertenecen al usuario root. ¿Puede ser que este comportamiento se deba a esto?
    Todo esta bien, es correcto que el creador de la carpeta sea el root. Yo tengo la misma configuración y funciona perfecto.

    Utilizas windows?, si es así verificá de que no tengas activado el "inicio rápido", eso suele generar problemas.

    No se me ocurre otra cosa.

    Saludos.

  7. #7
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.905
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola_

    Es un tema muy sencillo, generalmente lo hace en :var/run/media/francis/ en este caso var/run/media/user/.

    si es otro lugar pues se pone como dueño a el usuario y se aplica a todo el contenido .El disco, bóton derecho, propiedades, permisos, usuario , el mismo, dueño idem, grupo al que pertenezcas y aplicar a todo el contenido del disco .

    En partcionador, puedes completarlo 777, te permite todo y si lo montas dentro de home, te libras de poner una clave, solo te quedaría la del propietario que en este caso es el usuario .

    Te va a medias,porque creo que solo necesita el montaje,lo otro de hacerme el dueño,lo hago al principio, ademas me sumo al grupo del root .





    Edito: En mi caso,solo lo hago a un disco, de todos los que quedan sin montar, entro pass, en uno de ellos y ya los demás, están accesibles (vamos, que no tengo que hacerlo uno por uno) , otra manera mas, es montarlo en /home; y si lo hago en la raíz, pues igual que home; pero pondría mi usuario como propietario del disco, eso y a todo su contenido.

    Salu2 cordiales
    Última edición por mikrios; 22-jul-2019 a las 08:41 Razón: añadir

  8. #8
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.609
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola.

    Pero sigues teniendo las entradas correspondientes en el fstab?

    Salud!!

  9. Gracias mikrios ha agradecido este mensaje
  10. #9
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.905
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola :


    No porque se montan automáticamente (como si fuese un usb, bajo demanda) ; puedo acceder a los 5 discos sin montar, solo haciendo lo en uno cualquiera . en yast2 activar autofs y en preferencias del sistema ---> almacenamiento extraible ----> dispositivos extraibles .

    Si quiero montarlo fijo si estaría en /etc/fstab :

    Código:
    
    UUID=d4bc9a05-07a7-4d3d-ae00-2424460474d3 swap                 swap       defaults              0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /                    btrfs      defaults              0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /boot/grub2/i386-pc  btrfs      subvol=@/boot/grub2/i386-pc 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /boot/grub2/x86_64-efi btrfs      subvol=@/boot/grub2/x86_64-efi 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /opt                 btrfs      subvol=@/opt          0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /srv                 btrfs      subvol=@/srv          0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /tmp                 btrfs      subvol=@/tmp          0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /usr/local           btrfs      subvol=@/usr/local    0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/cache           btrfs      subvol=@/var/cache    0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/crash           btrfs      subvol=@/var/crash    0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/lib/libvirt/images btrfs      subvol=@/var/lib/libvirt/images 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/lib/machines    btrfs      subvol=@/var/lib/machines 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/lib/mailman     btrfs      subvol=@/var/lib/mailman 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/lib/mariadb     btrfs      subvol=@/var/lib/mariadb 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/lib/mysql       btrfs      subvol=@/var/lib/mysql 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/lib/named       btrfs      subvol=@/var/lib/named 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/lib/pgsql       btrfs      subvol=@/var/lib/pgsql 0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/log             btrfs      subvol=@/var/log      0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/opt             btrfs      subvol=@/var/opt      0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/spool           btrfs      subvol=@/var/spool    0 0
    UUID=ab0ed9b0-7705-46e5-8af5-323a194123b5 /var/tmp             btrfs      subvol=@/var/tmp      0 0
    UUID=1D81-8EBA       /boot/efi            vfat       umask=0002,utf8=true  0 0
    UUID=0892a0a2-e4c0-492e-b8a9-86b249e424fa /home                btrfs      defaults              0 0
    Si te fijas en la lista mas arriba de lsblk -fm , veras todos los que están (ni los ssd están configurados y por curiosidad, desconozco si las optimizaciones en los nvmeram, llevan configuración y discard, etc, como son muy rápidos ignoro eso (por desconocer como los trata btrfs, haber si lo miro por la web) .

    z87-delux:~ # hdparm -tT /dev/nvme1n1

    /dev/nvme1n1:
    Timing cached reads: 25004 MB in 1.99 seconds = 12575.98 MB/sec
    Timing buffered disk reads: 4748 MB in 3.00 seconds = 1582.11 MB/sec
    WD black 500Gb y el de 250 Gb


    z87-delux:~ # hdparm -tT /dev/nvme0n1

    /dev/nvme0n1:
    Timing cached reads: 24598 MB in 1.99 seconds = 12370.24 MB/sec
    Timing buffered disk reads: 3428 MB in 3.00 seconds = 1142.38 MB/sec
    Un poco mas lento, pero tu ya sabes como van, ya que vi que tenias uno en una placa .

    Edito: no los monto, por si tengo que cambiar y probar hard (así no aparece en fstab, ni tengo que editarlo, solo si quiero que sea fijo ) .

    Saludos Cordiales
    Última edición por mikrios; 22-jul-2019 a las 21:02 Razón: añadir

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Auto-montaje unidades NTFS
    By Wonder in forum General OpenSUSE
    Respuestas: 2
    Último mensaje: 26-nov-2017, 13:08
  2. Editar archivo fstab para montar partición ntfs
    By susemex in forum General OpenSUSE
    Respuestas: 4
    Último mensaje: 07-oct-2014, 11:52
  3. Montaje de sistemas de archivos con /etc/fstab
    By tranzorx in forum FAQs, Manuales y Tutoriales
    Respuestas: 1
    Último mensaje: 17-abr-2013, 14:38
  4. NTFS y fstab
    By kikofras in forum Software
    Respuestas: 8
    Último mensaje: 31-ene-2008, 01:56
  5. fstab y particiones que no monto bien...
    By Mdk in forum Hardware
    Respuestas: 22
    Último mensaje: 20-oct-2006, 21:33

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •