Gracias Gracias:  4
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: Zypper no responde y quedó bloqueado SOLUCIONADO

  1. #1
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    177
    Post Thanks / Like
    Poder de Credibilidad
    1

    Zypper no responde y quedó bloqueado SOLUCIONADO

    Hola gente, tengo Tumbleweed.

    Hoy ejecuté la actualización del dia (202 paquetes) mediante la consola, y cuando estaba procesando el paquete btrfsmaintenance la misma quedo paralizada.
    La dejé una hora y como no avanzaba intenté cancelar con ctrol+c y otros métodos, pero no funcionó y tuve que reiniciar el equipo a la fuerza.
    Por cierto, no utilizo particiones btrfs, solo ext4.

    A partir de entonces es que no me deja acceder a Zypper, cualquier comando que introduzca me dice: zypper: error while loading shared libraries: libzypp.so.1709: cannot open shared object file: No such file or directory

    Tampoco tengo acceso al instalador de aplicaciones del Yast, me dice que un proceso con PID 3840 la esta bloqueando, pero no tengo ningún proceso con ese PID, seguramente quedó bloqueado de la sesión anterior, cuando tuve que reiniciar el equipo a la fuerza.

    Antes de meter mano e instalar el RPM correspondiente al libzypp.so.1709 , les quería preguntar si existe algún método para desbloquear zypper para estos casos.

    Sldos.


    SOLUCIONADO:

    - Descargué desde el repo OSS el paquete libzypp-17.11.4-1.3.x86_64.rpm
    - Extraje el archivo libzypp.so.1709 (enlace) y el libzypp.so.1709.2.4 y los copié a la carpeta /usr/lib64

    Y listo, todo funciona nuevamente.
    Última edición por Tux83; 28-jun-2019 a las 19:48

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.402
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por Tux83 Ver Mensaje
    Hoy ejecuté la actualización del dia (202 paquetes) mediante la consola, y cuando estaba procesando el paquete btrfsmaintenance la misma quedo paralizada.
    La dejé una hora y como no avanzaba intenté cancelar con ctrol+c y otros métodos, pero no funcionó y tuve que reiniciar el equipo a la fuerza.
    Por cierto, no utilizo particiones btrfs, solo ext4.
    Cuando te ocurra eso otra vez, haz un REISUB , mano de santo, te lo digo yo que me ha sacado de apuros en los cuelgues.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. Gracias Tux83, Krovikan ha agradecido este mensaje
  4. #3
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    869
    Post Thanks / Like
    Poder de Credibilidad
    9
    Muchas gracias, @DR.

    Sabía lo de REISUB pero siempre que lo probé no iba. Ahorá sé que no sólo era REISUB (y s¡n dejarlas pulsadas, de forma secuencial) si no que también hacía falta dejar pulsado Alt+Impr Pant.


    Saludos

  5. Gracias Tux83 ha agradecido este mensaje
  6. #4
    Fecha de Ingreso
    15-enero-2019
    Ubicación
    Argentina
    Mensajes
    177
    Post Thanks / Like
    Poder de Credibilidad
    1
    Gracias por el TIP !

    En mi caso, tuve que habilitar previamente las combinaciones de teclas en:

    Yast -> Centro de seguridad y fortificación | Y seleccionar Habilitar todas las funciones , como se puede ver en la captura:

    ventana.jpg

    Saludos.

  7. Gracias Krovikan ha agradecido este mensaje
  8. #5
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    869
    Post Thanks / Like
    Poder de Credibilidad
    9
    Gracias @Tux83. Por si acaso he hecho lo mismo y he habilitado las SysReq.


    Saludos

  9. #6
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.402
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por Tux83 Ver Mensaje
    En mi caso, tuve que habilitar previamente las combinaciones de teclas en:

    Yast -> Centro de seguridad y fortificación | Y seleccionar Habilitar todas las funciones , como se puede ver en la captura:
    Me había olvidado de eso, como llevo actualizando versiones de openSUSE con zypper dup. Gracias por recordarlo.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Actualizar con zypper dup o zypper up en openSUSE Tumbleweed [solucionado]
    By ylarguex in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 23-mar-2018, 01:46
  2. Actualización zypper y yast2, y ahora zypper no funciona
    By Bauglir in forum Instalación y Actualizaciones
    Respuestas: 5
    Último mensaje: 10-ene-2012, 10:52
  3. Mouse no responde
    By cotoclop in forum Hardware
    Respuestas: 5
    Último mensaje: 22-mar-2009, 21:46
  4. Viejo zypper vs nuevo zypper
    By RedDwarf in forum El Contubernio
    Respuestas: 9
    Último mensaje: 21-mar-2008, 14:22
  5. mi ordenador no responde
    By angelinux in forum Hardware
    Respuestas: 8
    Último mensaje: 27-abr-2007, 01:42

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •