Gracias Gracias:  19
Me Gusta Me Gusta:  12
No me Gusta No me Gusta:  0
Página 3 de 4 PrimeroPrimero 1234 ÚltimoÚltimo
Mostrando resultados del 21 al 30 de 32

Tema: yast no funciona en mi opensuse tumbleweed

  1. #21
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.430
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por catlib Ver Mensaje
    El comando dice que todo esta instalado y correcto y nada que hacer.
    el resultado que pediste.
    Cita Iniciado por Tux83 Ver Mensaje
    No se mucho de repositorios, seguramente alguien mas aca te ayude mejor que yo, pero simple vista puedo notar que el repositorio 4 no corresponde, porque apunta a la versión Leap y utilizas Tumbleweed.
    El repositorio 8 apunta a un disco, es raro...
    El repo 4 es de Leap y no de TW como te dice el compañero, tienes que eliminarlo porque ya lo tienes para TW, es el repo 9.

    El repo 8 es el DVD de instalación, tienes que deshabilitarlo para no tener siempre el DVD insertado en la lectora y así no te de la lata con mensajes a actualizar los paquetes.

    El repo 6 es un repo particular de un usuario, ¿que paquetes has instalado ahí que no estén en los repos comunitarios de openSUSE?.

    Una vez, hecho los cambios. Ejecuta el siguiente comando (copia y pegarlo en una consola):
    sudo zypper ref && sudo zypper ve
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  2. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib, Tux83 le ha gustado este mensaje
  3. #22
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    496
    Post Thanks / Like
    Poder de Credibilidad
    10

    Eliminados los repos y hecho el comando s)g DR

    Haber yo como me dijo victorhc.hago un zypper dup una vez por semana,no e instalado nada mas que recuerde,para quitar esos repos como lo hago? lo del dvd hace tiempo me di cuenta,pensé que lo
    había anulado,no por lo visto.en cuanto al seis como no sea que intente instalar el mailspring,por favor explicarme como eliminarlos repos.
    E borrado los repos 4,6 y 8 con zypper y seguido las instrucciones de DiabloRojo pero yast sigue igual.

    miquel@linux-h7ib:~> su
    Contrasenya:
    linux-h7ib:/home/miquel # zypper lr -upPE
    # | Àlies | Nom | Habilitat | Comprovació GPG | Refresca | Prioritat | URI (adreça del recurs)
    --+----------------------------------------+----------------------------------------------------+-----------+-----------------+----------+-----------+------------------------------------------------------
    6 | packman.inode.at-openSUSE_Tumbleweed | Packman | Sí | (r ) Sí | Sí | 70 | http://packman.inode.at/suse/openSUSE_Tumbleweed/
    1 | download.opensuse.org-non-oss | Repositori principal (Programari de codi NO obert) | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/tumbleweed/repo/non-oss/
    2 | download.opensuse.org-oss | Repositori principal (Programari de codi obert) | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/tumbleweed/repo/oss/
    3 | download.opensuse.org-tumbleweed | Repositori d'actualització principal | Sí | (r ) Sí | Sí | 99 | http://download.opensuse.org/update/tumbleweed/
    4 | google-chrome | google-chrome | Sí | (r ) Sí | Sí | 99 | http://dl.google.com/linux/chrome/rpm/stable/x86_64
    5 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository | Sí | (r ) Sí | Sí | 99 | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/
    linux-h7ib:/home/miquel #
    Última edición por catlib; 04-jul-2019 a las 12:59 Razón: mas informacion

  4. #23
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.666
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola.

    Código:
    sudo zypper se libyui
    Salud!!

  5. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib, Tux83 le ha gustado este mensaje
  6. #24
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    496
    Post Thanks / Like
    Poder de Credibilidad
    10
    Lo siento no funciona.

  7. #25
    Fecha de Ingreso
    15-enero-2019
    Mensajes
    190
    Post Thanks / Like
    Poder de Credibilidad
    1
    Cita Iniciado por catlib Ver Mensaje
    Lo siento no funciona.
    Puedes instalar la librería que dice karlggest, junto a otras dependencias necesarias con este comando:

    Código:
    sudo zypper in libyui-ncurses-pkg10 libyui-ncurses10 libyui-qt-graph10 libyui-qt-pkg10 libyui-qt10 libyui10 openSUSE-release patterns-kde-kde_yast patterns-yast-yast2_basis yast2-control-center-qt yast2-packager yast2-ycp-ui-bindings

  8. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib le ha gustado este mensaje
  9. #26
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    496
    Post Thanks / Like
    Poder de Credibilidad
    10

    Solucionado yast ya funciona

    Al fin como siempre me habéis solucionado el problema,pero por favor decidme que a provocado este fallo,y que debo hacer para no volver a repetirlo,adjunto una captura de como han quedado los

    repositorios de programación por si falta o sobra alguno,también a la hora de actualizar con zypper dup,debo de vigilar algo en concreto.

    Muchas gracias a todos y saludos cordiales.
    Última edición por catlib; 04-jul-2019 a las 17:33 Razón: Solucionado

  10. #27
    Fecha de Ingreso
    15-enero-2019
    Mensajes
    190
    Post Thanks / Like
    Poder de Credibilidad
    1
    El fallo se produjo porque faltaba una librería. A lo que lleva..., porque faltaba esa librería?, y ahí entramos en teorías...

    1) Estimo que la causa es tener mal configurado los repositorios, eso hace que el sistema descargue distintos paquetes de distintas versiones y genere todo tipo de conflictos.
    2) Que hayas desinstalado algún programa, del cual requiera ese paquete y por dependencia lo haya eliminado. Esto lo veo difícil igual...
    3) Que hayas insertado algún comando para limpiar paquetes huérfanos y por error elimine uno que era importante.

    Para mi el 1° es el mas lógico.. se me ocurren otros que no cito porque son mas raros aun.

    Lo importante es que lo hayas solucionado, que sepas gestionar los repositorios adecuadamente y para nosotros.., ya sabemos que esa librería puntual genera problemas con el Yast (para futuros casos).


    Me alegra que este solucionado!
    Saludos.

  11. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib le ha gustado este mensaje
  12. #28
    Fecha de Ingreso
    29-agosto-2010
    Ubicación
    Sabadell ( Barcelona )
    Mensajes
    496
    Post Thanks / Like
    Poder de Credibilidad
    10
    Perdón e olvidado la captura.

    http://paste.opensuse.org/29381442

  13. #29
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.666
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola.

    Abrás visto que algunas librerías incluyen su número de versión en el nombre. Supuestamente, además, el paquete incluye información entre otras cosas de qué otras librerías depende, y también a qué librerías sustituye.

    YaST depende de, entre otras cosas, libyuiN. Por lo que vemos, tu sistema no ha sido capaz de interpretar que debía de actualizar dicha librería, principalmente porque YaST sí ha detectado que libyui estaba instalado. Por ejemplo, porque tenías libyui9 en lugar de libyui10.

    Por supuesto, al actualizar YaST lo correcto es que se actualice libyui; pero por lo que sea, o bien el paquete de YaST no incluía información suficiente o correcta para saber que libyui también debería de ser actualizada.

    Cuando lo has ejecutado en consola, has publicado que el resultado de esa ejecución había sido:
    Código:
    Run command: /sbin/yast2 hwinfo &
    terminate called after throwing an instance of 'YUIPluginException'
      what():  Couldn't load plug-in qt
    /sbin/yast2 línia 461:  9941 Avortat                 (s'ha bolcat la  memòria)$ybindir/y2start $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY  $Y2UI_ARGS
    linux-h7ib:/home/miquel #
    Finalmente, buscando por yui y YaST encontré el enlace que he posteado anteriormente: https://superuser.com/questions/1385...e-leap-15?rq=1 que muestra un mensaje de consola muy similar al tuyo.

    Salud!!

  14. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib le ha gustado este mensaje
  15. #30
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.942
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    Algunos repositotios (como yast2) ; se encargan de la mayoría de las aplicaciones:






    Otra forma es verlo por el instalador de yast y en su defecto desde consola (hay una espina clavada, que es el sistema de resolución, que se le va hacer, pero idem hay herramientas de ystemd, que pueden ayudar, pero complejas.

    YAST2 un paquete, que carga la mayoría de yast2,desde consola se puede ver , algunas con el mismo nombre, también acudir a la wiki o a ficheros de algún compañero .

    zypper if yast2* o bien zypper if --requires yast2* .

    El tema es que un compañero que le funcione, haga una lista par que pueda, ser comparada con el que falla y de esa forma añadir las que falta hasta que se solucione.

    Salu2.

    PD. hay otra forma que es mas compleja,por lo que me abstengo de nombrarla (basada en systemd, pero es mas complicado de seguir, que resolución de un sistema.

  16. Gracias catlib ha agradecido este mensaje
    Me Gusta catlib, Tux83 le ha gustado este mensaje

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Respuestas: 6
    Último mensaje: 26-mar-2019, 13:40
  2. Respuestas: 3
    Último mensaje: 06-ene-2017, 12:24
  3. No funciona suspensión openSUSE Tumbleweed
    By netSys in forum Hardware
    Respuestas: 19
    Último mensaje: 03-ene-2014, 07:08
  4. Twitter no funciona, con Tumbleweed KDE.
    By Bauglir in forum Software
    Respuestas: 8
    Último mensaje: 22-jul-2013, 20:46
  5. YAST no FUnciona en KDE!!
    By chester08 in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 4
    Último mensaje: 22-jun-2009, 07:40

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •