Mostrando resultados del 1 al 5 de 5

Tema: "Las siguientes 11 actualizaciones NO serán instaladas" al hacer 'zypper update'

  1. #1
    Fecha de Ingreso
    25-marzo-2013
    Mensajes
    26
    Poder de Credibilidad
    0

    Exclamation "Las siguientes 11 actualizaciones NO serán instaladas" al hacer 'zypper update'

    Buen día

    Hasta ayer mis repositorios funcionaban normalmente, no obstante, hoy instalé los codecs necesarios para oír mp3, ver mp4, etc, etc. usando la página de 1 click install de OpenSuse Tumbleweed.

    Un rato después de instalados, hice "sudo zypper update", y me apareció:

    Las siguientes 11 actualizaciones NO serán instaladas:
    gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang libgstphotography-1_0-0 libquicktime0 libvlc5 libvlccore9 vlc
    vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt
    Así mismo, noté que se habían añadido los repositorios pacman, supongo que para instalar los codecs; Los desactive, y me dejó de aparecer el mensaje, los reactive volvió a aparecer... lo que conjeturo es que hay paquetes en pacman que también está en versiones distintas en otros repositorios.

    Mi pregunta es ¿es éste mensaje síntoma de algo grave? no quiero tener un os con los repos. desordenados, y que esté dañado dentro de unos meses. ¿debo preocuparme por este mensaje? ¿ o es algo trivial?

    Muchas gracias.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.174
    Poder de Credibilidad
    10
    Eso que te ocurre es normal, hay un paquete que no se puede actualizar porque no cumple las dependencias que te falta o tienes que migrarlo a otro repositorio. Como has contado que has actualizado Packman con 1-Clic, te falta un paso mas:
    sudo zypper dup --from Alias-o-numero-del-repo-Packman

    El numero o Alias del repositorio Packman lo veras con el comando
    sudo zypper lr

    TRUCO. Para actualizar ejecuta el comando
    sudo zypper up gstreamer-plugins-bad-lang

    Te aparecerá un mensaje con las instrucciones para actualizarlo, reportarlo y te lo explico.
    Última edición por DiabloRojo; 15-dic-2018 a las 10:11
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    25-marzo-2013
    Mensajes
    26
    Poder de Credibilidad
    0
    Cita Iniciado por DiabloRojo Ver Mensaje
    Eso que te ocurre es normal, hay un paquete que no se puede actualizar porque no cumple las dependencias que te falta o tienes que migrarlo a otro repositorio. Como has contado que has actualizado Packman con 1-Clic, te falta un paso mas:
    sudo zypper dup --from Alias-o-numero-del-repo-Packman

    El numero o Alias del repositorio Packman lo veras con el comando
    sudo zypper lr

    TRUCO. Para actualizar ejecuta el comando
    sudo zypper up gstreamer-plugins-bad-lang

    Te aparecerá un mensaje con las instrucciones para actualizarlo, reportarlo y te lo explico.
    Muchas gracias; hice sudo zypper dup, y me aparece

    daniel@linux-cbd0:~> sudo zypper dup --from http-ftp.uni-erlangen.de-30c54408
    Cargando datos del repositorio...
    Leyendo los paquetes instalados...
    Calculando actualización de distribución...
    11 Problemas:
    Problema: se ha producido un problema con el paquete instalado vlc-noX-3.0.4-1.3.x86_64
    Problema: se ha producido un problema con el paquete instalado libvlc5-3.0.4-1.3.x86_64
    Problema: se ha producido un problema con el paquete instalado vlc-3.0.4-1.3.x86_64
    Problema: se ha producido un problema con el paquete instalado vlc-codec-gstreamer-3.0.4-1.3.x86_64
    Problema: se ha producido un problema con el paquete instalado libgstphotography-1_0-0-1.14.4-1.2.x86_64
    Problema: se ha producido un problema con el paquete instalado libquicktime0-1.2.4+git20180207.666c35c-1.4.x86_64
    Problema: se ha producido un problema con el paquete instalado vlc-qt-3.0.4-1.3.x86_64
    Problema: se ha producido un problema con el paquete instalado libvlccore9-3.0.4-1.3.x86_64
    Problema: se ha producido un problema con el paquete instalado gstreamer-plugins-bad-lang-1.14.4-1.2.noarch
    Problema: se ha producido un problema con el paquete instalado gstreamer-plugins-ugly-lang-1.14.4-1.1.noarch
    Problema: se ha producido un problema con el paquete instalado vlc-lang-3.0.4-1.3.noarch

    Problema: se ha producido un problema con el paquete instalado vlc-noX-3.0.4-1.3.x86_64
    Solución 1: instalar vlc-noX-3.0.4-4.14.x86_64 (con cambio de proveedor)
    openSUSE --> http://packman.links2linux.de
    Solución 2: mantener el antiguo vlc-noX-3.0.4-1.3.x86_64

    Elija las soluciones usando '1' u omitir, reintentar o cancelar [1/2/o/r/c] (c): ^Cdaniel@linux-cbd0:~>


    por lo que no he hecho

    sudo zypper up gstreamer-plugins-bad-lang

  4. #4
    Fecha de Ingreso
    25-marzo-2013
    Mensajes
    26
    Poder de Credibilidad
    0
    Olvida mi mensaje de arriba, todo reparado.

    Leí el mensaje de error, y me di cuenta que era solo cambiar el repositorio que "maneja" esos paquetes de OpenSuse a Pacman

    Ya no me aparece lo de los 11 paquetes al hacer zypper update.

  5. #5
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.174
    Poder de Credibilidad
    10
    Me alegro de ello.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. bluray Linux
    By jolop in forum Hardware
    Respuestas: 39
    Último mensaje: 18-ene-2016, 05:42
  2. Comandos y mantenimiento de OpenSUSE Tumbleweed
    By joakoej in forum General OpenSUSE
    Respuestas: 54
    Último mensaje: 10-abr-2015, 21:12
  3. no serán instaladas actualizaciones
    By jjers in forum Instalación y Actualizaciones
    Respuestas: 2
    Último mensaje: 18-oct-2014, 17:58
  4. Instalar jDownloader con Java.
    By tranzorx in forum FAQs, Manuales y Tutoriales
    Respuestas: 66
    Último mensaje: 23-ago-2011, 00:04
  5. ¿Update? ¿Upgrade?
    By eltitu in forum General OpenSUSE
    Respuestas: 5
    Último mensaje: 08-oct-2008, 15:25

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •