Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 5 de 5

Tema: convert: not authorized `im1.pdf' @ error/constitute.c/WriteImage/1048.

  1. #1
    Fecha de Ingreso
    11-junio-2011
    Ubicación
    Canarias
    Mensajes
    939
    Post Thanks / Like
    Poder de Credibilidad
    9

    convert: not authorized `im1.pdf' @ error/constitute.c/WriteImage/1048. [Solucionado]

    Hola!!!
    Estoy intentando convertir como toda la vida un .png en un .pdf con el comando convert, pero no sé qué es lo que falla.

    Código:
    convert: not authorized `im1.pdf' @ error/constitute.c/WriteImage/1048.
    Tengo instalado el Image Magick, al menos el que viene en la Distro por defecto. También tengo instalados unos codecs que veo en los repos, pero...
    ¿Qué será lo que falla?
    Gracias.
    Última edición por SergioNN; 18-sep-2018 a las 21:40

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.283
    Post Thanks / Like
    Poder de Credibilidad
    10
    ¿Has probado buscarlo por Internet ese error? https://stackoverflow.com/questions/...-readimage-453

    Acabo de comprobar que me pasaba lo mismo pero haciendo lo que dice ahí, lo he solucionado. Aquí te dejo la secuencia de comandos que ejecute para solucionarlo.




    Solo te en cuenta que la carpeta ImageMagick-7_Q16HDRI6 es "personal" y esta asociada a la version instalada de ImageMagick, en mi caso la 7 y me aparecía dos carpetas ImageMagick-6...... y ImageMagick-7........
    Última edición por DiabloRojo; 18-sep-2018 a las 10:19
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    11-junio-2011
    Ubicación
    Canarias
    Mensajes
    939
    Post Thanks / Like
    Poder de Credibilidad
    9
    ¡Bien, me diste la idea!
    1. A mí, el comando Kdesu no me funciona, así que abrí Dolphin modo superusuario y me fui a los directorios que me indicaste.
    2. Una vez en policy.xml, lo abrí con Kwrite.
    3. Me lié a quitar toda aquella sarta de órdenes que tenía incrustada en el path del archivo, lo dejé limpio.
    4. Funcionó.
    (Yo sólo tenía instalada la versión 7, pero puede ser que al tratarse de una reinstalación que conserva usuario anterior, se haya montado un archivo con otro. Otra explicación no se me ocurre.)
    Muuuuchas gracias.

  4. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.283
    Post Thanks / Like
    Poder de Credibilidad
    10
    No te di la idea, te di la solución.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  5. #5
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.877
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    Lo que puedes tener ahora es un problema de seguridad y nivel crítico.

    Si lees los comentarios de ambos archivos, veras que eso a se notifico, mira el nº de bug y busca por la web.

    Los archivos no son iguales y cada versión es operativa (puede que algunos programas dependan de uno u de otro, el tema es que las dependencias son muchas) .

    Estoy de acuerdo con @kristina, nada de borrar ni nada de comentar, en su día se le dio la solución, por defecto vienen des-activados y la solución es actualizar a uno corregido; mientras tanto la solución es la que ha dado @D.Rojo, habilita aquel que necesites, ya sea en lectura o lectura y escritura, y no toques nada mas por que ya están fijado el tamaño, para evitar un desbordamiento .

    La solución que está en el enlace es modificar esa linea : <policy domain="coder" rights="read|write" pattern="LABEL" /> creo que es la nº 92.

    "https://bugzilla.suse.com/show_bug.cgi?id=978061" , "https://www.google.com/search?q=https%3A%2F%2Fbugzilla.suse.com%2Fshow_bu g.cgi%3Fid%3D978061&ie=utf-8&oe=utf-8&client=firefox-b", "https://build.opensuse.org/package/view_file/openSUSE:Factory/ImageMagick/ImageMagick-disable-insecure-coders.patch?expand=0" , "https://forums.suse.com/archive/index.php/t-7633.html" , ..... etc

    Recuerda que en xml, idem wiki, etc los comentarios para el editor programador y que no sean visibles en la pagina es <¡-- comentario --> y este error se comunico en mayo del 2016 (debe haber una ya corregido, bueno puse un enlace del archivo :Index: ImageMagick-7.0.8-10/config/policy.xml

    para mi gusto ya que lo usa converter, ImageMagik, etc , sería actualizar o volver a instalar el programa que has modificado y aplicar la solución dada por @D.Rojo.

    Edito: de la madrugada del domingo se ha actualizado a la nueva versión (fechada del 21-9-2018), es la ImageMagick
    Código:
    Z87-Deluxe:~ # zypper if ImageMagick
    Loading repository data...
    Reading installed packages...
    
    
    Information for package ImageMagick:
    ------------------------------------
    Repository     : graficos                         
    Name           : ImageMagick                      
    Version        : 7.0.8.11-397.1                   
    Arch           : x86_64                           
    Vendor         : obs://build.opensuse.org/graphics
    Installed Size : 117.9 KiB                        
    Installed      : Yes                              
    Status         : up-to-date                       
    Source package : ImageMagick-7.0.8.11-397.1.src   
    Summary        : Viewer and Converter for Images  
    Description    :                                  
        ImageMagick is a robust collection of tools and libraries to read,
        write, and manipulate an image in many image formats, including popular
        formats like TIFF, JPEG, PNG, PDF, PhotoCD, and GIF. With ImageMagick,
        you can create images dynamically, making it suitable for Web
        applications. You can also resize, rotate, sharpen, color-reduce, or
        add special effects to an image and save your completed work in many
        different image formats. Image processing operations are available from
        the command line as well as through C, C++, and Perl-based programming
        interfaces.
    
    
    Versión instalada
    7.0.8.11-397.1
    vie 21 sep 2018 20:06:47 WEST
    
    dom 23 sep 2018 01:59:32 WEST
    Productivity/Graphics/Other
    Saludos Cordiales .

    system-files-can.png

    system-files-3.png

    system-files-general-base.png
    Última edición por mikrios; 23-sep-2018 a las 21:26 Razón: añadir corregir

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. No se pudo montar disco (Not authorized to perform operation)
    By depto_cool in forum General OpenSUSE
    Respuestas: 4
    Último mensaje: 04-feb-2017, 19:05

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •