Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 3 123 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 28

Tema: Widget Actualizaciones de Software pide ejecutar zyyper dup manualmente

  1. #1
    Fecha de Ingreso
    12-septiembre-2014
    Mensajes
    45
    Post Thanks / Like
    Poder de Credibilidad
    0

    Question Widget Actualizaciones de Software pide ejecutar zyyper dup manualmente

    Desde principios de la semana pasada (creo) el widget de Actualizaciones de Software en mi PC, con Plasma 5.13 en openSUSE Tumbleweed muestra las actualizaciones disponibles, pero en lugar de mostrar el botón "Instalar actualizaciones" dice que ejecute zypper dup manualmente.

    Vi varios bugs al respecto sin resolver (1030829 y su duplicado, por ejemplo), por lo que no le di mayor importancia y supuse que era un fallo transitorio que se resolvería y, de momento, no es así.

    Este fin de semana actualicé el portátil (también con Tumbleweed) y tras el reincio me ocurre lo mismo.

    El principal problema es que no me atrevo a ejecutar zypper dup porque me dice que va a borrar varios paquetes que me parecen fundamentales (Firefox, bundle* y otros más). Al final muestro lo que dice (y pongo en negrita algunos de esos paquetes).

    Al principio lo achacaba a que me estuve peleando con el PC para intentar hacer funcionar el DNI electrónico con un lector que compré "compatible con Linux": intenté instalar un paquete para openSUSE 42.2 de la web de la DGP, que me dio error (y supongo que no se instaló), además de descargar y ejecutar varias versiones de Firefox (FF ESR, p, ej.) porque algunas webs oficiales pedían soporte a la máquina Java y el Firefox actual bloquea Java.

    Supongo que en el PC, el problema de Firefox vendrá por ahí, pero el resto de paquetes, ni idea. En el portátil no recuerdo qué decía (no lo tengo aquí ahora), pero no amenazaba con borrarme la instalación (o eso me parece) y ahora el widget me manda ejecutar zypper dup manualmente, sin haber instalado software para el DNIe (en el portátil).

    De momento, actualizo con pkcon get-updates && pkcon update (porque pkcon-update solo me suele dar error de que el demonio se "rompe" en la mitad del proceso) y las actualizaciones pendientes desaparecen una vez instaladas.

    Mis repositorios en el PC:
    Código:
    localhost:~ # zypper lr -upPE
    #  | Alias                               | Name                        | Enabled | GPG Check | Refresh | Priority | URI                                                                            
    ---+-------------------------------------+-----------------------------+---------+-----------+---------+----------+--------------------------------------------------------------------------------
     3 | http-ftp.gwdg.de-c53244d4           | Packman Repository          | Yes     | (r ) Yes  | Yes     |   70     | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/                 
     1 | http-download.opensuse.org-158e01fa | Application:Geo             | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_Tumbleweed/
     2 | http-download.opensuse.org-9f947a2a | hardware                    | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/repositories/hardware/openSUSE_Tumbleweed/        
     4 | http-opensuse-guide.org-c57d847a    | libdvdcss repository        | Yes     | (r ) Yes  | Yes     |   99     | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                            
     7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/                          
     8 | repo-oss                            | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/                              
    10 | repo-update                         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/

    Y ahora los mensajes que me "aterrorizan" cuando ejecuto zypper dup, y a los que le digo que no:

    Código:
    localhost:~ # zypper dup  
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    3 Problems:
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
    Problem: problem with installed package libvidstab1_1-1.1.0-5.1.x86_64
    
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
     Solution 1: install libmpeg2-0-0.5.1-2.2.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libmpeg2-0-0.5.1-3.42.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2
    
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
     Solution 1: install libmpeg2convert0-0.5.1-2.2.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libmpeg2convert0-0.5.1-3.42.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2
    
    Problem: problem with installed package libvidstab1_1-1.1.0-5.1.x86_64
     Solution 1: install libvidstab1_1-1.1.0-1.1.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libvidstab1_1-1.1.0-5.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2
    Resolving dependencies...
    Computing distribution upgrade...
    
    The following 27 items are locked and will not be changed by any action:
     Available:
      gtk2-immodule-amharic gtk2-immodule-amharic-32bit gtk2-immodule-inuktitut gtk2-immodule-inuktitut-32bit gtk2-immodule-thai gtk2-immodule-thai-32bit gtk2-immodule-vietnamese
      gtk2-immodule-vietnamese-32bit gtk3-immodule-amharic gtk3-immodule-amharic-32bit gtk3-immodule-inuktitut gtk3-immodule-inuktitut-32bit gtk3-immodule-thai
      gtk3-immodule-thai-32bit gtk3-immodule-vietnamese gtk3-immodule-vietnamese-32bit gtk4-immodule-amharic gtk4-immodule-amharic-32bit gtk4-immodule-inuktitut
      gtk4-immodule-inuktitut-32bit gtk4-immodule-thai gtk4-immodule-thai-32bit gtk4-immodule-vietnamese gtk4-immodule-vietnamese-32bit
     Installed:
      libmpeg2-0 libmpeg2convert0 libvidstab1_1
    
    The following 23 NEW packages are going to be installed:
      cdrecord dolphin-part-lang gtk3-lang kactivitymanagerd-lang kdelibs4-branding-upstream konsole-part-lang kwallet-tools-lang libcdrdeflt1_0 libdeflt1_0 libedc_ecc1_0
      libedc_ecc_dec1_0 libesmtp6 libfile1_0 libfind2_0 libgcj-jar-gcc6 libkgantt-lang librscg1_0 libscg1_0 libscgcmd1_0 libschily1_0 libstorage-ng-lang mkisofs readcd
    
    The following 119 packages are going to be REMOVED:
      MozillaFirefox MozillaFirefox MozillaFirefox MozillaFirefox MozillaFirefox android-tools boost-license1_66_0 bundle-lang-common-en bundle-lang-common-es bundle-lang-gnome-en
      bundle-lang-gnome-es bundle-lang-kde-en bundle-lang-kde-es cdrkit-cdrtools-compat clamav clamav gegl-0_2 gegl-0_2-lang gegl-0_3 gegl-0_3-lang genisoimage goffice-0_8-lang
      ibus-branding-openSUSE-KDE icedax kdelibs4-branding-openSUSE ksplash-qml-branding-openSUSE ksplashx-branding-openSUSE libMagickCore-7_Q16HDRI5 libMagickWand-7_Q16HDRI5
      libSPIRV-Tools-suse5 libSPIRV-Tools-suse5-32bit libSoundTouch0 libamd-2_4_6 libboost_date_time1_66_0 libboost_filesystem1_66_0 libboost_iostreams1_66_0 libboost_locale1_66_0
      libboost_regex1_66_0 libboost_system1_66_0 libboost_thread1_66_0 libcamd-2_4_6 libccolamd-2_9_6 libcdio16 libcholmod-3_0_11 libcolamd-2_9_6 libesmtp libgdbm4 libgdbm4-32bit
      libgegl-0_2-0 libgegl-0_3-0 libgit2-26 libgoffice-0_8-8 libgstbadbase-1_0-0 libical2 libicu60_2 libicu60_2-ledata libidn11 libieee1284-3 libieee1284-3-32bit libisl15
      libiso9660-10 libjasper1 libjavascriptcoregtk-1_0-0 libjson-c3 libjson-c3-32bit libkdecorations2private5 libkerfuffle17 liblmdb-0_9_17 libminiupnpc16 libmozjs-17_0 libnetcdf11
      libopencv3_3 libpoppler73 libprocps6 libqalculate13 libsuitesparseconfig-4_5_5 libsynctex1 libudisks2_btrfs libumfpack-5_7_6 libvolume_key1 libvpx4 libwebkitgtk-1_0-0
      libwebkitgtk2-lang libwebp6 libwebp6-32bit libwebpmux2 libwx_baseu-suse-nostl3 libwx_baseu-suse3 libwx_baseu_net-suse-nostl3 libwx_baseu_net-suse3 libwx_baseu_xml-suse-nostl3
      libwx_baseu_xml-suse3 libwx_gtk2u_adv-suse-nostl3 libwx_gtk2u_adv-suse3 libwx_gtk2u_aui-suse3 libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_core-suse3 libwx_gtk2u_gl-suse3
      libwx_gtk2u_html-suse-nostl3 libwx_gtk2u_html-suse3 libwx_gtk2u_qa-suse-nostl3 libwx_gtk2u_qa-suse3 libwx_gtk2u_xrc-suse3 openldap2-client openldap2-client openldap2-client
      openldap2-client python3 python3 python3 python3 systemd-bash-completion wine wine wine wine wine wine wodim
    
    The following package is going to be upgraded:
      libgtk-3-0
    
    The following 13 packages are going to be downgraded:
      gtk2-branding-openSUSE gtk3-branding-openSUSE libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libpostproc54 libreadline7 libswresample2
      libswscale4 readline-doc
    
    1 package to upgrade, 13 to downgrade, 23 new, 119 to remove.
    Overall download size: 27.9 MiB. Already cached: 0 B. After the operation, 2.1 GiB will be freed.
    Continue? [y/n/...? shows all options] (y): n

    He probado a ejecutar zypper clean && zypper refs && zypper ref, tras leer este hilo, a ver si sonaba la flauta, y sigue diciendo lo mismo.

    ¿Alguna idea y/o sugerencia de qué probar antes de reinstalar el PC (aunque el portátil está en un situación similar)?

  2. #2
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.163
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:

    también tenía esa duda; pero me lo aclaro un moderador, en TW las actualizaciones se hacen con zypper dup.

    Si te cambia de proveedor, creo que la prioridad de packman es alta y eso es normal, ya que los codecs y demás son operativos en ese proveedor, es decir que funcionan .

    Que te borre u programa, no implica que te lo quita, puede ser sustituido por una nueva versión y es más fácil eliminarlo e instalarlo de nuevo, así que no te preocupes no te lo quita, y si no lo vuelves a instalar ( pero no creo que haga falta) .

    && son para ejecutar tres comandos en una sola lineá, y es para cuando da un error de chache en los rpm, lo que me quedo la duda de los archivos aquellos, si había que borrarlos .

    Normalmente es la opción 1, pero si es por que pasa a packman, no me preocuparía, y si es por que lo que te va instalar de ese proveedor, aunque la versión sea inferior o superior, no me preocuparía y menos cuando tiene prioridad de 70 (nº mas bajo, prioridad mas alta) .

    Lo veo todo normal, haber que te comentan los demás .

    Saludos cordiales.

  3. #3
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.671
    Post Thanks / Like
    Poder de Credibilidad
    10
    Una pregunta, ¿para que necesitas el repo hardware?.

    A mi me parece un poco raro que elimine el Firefox y no proponga sustituirlo por otra versión pero sospecho que el problema están en los paquetes gtk2, gtk3 y gtk4 que va a bloquear, a parecer son de idiomas. Como no tengo TW, espera que te lea algún compañero que lo use para que te oriente.
    Última edición por DiabloRojo; 04-jul-2018 a las 09:28
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  4. #4
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    No tengo TW pero recuerdo que en su momento tener bloqueado (como tabú) bluez (creo que era) me afectaba para la instalación de otras cosas y al final lo desbloqueé.


    Prueba a quitar esos bloqueos como dice @DR.




    Saludos

  5. #5
    Fecha de Ingreso
    08-abril-2010
    Ubicación
    /HOME
    Mensajes
    3.833
    Post Thanks / Like
    Poder de Credibilidad
    15
    Hola!

    En Tumbleweed la opción recomendada para actualizar el sistema es mediante zypper dup.
    El widget de actualizaciones no ejecuta ese comando, por eso creo recordar que en Tumbleweed añadieron ese comentario.

    Lo que te avisa es que esos paquetes de software van a cambiar de proveedor, algo a veces normal en Tumbleweed. No veo ningún problema por eso.

    Yo cada vez que sale una nueva "snapshot" actualizo de esa manera y acepto las advertencias que me ofrece y no he tenido problemas.

    Si utilizas Brtfs, crea un punto de recuperación e instala las actualizaciones. Si todo va bien Ok. Si por lo que sea crees que no te va bien, vuelve al punto que creaste... aunque creo que no te haría falta.

    Saludos.

    PS: Me permito poner un enlace son información sobre el método para actualizar el sistema:
    https://victorhckinthefreeworld.com/...segunda-parte/
    Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
    → Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
    → Me puedes seguir en: Mastodon - diaspora* - PixelFed

  6. #6
    Fecha de Ingreso
    12-septiembre-2014
    Mensajes
    45
    Post Thanks / Like
    Poder de Credibilidad
    0

    Thumbs up

    Gracias a todos por vuestras respuestas. A ver si soy no me olvido de responder a las cuestiones que surgen en las respuestas:

    mikrios

    Que te borre u programa, no implica que te lo quita, puede ser sustituido por una nueva versión y es más fácil eliminarlo e instalarlo de nuevo, así que no te preocupes no te lo quita, y si no lo vuelves a instalar ( pero no creo que haga falta) .
    Que yo recuerde, en el pasado alguna vez me dijo que iba a eliminar un paquete, pero me aparecía en la lista de paquetes nuevos a instalar (aunque es posible que me equivoque).

    DiabloRojo

    Una pregunta, ¿para que necesitas el repo hardware?.

    A mi me parece un poco raro que elimine el Firefox y no proponga sustituirlo por otra versión pero sospecho que el problema están en los paquetes gtk2, gtk3 y gtk4 que va a bloquear, a parecer son de idiomas
    Creo recordar que el repositorio hardware es para usar el QlandkarteGT con un GPS Garmin antiguo que tengo.

    Los paquetes bloqueados son de idiomas (vietnamita, thai, etc.), que me gastan datos de la cantidad de GB que tengo para el mes cuando se actualizan, y que no uso; me ocurre lo mismo con todos los paquetes (menos uno) de texlive.

    DiabloRojo y Krovikan:

    Los desbloquee,y sigue con la "amenaza" de borrar paquetes que uso:

    Código:
    localhost:~ # zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    3 Problems:
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
    Problem: problem with installed package libvidstab1_1-1.1.0-5.1.x86_64
    
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
     Solution 1: install libmpeg2-0-0.5.1-2.2.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libmpeg2-0-0.5.1-3.42.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2
    
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
     Solution 1: install libmpeg2convert0-0.5.1-2.2.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libmpeg2convert0-0.5.1-3.42.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2
    
    Problem: problem with installed package libvidstab1_1-1.1.0-5.1.x86_64
     Solution 1: install libvidstab1_1-1.1.0-1.1.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libvidstab1_1-1.1.0-5.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2
    Resolving dependencies...
    Computing distribution upgrade...
    
    The following 3 items are locked and will not be changed by any action:
     Installed:
      libmpeg2-0 libmpeg2convert0 libvidstab1_1
    
    The following 31 NEW packages are going to be installed:
      cdrecord dolphin-part-lang gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk3-immodule-amharic gtk3-immodule-inuktitut
      gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-lang kactivitymanagerd-lang kdelibs4-branding-upstream konsole-part-lang kwallet-tools-lang libcdrdeflt1_0 libdeflt1_0
      libedc_ecc1_0 libedc_ecc_dec1_0 libesmtp6 libfile1_0 libfind2_0 libgcj-jar-gcc6 libkgantt-lang librscg1_0 libscg1_0 libscgcmd1_0 libschily1_0 libstorage-ng-lang mkisofs readcd
    
    The following 119 packages are going to be REMOVED:
      MozillaFirefox MozillaFirefox MozillaFirefox MozillaFirefox MozillaFirefox android-tools boost-license1_66_0 bundle-lang-common-en bundle-lang-common-es bundle-lang-gnome-en
      bundle-lang-gnome-es bundle-lang-kde-en bundle-lang-kde-es cdrkit-cdrtools-compat clamav clamav gegl-0_2 gegl-0_2-lang gegl-0_3 gegl-0_3-lang genisoimage goffice-0_8-lang
      ibus-branding-openSUSE-KDE icedax kdelibs4-branding-openSUSE ksplash-qml-branding-openSUSE ksplashx-branding-openSUSE libMagickCore-7_Q16HDRI5 libMagickWand-7_Q16HDRI5
      libSPIRV-Tools-suse5 libSPIRV-Tools-suse5-32bit libSoundTouch0 libamd-2_4_6 libboost_date_time1_66_0 libboost_filesystem1_66_0 libboost_iostreams1_66_0 libboost_locale1_66_0
      libboost_regex1_66_0 libboost_system1_66_0 libboost_thread1_66_0 libcamd-2_4_6 libccolamd-2_9_6 libcdio16 libcholmod-3_0_11 libcolamd-2_9_6 libesmtp libgdbm4 libgdbm4-32bit
      libgegl-0_2-0 libgegl-0_3-0 libgit2-26 libgoffice-0_8-8 libgstbadbase-1_0-0 libical2 libicu60_2 libicu60_2-ledata libidn11 libieee1284-3 libieee1284-3-32bit libisl15
      libiso9660-10 libjasper1 libjavascriptcoregtk-1_0-0 libjson-c3 libjson-c3-32bit libkdecorations2private5 libkerfuffle17 liblmdb-0_9_17 libminiupnpc16 libmozjs-17_0 libnetcdf11
      libopencv3_3 libpoppler73 libprocps6 libqalculate13 libsuitesparseconfig-4_5_5 libsynctex1 libudisks2_btrfs libumfpack-5_7_6 libvolume_key1 libvpx4 libwebkitgtk-1_0-0
      libwebkitgtk2-lang libwebp6 libwebp6-32bit libwebpmux2 libwx_baseu-suse-nostl3 libwx_baseu-suse3 libwx_baseu_net-suse-nostl3 libwx_baseu_net-suse3 libwx_baseu_xml-suse-nostl3
      libwx_baseu_xml-suse3 libwx_gtk2u_adv-suse-nostl3 libwx_gtk2u_adv-suse3 libwx_gtk2u_aui-suse3 libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_core-suse3 libwx_gtk2u_gl-suse3
      libwx_gtk2u_html-suse-nostl3 libwx_gtk2u_html-suse3 libwx_gtk2u_qa-suse-nostl3 libwx_gtk2u_qa-suse3 libwx_gtk2u_xrc-suse3 openldap2-client openldap2-client openldap2-client
      openldap2-client python3 python3 python3 python3 systemd-bash-completion wine wine wine wine wine wine wodim
    
    The following 2 packages are going to be upgraded:
      libgtk-3-0 youtube-dl
    
    The following 13 packages are going to be downgraded:
      gtk2-branding-openSUSE gtk3-branding-openSUSE libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libpostproc54 libreadline7 libswresample2
      libswscale4 readline-doc
    
    2 packages to upgrade, 13 to downgrade, 31 new, 119 to remove.
    Overall download size: 30.6 MiB. Already cached: 0 B. After the operation, 2.1 GiB will be freed.
    Continue? [y/n/...? shows all options] (y): n
    victorhck

    Lo que te avisa es que esos paquetes de software van a cambiar de proveedor, algo a veces normal en Tumbleweed. No veo ningún problema por eso.
    Yo tampoco. Simplemente prefiero usar los de Packman, que están más actualizados.

    Si utilizas Brtfs, crea un punto de recuperación e instala las actualizaciones. Si todo va bien Ok. Si por lo que sea crees que no te va bien, vuelve al punto que creaste... aunque creo que no te haría falta.
    No recuerdo qué problemas tuve, pero tras anunciar RedHat y la propia SUSE (si no recuerdo mal) que dejaban de dar soporte a Brtfs en breve, me pasé a Ext4 en cuanto tuve que instalar de cero el PC.


    Resumiendo:

    A ver si voy a una cafetería a bajarme una versión actualizada de Tumbleweed, y cuando la tenga grabada en un DVD le doy el OK a zypper dup, y a ver qué pasa.

    Una vez más: Gracias por vuestra ayuda.

  7. #7
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    Sigues teniendo 3 paquetes bloqueados:


    libmpeg2-0 libmpeg2convert0 libvidstab1_1


    Esos 3 paquetes son los que te están dando problemas de dependencias y son los que te dan a elegir entre mantenerlos o cambiarlos de proveedor.


    Desbloquéalos y prueba de nuevo si no has reinstalado ya.






    Saludos

  8. #8
    Fecha de Ingreso
    12-septiembre-2014
    Mensajes
    45
    Post Thanks / Like
    Poder de Credibilidad
    0
    Esos paquetes no están bloqueados (lo he comprobado, por si acaso), si no que me da la opción de cambiar el proveedor de los mismos. Como el cambio de proveedor de Packman a openSUSE me deja con una versión inferior rechazaba el cambio de proveedor.

    De todos modos, como son los tres únicos paquetes de los que aún se "quejaba" acepté el cambio de proveedor para ver si había algún cambio, y sigue la "amenaza" de borrado de paquetes que me parecen fundamentales, por lo que he vuelto a decir que no:

    Código:
    localhost:~ # zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    3 Problems:
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
    Problem: problem with installed package libvidstab1_1-1.1.0-5.1.x86_64
    
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
     Solution 1: install libmpeg2-0-0.5.1-2.2.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libmpeg2-0-0.5.1-3.42.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1
    
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
     Solution 1: install libmpeg2convert0-0.5.1-2.2.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libmpeg2convert0-0.5.1-3.42.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1
    
    Problem: problem with installed package libvidstab1_1-1.1.0-5.1.x86_64
     Solution 1: install libvidstab1_1-1.1.0-1.1.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libvidstab1_1-1.1.0-5.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1
    Resolving dependencies...
    Computing distribution upgrade...
    
    The following 32 NEW packages are going to be installed:
      cdrecord dolphin-part-lang gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk3-immodule-amharic gtk3-immodule-inuktitut
      gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-lang kactivitymanagerd-lang kdelibs4-branding-upstream konsole-part-lang kwallet-tools-lang libcdrdeflt1_0 libdeflt1_0
      libedc_ecc1_0 libedc_ecc_dec1_0 libesmtp6 libfile1_0 libfind2_0 libgcj-jar-gcc6 libkgantt-lang libmediacheck4 librscg1_0 libscg1_0 libscgcmd1_0 libschily1_0 libstorage-ng-lang
      mkisofs readcd
    
    The following 119 packages are going to be REMOVED:
      MozillaFirefox MozillaFirefox MozillaFirefox MozillaFirefox MozillaFirefox android-tools boost-license1_66_0 bundle-lang-common-en bundle-lang-common-es bundle-lang-gnome-en
      bundle-lang-gnome-es bundle-lang-kde-en bundle-lang-kde-es cdrkit-cdrtools-compat clamav clamav gegl-0_2 gegl-0_2-lang gegl-0_3 gegl-0_3-lang genisoimage goffice-0_8-lang
      ibus-branding-openSUSE-KDE icedax kdelibs4-branding-openSUSE ksplash-qml-branding-openSUSE ksplashx-branding-openSUSE libMagickCore-7_Q16HDRI5 libMagickWand-7_Q16HDRI5
      libSPIRV-Tools-suse5 libSPIRV-Tools-suse5-32bit libSoundTouch0 libamd-2_4_6 libboost_date_time1_66_0 libboost_filesystem1_66_0 libboost_iostreams1_66_0 libboost_locale1_66_0
      libboost_regex1_66_0 libboost_system1_66_0 libboost_thread1_66_0 libcamd-2_4_6 libccolamd-2_9_6 libcdio16 libcholmod-3_0_11 libcolamd-2_9_6 libesmtp libgdbm4 libgdbm4-32bit
      libgegl-0_2-0 libgegl-0_3-0 libgit2-26 libgoffice-0_8-8 libgstbadbase-1_0-0 libical2 libicu60_2 libicu60_2-ledata libidn11 libieee1284-3 libieee1284-3-32bit libisl15
      libiso9660-10 libjasper1 libjavascriptcoregtk-1_0-0 libjson-c3 libjson-c3-32bit libkdecorations2private5 libkerfuffle17 liblmdb-0_9_17 libminiupnpc16 libmozjs-17_0 libnetcdf11
      libopencv3_3 libpoppler73 libprocps6 libqalculate13 libsuitesparseconfig-4_5_5 libsynctex1 libudisks2_btrfs libumfpack-5_7_6 libvolume_key1 libvpx4 libwebkitgtk-1_0-0
      libwebkitgtk2-lang libwebp6 libwebp6-32bit libwebpmux2 libwx_baseu-suse-nostl3 libwx_baseu-suse3 libwx_baseu_net-suse-nostl3 libwx_baseu_net-suse3 libwx_baseu_xml-suse-nostl3
      libwx_baseu_xml-suse3 libwx_gtk2u_adv-suse-nostl3 libwx_gtk2u_adv-suse3 libwx_gtk2u_aui-suse3 libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_core-suse3 libwx_gtk2u_gl-suse3
      libwx_gtk2u_html-suse-nostl3 libwx_gtk2u_html-suse3 libwx_gtk2u_qa-suse-nostl3 libwx_gtk2u_qa-suse3 libwx_gtk2u_xrc-suse3 openldap2-client openldap2-client openldap2-client
      openldap2-client python3 python3 python3 python3 systemd-bash-completion wine wine wine wine wine wine wodim
    
    The following 54 packages are going to be upgraded:
      checkmedia clang6 glibc glibc-32bit glibc-devel glibc-extra glibc-locale grub2 grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin grub2-x86_64-efi libLLVM6
      libLLVM6-32bit libLTO6 libbrotlicommon1 libbrotlidec1 libc++-devel libc++1 libc++abi-devel libc++abi1 libclang6 libefivar1 libgtk-3-0 libibverbs libibverbs1 libldap-2_4-2
      libldap-2_4-2-32bit libldap-data liblz4-1 liblz4-1-32bit libmariadb-devel libmariadb3 libmlx4-1 libmlx5-1 libp11-kit0 libp11-kit0-32bit libqt5-qtwebengine libsqlite3-0
      libsqlite3-0-32bit libsrt1 libvcdinfo0 linux-glibc-devel lz4 nscd openSUSE-release openSUSE-release-ftp openldap2-client p11-kit p11-kit-32bit p11-kit-tools rdma-core vcdimager
      xen-libs
    
    The following product is going to be upgraded:
      openSUSE Tumbleweed  20180701-0 -> 20180702-0
    
    The following 16 packages are going to be downgraded:
      gtk2-branding-openSUSE gtk3-branding-openSUSE libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libmpeg2-0 libmpeg2convert0 libpostproc54
      libreadline7 libswresample2 libswscale4 libvidstab1_1 readline-doc
    
    The following 3 packages are going to change vendor:
      libmpeg2-0        http://packman.links2linux.de -> openSUSE
      libmpeg2convert0  http://packman.links2linux.de -> openSUSE
      libvidstab1_1     http://packman.links2linux.de -> openSUSE
    
    54 packages to upgrade, 16 to downgrade, 32 new, 119 to remove, 3  to change vendor.
    Overall download size: 133.7 MiB. Already cached: 0 B. After the operation, 2.1 GiB will be freed.
    Continue? [y/n/...? shows all options] (y): n
    Muchas gracias

  9. #9
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.855
    Post Thanks / Like
    Poder de Credibilidad
    25
    Hola.


    Guarda en un fichero de texto los paquetes eliminados y los tres a los que cambias proveedor. Haz la actualización completa. Instala lo que eches en falta.


    Salud!!

  10. #10
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.855
    Post Thanks / Like
    Poder de Credibilidad
    25
    Hola.


    Guarda en un fichero de texto los paquetes eliminados y los tres a los que cambias proveedor. Haz la actualización completa. Instala lo que eches en falta.


    Salud!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. error repositorios
    By jjers in forum Instalación y Actualizaciones
    Respuestas: 35
    Último mensaje: 07-nov-2017, 02:42
  2. Software libre y GNU/Linux
    By Jersoncito in forum El Contubernio
    Respuestas: 1
    Último mensaje: 26-jun-2012, 04:06
  3. Algunos somos asi
    By wiri in forum La cafetería
    Respuestas: 9
    Último mensaje: 23-mar-2010, 23:34
  4. Respuestas: 2
    Último mensaje: 28-feb-2009, 17:15
  5. Canonical, a punto de ser rentable
    By Dux in forum Noticias
    Respuestas: 12
    Último mensaje: 19-feb-2009, 04:01

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •