Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 4 de 4

Tema: Mensajes/Advertencias al instalar controlador Nvidia.

  1. #1
    Fecha de Ingreso
    04-abril-2014
    Ubicación
    Islas Canarias - España
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Question Mensajes/Advertencias al instalar controlador Nvidia.

    Buenos Días.
    En el enlace a la imagen que adjunto, se puede observar a qué me refiero con los mensajes de advertencia.
    Al instalar Nvidia, la versión 390, mediante terminal. Por ejemplo con zypper inr, al finalizar la instalación en Opensuse Leap 42.3 aparecen esos mensajes de advertencia, que son muchos, uno por cada archivo:

    "depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknow symbol __X86_indirect_"
    La lista de archivos que necesitan ese "unknow symbol" es larga.

    Luego, aparece otro dos mensaje:
    "WARNING: /lib/modules/4.4.76-default is inconsistent"
    "WARNING: weak updates symlinks might not be created"

    Cabe destacar que el desempeño del driver es correcto, pero no deja de llamarme la atención la cantidad de advertencias. En Tumbleweed no sucede, así como tampoco en otras distros como Debian (usa la versión 375), Ubuntu y derivadas (usan la 396).

    ¿Alguna idea sobre qué puede causar esos "errores"?

    Gracias de antemano.

    https://i.imgur.com/pehmwwA.jpg

  2. #2
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    1.086
    Post Thanks / Like
    Poder de Credibilidad
    12
    Yo siempre lo hago manual (hay muchos posts mios en el foro con los pasos y cosas previas a hacer) y 0 problemas.

    Lo de los símbolos igual es que te falta uno de los paquetes de kernel.

    Has de tener kernel-default, kernel-default-devel, kernel-devel y kernel-macros (este último tiene símbolos). Los 4 con la misma versión, en tu caso 4.4.76-1 (a día de hoy la versión de tu rama de kernel es la 4.4.128 por si lo quieres actualizar).
    Respeta la numeración completa del kernel. En mi caso es 4.15.8-1.1 (acaba en 1.1, eso lo ves fácil en Yast).

    No olvides de instalar siempre el kernel-firmware para estar actualizado de info sobre Hardware para manejar dispositivos.


    Saludos

  3. #3
    Fecha de Ingreso
    04-abril-2014
    Ubicación
    Islas Canarias - España
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Thumbs up

    Cita Iniciado por Krovikan Ver Mensaje
    Yo siempre lo hago manual (hay muchos posts mios en el foro con los pasos y cosas previas a hacer) y 0 problemas.

    Lo de los símbolos igual es que te falta uno de los paquetes de kernel.

    Has de tener kernel-default, kernel-default-devel, kernel-devel y kernel-macros (este último tiene símbolos). Los 4 con la misma versión, en tu caso 4.4.76-1 (a día de hoy la versión de tu rama de kernel es la 4.4.128 por si lo quieres actualizar).
    Respeta la numeración completa del kernel. En mi caso es 4.15.8-1.1 (acaba en 1.1, eso lo ves fácil en Yast).

    No olvides de instalar siempre el kernel-firmware para estar actualizado de info sobre Hardware para manejar dispositivos.


    Saludos
    Pues esta tarde te comento. Usualmente hago la instalación de los drivers vía terminal y zypper. Al poner zypper inr se instalan los programas recomendados así como también los drivers de nvidia. Voy a probar instalar previamente las dependencias que me indicas y lo comento por aquí.
    En cuanto al kernel, previo iniciar las X, hago todas las actualizaciones que correspondan hasta esa fecha, en modo consola. Una vez actualizado todo y configurado el firewall, los grupos a los que quiero que mi usuario pertenezca, etc, reinicio, y ejecuto zypper inr y zypper dup --from packman... etc.
    No inicio servidor gráfico alguno hasta que todo esté totalmente instalado y actualizado. Manías que uno coge luego de años de linux. jejejeje
    Nuevamente Gracias.
    Última edición por juanchusjuan; 19-abr-2018 a las 15:48

  4. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.674
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por juanchusjuan Ver Mensaje
    Buenos Días.
    En el enlace a la imagen que adjunto, se puede observar a qué me refiero con los mensajes de advertencia.
    Al instalar Nvidia, la versión 390, mediante terminal. Por ejemplo con zypper inr, al finalizar la instalación en Opensuse Leap 42.3 aparecen esos mensajes de advertencia, que son muchos, uno por cada archivo:

    "depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknow symbol __X86_indirect_"
    La lista de archivos que necesitan ese "unknow symbol" es larga.

    Luego, aparece otro dos mensaje:
    "WARNING: /lib/modules/4.4.76-default is inconsistent"
    "WARNING: weak updates symlinks might not be created"

    Cabe destacar que el desempeño del driver es correcto, pero no deja de llamarme la atención la cantidad de advertencias. En Tumbleweed no sucede, así como tampoco en otras distros como Debian (usa la versión 375), Ubuntu y derivadas (usan la 396).

    ¿Alguna idea sobre qué puede causar esos "errores"?

    Gracias de antemano.

    https://i.imgur.com/pehmwwA.jpg
    Son Warning o Avisos, no implica que tenga un error. Más bien parece que no coincide el kernel con el paquete instalado de Nvidia.

    Enviado desde mi m2 note mediante Tapatalk
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Instalar Skype en open Suse 11.3 64 bits.
    By tranzorx in forum FAQs, Manuales y Tutoriales
    Respuestas: 12
    Último mensaje: 11-abr-2020, 09:42
  2. Instalar osx, windows 7 y opensuse 11.4 en un imac... y no morir en el intento
    By oscarpoio in forum FAQs, Manuales y Tutoriales
    Respuestas: 6
    Último mensaje: 04-abr-2013, 23:37
  3. Que hacer después de Instalar Opensuse 12.2
    By Jonathan Miguel in forum Instalación y Actualizaciones
    Respuestas: 10
    Último mensaje: 23-oct-2012, 15:40
  4. Guia como instalar my paint
    By arag in forum Multimedia
    Respuestas: 8
    Último mensaje: 13-mar-2011, 17:28
  5. conflicto al instalar beryl
    By linuxsuse10.2 in forum Software
    Respuestas: 6
    Último mensaje: 24-abr-2007, 06:45

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •