Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 13

Tema: Actualizar con zypper dup o zypper up en openSUSE Tumbleweed [solucionado]

  1. #1
    Fecha de Ingreso
    01-octubre-2016
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0

    Actualizar con zypper dup o zypper up en openSUSE Tumbleweed [solucionado]

    Buenas tardes,

    Creo que es un tema ya un poco pasado de moda, pero para ser honestos no he encontrado una documentación que me aclare las dudas, en algunos foros recomiendan actualizar el sistema con #zypper up y en otros casos aconsejan #zypper dup que dicen que es mejor etc etc... pero me sucede que cuando intento actualizar con #zypper dup me intenta volver a instalar un conjunto de paquetes y aplicaciones que no uso y que por lo tanto desinstalé y no entiendo porque, hasta el mismo openSUSE aconseja actualizar con #zypper dup, agradecería que me compartan sus experiencias y si me pueden aclarar si existe alguna forma de usar #zypper dup sin que me vuelva a instalar todos esos paquetes que no uso???

    Código:
    isabella:~ # zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    The following 19 applications are going to be installed:
      Contacts Documents Evolution "Firefox Web Browser" GIMP "GNOME Clocks" "GNOME Dictionary" "GNOME Mahjongg" "GNOME Mines" "GNOME Music" "GNOME Software" "GNOME Sudoku"
      Iagno "Lights Off" Polari Quadrapassel "Swell Foop" Videos Weather
    
    The following 75 NEW packages are going to be installed:
      AdobeICCProfiles MozillaFirefox PackageKit PackageKit-backend-zypp PackageKit-branding-openSUSE PackageKit-lang btrfsmaintenance btrfsprogs btrfsprogs-udev-rules
      empathy empathy-lang evolution evolution-lang exim gimp gimp-help gimp-lang gimp-plugins-python gnome-clocks gnome-clocks-lang gnome-contacts gnome-contacts-lang
      gnome-dictionary gnome-dictionary-lang gnome-documents gnome-documents-lang gnome-documents_books-common gnome-mahjongg gnome-mahjongg-lang gnome-mines gnome-mines-lang
      gnome-music gnome-music-lang gnome-shell-search-provider-contacts gnome-shell-search-provider-documents gnome-shell-search-provider-gnome-clocks
      gnome-shell-search-provider-gnome-weather gnome-software gnome-software-lang gnome-sudoku gnome-sudoku-lang gnome-weather gnome-weather-lang iagno iagno-lang libgcc_s1
      libgomp1 libmariadb3 libobjc4 libpq5 libquadmath0 libreofficekit libspf2-2 libstdc++6 lightsoff lightsoff-doc lightsoff-lang nautilus-totem os-prober polari polari-lang
      quadrapassel quadrapassel-lang snapper snapper-zypp-plugin swell-foop swell-foop-lang tigervnc totem totem-lang totem-plugins typelib-1_0-Polari-1_0 unoconv xboard
      yast2-snapper
    
    The following 5 packages are going to be REMOVED:
      libgcc_s1-gcc8 libgomp1-gcc8 libobjc4-gcc8 libquadmath0-gcc8 libstdc++6-gcc8
    
    75 new packages to install, 5 to remove.
    Overall download size: 127.3 MiB. Already cached: 0 B. After the operation, additional 404.1 MiB will be used.
    Continue? [y/n/...? shows all options] (y):

  2. #2
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.904
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    Espero que esto te aclare el tema : "https://es.opensuse.org/Zypper" .

    Dup hay que utilizarlo en ciertas situaciones y no es recomendable para actualizar ( usar solo con repositorios principales y una vez terminado una instalación, también para cambios de versión ) .

    No se si zypper clean + refs y ref , pueda solventar el problema, creo que no, pero si instala algo pueda ser que haya algún link o dependencia con algo que tengas instalado; quizás con yast en instalación de soft, se pueda averiguar el problema, eso si es que han arreglado lo de libqdialogsolver, del apartado de yast instalar/desinstalar soft en la pestaña de paquete y en mostrar información del sistema de resolución, ahí es donde se puede averiguar, si determinada aplicación necesita determinadas cosas y ver en conjunto sus dependencias (otra sería mirar en el apartado de dependencias) .

    Lo que se a comentado en el foro es no abusar de zypper dup, con up, a lo mejor aparece esas aplicaciones en el apartado de no instalar .

    Si usas pakagekit, tu puedes seleccionar o quitar de la actualización alguna de las cosas que se instala, pero no las partes que necesita una aplicación para cumplir sus dependencias (como pueda ser las librerías, etc ) .

    En mi caso, un ejemplo puede ser esto :



    De la actualización, he quitado esa; ya que utilizo Intel y no amd , pienso que debería bloquearla, para que no me vuelva aparecer.

    Te aconsejo que pongas bien la lista de prioridad de los repositorios y si tienes muchos no uses dup, excepto que lo conozcas bien, ya que un mal uso puede crear problemas de dependencias; también lee lo que he puesto del enlace al principio.

    Saludos cordiales.

  3. #3
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.366
    Post Thanks / Like
    Poder de Credibilidad
    10
    En TW se usa zypper dup, lo comento nuestro compañero @victorhck aquí y en su blog en dos articulos: https://victorhckinthefreeworld.com/...diante-zypper/
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  4. #4
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.904
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    ¿ con esos parámetros ? zypper dup --no-allow-vendor-change, o vale hacerlo solo con zypper dup ; lo comento por si tiene añadido muchos repositorios .

    Saludos cordiales.

  5. #5
    Fecha de Ingreso
    08-abril-2010
    Ubicación
    /HOME
    Mensajes
    3.749
    Post Thanks / Like
    Poder de Credibilidad
    13
    Hola!

    En Tumbleweed zypper dup ya está configurado para funcionar con el parámetro --no-allow-vendor-changes

    Tal como explicaron en las listas de correo:
    https://lists.opensuse.org/opensuse-.../msg00172.html


    y también en mi blog:
    https://victorhckinthefreeworld.com/...segunda-parte/

    Saludos.

    EDITO:


    En el archivo de configuración /etz/zypp/zypp.conf podemos leer:

    ## EXPERTS ONLY: TUNE DISTRIBUTION UPGRADE (DUP)
    ## Set whether to allow changing the packages vendor upon DUP. If you
    ## are following a continuous distribution like Tumbleweed or Factory
    ## where you use 'zypper dup --no-allow-vendor-change' quite frequently,
    ## you may indeed benefit from disabling the VendorChange. Packages from
    ## OBS repos will then be kept rather than being overwritten by Tumbleweeds
    ## version.
    ##
    ## CHANGING THE DEFAULT IS NOT RECOMMENDED.
    ##
    ## Valid values: boolean
    ## Default value: true
    ##
    solver.dupAllowVendorChange = false
    Por tanto lo pongamos o no el parámetro en Tumbleweed ya está configurado por defecto, ya que es la mejor opción
    Última edición por victorhck; 22-mar-2018 a las 11:47 Razón: añadir texto
    Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
    → Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
    → Me puedes seguir en: Mastodon - diaspora* - PixelFed

  6. #6
    Fecha de Ingreso
    01-octubre-2016
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0

    Gracias por su pronta respuesta.

    Hola a todos, gracias por sus sugerencias y/o compartir experiencias, respondiendo a todos.

    1. Si ya visite el blog de victorhck (muy bueno por cierto, excelente) de igual forma me dio a entender que era mejor con dup, pero igual intenta actualizar los paquetes que ya yo habia desinstalado y en su momento lo tuve que volver a deinstalar una vez actualizado el sistema.

    2. Mikrios, cuando hago una actualización con up, solamente se limita a actualizar todos los paquetes que tengo instalados, nada mas... y no uso PackageKit, ni nada relacionado con el... nunca me ha gustado y fue unos de los paquetes que primero desinstale junto a gnome-software, en temas de instalacion/mantenimiento/actualizacion de paquetes prefiero usar terminal, quizás por costumbre que por otro tema en particular.

    3- Ya me habia leido el articulo de Zypper del sitio de openSUSE, no habia resuelto mis interrogantes, mas si me ocurrio una idea... quizás si bloqueo esos paquetes que venían por defecto en el sistema una vez finalizada la instalación y que yo desinstale pq no uso.. cuando haga un #zypper dup, bueno en teoría no debería volverlos a instalar ya que estan bloqueados, que creen uds?

  7. #7
    Fecha de Ingreso
    01-octubre-2016
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Que pena se me olvidó adjuntar el listado de mis repositorios, como habian solicitado, mil disculpas.


    Código:
    isabella:~ # zypper lr 
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    # | Alias                               | Name                           | Enabled | GPG Check | Refresh
    --+-------------------------------------+--------------------------------+---------+-----------+--------
    1 | http-download.opensuse.org-59003f4e | home:alteratio:Themes          | Yes     | (r ) Yes  | Yes    
    2 | openSUSE-20180314-0                 | openSUSE-20180314-0            | Yes     | (r ) Yes  | Yes    
    3 | packman                             | packman                        | Yes     | (r ) Yes  | No     
    4 | repo-debug                          | openSUSE-Tumbleweed-Debug      | No      | ----      | ----   
    5 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss    | Yes     | (r ) Yes  | Yes    
    6 | repo-source                         | openSUSE-Tumbleweed-Source     | No      | ----      | ----   
    7 | repo-update                         | openSUSE-Tumbleweed-Update     | Yes     | (r ) Yes  | Yes    
    8 | sublime-text                        | Sublime Text - x86_64 - Stable | Yes     | (r ) Yes  | Yes

  8. #8
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.904
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    @victorhck y @D.R. gracias por la aclaración.

    Ahora no tengo delante a TW por lo que no puedo comparar los repositorios, pero me parece que te falta el principal, que es oss : "http://download.opensuse.org/tumbleweed/repo/oss/" .

    Packman tiene que tener la prioridad alta ( es decir nº mas bajo prioridad mas alta , oss y Non-oss, los pondría a 90 y a packman a 70) ; no mantendría los repos de aplicaciones instaladas, o al menos des activaría la auto-actualización, eso va para repositorios no oficiales y comunitarios, es decir repos de usuarios o que no son de origen de openSUSE es decir aquellos que no están en el indice de distribución y en la lista de comunitarios, excepto aquellos que sean propios del indice de repositorios : "http://tube.opensuse.org/repositories/" , me refiero las direcciones de aquellos que se añaden de la pagina de descargas ( algunos de estos, pueden pasar a oss y non-oss, por lo que si están en los oficiales, borraría esos repos, o los desactivo) .

    Otras veces lo que hago es bajarle la prioridad, es decir en vez de 99, los pongo a por encima, ejemplo a 100 o 101 (nº alto prioridad mas baja ) .

    Añade la lista de tus repositorios en : ¿Que repositorios utilizas y que versión de openSUSE? "http://www.forosuse.org/forosuse/showthread.php?t=33135" , ya ahí te comentaran como los tienes y te aconsejaran mejor (te piden que des : zypper lr -upPE y también cat /etc/os-release, que en tu caso es TW ( Tumbleweed ) ) .

    Saludos cordiales.

  9. #9
    Fecha de Ingreso
    08-abril-2010
    Ubicación
    /HOME
    Mensajes
    3.749
    Post Thanks / Like
    Poder de Credibilidad
    13
    Marca los paquetes como "tabú" para que no vuelvan a ser instalados:

    https://victorhckinthefreeworld.com/...e-en-opensuse/

    Saludos.
    Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
    → Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
    → Me puedes seguir en: Mastodon - diaspora* - PixelFed

  10. #10
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.606
    Post Thanks / Like
    Poder de Credibilidad
    22
    Hola.

    Como curiosidad, si en Tumbleweed tú haces "zypper up" lo primero que te dice es que te dejes de milongas y hagas un "zypper dup".

    También puede que quiera configurar el sistema para que no instale paquetes "recomendados" -porque es la única forma de que instale paquetes que no se han pedido y no están instalados-.

    Salud!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Respuestas: 12
    Último mensaje: 01-mar-2015, 23:39
  2. Yast abre pero no funciona
    By enae in forum General OpenSUSE
    Respuestas: 15
    Último mensaje: 23-feb-2015, 16:59
  3. Cómo actualizar en línea a openSUSE 12.2 desde openSUSE 12.1
    By toniem in forum Instalación y Actualizaciones
    Respuestas: 36
    Último mensaje: 13-ene-2013, 23:48
  4. Disponible para descarga openSUSE 12.2
    By DiabloRojo in forum Portal de ForoSUSE
    Respuestas: 60
    Último mensaje: 01-nov-2012, 23:25
  5. pantalla blanca tras actualizar con zypper.
    By spiderman3000p in forum General OpenSUSE
    Respuestas: 2
    Último mensaje: 26-feb-2011, 00:13

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •