Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 3 de 3

Tema: Yast + Cargador de Arranque = Not space left on device

  1. #1
    Fecha de Ingreso
    25-agosto-2008
    Ubicación
    Bogotá D.C, Colombia
    Mensajes
    286
    Post Thanks / Like
    Poder de Credibilidad
    11

    Yast + Cargador de Arranque = Not space left on device

    Hola a todos. Tengo el siguiente problema:

    Acabo de actualizar, y debido a que el kernel también se actualiza y tengo mi equipo con arranque dual debo entrar forzosamente a Yast->Cargador de arranque para que el solo actualice el cargador con el kernel recién actualizado.

    El día de hoy me ha pasado algo curioso o raro, no se cómo llamarlo, pero me arroja un error de Not space left on device pero se me hace extraño puesto que el espacio ocupado en root no llega ni al 50%:
    Código:
    S.ficheros     Tamaño Usados  Disp Uso% Montado en
    devtmpfs         5,4G   8,0K  5,4G   1% /dev
    tmpfs            5,4G    24M  5,4G   1% /dev/shm
    tmpfs            5,4G   2,1M  5,4G   1% /run
    tmpfs            5,4G      0  5,4G   0% /sys/fs/cgroup
    /dev/sda6        100G    34G   64G  35% /
    /dev/sda6        100G    34G   64G  35% /.snapshots
    /dev/sda6        100G    34G   64G  35% /var/crash
    /dev/sda6        100G    34G   64G  35% /var/opt
    /dev/sda6        100G    34G   64G  35% /var/lib/libvirt/images
    /dev/sda6        100G    34G   64G  35% /var/lib/mailman
    /dev/sda6        100G    34G   64G  35% /var/lib/mariadb
    /dev/sda6        100G    34G   64G  35% /var/lib/named
    /dev/sda6        100G    34G   64G  35% /boot/grub2/i386-pc
    /dev/sda6        100G    34G   64G  35% /srv
    /dev/sda6        100G    34G   64G  35% /var/lib/machines
    /dev/sda6        100G    34G   64G  35% /var/spool
    /dev/sda6        100G    34G   64G  35% /var/log
    /dev/sda6        100G    34G   64G  35% /boot/grub2/x86_64-efi
    /dev/sda6        100G    34G   64G  35% /var/cache
    /dev/sda6        100G    34G   64G  35% /var/tmp
    /dev/sda6        100G    34G   64G  35% /tmp
    /dev/sda6        100G    34G   64G  35% /var/lib/mysql
    /dev/sda6        100G    34G   64G  35% /usr/local
    /dev/sda6        100G    34G   64G  35% /opt
    /dev/sda6        100G    34G   64G  35% /var/lib/pgsql
    /dev/sda2         96M    42M   55M  44% /boot/efi
    /dev/sda7        359G    20G  340G   6% /home
    /dev/sda4        467G   224G  243G  48% /windows
    tmpfs            1,1G    28K  1,1G   1% /run/user/1000
    Si ejecuto
    Código:
    dracut --force
    funciona pero con el problema de perder la entrada de Windows que es el segundo S.O que uso por lo que debo hacer lo comentado antes.

    Adjunto el error que sale.

    ¿Por qué se genera un error de espacio en disco si ninguna de las particiones está llena? ¿cómo saber cuál es la que causa el error y cómo liberarle espacio?

    Muchas gracias.

    EDITO:
    Ejecutando
    Código:
    shim-install --config-file=/boot/grub2/grub.cfg --no-nvram
    no genera el error mencionado.
    Imágenes Adjuntas Imágenes Adjuntas
    Última edición por NestorAcevedo; 18-dic-2017 a las 21:10

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.365
    Post Thanks / Like
    Poder de Credibilidad
    10
    Tengo curiosidad de donde has conseguido el comando indicado, es para leer la explicación.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    25-agosto-2008
    Ubicación
    Bogotá D.C, Colombia
    Mensajes
    286
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola @DiabloRojo, bueno, el comando lo conseguí de la imagen, pero el parámetro adicional lo vi primero, revisando el script shim-install y luego buscando qué es nvram donde en varios foros de archlinux y debian recomendaban ejecutar efibootmgr con ese parámetro.

    Varias veces ejecutaba el mismo comando, reiniciaba entrando por el archivo EFI y ejecutando desde Yast el Cargador de Arranque pero seguía igual. El día de hoy ejecuté de nuevo el Cargador de Arranque desde Yast y esta vez ejecutó sin problemas y reconstruyó el Grub.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Reinstalar el cargador de arranque GRUB
    By sanjui in forum Instalación y Actualizaciones
    Respuestas: 42
    Último mensaje: 08-feb-2016, 23:25
  2. Multiseat [documento de trabajo]
    By soyasi in forum La cafetería
    Respuestas: 15
    Último mensaje: 15-jul-2014, 16:45
  3. alsa microfono con bajo volumen
    By ÆPEDRAZA in forum Hardware
    Respuestas: 0
    Último mensaje: 03-abr-2010, 07:28
  4. Sonido Opensuse Toshiba l45 2046
    By rexito in forum Hardware
    Respuestas: 5
    Último mensaje: 30-nov-2008, 00:55
  5. Suse 10.2 - KDE - A veces lento, a veces no
    By Ragnarok in forum General OpenSUSE
    Respuestas: 0
    Último mensaje: 14-abr-2007, 12:12

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •