Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 13

Tema: Duda Nvidia y TW

  1. #1
    Fecha de Ingreso
    04-julio-2017
    Mensajes
    22
    Post Thanks / Like
    Poder de Credibilidad
    0

    Duda Nvidia y TW

    Hola



    Actualmente tengo tumbleweed en el portatil,me va tan bien que estoy pensando instalarla en el de sobremesa. Este, tiene una GeForce GTX 960/PCIe/SSE2. Como he visto que hay un repo especial para nvidia.como sabre que instalar el driver correcto y que no se me quede la pantalla en negro al reiniciar.

    Es que lo he intentado , pero al reiniciar me da pantallazo en negro y linux# parpedeo de las tty

    el repo nvidia para tembleweed es https://download.nvidia.com/opensuse/tumbleweed/ pero después no se que divrers instalar .Creo que el que pone G04 pero no estoy seguro.Aparte, ¿primero tengo que desinstalar los drives"libres" noveau,? no?

    He visto esto https://lists.opensuse.org/opensuse-.../msg00567.html según lo que he entendido (por el traductor)

    Significa que solo debo añadir el repo y actualizar .No tengo que elegir ningun driver?

    Gracias

  2. #2
    Fecha de Ingreso
    20-noviembre-2017
    Ubicación
    Limpio - Paraguay
    Mensajes
    137
    Post Thanks / Like
    Poder de Credibilidad
    3
    Actualmente tengo tumbleweed en el portatil,me va tan bien que estoy pensando instalarla en el de sobremesa. Este, tiene una GeForce GTX 960/PCIe/SSE2. Como he visto que hay un repo especial para nvidia.como sabre que instalar el driver correcto y que no se me quede la pantalla en negro al reiniciar.

    Es que lo he intentado , pero al reiniciar me da pantallazo en negro y linux# parpedeo de las tty
    Una vez que añades el repositorio de nvidia en openSUSE Tumbleweed, debes pasar el comando:

    Código:
    sudo zypper inr
    El te marcara automáticamente todos los paquetes necesario junto con los drivers privativos adecuado para tu acelerador gráfico.

    el repo nvidia para tembleweed es https://download.nvidia.com/opensuse/tumbleweed/ pero después no se que divrers instalar .Creo que el que pone G04 pero no estoy seguro.Aparte, ¿primero tengo que desinstalar los drives"libres" noveau,? no?
    Es correcto, ese es el repositorio privativo de nvidia para nuestra distribución, y no te preocupes que pasándole el comando que te deje arriba automáticamente te marcara dos paquetes mas si mal no recuerdo, o puede que mas en base a los paquetes que necesite para correr el driver privativo en tu pc. Indistintamente a si tienes o no instalado el driver libre cuando instalas el driver privativo ya sea desde el repositorio o descargando el binario de la pagina de nvidia, este lo marca como tabu y lo agrega a la lista negra de los controladores para que no se cargue.

    He visto esto https://lists.opensuse.org/opensuse-.../msg00567.html según lo que he entendido (por el traductor)

    Significa que solo debo añadir el repo y actualizar .No tengo que elegir ningún driver?
    Así es, en este caso actualizar se refiere a pasar el parámetro inr (install new recommend) y no a zypper up.

    Saludos Cordiales

  3. #3
    Fecha de Ingreso
    31-julio-2015
    Mensajes
    197
    Post Thanks / Like
    Poder de Credibilidad
    0
    Cita Iniciado por Silen Ver Mensaje
    Hola



    Actualmente tengo tumbleweed en el portatil,me va tan bien que estoy pensando instalarla en el de sobremesa. Este, tiene una GeForce GTX 960/PCIe/SSE2. Como he visto que hay un repo especial para nvidia.como sabre que instalar el driver correcto y que no se me quede la pantalla en negro al reiniciar.

    Es que lo he intentado , pero al reiniciar me da pantallazo en negro y linux# parpedeo de las tty

    el repo nvidia para tembleweed es https://download.nvidia.com/opensuse/tumbleweed/ pero después no se que divrers instalar .Creo que el que pone G04 pero no estoy seguro.Aparte, ¿primero tengo que desinstalar los drives"libres" noveau,? no?

    He visto esto https://lists.opensuse.org/opensuse-.../msg00567.html según lo que he entendido (por el traductor)

    Significa que solo debo añadir el repo y actualizar .No tengo que elegir ningun driver?

    Gracias
    Exacto... Yo llevo unas cuantas actualizaciones haciéndolo así y no he tenido ningún problema incluso con frecuente cambios de kernel

    Enviado desde mi ASUS_Z012D mediante Tapatalk

  4. #4
    Fecha de Ingreso
    04-julio-2017
    Mensajes
    22
    Post Thanks / Like
    Poder de Credibilidad
    0
    Muchas Gracias a los dos ,

    Los pasos serian estos

    1- añado el repo (por consola o por Yast)
    2-En consola como root zipper inr
    Y con esto ya estaria todo.
    Para actualizar la TW zypper dup

    Es correcto?

    Gracias

  5. #5
    Fecha de Ingreso
    04-julio-2017
    Mensajes
    22
    Post Thanks / Like
    Poder de Credibilidad
    0
    Bueno, siguiendo vuestro consejos/ayudas .He instalado opensuse TW en el pc de sobremesa. El tema de las drivers a la primera todo bien.
    He tenido algo de tearing (rasgado ) pero lo he solucionado con el compositor en pantalla, a falta de 4 cositas ya la tengo a mi gusto con kde.

    Muchas gracias

  6. #6
    Fecha de Ingreso
    20-noviembre-2017
    Ubicación
    Limpio - Paraguay
    Mensajes
    137
    Post Thanks / Like
    Poder de Credibilidad
    3
    Bueno, siguiendo vuestro consejos/ayudas .He instalado opensuse TW en el pc de sobremesa. El tema de las drivers a la primera todo bien.
    He tenido algo de tearing (rasgado ) pero lo he solucionado con el compositor en pantalla, a falta de 4 cositas ya la tengo a mi gusto con kde.

    Muchas gracias
    Me alegro, el tema del tearing con Kde realmente es muy molesto , normalmente después de instalar el controlador privativo ese es el siguiente objetivo, especialmente para hacer screencast

    Saludos

  7. #7
    Fecha de Ingreso
    31-julio-2015
    Mensajes
    197
    Post Thanks / Like
    Poder de Credibilidad
    0
    Solo comentarte que si usas TW y kde, a veces, los problemas de la pantalla están más relacionados con plasma que, en tu caso, con Nvidia.
    Que vaya todo muy bien...
    Saludos

    Enviado desde mi ASUS_Z012D mediante Tapatalk

  8. #8
    Fecha de Ingreso
    04-julio-2017
    Mensajes
    22
    Post Thanks / Like
    Poder de Credibilidad
    0
    Si la verdad, Nvidia para mi ha sido un dolor de muelas con el tearing .Tanto en Antergos,Debian y ahora TW ,pero bueno pelearemos un poquito ejejee

    Gracias

  9. #9
    Fecha de Ingreso
    11-enero-2018
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Hola a todos, para evitar abrir un nuevo tema, lo escribo aquí ya que es un tema relacionado.
    Tengo un portátil al que instale OpenSuse 42.3, aunque con el controlador libre de NVIDIA funcionaba bien, decidí instalar el controlador privativo para poder sacar más chica a la GPU a la hora de jugar.
    Para ello me base en este tutorial.
    A la hora de reiniciar, el escritorio estaba a muy baja resolución. Ejecuté sudo nvidia-xconfig y reinicié el equipo
    Ahora inicia únicamente la CLI y al escribir el comando startx me encontro el siguiente error:

    [ 749.094]
    X.Org X Server 1.18.3
    Release Date: 2016-04-04
    [ 749.094] X Protocol Version 11, Revision 0
    [ 749.094] Build Operating System: openSUSE SUSE LINUX
    [ 749.094] Current Operating System: Linux J-20 4.4.104-39-default #1 SMP Thu Jan 4 08:11:03 UTC 2018 (7db1912) x86_64
    [ 749.094] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.104-39-default root=UUID=a5561dae-4d66-4693-94bd-baea0066e494 ro resume=/dev/sda5 splash=silent quiet showopts
    [ 749.094] Build Date: 16 October 2017 07:19:15PM
    [ 749.094]
    [ 749.094] Current version of pixman: 0.34.0
    [ 749.094] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 749.094] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 749.094] (==) Log file: "/home/axel/.local/share/xorg/Xorg.0.log", Time: Thu Jan 11 00:06:54 2018
    [ 749.094] (==) Using config file: "/etc/X11/xorg.conf"
    [ 749.094] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [ 749.094] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [ 749.094] (==) ServerLayout "Layout0"
    [ 749.094] (**) |-->Screen "Screen0" (0)
    [ 749.094] (**) | |-->Monitor "Monitor0"
    [ 749.094] (**) | |-->Device "Device0"
    [ 749.094] (**) |-->Input Device "Keyboard0"
    [ 749.094] (**) |-->Input Device "Mouse0"
    [ 749.094] (==) Automatically adding devices
    [ 749.094] (==) Automatically enabling devices
    [ 749.094] (==) Automatically adding GPU devices
    [ 749.095] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [ 749.095] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [ 749.095] Entry deleted from font path.
    [ 749.095] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/ghostscript/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/,
    built-ins
    [ 749.095] (==) ModulePath set to "/usr/lib64/xorg/modules"
    [ 749.095] (**) Extension "XFree86-DGA" is disabled
    [ 749.095] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    [ 749.095] (WW) Disabling Keyboard0
    [ 749.095] (WW) Disabling Mouse0
    [ 749.095] (II) Loader magic: 0x80fce0
    [ 749.095] (II) Module ABI versions:
    [ 749.095] X.Org ANSI C Emulation: 0.4
    [ 749.095] X.Org Video Driver: 20.0
    [ 749.095] X.Org XInput driver : 22.1
    [ 749.095] X.Org Server Extension : 9.0
    [ 749.095] (++) using VT number 1

    [ 749.095] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
    [ 749.095] (II) xfree86: Adding drm device (/dev/dri/card0)
    [ 749.096] (--) PCI:*(0:0:2:0) 8086:591b:1462:1207 rev 4, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64
    [ 749.096] (--) PCI: (0:1:0:0) 10de:1d10:1462:1207 rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
    [ 749.096] (II) LoadModule: "glx"
    [ 749.096] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [ 749.097] (II) Module glx: vendor="X.Org Foundation"
    [ 749.097] compiled for 1.18.3, module version = 1.0.0
    [ 749.097] ABI class: X.Org Server Extension, version 9.0
    [ 749.097] (==) AIGLX enabled
    [ 749.097] (II) LoadModule: "nvidia"
    [ 749.097] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
    [ 749.097] (II) Module nvidia: vendor="NVIDIA Corporation"
    [ 749.097] compiled for 4.0.2, module version = 1.0.0
    [ 749.097] Module class: X.Org Video Driver
    [ 749.097] (II) NVIDIA dlloader X Driver 384.111 Tue Dec 19 22:25:34 PST 2017
    [ 749.097] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [ 749.097] (WW) xf86OpenConsole: VT_ACTIVATE failed: Operation not permitted
    [ 749.097] (EE)
    Fatal server error:
    [ 749.097] (EE) xf86OpenConsole: Switching VT failed
    [ 749.097] (EE)
    [ 749.097] (EE)
    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    [ 749.097] (EE) Please also check the log file at "/home/axel/.local/share/xorg/Xorg.0.log" for additional information.
    [ 749.097] (EE)
    .

    ¿Alguien me podría ayudar a solucionarlo? Gracias de antemano

  10. #10
    Fecha de Ingreso
    31-julio-2015
    Mensajes
    197
    Post Thanks / Like
    Poder de Credibilidad
    0

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. problema con pci.
    By LUKE10 in forum Software
    Respuestas: 6
    Último mensaje: 19-feb-2014, 23:58
  2. T. wifi ovislink en OpenSuse 11.2
    By atami in forum Hardware
    Respuestas: 1
    Último mensaje: 14-nov-2009, 17:34
  3. wireless en opensuse 10.2
    By rub in forum Hardware
    Respuestas: 5
    Último mensaje: 27-abr-2009, 05:08
  4. Tarjeta de video
    By korn_head in forum Hardware
    Respuestas: 5
    Último mensaje: 03-may-2007, 19:24
  5. Linux Desktop multiples
    By rock in forum General OpenSUSE
    Respuestas: 20
    Último mensaje: 03-dic-2006, 19:02

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •