Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 5 de 5

Tema: Problema en glxgears con Bumblebee/Nvidia

  1. #1
    Fecha de Ingreso
    22-septiembre-2013
    Mensajes
    245
    Post Thanks / Like
    Poder de Credibilidad
    8

    Problema en glxgears con Bumblebee/Nvidia

    Hola a todos, hace tiempo que me pasa esto, a ver si me podéis decir qué pasa. Tengo opensuse 42.2 con tarjeta intel/Nvidia, así que uso bumblebee para cambiar de una a otra. Probando glxgears

    Código:
    > optirun glxgears
    X Error of failed request:  BadValue (integer parameter out of range for operation)
      Major opcode of failed request:  154 (GLX)
      Minor opcode of failed request:  24 (X_GLXCreateNewContext)
      Value in failed request:  0x0
      Serial number of failed request:  22
      Current serial number in output stream:  23
    Y no llega a ejecutarse, se cierra. Esto me pasa con todas las glx**** (gears, spheres, info). En cambio si lanzo cualquier programa, por ejemplo okular, va bien.

    Saludos!!

    Have a lot of fun!!

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.671
    Post Thanks / Like
    Poder de Credibilidad
    10
    ¿Tienes aceleración 3D?, ejecuta el comando de abajo, como ves en la salida dice que si:

    glxinfo | grep "direct rendering"
    direct rendering: Yes
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    22-septiembre-2013
    Mensajes
    245
    Post Thanks / Like
    Poder de Credibilidad
    8


    Código:
    > glxinfo | grep "direct rendering"
    direct rendering: Yes
    EDIT:
    Me acabo de dar cuenta que parece un problema de permisos. Con

    Código:
    kdesu optriun glxgears
    Sí que funciona.

    glxspheres da un error pero se ejecuta bien igualmente

    Código:
    > kdesu optirun glxspheres
    QXcbConnection: XCB error: 3 (BadWindow), sequence: 583, resource id: 31457432, major code: 40 (TranslateCoords), minor code: 0

    glxinfo solo da esto:
    Código:
    > kdesu optirun glxinfo
    QXcbConnection: XCB error: 3 (BadWindow), sequence: 587, resource id: 31457439, major code: 40 (TranslateCoords), minor code: 0

    Por lo que veo en internet estos errores anteriores son por estar ejecutando con permisos de root...
    Última edición por J_VM; 19-sep-2017 a las 09:05 Razón: Más información

  4. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.671
    Post Thanks / Like
    Poder de Credibilidad
    10
    optriun esta asociado a las tarjetas Nvidia. Parece que has dado con el comando correcto.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  5. #5
    Fecha de Ingreso
    22-septiembre-2013
    Mensajes
    245
    Post Thanks / Like
    Poder de Credibilidad
    8
    pero deberia funcionar sin root (sin kdesu). De hecho glxinfo no va bien de ninguna de las dos maneras...

    EDITO: solucionado! Resulta que no me había añadido al grupo video

    sudo usermod -aG video username

    Creo que eso debería añadirse en el tutorial de aquí . En una versión anterior creo que sí que estaba.

    Have a lot of fun!
    Última edición por J_VM; 20-sep-2017 a las 08:53

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ntfs, problema accediendo a directorio
    By NestorAcevedo in forum Hardware
    Respuestas: 1
    Último mensaje: 23-jul-2010, 18:00
  2. Problema con Video Intel 82845G
    By sescalad in forum Hardware
    Respuestas: 4
    Último mensaje: 23-jul-2010, 16:51
  3. problema con Driver ATI
    By head777 in forum Software
    Respuestas: 13
    Último mensaje: 02-sep-2007, 17:07
  4. Problema al acceder a carpeta con kde
    By aleromar in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 5
    Último mensaje: 09-mar-2007, 00:27
  5. Problema con audio
    By Clufis in forum Multimedia
    Respuestas: 4
    Último mensaje: 19-sep-2005, 12:18

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •