Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: Opensuse Leap 42.3: Pantalla negra con nvidia + metamodes + ForceCompositionPipeline

  1. #1
    Fecha de Ingreso
    04-abril-2014
    Ubicación
    Islas Canarias - España
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Question Opensuse Leap 42.3: Pantalla negra con nvidia + metamodes + ForceCompositionPipeline

    Uso Opensuse desde la versión 9.
    Actualmente, la Leap 42.3 con Plasma.
    Mi equipo consta de:
    Procesador: AMD A10-7870K con Radeon R7 GPU
    Motherboard: Gigabyte F2A88X-D3H
    Memoria: 8G
    Monitor: Televisor Samsung 48" conectado vía HDMI

    He comprado una tarjeta gráfica Nvidia GForce 1050ti que me da al conectarla, una vez instalados los drivers privativos (la versión 384 que instala Leap 42.3) una resolución por defecto 3840x2160.
    Es una excelente definición, pero su visibilidad es 0, ya que todo se ve demasiado pequeño.
    La solución es ya conocida: escalado o cambio de resolución a 1920x1080.
    Opto por lo segundo. Hasta aquí, sin problemas.
    Para resolver el famoso tearing de las Nvidias, la solución más actual es agregar la siguiente línea al archivo xorg.conf o 20-nvidia.conf mediante nvidia-settings:

    Option "metamodes" "1920x1080 +0+0 {ForceFullCompositionPipeline=On}"

    Notese que nvidia, automáticamente coloca metamodes con la resolución que tiene mi escritorio una vez hecho el cambio de resolución a algo más "legible".
    He probado otras distros con Plasma: Arch, Manjaro, Antergos, Debian 9, y en todas me sorprendí gratamente al ver que hasta la configuración de sddm automáticamente cambia y me da esa resolución,lo que mi vista lo agradece.
    Pero con Opensuse, NO.
    Si llego a poner eso, o copiar mi archivo 20-nvidia.conf, que siempre guardo con mis configuraciones preferidas, o que nvidia cree un nuevo archivo xorg.conf; el resultado será el mismo. Pantalla negra primero, al rato sale sólo loggear por consola, pero es imposible escribir nada porque la pantalla titila continuamente y las letras van apareciendo a cuentagotas.
    Toca apagado forzoso, reinicio con alguna distro live de linux para resolver el problema, porque incluso en modo seguro Opensuse no responde.
    Resultado, aún borrando el susodicho archivo, Opensuse se niega en redondo a iniciar las X.
    En algunas ocasiones, borrando la parte "metamodes" vuelve a funcionar, pero en la pantalla de sddm, la resolución es la máxima, excelente definición, cero legibilidad.
    El fallo se da tanto en Leap 42.3 como en Tumbleweed.
    He puesto en el foro: nvidia + metamodes; metamodes + sddm; nvidia + sddm y el resultado de la búsqueda es el mismo....nada.
    He navegado por el foro buscando; o bien me estoy perdiendo por no buscar correctamente, o nadie tiene mi problema.
    ¿Alguna sugerencia?
    Juan.
    Nota: Opté nuevamente por una Nvidia porque con semejante pantalla los drivers libres de Amdgpu dejan mucho que desear. Pero las dificultades persisten.

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.244
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por juanchusjuan Ver Mensaje
    He probado otras distros con Plasma: Arch, Manjaro, Antergos, Debian 9, y en todas me sorprendí gratamente al ver que hasta la configuración de sddm automáticamente cambia y me da esa resolución,lo que mi vista lo agradece.
    Pero con Opensuse, NO.
    Si llego a poner eso, o copiar mi archivo 20-nvidia.conf, que siempre guardo con mis configuraciones preferidas, o que nvidia cree un nuevo archivo xorg.conf; el resultado será el mismo.
    Primero tengo que decirte que no tengo una tarjeta Nvidia para hacer una sencilla prueba que deberías hacer tu.

    https://devtalk.nvidia.com/default/t...opensuse-13-1/
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    04-abril-2014
    Ubicación
    Islas Canarias - España
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Procedimiento más detallado

    Buenas Tardes, Diablorojo.
    Te comento qué pasos son los que sigo:

    .Instalación limpia de Opensuse (tanto Tumbleweed como Leap 42.3)

    .Luego del primer reinicio (sin drivers privativos y con nouveau que no reconoce la tarjeta gráfica por ser demasiado nueva), ctrl+alt+f2 (terminal)

    .Procedo a realizar un zypper ref, luego zypper up, y reiniciar.

    .Nuevamente ctrl+alt+f2, terminal, y activo los repositorios de nvidia, packman y libdvdcss.
    zypper ref
    zypper dup --from packman-inode-at.suse (cambia la versión de varias aplicaciones por las de Packman)
    zypper inr (instala las aplicaciones recomendadas).
    En el caso de Nvidia, hasta la versión 42.2, en el momento de ejecutar este comando, se instalaba la versión correspondiente del controlador. En la versión 42.3 se debe elegir por separado:
    zypper in x11-video-nvidiaG04. Reinicio.

    .La resolución por defecto queda en 3840x2160, tanto en sddm como en el escritorio.

    .Me identifico con mi usuario, cambio la resolución a 1920x1080 (lo prefiero al escalado), cambio servidor opengl a 3.1, cambio el suavizado de fuentes, cambio la velocidad de los efectos un poco más rápidos, cambio el puerto de salida de sonido hdmi de nvidia (opensuse no lo hace automáticamente, otras distros sí) y controlo el tearing.... horrible.

    .Ejecuto nvidia-settings en modo gráfico y genero un archivo xorg.conf (que en la opción metamodes se genera con la resolución elegida por mí. Guardo el archivo como 20-nvidia.conf (arch wiki).

    .Abro la terminal, copio como administrador tal archivo en /etc/X11/xorg.conf.d/ o en /usr/share/X11/xorg.conf.d.

    .En los escritorios plasma de Debian, Arch, Manjaro, Chakra, Kubuntu, obtengo un sddm de 1920x1080, igual que en el escritorio. El tearing desaparece y mi escritorio es totalmente funcional.

    .En Opensuse Leap 42.3, o en Tumbleweed (instalando Nvidia a la "hard way"), el resultado será pantalla negra, consola, letras que titilan, imposibilidad de escribir mi usuario y contraseña. Al reiniciar, en modo seguro, el mismo resultado.
    Me queda iniciar con una distro live tipo Ubuntu, PartedMagic u otra, borrar el archivo 20-nvidia.conf y cruzar los dedos para que Opensuse no se me haya "ofendido mucho".

    .He probado cambiando la definición en metamodes a auto. Las X inician, pero con la máxima resolución, no como en el caso de las distros nombradas arriba, que respetan lo que mi archivo de configuración indica.

    . Las versiones de nvidia varían entre la 370 y la 384, siendo Opensuse la única que usa esta última por defecto. El próximo intento será ver cómo cambiar la versión a una más antigua, como la que usan en las otras distros.

    Hice la prueba de nvidia-xconfig -query-gpu-info y la respuesta es la correcta,
    Number of GPUs: 1

    GPU #0:
    Name : GeForce GTX 1050 Ti
    UUID : GPU-d127e0d8-89ad-ec87-f2fb-0ed055f18495
    PCI BusID : PCI:1:0:0

    Number of Display Devices: 1

    Display Device 0 (TV-1):
    EDID Name : SAMSUNG
    Minimum HorizSync : 15.000 kHz
    Maximum HorizSync : 81.000 kHz
    Minimum VertRefresh : 24 Hz
    Maximum VertRefresh : 75 Hz
    Maximum PixelClock : 594.000 MHz
    Maximum Width : 4096 pixels
    Maximum Height : 2160 pixels
    Preferred Width : 3840 pixels
    Preferred Height : 2160 pixels
    Preferred VertRefresh : 30 Hz
    Physical Width : 1050 mm
    Physical Height : 590 mm

  4. #4
    Fecha de Ingreso
    04-abril-2014
    Ubicación
    Islas Canarias - España
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Posible solución.

    Buscando en el foro en inglés, un usuario, hace unos pocos días, el 17 de agosto, indicó este procedimiento.
    Cito al usuario itaranto7:
    https://forums.opensuse.org/showthre...NVIDIA-drivers
    Re: Installing NVIDIA drivers

    I had the similar problem after a fresh install of NVIDIA RPMs from the official openSUSE repository (https://download.nvidia.com/opensuse/leap/42.3).

    After installing x11-video-nvidiaG04, nvidia-gfxG04-kmp-default ,nvidia-computeG04, nvidia-glG04, and rebooting, I had a black screen (mouse worked but SDDM crashed).

    I fixed this by reverting to a previous snapshot (without NVIDIA installed) and uninstalling drm-kmp-default + running mkinitrd first, then reboot.

    After this I installed the NVIDIA driver and after a second reboot everything was OK.

    I added this comments in https://bugzilla.suse.com/show_bug.cgi?id=1044816

    Resumiendo (en este caso previo a la instalación de los drivers de Nvidia)
    - Desinstalar drm-kmp-default
    - Ejecutar mkinitrd
    - Reiniciar
    - Instalar los drivers.
    - Reiniciar.

    Probaré y comento los resultados.

  5. #5
    Fecha de Ingreso
    16-noviembre-2010
    Ubicación
    Delante del ordenador
    Mensajes
    813
    Post Thanks / Like
    Poder de Credibilidad
    9
    Recuerda de poner como tabú el drm-kmp-default o una actualización de kernel te lo puede volver a poner porque él lo vale....

    Ese paquete se usa en kernels 4.9 o superior, mientras tanto estorba como te pasa a ti.

    Ya comenté en otro hilo lo del drm-kmp-default pero no recuerdo cual.


    Saludos

  6. #6
    Fecha de Ingreso
    03-abril-2007
    Ubicación
    Mexico/SanLuisPotosi
    Mensajes
    872
    Post Thanks / Like
    Poder de Credibilidad
    13
    si logras tener un escritorio funcional en opensuse (aunque la letra sea pequeña) y el driver instalado, puedes probar primero en kde/plasma en preferencias de sistema puedes cambiar temporalmente el tamaño de la fuente para poder leer y después ejecutando como root:

    Código:
    nvidia-settings
    y configurar la pantalla, desde la ventana que aparece, una vez que logres la resolución que quieras desde la misma ventana puedes guardar la configuración (sobre-escribiendo /etc/X11/xorg.conf si ya exite)

    en mi caso la letra tanto en sddm como en KDE se ve muy pequeña, para solucionarlo ay que agregar el DPI manualmente a sddm en el archivo:

    /etc/sddm.conf


    ServerArguments=-nolisten tcp -dpi 120
    en mi caso, mi conexión es hdmi y el monitor me agarra 1920x1080 y la letra pequeñísima, con 120 me va perfecto seria cosa de buscar el valor que te funcione.
    Saludos.
    __________________________________________________

    Mi Blog:
    http://elblogdedarkspark.blogspot.mx/
    Canales de Youtube:
    http://www.youtube.com/user/DarkSpark2099
    http://www.youtube.com/user/defton En des-uso

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ¿ Ciclos de vida de Leap ?
    By mikrios in forum La cafetería
    Respuestas: 12
    Último mensaje: 28-abr-2017, 00:36
  2. Instalación y Arranque opensuse Leap 42.1 [solucionado]
    By numael07 in forum Instalación y Actualizaciones
    Respuestas: 3
    Último mensaje: 30-may-2016, 08:11
  3. Actualización de seguridad
    By el_nuberu in forum General OpenSUSE
    Respuestas: 5
    Último mensaje: 22-sep-2015, 18:19
  4. Disponible para descarga openSUSE 12.2
    By DiabloRojo in forum Portal de ForoSUSE
    Respuestas: 60
    Último mensaje: 01-nov-2012, 23:25
  5. T. wifi ovislink en OpenSuse 11.2
    By atami in forum Hardware
    Respuestas: 1
    Último mensaje: 14-nov-2009, 18:34

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •