Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 17

Tema: Problemas para formatear tarjeta microSD

  1. #1
    Fecha de Ingreso
    06-febrero-2013
    Ubicación
    Buenos Aires - Argentina
    Mensajes
    260
    Post Thanks / Like
    Poder de Credibilidad
    8

    Red face Problemas para formatear tarjeta microSD

    Que tal amigos, tengo un problema con una tarjeta microSd de marca Sandisk, y de 32 gb. Esta tarjeta la estaba utilizando en un teléfono samsung. Tenia dos particiones, una de 1 gb y pico para pasar las aplicaciones del teléfono en ella y la otra para guardar cosas personales (fotos, videos, etc.). Venia funcionando de lujo (hasta ahora..). El problema se dio al cambiar el chip de movistar por otro de personal. Previamente retire la micro sd. El tema es que al volver a insertar el chip de movistar quedo como si recién lo hubiese formateado, es decir desaparecieron los programas instalados y la microsd quedo inaccesible. Intente con gparted darle formato, pero ya cuando esta detectando los dispositivos me da un mensaje de error, como este...



    Me dice gparted que debería crear una tabla de particiones, cosa que intente hacer pero me sigue dando error como el de la captura anterior. Si alguien pudiera recomendarme algún programa para hacer algo como un formateo de bajo nivel, en winbugs estaba hdd low level format, pero no se si habra algun equivalente en linux, o por lo menos como podria acceder para formatear la tarjeta. El telefono no la reconoce a la tarjeta, ni siquiera me da opciones de formatear ni nada.

    Como decia antes tenia dos particiones, ahora gparted me muestra como que hay una y al hacer clic derecho me da solo la opcion nueva, como si todo hubiera sido borrado. Al darle en nueva me dice que tengo que crear una nueva tabla de particiones y hasta alli llego. Si alguien conoce la solucion por favor le agradecere me la diga.
    Un buen caminante no deja huella...

  2. #2
    Fecha de Ingreso
    03-abril-2007
    Ubicación
    Mexico/SanLuisPotosi
    Mensajes
    909
    Post Thanks / Like
    Poder de Credibilidad
    14
    Código:
    dd if=/dev/zero of=/dev/sdX
    la X es la letra que le asigna el sistema y el comando va sin numero de particion.
    para saber cual dispositivo es y no formatear otra cosa, como root:

    Código:
    fdisk -l
    saludos.
    __________________________________________________

    Mi Blog:
    http://elblogdedarkspark.blogspot.mx/
    Canales de Youtube:
    http://www.youtube.com/user/DarkSpark2099
    http://www.youtube.com/user/defton En des-uso

  3. #3
    Fecha de Ingreso
    06-febrero-2013
    Ubicación
    Buenos Aires - Argentina
    Mensajes
    260
    Post Thanks / Like
    Poder de Credibilidad
    8
    Puse el comando fdisk -l pero ni siquiera aparece la unidad.
    Un buen caminante no deja huella...

  4. #4
    Fecha de Ingreso
    06-enero-2008
    Ubicación
    Almazora
    Mensajes
    3.480
    Post Thanks / Like
    Poder de Credibilidad
    16
    Hola, aquí se habla de eso. Mira la respuesta de @jcsl
    http://www.forosuse.org/forosuse/showthread.php?t=26773
    Última edición por jesusx; 27-mar-2017 a las 07:59

  5. #5
    Fecha de Ingreso
    06-febrero-2013
    Ubicación
    Buenos Aires - Argentina
    Mensajes
    260
    Post Thanks / Like
    Poder de Credibilidad
    8
    Estoy probando con la respuesta del amigo jcsl...después cuento como me ha ido...


    Edito: probe este comando dd if=/dev/zero of=/dev/hda bs=4096
    Me da un mensaje de error de lectura... gparted es como que me da ese mensaje de error y desde ahi no puedo hacer nada...
    Última edición por Germanlokura; 28-mar-2017 a las 02:02
    Un buen caminante no deja huella...

  6. #6
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.168
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:

    Mira si te lo reconoce el hardware desde consola.
    Mira si el adaptador tiene algún interruptor de protección de lectura escritura .
    Como aparece en gparted?
    Como aparece en consola con lsusb ?

    Se puede variar el valor, vamos los bloques de memoria , no necesariamente sean de 4096, pueden ser 2048, 8192,4096 o no poner ese valor, creo que es un borrado total , escribiendo o bien ceros o unos en cada celda de memoria (se aplica a pendrives,ssd, micro sd, etc ) .

    Se pierde todo, esto se usa para reparar usb, micro sd, etc que se suponen que están dañados, también para dejar un ssd que se a vuelto lento, con el tiempo en las mismas condiciones que cuando se compro.

    Busca por la web como reparar pendrive usb desde linux y te va aparecer muchas páginas.

    Ojo a mi una micro sd me iba bien en un adaptador y pc, pero me dio fallos en otros.

    Edito: no se si estaré, equivocado, pero dd, me parece que suele hacerlo bit a bit , por lo que sin parámetros puede tardar mucho, mire de que lo expertos lo confirmen, pero eso ya es un tema de lo de escribir ceros o unos, bastante conocido, e incluso hay aplicaciones que hacen eso. (ya se había hablado en el foro ).

    Edito: muchos de estos problemas, se originan, al sacar el dispositivo, sin haberle dado extraer de forma segura o bien el notificador no responde y avisa que se puede hacer; las causas pueden ser :

    Que haya una aplicación que aún lo está usando o está abierta, procurar cerrarlas las que impliquen al usb.
    Que se efectuara una operación, ejemplo copiar algo, y aún que figura como copiado, no deja, extraer el dispositivo, o bien está ocupado vaciando el buffer, o no le dice al sistema que ya lo ha hecho, esperar un tiempo prudencial, y si no reiniciar o apagar el equipo pasado un tiempo y quitar el usb, volver a encender el equipo y comprobar que el usb funciona; no quitarlo si no dice que se puede, o hacer esto, se corre el riesgo de que se estropee las tablas de particiones la estructura del dispositivo.

    Las isos de instalación, tienen otro tipo de formato y el notificador no avisa de que se conecta (las de openSUSE, usan un sistema híbrido, que sirve para efi (mbr), como para uefi (gpt-sistemas boot efi) , y que la iso no es reconocido como un sistema de archivos; cosa que no ocurre si ponemos un dvd, ya que nos abre una carpeta, pero no muestra el contenido iso, si no mas bien creo que es el contenido del boot, el espacio que sobra queda sin partición, si se usa, puede funcionar, pero también puede pasar, lo que a @jesusx , aunque no tengo mucha seguridad del tema, ya que hice pruebas y a veces el comportamiento es algo diferente, ejemplo dos particiones en un usb, aparecen como 2 dispositivos .

    ejemplo iso híbrido openSUSE :

    y de como se vería un dvd , pero no todo el contenido :



    Aunque en el caso mencionado de haber aprovechado la partición, no se como le habría quedado a @jesusx.

    También me he encontrado a veces que algún proceso ha detenido o seguía ocupado con lo del pendrive, que la única forma de hacerlo, es reiniciar o apagar equipo y después sacarlo (la causa posible puede que haya sido el kernel, ademas de no figurar en él, el comportamiento no era el correcto, transferencias bestiales al principio y después se quedan a transferencias de 10a 14 kb/s y eso a pesar de ser un usb 3.0) .

    Bueno espero que se solucione pronto y así aprender de esta experiencia, gracias y un saludo.

    Saludos cordiales
    Última edición por mikrios; 28-mar-2017 a las 03:49 Razón: añadir

  7. #7
    Fecha de Ingreso
    06-febrero-2013
    Ubicación
    Buenos Aires - Argentina
    Mensajes
    260
    Post Thanks / Like
    Poder de Credibilidad
    8
    Que tal amigo Mikrios, pues al darle al comando fdisk -l lo único que aparece son los dos discos duros que tengo, la micro sd ni aparece. Problema de protección contra escritura no es, es mas estaba funcionando re bien hasta el momento que cambie el chip del teléfono. El comando que mencionaba arriba dd tambien me da un mensaje de error de lectura escritura.
    Gparted me da el error que muestro en el primer mensaje, me dice que debo crear una tabla de particiones, al querer hacerlo me da el mismo mensaje de error y luego de cancelar varios mensajes no aparece mas la micro sd. Buscare lo que me sugerís de reparar la micro sd. Es una situación bastante extraña la verdad nunca me paso.


    EDITO: luego de darle a ignorar a todos los mensajes de error que me da gparted me queda asi



    Al querer darle en nueva


    Al intentar crear tabla de particiones
    Última edición por Germanlokura; 28-mar-2017 a las 04:27
    Un buen caminante no deja huella...

  8. #8
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.168
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:

    Lo interesante es saber como está y a la hora de crear una partición con gparted, hacerlo desde la pestaña de dispositivo, y desde ahí en la opción de crear una tabla de particiones, la opción que hay debajo es la intentar rescatar datos, pues bien crearla desde ahí en vez desde la pestaña de particiones.

    El tema, puede ser que no deje crear una hasta borrar la existente, y eso si es que pueda estar estropeada.

    Mirar si de alguna forma, puede ser reconocida o bien usar un programa tipo testdisk y por último, lo del comando dd, nos deja la posibilidad de dejarla en blanco y recuperar la de nuevo,volviendo a partcionar y formatear la misma.

    mira primero si lsusb lo reconoce (listado de dispositivos usb) , otra cosa mas que nos muestra dmesg |tail , cuando la conectamos o desconectamos,etc.

    Ejemplo lsusb :

    Código:
    Z-87-DELUXE:~ # lsusb
    Bus 002 Device 002: ID 8087:8000 Intel Corp. 
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:8008 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 006: ID 2109:0810  
    Bus 004 Device 005: ID 0480:b207 Toshiba America Info. Systems, Inc. 
    Bus 004 Device 004: ID 174c:3074 ASMedia Technology Inc. 
    Bus 004 Device 003: ID 0930:0b1f Toshiba Corp. 
    Bus 004 Device 002: ID 0480:a207 Toshiba America Info. Systems, Inc. 
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 004: ID 0930:0b1a Toshiba Corp. 
    Bus 003 Device 003: ID 0b05:17cf ASUSTek Computer, Inc. 
    Bus 003 Device 002: ID 174c:2074 ASMedia Technology Inc. 
    Bus 003 Device 008: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
    Bus 003 Device 007: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
    Bus 003 Device 006: ID 0930:6544 Toshiba Corp. Kingston DataTraveler 2.0 Stick (2GB)
    Bus 003 Device 005: ID 2109:3431  
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bueno me he pasado, con los dispositivos, pero como que estoy mucho tiempo en reposo, tengo muchos conectados :
    Código:
    Z-87-DELUXE:~ # lsblk -fm                                                                                      
    NAME   FSTYPE  LABEL       UUID                                 MOUNTPOINT NAME     SIZE OWNER GROUP MODE      
    sdf                                                                        sdf    931.5G root  disk  brw-rw----
    └─sdf1 ntfs    toshiba-fotos-copia                                                                             
                               98D0A724D0A70798                     /run/media └─sdf1 931.5G root  disk  brw-rw----
    sdd                                                                        sdd      1.8T root  disk  brw-rw----
    └─sdd1 ntfs    TOSHIBA EXT DE8E50818E5053DD                     /run/media └─sdd1   1.8T root  disk  brw-rw----
    sdb                                                                        sdb    931.5G root  disk  brw-rw----
    ├─sdb4 btrfs               3964843f-bdf0-468b-83f8-1a1548dde89e /home      ├─sdb4 889.4G root  disk  brw-rw----
    ├─sdb2 swap                31299d95-9883-424e-aac0-da797fa9b22f [SWAP]     ├─sdb2     2G root  disk  brw-rw----
    ├─sdb3 btrfs               e8ace98d-5ef2-478b-bb1a-990a5d6a333b /usr/local ├─sdb3    40G root  disk  brw-rw----
    └─sdb1 vfat                63B6-6168                            /boot/efi  └─sdb1   156M root  disk  brw-rw----
    sr0                                                                        sr0     19.3M root  cdrom brw-rw----
    sdg    iso9660 openSUSE-Leap-42.3-DVD-x86_64011
    │                          2017-02-23-09-52-24-00                          sdg      7.2G root  disk  brw-rw----
    ├─sdg1 vfat                970C-85DD                                       ├─sdg1   3.7M root  disk  brw-rw----
    └─sdg2 iso9660 openSUSE-Leap-42.3-DVD-x86_64011
                               2017-02-23-09-52-17-00                          └─sdg2   4.1G root  disk  brw-rw----
    sde                                                                        sde    931.5G root  disk  brw-rw----
    └─sde1 ntfs    THOSHIBA_1TB
                               103CAF1114405833                     /run/media └─sde1 931.5G root  disk  brw-rw----
    sdc                                                                        sdc    931.5G root  disk  brw-rw----
    └─sdc1 btrfs   DATOS       eb00e01e-ac83-4028-8974-45ff54fe7aa0 /run/media └─sdc1 931.5G root  disk  brw-rw----
    sda                                                                        sda    119.2G root  disk  brw-rw----
    ├─sda2 btrfs               9ca27b50-ff42-4f81-b8c7-6fabfea28555 /run/media ├─sda2    40G root  disk  brw-rw----
    ├─sda3 btrfs               6229c8ce-8c12-422e-bc41-17098eb48171 /run/media ├─sda3  79.1G root  disk  brw-rw----
    └─sda1 vfat                4390-C53C                                       └─sda1   156M root  disk  brw-rw----
    sdh                                                                        sdh    465.8G root  disk  brw-rw----
    └─sdh1 ntfs                28D0676AD0673CE6                     /run/media └─sdh1 465.8G root  disk  brw-rw----
    Z-87-DELUXE:~ #
    Y eso que ahora hay unos cuantos menos, mira de probar en otro conector,etc o otro adaptador, si es que se puede.

    Lo que se es que las soluciones que te han comentado suelen funcionar y ir bien, pero si da error de escritura, mira de intentar lo varias veces, si no hay utilidades para hacer formato a bajo nivel que son gratis (HDD Low Level Format Tool) , pero casi ,mejor busques lo de recuperar desde linux.

    Y hay que hacerlo con seguridad, ahí una equivocación ya no hay vuelta atras.

    Animo y suerte.

    Saludos cordiales

  9. #9
    Fecha de Ingreso
    06-febrero-2013
    Ubicación
    Buenos Aires - Argentina
    Mensajes
    260
    Post Thanks / Like
    Poder de Credibilidad
    8
    Los comandos que mencionas me dan como resultado esto:


    lsusb



    lsblk -fm
    Un buen caminante no deja huella...

  10. #10
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    5.168
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola:

    Bueno voy hacer la prueba con una micro-sd con adaptador , solo pongo lo referente a ella :

    Código:
    Bus 003 Device 011: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
    Esta es una de las tantas salidas de lsusb y ese es el lector de micro (está con adaptador, pero creo que puedo ponerlo directo, tengo otro, pero en las pruebas que hice hace tiempo no iba, así que lo hago con este) .

    Reconocida como :
    Código:
    sdi                                                                        sdi      7.5G root  disk  brw-rw----
    └─sdi1 vfat                9016-4EF8                            /run/media └─sdi1   7.5G root  disk  brw-rw----
    Sigo con esto :
    Edito:
    Código:
    Z-87-DELUXE:~ # fdisk -l /dev/sdi
    Disk /dev/sdi: 7.5 GiB, 8026849280 bytes, 15677440 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x00000000
    
    Device     Boot Start      End  Sectors  Size Id Type
    /dev/sdi1        8192 15677439 15669248  7.5G  b W95 FAT32
    Sigo con las pruebas, ahora con gparted :



    Esta es lo que me da gparted, con la micro sd de 8Gb, la voy a extraer y ver dmesg.

    Código:
    Z-87-DELUXE:~ # dmesg |tail 
    [21721.558188] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=5.44.168.141 DST=192.168.1.233 LEN=145 TOS=0x00 PREC=0x00 TTL=102 ID=9020 PROTO=UDP SPT=47560 DPT=7881 LEN=125 
    [21741.478246] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=106.166.87.127 DST=192.168.1.233 LEN=129 TOS=0x00 PREC=0x00 TTL=110 ID=18006 PROTO=UDP SPT=23900 DPT=7881 LEN=109 
    [21761.542423] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=219.82.202.225 DST=192.168.1.233 LEN=129 TOS=0x00 PREC=0x00 TTL=44 ID=26031 PROTO=UDP SPT=38386 DPT=7881 LEN=109 
    [21781.791401] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=222.245.249.36 DST=192.168.1.233 LEN=129 TOS=0x00 PREC=0x00 TTL=110 ID=27673 PROTO=UDP SPT=16001 DPT=7881 LEN=109 
    [21801.387938] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=101.166.139.118 DST=192.168.1.233 LEN=126 TOS=0x00 PREC=0x00 TTL=106 ID=29283 PROTO=UDP SPT=14821 DPT=7881 LEN=106 
    [21804.441595] sdi: detected capacity change from 8026849280 to 0
    [21823.695292] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=91.151.178.74 DST=192.168.1.233 LEN=143 TOS=0x00 PREC=0x00 TTL=112 ID=23048 PROTO=UDP SPT=16035 DPT=7881 LEN=123 
    [21841.910033] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=80.99.254.218 DST=192.168.1.233 LEN=126 TOS=0x00 PREC=0x00 TTL=114 ID=944 PROTO=UDP SPT=8854 DPT=7881 LEN=106 
    [21863.036603] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=46.32.85.178 DST=192.168.1.233 LEN=132 TOS=0x00 PREC=0x00 TTL=106 ID=2447 PROTO=UDP SPT=49172 DPT=7881 LEN=112 
    [21882.037586] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=74:d0:2b:2c:35:ce:ac:9e:17:69:e4:80:08:00 SRC=213.144.12.43 DST=192.168.1.233 LEN=123 TOS=0x00 PREC=0x00 TTL=49 ID=53961 DF PROTO=UDP SPT=8526 DPT=7881 LEN=103
    Os sea me detecta: [21804.441595] sdi: detected capacity change from 8026849280 to 0 que al quitarla se quedo en 0 (es de 8Gb y pasa a 0, porque ya no hay ninguna conectada) .

    Volví a conectar otra :
    Código:
    sdi    iso9660 openSUSE-Leap-42.2-DVD-x86_64028
    │                          2016-11-09-10-39-11-00                          sdi      7.3G root  disk  brw-rw----
    ├─sdi1 vfat                1E63-B137                                       ├─sdi1   3.7M root  disk  brw-rw----
    └─sdi2 vfat                DD5F-0EDE                                       └─sdi2   4.1G root  disk  brw-rw----
    dmesg me informa :[22163.827558] sd 15:0:0:0: [sdi] 15196160 512-byte logical blocks: (7.78 GB/7.25 GiB)
    [22163.830890] sdi: sdi1 sdi2

    Esta tarjeta viene con un sistema, así que el notificador no me dice nada, pues la voy a quitar, ya que lo que podría hacer es desmontarla, pero creo que tiene la iso de opensuse 42.2



    Hasta ahora el comportamiento ha sido normal, con varias micro-sd, mira de comprobar haber que es lo que sucede, si necesitas que haga, pruebas, cuenta con las que tengo aquí, puedo coger la de 42.2 y dejarla en blanco con el dd, después crear partición y formatear.



    de una tarjeta con varias particiones (tb de 8Gb)


    Saludos cordiales
    Última edición por mikrios; 28-mar-2017 a las 05:26 Razón: añadir

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ¿cuantos gigas en total en partición para OpenSuse?
    By darkanxo in forum Instalación y Actualizaciones
    Respuestas: 12
    Último mensaje: 25-ene-2014, 11:06
  2. Guía: Instalar el controlador para tarjetas de vídeo NVIDIA
    By jcsl in forum FAQs, Manuales y Tutoriales
    Respuestas: 4
    Último mensaje: 21-jul-2012, 15:51
  3. Ares en Linux sin emular
    By willicl in forum Software
    Respuestas: 18
    Último mensaje: 11-ago-2009, 21:11
  4. Guía de Instalación de OpenSuSE 10.3
    By DiabloRojo in forum Instalación y Actualizaciones
    Respuestas: 5
    Último mensaje: 11-feb-2008, 10:41
  5. Todo lo necesario para empezar con SUSE 10.0
    By maldito71 in forum General OpenSUSE
    Respuestas: 4
    Último mensaje: 18-abr-2007, 08:25

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •