Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 19

Tema: Tumbleweed + controlador Nvidia propietario + Kernel 4.10.x : ¿Alguien lo consiguió?

  1. #1
    Fecha de Ingreso
    06-agosto-2013
    Ubicación
    España
    Mensajes
    243
    Post Thanks / Like
    Poder de Credibilidad
    7

    Tumbleweed + controlador Nvidia propietario + Kernel 4.10.x : ¿Alguien lo consiguió?

    Hasta la fecha, con Tumbleweed, a pesar de compilar el controlador propietario de Nvidia incluyendo DKMS, a cada nueva actualización del kernel no me queda otra que compilar de nuevo .

    Sin embargo, con la versión kernel 4.10.x (dos oficiales hasta ahora) me ha sido imposible compilar sin tener que hacer algún truco, como ya he leído que han conseguido hacer por el mismo problema en algún foro de Ubuntu.

    ¿Alguien que use Tumbleweed y el controlador propietario de Nvidia ha conseguido compilarlo sin tener que hacer algún parcheo?

    Graaacias
    Yo sólo me limito a sugerir, no soy quién para dar consejos

  2. #2
    Fecha de Ingreso
    15-julio-2006
    Ubicación
    /home/icomputo
    Mensajes
    701
    Post Thanks / Like
    Poder de Credibilidad
    14
    Bueno, hay que esperar que liberen el nuevo driver, por el momento usa el kernel anterior (con el driver libre no se tiene problemas)


    saludos
    "Solamente cuando el último árbol este muerto, el último río esté envenenado y el último pez esté atrapado, entenderemos que no se puede comer dinero".

    icomputo.com
    GNU social
    Chat #opensuse-es

  3. #3
    Fecha de Ingreso
    06-agosto-2013
    Ubicación
    España
    Mensajes
    243
    Post Thanks / Like
    Poder de Credibilidad
    7
    Gracias iComputo, pero como comentaba el problema realmente no es del controlador, sino del Kernel, por eso como solución han sacado un parche.

    Lógicamente no me interesa usar el controlador libre, porque el rendimiento sigue siendo notablemente inferior

    Un saludo
    Yo sólo me limito a sugerir, no soy quién para dar consejos

  4. #4
    Fecha de Ingreso
    15-julio-2006
    Ubicación
    /home/icomputo
    Mensajes
    701
    Post Thanks / Like
    Poder de Credibilidad
    14
    Cita Iniciado por Mazinger-Z Ver Mensaje
    Gracias iComputo, pero como comentaba el problema realmente no es del controlador, sino del Kernel, por eso como solución han sacado un parche.

    Lógicamente no me interesa usar el controlador libre, porque el rendimiento sigue siendo notablemente inferior

    Un saludo
    si tienes problemas para seguir usando. en el grub tiene la lista de los parches anteriores y con esos puedes entrar sin problemas y seguir usándolo , hasta que saquen uno nuevo compatible con el nuevo kernel
    "Solamente cuando el último árbol este muerto, el último río esté envenenado y el último pez esté atrapado, entenderemos que no se puede comer dinero".

    icomputo.com
    GNU social
    Chat #opensuse-es

  5. #5
    Fecha de Ingreso
    22-septiembre-2013
    Mensajes
    245
    Post Thanks / Like
    Poder de Credibilidad
    6
    A mí me iba más o menos bien (sí he tenido algún cuelgue) hasta que hoy me ha saltado un error que no me dejaba iniciar opensuse después del grub,....

    Código:
    mar 01 09:14:15 localhost.localdomain kernel: pcieport 0000:00:1d.3: PCIe Bus Error: severity=Corrected, type=Data Link Layer, id=00eb(Transmitter ID)                             
    mar 01 09:14:15 localhost.localdomain kernel: pcieport 0000:00:1d.3:   device [8086:9d1b] error status/mask=00001000/00002000                                                      
    mar 01 09:14:15 localhost.localdomain kernel: pcieport 0000:00:1d.3:    [12] Replay Timer Timeout
    Y he iniciado con el kernel 4.9 y de momento bien. Uso bumblebee pero suelo tener apagada la tarjeta de video de Nvidia.

    Saludos!

  6. #6
    Fecha de Ingreso
    15-julio-2006
    Ubicación
    /home/icomputo
    Mensajes
    701
    Post Thanks / Like
    Poder de Credibilidad
    14
    Cita Iniciado por Mazinger-Z Ver Mensaje
    Hasta la fecha, con Tumbleweed, a pesar de compilar el controlador propietario de Nvidia incluyendo DKMS, a cada nueva actualización del kernel no me queda otra que compilar de nuevo .

    Sin embargo, con la versión kernel 4.10.x (dos oficiales hasta ahora) me ha sido imposible compilar sin tener que hacer algún truco, como ya he leído que han conseguido hacer por el mismo problema en algún foro de Ubuntu.

    ¿Alguien que use Tumbleweed y el controlador propietario de Nvidia ha conseguido compilarlo sin tener que hacer algún parcheo?

    Graaacias
    Tengo una lap con TW y los propietarios funcionando bien, es una nvidia 750m

    http://www.geforce.com/drivers/results/114708

    Version 375.39
    Release Date Tue Feb 14, 2017
    Operating System Linux 64-bit
    Language English (US)
    "Solamente cuando el último árbol este muerto, el último río esté envenenado y el último pez esté atrapado, entenderemos que no se puede comer dinero".

    icomputo.com
    GNU social
    Chat #opensuse-es

  7. #7
    Fecha de Ingreso
    06-agosto-2013
    Ubicación
    España
    Mensajes
    243
    Post Thanks / Like
    Poder de Credibilidad
    7
    Pues no ha habido forma. Imposible compilar el controlador nvidia con la rama 4.10 del kernel.

    Sin embargo, si cada vez que hay cambio de kernel desinstalo e instalo todo lo relacionado con Nvidia desde los repos oficiales (x-video-nvidia, x-video-nvidia-devel, cuda, nvidia-compute, dkms-nvidia e incluso libdrm_nouveau2) ... automátigamente tengo los controladores de nvidia instalados ....

    Controlador:
    NVIDIA Corporation
    GeForce GTX 650
    Versión OpenGL 4.5.0 NVidia 378.13

    ¿magia?
    Yo sólo me limito a sugerir, no soy quién para dar consejos

  8. #8
    Fecha de Ingreso
    15-julio-2006
    Ubicación
    /home/icomputo
    Mensajes
    701
    Post Thanks / Like
    Poder de Credibilidad
    14

    Question

    Cita Iniciado por Mazinger-Z Ver Mensaje
    Pues no ha habido forma. Imposible compilar el controlador nvidia con la rama 4.10 del kernel.

    Sin embargo, si cada vez que hay cambio de kernel desinstalo e instalo todo lo relacionado con Nvidia desde los repos oficiales (x-video-nvidia, x-video-nvidia-devel, cuda, nvidia-compute, dkms-nvidia e incluso libdrm_nouveau2) ... automátigamente tengo los controladores de nvidia instalados ....

    Controlador:
    NVIDIA Corporation
    GeForce GTX 650
    Versión OpenGL 4.5.0 NVidia 378.13

    ¿magia?
    a ver a ver.. barajeala mas despacio.. como esta eso? o.O

    me dio ese problema con una tarjeta mas vieja..una 9800GT..

    -instalaste el ultimo driver disponible desde la pagina de nvidia (los cuales no dejan instalarse).
    -Después reinstalaste esos paquetes que pusiste?

    como esta el asunto?

    quise parchear y me salio eso y no supe que poner

    ./NVIDIA-Linux-x86_64-340.102.run --apply-patch 4.10.0_kernel.patch
    Verifying archive integrity... OK
    Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 340.102........................................... .................................................. .................................................. .................................................. ................................
    can't find file to patch at input line 16
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |From 983a2ca221a371e08bb5ad11758a729cfa5aa88c Mon Sep 17 00:00:00 2001
    |From: Alberto Milone <alberto.milone@canonical.com>
    |Date: Wed, 15 Feb 2017 17:05:55 +0100
    |Subject: [PATCH 1/1] Add support for Linux 4.10
    |
    |---
    | nv-linux.h | 7 +++++++
    | nv-pat.c | 40 ++++++++++++++++++++++++++++++++++++++++
    | uvm/nvidia_uvm_lite.c | 4 ++++
    | 3 files changed, 51 insertions(+)
    |
    |diff --git a/kernel/nv-linux.h b/kernel/nv-linux.h
    |index e7068e3..2d62492 100644
    |--- a/kernel/nv-linux.h
    |+++ b/kernel/nv-linux.h
    --------------------------
    File to patch:
    Última edición por icomputo; 21-mar-2017 a las 07:34
    "Solamente cuando el último árbol este muerto, el último río esté envenenado y el último pez esté atrapado, entenderemos que no se puede comer dinero".

    icomputo.com
    GNU social
    Chat #opensuse-es

  9. #9
    Fecha de Ingreso
    06-agosto-2013
    Ubicación
    España
    Mensajes
    243
    Post Thanks / Like
    Poder de Credibilidad
    7

    No es exactamente el mismo problema

    Aunque veo que tu incidencia coincide con la mía en que tienes problemas con el kernel 4.10 y la tarjeta Nvidia, no partimos del mismo intento de solución.

    Yo uso el instalador de Nvidia (ya sabes. el ".run" que te descargas de su web para tu tarjeta) pero siempre con la opción "--update" , para que él solito se descargue de Nvidia la versión más reciente del controlador. Pues bien, tanto con la versión descargada como con la de "autoactualización" las incidencias que se producen son básicamente dos:

    1. Muestra una advertencia, si eliges la opción con DKMS, que dice que no es necesario con esa versión del kernel
    2. Acaba, tras ponerse a generar el módulo, dando un error que viene a decir que no se ha podido generar y poco más

    Tú has aplicado el parche. Yo no. En cualquier caso lo dos métodos acaban sin resolver el problema.

    El caso es que tras mucho leer, me encontré una sugerencia (que no tenía que ver con el problema) respecto a instalar controladores Nvidia que hablaba concretamente de "x-video-nvidia". Así que no tenía que perder por probar, y si mucho que ganar, porque podría usar si funcionaba el "invento" la versión 4.10 del kernel.


    El proceso ya lo he comentado:

    1. Desinstalar el software Nvidia (uninstall-nvidia)
    2. Desinstalar (si aparecen instalados) los paquetes: x-video-nvidia, x-video-nvidia-devel, cuda, nvidia-compute, dkms-nvidia y de paso instalar todo lo relacionado con nouveau (como libdrm_nouveau2)
    3. Reiniciar
    4. Cuando arranque KDE (si arranca) lo más probable es que aparezca con una resolución muy baja. Nos da igual.
    5. <Ctrl + Alt + F1>
    6. root y correspondiente contraseña
    7. init 3
    8. yast, y desde él instalar todo lo que anteriormente hemos desinstalado en el punto 2.
    9. Automágicamente, en el próximo reinicio ¡¡¡habemus papa!!!

    Prueba y me cuentas

    Nota para administradores: Cuando trato de editar un mensaje ya publicado desde Firefox + OpenSUSE, aparece todo el contenido en blanco ... ¿sólo me ocurre a mi?
    Última edición por Mazinger-Z; 21-mar-2017 a las 14:56 Razón: Aplicar negritas y aclarar ambigüedad
    Yo sólo me limito a sugerir, no soy quién para dar consejos

  10. #10
    Fecha de Ingreso
    07-noviembre-2016
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0
    No sé si servirá esto. Parece un instalador del driver de nvidia que parchea el kernel 4.10: https://build.opensuse.org/package/s...=nvidia-driver

    https://software.opensuse.org/package/nvidia-driver
    Última edición por Klingklang; 21-mar-2017 a las 20:10

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Kernel Gestión
    By feroSUSEANDO in forum General OpenSUSE
    Respuestas: 11
    Último mensaje: 10-oct-2013, 23:24
  2. ahora, pc se cuelga aleatoriamente
    By sic in forum General OpenSUSE
    Respuestas: 6
    Último mensaje: 29-dic-2010, 16:40
  3. Inestabilidad de opensuse 10.2 (ayuda)
    By p3g4z0 in forum General OpenSUSE
    Respuestas: 25
    Último mensaje: 17-feb-2007, 11:00
  4. Problema con red en SuSE 9.0 Pro
    By arandaedgar in forum Internet, Redes y Wireless
    Respuestas: 6
    Último mensaje: 16-oct-2006, 02:52
  5. Respuestas: 1
    Último mensaje: 01-ago-2006, 18:44

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •