Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 4 de 4

Tema: Instalar wxPython wxWidgets 2.8 en openSuSE

  1. #1
    Fecha de Ingreso
    22-septiembre-2013
    Mensajes
    245
    Post Thanks / Like
    Poder de Credibilidad
    6

    Unhappy Instalar wxPython wxWidgets 2.8 en openSuSE

    Hola a todos,

    Estoy en openSUSE Tumbleweed (64 bits). Necesito algunas dependencias de Python para instalar un programa que está escrito en python. Entre las dependencias está wxPython / wxWidgets 2.8... pues bien, si instalo el paquete python-wxWidgets (2.8) de LEAP 42.2 (el link en software.opensuse.org al python-wxWidgets 2.8 de Tumbleweed está roto, y en el instalador de paquetes de yast solo aparece la 3.0), el programa da este error:

    Código:
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1010,STL containers,compatible with 2.6),
    and wxPython used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,STL containers,compatible with 2.6).
    Abortado (`core' generado)
    Con la versión 3.0 que es la que viene en Tumbleweed me dice que las versiones no son compatibles ("Requested version of wxPython not found")


    También intenté compilarlo yo mismo pero no fui capaz...si alguien ha tenido algún problema similar y puede echarme una mano lo agradecería. Saludos!!


    P.D.: para más información, os pongo parte del README

    The following packages are required: Python, gcc

    These packages can be installed in UBUNTU as follows:

    - Installing Python (this is necessary for gLAB GUI and for graph.py):

    sudo apt-get install python python-wxtools python-matplotlib python-tk python-wxgtk2.8 python-mpltoolkits.basemap python-mpltoolkits.basemap-data python-numpy


    - Installing C compiler (gcc)

    sudo apt-get install gcc
    Última edición por J_VM; 23-ene-2017 a las 10:15

  2. #2
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.244
    Post Thanks / Like
    Poder de Credibilidad
    10
    ¿No funciona gLAB con la version 3?.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  3. #3
    Fecha de Ingreso
    22-septiembre-2013
    Mensajes
    245
    Post Thanks / Like
    Poder de Credibilidad
    6
    qué va, pide específicamente la versión 2.8, si pruebas la 3.0 da error porque no tienes la versión correcta "Requested version of wxPython not found". Desde pip y easy_install me dice que no encuentra wxPython

    Es muy raro porque si intento descargar desde software.opensuse.org el paquete python-wxWidgets me sale que no se encuentra el objeto (podéis verlo aquí)

  4. #4
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.523
    Post Thanks / Like
    Poder de Credibilidad
    21
    Hola.

    En 42.2 funciona sin novedad.
    Código:
    Información de Paquete python-wxWidgets:
    ----------------------------------------
    Repositorio      : openSUSE-Leap-42.2-Oss       
    Nome             : python-wxWidgets             
    Versión          : 2.8.12.1-12.4                
    Arq              : x86_64                       
    Vendedor         : openSUSE                     
    Tamaño Instalado : 43,4 MiB                     
    Instalado        : Si                           
    Estado           : actualizado                  
    Resumo           : Python Bindings for wxWidgets
    Descrición       :                              
        wxWidgets is a free C++ library for cross-platform GUI. This package contains python bindings for wxWidgets.
    Instala el patrón python desde yast y busca los paquetes wxWidgets, python-tk, python-numpy. Ciertamente, tengo un montón de módulos de python instalados, así que a saber XD

    Instala de paso, si no lo tienes ya, el patrón de desarrollo C/C++ (y el básico). Después, la compilación debería de ser trivial.

    Salud!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. No es posible acceder al medio de instalación http://download.opensuse.org/repositori
    By tecnocyber001 in forum Instalación y Actualizaciones
    Respuestas: 4
    Último mensaje: 30-may-2014, 23:05
  2. Instalar Skype en open Suse 11.3 64 bits.
    By tranzorx in forum FAQs, Manuales y Tutoriales
    Respuestas: 10
    Último mensaje: 31-dic-2012, 01:50
  3. KDEInit no pudo lanzar «/usr/bin/xdg-su».
    By jes_sus50 in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 14
    Último mensaje: 02-dic-2012, 12:02
  4. Cómo instalar WinXp, OpenSuse 11 y Ubuntu 8.04
    By starsun in forum Instalación y Actualizaciones
    Respuestas: 7
    Último mensaje: 02-oct-2008, 08:22
  5. Anuncio oficial openSUSE 11.0 (español)
    By elpreto in forum Portal de ForoSUSE
    Respuestas: 66
    Último mensaje: 18-ago-2008, 16:48

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •