Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 13

Tema: Otro "The following 48 package updates will NOT be installed" al actualizar openSUSE

  1. #1
    Fecha de Ingreso
    22-enero-2015
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0

    Otro "The following 48 package updates will NOT be installed" al actualizar openSUSE

    Hola a todos, según he visto, es un error bastante común en openSUSE por culpa de incompatibilidades entre repositorios.

    Mostraría mis repositorios antiguos, que imagino que son los causantes de tal desastre, pero no puedo porque los mostré con un pantallazo y lo subí a MediaCrush, un excelente servicio que desgraciadamente ha desaparecido. La cosa está en que los cambié por los actuales (desde entonces no he tocado los repos) y después dejaron de salirme los mensajes sobre los paquetes que no se iban a instalar pero poco a poco, han ido apareciendo.

    Código:
    ┌─ alberto openSUSE ~ 
    └──┤|▶ zypper lr -P 
    # | Alias        | Name         | Enabled | Refresh | Priority
    --+--------------+--------------+---------+---------+---------
    1 | repo-debug   | repo-debug   | Yes     | Yes     |   99    
    2 | repo-non-oss | repo-non-oss | Yes     | Yes     |   99    
    3 | repo-oss     | repo-oss     | Yes     | Yes     |   99    
    4 | repo-update  | repo-update  | Yes     | Yes     |   99    
    ┌─ alberto openSUSE ~ 
    └──┤|▶ sudo zypper up
    root's password:
    Loading repository data...
    Reading installed packages...
    
    The following 48 package updates will NOT be installed:
      libass5-32bit libdvdnav4-32bit libdvdread4-32bit liblrdf2 liblrdf2-32bit libogg0-32bit libopenal1-32bit libpulse0 libpulse0-32bit libpulse-mainloop-glib0 libxine2 
      libxine2-pulse pulseaudio pulseaudio-bash-completion pulseaudio-module-bluetooth pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-x11 
      pulseaudio-module-zeroconf pulseaudio-utils xf86-video-ark xf86-video-ast xf86-video-ati xf86-video-chips xf86-video-cirrus xf86-video-dummy xf86-video-fbdev 
      xf86-video-glint xf86-video-i128 xf86-video-intel xf86-video-mach64 xf86-video-mga xf86-video-neomagic xf86-video-nouveau xf86-video-nv xf86-video-qxl xf86-video-r128 
      xf86-video-savage xf86-video-siliconmotion xf86-video-sis xf86-video-sisusb xf86-video-tdfx xf86-video-tga xf86-video-trident xf86-video-vesa xf86-video-vmware 
      xf86-video-voodoo xorg-x11-server 
    
    No hay nada que hacer.
    ┌─ alberto openSUSE ~ 
    └──┤|▶ sudo zypper dup
    root's password:
    AdvertenciaYou are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Retrieving repository 'repo-debug' metadata .........................................................................................................................[hecho]
    Construyendo el caché del repositorio 'repo-debug' ..................................................................................................................[hecho]
    Retrieving repository 'repo-oss' metadata ...........................................................................................................................[hecho]
    Construyendo el caché del repositorio 'repo-oss' ....................................................................................................................[hecho]
    Loading repository data...
    Reading installed packages...
    Calculando actualización...
    
    The following 2 NEW packages are going to be installed:
      libsnapper3 openSUSE-release-ftp 
    
    The following 34 packages are going to be REMOVED:
      bind-libs boost-license1_54_0 libavcodec55 libavformat55 libboost_date_time1_54_0 libboost_filesystem1_54_0 libboost_iostreams1_54_0 libboost_program_options1_54_0 
      libboost_system1_54_0 libboost_thread1_54_0 libcmis-0_4-4 libffms2-3 libgif6 libHalf11 libHalf11-32bit libhdf5-8 libhdf5_hl8 libIex-2_1-11 libIex-2_1-11-32bit 
      libIlmImf-Imf_2_1-21 libIlmImf-Imf_2_1-21-32bit libIlmThread-2_1-11 libIlmThread-2_1-11-32bit libisl10 libmsn0_3 libmusicbrainz5-0 libpostproc52 libsnapper2 
      libswresample0 libxine2-codecs vlc-codecs x264 xf86-video-modesetting xf86-video-v4l 
    
    The following 111 packages are going to be upgraded:
      binutils bundle-lang-common-en bundle-lang-common-es bundle-lang-gnome-ar bundle-lang-gnome-en bundle-lang-gnome-es cabextract fd0ssh glibc glibc-32bit glibc-extra 
      glibc-locale glibc-locale-32bit kdebase4-openSUSE kdebase4-runtime kdebase4-runtime-branding-openSUSE kdebase4-workspace-branding-openSUSE krb5 krb5-32bit krb5-client 
      libass5-32bit libdvdnav4-32bit libdvdread4-32bit libgpg-error0 libgpg-error0-32bit libLLVM libLLVM-32bit liblrdf2 liblrdf2-32bit libnfsidmap-sss libntfs-3g85 
      libogg0-32bit libopenal1-32bit libpulse0 libpulse0-32bit libpulse-mainloop-glib0 libsss_idmap0 libsss_nss_idmap0 libsss_sudo libupnp6 libvmtools0 libwicked-0-6 
      libxapian22 libxerces-c-3_1 libxine2 libxine2-pulse linuxconsoletools logrotate memtest86+ metamail nscd ntfs-3g ntfsprogs ofl openSUSE-release open-vm-tools 
      open-vm-tools-desktop pulseaudio pulseaudio-bash-completion pulseaudio-module-bluetooth pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-x11 
      pulseaudio-module-zeroconf pulseaudio-utils shared-mime-info snapper snapper-zypp-plugin sssd sssd-32bit sssd-krb5-common sssd-ldap vim vim-data wicked wicked-service 
      xf86-video-ark xf86-video-ast xf86-video-ati xf86-video-chips xf86-video-cirrus xf86-video-dummy xf86-video-fbdev xf86-video-glint xf86-video-i128 xf86-video-intel 
      xf86-video-mach64 xf86-video-mga xf86-video-neomagic xf86-video-nouveau xf86-video-nv xf86-video-qxl xf86-video-r128 xf86-video-savage xf86-video-siliconmotion 
      xf86-video-sis xf86-video-sisusb xf86-video-tdfx xf86-video-tga xf86-video-trident xf86-video-vesa xf86-video-vmware xf86-video-voodoo xorg-x11-server yast2-country 
      yast2-country-data yast2-hardware-detection yast2-installation yast2-snapper yast2-users youtube-dl 
    
    The following product is going to be upgraded:
      "openSUSE Tumbleweed" 
    
    The following 101 packages are going to be downgraded:
      alsa-oss-32bit enigmail exiftool gimp gimp-help-browser gimp-plugin-aa gimp-plugins-python gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-vaapi 
      gstreamer-plugins-vaapi libasound2-32bit libatk-1_0-0 libavutil52 libcdaudio1 libcelt0-2-32bit libchromaprint0-32bit libdv4-32bit libenca0-32bit libfftw3-3-32bit 
      libFLAC8-32bit libfluidsynth1 libfluidsynth1-32bit libgimp-2_0-0 libgimpui-2_0-0 libgme0-32bit libgsm1-32bit libgstapp-1_0-0-32bit libgstaudio-1_0-0-32bit 
      libgstbadbase-1_0-0 libgstbadbase-1_0-0-32bit libgstbadvideo-1_0-0 libgstbadvideo-1_0-0-32bit libgstbasecamerabinsrc-0_10-23 libgstbasecamerabinsrc-1_0-0 
      libgstbasecamerabinsrc-1_0-0-32bit libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 libgstcodecparsers-1_0-0 libgstcodecparsers-1_0-0-32bit libgstcodecparsers_vpx0 
      libgstfft-1_0-0-32bit libgstgl-1_0-0 libgstgl-1_0-0-32bit libgstmpegts-1_0-0 libgstmpegts-1_0-0-32bit libgstpbutils-1_0-0-32bit libgstphotography-0_10-23 
      libgstphotography-1_0-0 libgstphotography-1_0-0-32bit libgstreamer-1_0-0-32bit libgstrtp-1_0-0-32bit libgstsdp-1_0-0-32bit libgstsignalprocessor-0_10-23 
      libgsttag-1_0-0-32bit libgsturidownloader-1_0-0 libgsturidownloader-1_0-0-32bit libgstvaapi-0_10-3 libgstvaapi-1_4-0 libgstvaapi-drm-0_10-3 libgstvaapi-drm-1_4-0 
      libgstvaapi-glx-0_10-3 libgstvaapi-glx-1_4-0 libgstvaapi-wayland-0_10-3 libgstvaapi-wayland-1_4-0 libgstvaapi-x11-0_10-3 libgstvaapi-x11-1_4-0 libgstvdp-0_10-23 
      libgstvideo-1_0-0-32bit libjack0-32bit libkate1-32bit liblash1 liblash1-32bit libmjpegutils-2_0-0-32bit libmms0 libmms0-32bit libmodplug1-32bit libmusicbrainz4 libofa0 
      libofa0-32bit libopus0-32bit liborc-0_4-0-32bit libQtWebKit4 libquicktime0-32bit libraptor2-0-32bit libsamplerate0-32bit libsbc1-32bit libschroedinger-1_0-0-32bit 
      libsndfile1-32bit libSoundTouch0 libSoundTouch0-32bit libspeex1-32bit libtheora0-32bit libtimidity-0_1-0 libvorbis0-32bit libvorbisenc2-32bit mc mc-lang 
      perl-File-RandomAccess perl-Image-ExifTool typelib-1_0-Atk-1_0 yast2-slp 
    
    The following 96 packages are going to change vendor:
      alsa-oss-32bit                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      gstreamer-0_10-plugins-bad          obs://build.opensuse.org/multimedia:libs -> openSUSE
      gstreamer-0_10-plugins-vaapi        obs://build.opensuse.org/multimedia:libs -> openSUSE
      gstreamer-plugins-vaapi             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libasound2-32bit                    obs://build.opensuse.org/multimedia:libs -> openSUSE
      libass5-32bit                       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libavutil52                         http://packman.links2linux.de -> openSUSE           
      libcdaudio1                         obs://build.opensuse.org/multimedia:libs -> openSUSE
      libcelt0-2-32bit                    obs://build.opensuse.org/multimedia:libs -> openSUSE
      libchromaprint0-32bit               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libdv4-32bit                        obs://build.opensuse.org/multimedia:libs -> openSUSE
      libdvdnav4-32bit                    obs://build.opensuse.org/multimedia:libs -> openSUSE
      libdvdread4-32bit                   obs://build.opensuse.org/multimedia:libs -> openSUSE
      libenca0-32bit                      openSUSE-Education -> openSUSE                      
      libfftw3-3-32bit                    obs://build.opensuse.org/multimedia:libs -> openSUSE
      libFLAC8-32bit                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libfluidsynth1                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libfluidsynth1-32bit                obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgme0-32bit                       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgsm1-32bit                       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstapp-1_0-0-32bit               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstaudio-1_0-0-32bit             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbadbase-1_0-0                 obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbadbase-1_0-0-32bit           obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbadvideo-1_0-0                obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbadvideo-1_0-0-32bit          obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbasecamerabinsrc-0_10-23      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbasecamerabinsrc-1_0-0        obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbasecamerabinsrc-1_0-0-32bit  obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstbasevideo-0_10-23             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstcodecparsers-0_10-23          obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstcodecparsers-1_0-0            obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstcodecparsers-1_0-0-32bit      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstcodecparsers_vpx0             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstfft-1_0-0-32bit               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstgl-1_0-0                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstgl-1_0-0-32bit                obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstmpegts-1_0-0                  obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstmpegts-1_0-0-32bit            obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstpbutils-1_0-0-32bit           obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstphotography-0_10-23           obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstphotography-1_0-0             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstphotography-1_0-0-32bit       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstreamer-1_0-0-32bit            obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstrtp-1_0-0-32bit               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstsdp-1_0-0-32bit               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstsignalprocessor-0_10-23       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgsttag-1_0-0-32bit               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgsturidownloader-1_0-0           obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgsturidownloader-1_0-0-32bit     obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-0_10-3                  obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-1_4-0                   obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-drm-0_10-3              obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-drm-1_4-0               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-glx-0_10-3              obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-glx-1_4-0               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-wayland-0_10-3          obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-wayland-1_4-0           obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-x11-0_10-3              obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvaapi-x11-1_4-0               obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvdp-0_10-23                   obs://build.opensuse.org/multimedia:libs -> openSUSE
      libgstvideo-1_0-0-32bit             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libjack0-32bit                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libkate1-32bit                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      liblash1                            obs://build.opensuse.org/multimedia:libs -> openSUSE
      liblash1-32bit                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      liblrdf2                            obs://build.opensuse.org/multimedia:libs -> openSUSE
      liblrdf2-32bit                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libmjpegutils-2_0-0-32bit           obs://build.opensuse.org/multimedia:libs -> openSUSE
      libmms0                             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libmms0-32bit                       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libmodplug1-32bit                   obs://build.opensuse.org/multimedia:libs -> openSUSE
      libmusicbrainz4                     obs://build.opensuse.org/multimedia:libs -> openSUSE
      libofa0                             obs://build.opensuse.org/multimedia:libs -> openSUSE
      libofa0-32bit                       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libogg0-32bit                       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libopenal1-32bit                    obs://build.opensuse.org/multimedia:libs -> openSUSE
      libopus0-32bit                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      liborc-0_4-0-32bit                  obs://build.opensuse.org/multimedia:libs -> openSUSE
      libpulse0-32bit                     obs://build.opensuse.org/multimedia:libs -> openSUSE
      libquicktime0-32bit                 obs://build.opensuse.org/multimedia:libs -> openSUSE
      libraptor2-0-32bit                  obs://build.opensuse.org/multimedia:libs -> openSUSE
      libsamplerate0-32bit                obs://build.opensuse.org/multimedia:libs -> openSUSE
      libsbc1-32bit                       obs://build.opensuse.org/multimedia:libs -> openSUSE
      libschroedinger-1_0-0-32bit         obs://build.opensuse.org/multimedia:libs -> openSUSE
      libsndfile1-32bit                   obs://build.opensuse.org/multimedia:libs -> openSUSE
      libSoundTouch0                      obs://build.opensuse.org/multimedia:libs -> openSUSE
      libSoundTouch0-32bit                obs://build.opensuse.org/multimedia:libs -> openSUSE
      libspeex1-32bit                     obs://build.opensuse.org/multimedia:libs -> openSUSE
      libtheora0-32bit                    obs://build.opensuse.org/multimedia:libs -> openSUSE
      libtimidity-0_1-0                   obs://build.opensuse.org/multimedia:libs -> openSUSE
      libvorbis0-32bit                    obs://build.opensuse.org/multimedia:libs -> openSUSE
      libvorbisenc2-32bit                 obs://build.opensuse.org/multimedia:libs -> openSUSE
      libxine2                            http://packman.links2linux.de -> openSUSE           
      libxine2-pulse                      http://packman.links2linux.de -> openSUSE           
      pulseaudio-bash-completion          obs://build.opensuse.org/multimedia:libs -> openSUSE
    
    
    111 packages to upgrade, 101 to downgrade, 2 new, 10 to reinstall, 34 to remove, 96  to change vendor.
    Overall download size: 100,6 MiB. Already cached: 0 B  After the operation, 30,0 MiB will be freed.
    ¿Desea continuar? [s/n/? mostrar todas las opciones] (s):
    Lo más raro es que me sugiere (s) que elimine varios paquetes que considero básicos como vlc-codecs, x264, xf86-video-modesetting y xf86-video-v4. Vamos, que si desinstalo eso, me quedo sin poder abrir archivos multimedia prácticamente.

  2. #2
    Fecha de Ingreso
    08-septiembre-2005
    Ubicación
    ±43º21'N8º22'W
    Mensajes
    1.232
    Post Thanks / Like
    Poder de Credibilidad
    15
    Bajo mi punto de vista no debieras hacer un zypper dup ni loco.
    Tienes solo los repos básicos (y el debug no creo que te sirva para nada) pero te falta uno muy importante el de packman que tenías y ya no tienes. También tenías el multimedia
    Añádelos y no hagas dup; haz up, por lo menos hasta que tengas claro con qué repositorios quieres vivir.
    Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
    Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

  3. #3
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.871
    Post Thanks / Like
    Poder de Credibilidad
    11
    Cita Iniciado por XisEme Ver Mensaje
    Bajo mi punto de vista no debieras hacer un zypper dup ni loco.
    Tienes solo los repos básicos (y el debug no creo que te sirva para nada) pero te falta uno muy importante el de packman que tenías y ya no tienes. También tenías el multimedia
    Añádelos y no hagas dup; haz up, por lo menos hasta que tengas claro con qué repositorios quieres vivir.
    Eso y aumentar la prioridad a packman.

    Así aseguras que packman te los va a mantener.

    Aumentar prioridad es bajar el número de 99 a menos :

    Código:
    X79-PRO:~ # zypper lr -p
    #  | Alias                                 | Name                                  | Enabled | Refresh | Priority
    ---+---------------------------------------+---------------------------------------+---------+---------+---------
     1 | Education/openSUSE_Tumbleweed         | Education/openSUSE_Tumbleweed         | Yes     | Yes     |   99    
     2 | KDE:/Extra                            | KDE:/Extra                            | Yes     | Yes     |   99    
     3 | Kernel:/stable/standard               | Kernel:/stable/standard               | Yes     | Yes     |   90    
     4 | Printing/openSUSE_Tumbleweed          | Printing/openSUSE_Tumbleweed          | Yes     | Yes     |   99    
     5 | SUSEStudio/openSUSE_Tumbleweed        | SUSEStudio/openSUSE_Tumbleweed        | Yes     | Yes     |   99    
     6 | VirtualBox_Tumbleweed                 | VirtualBox_Tumbleweed                 | Yes     | Yes     |   99    
     7 | Virtualization/Kernel_stable_standard | Virtualization/Kernel_stable_standard | Yes     | Yes     |   90    
     8 | http-download.opensuse.org-c3996aea   | devel:tools                           | Yes     | Yes     |   99    
     9 | packman                               | packman                               | Yes     | Yes     |   70    
    10 | repo-debug                            | repo-debug                            | Yes     | Yes     |   99    
    11 | repo-non-oss                          | repo-non-oss                          | Yes     | Yes     |   99    
    12 | repo-oss                              | repo-oss                              | Yes     | Yes     |   99    
    13 | repo-src-non-oss                      | repo-src-non-oss                      | No      | Yes     |   99    
    14 | repo-src-oss                          | repo-src-oss                          | No      | Yes     |   99    
    15 | tumbleweed/repo/debug/                | tumbleweed/repo/debug/                | Yes     | Yes     |   99
    Saludos cordiales

    PD. De que ajuste bien las prioridades en los repositorios, no me han salido ya esos anuncios de que no se van a instalar (por ahora, no se que pasara en futuras actualizaciones) .

  4. #4
    Fecha de Ingreso
    22-enero-2015
    Mensajes
    7
    Post Thanks / Like
    Poder de Credibilidad
    0
    Muchísimas gracias a ambos

    He añadido el repo Pakman desde Yast a través de la URL http://packman.inode.at/suse/openSUSE_Tumbleweed/, después, he actualizado los repositorios (todos con 99 de prioridad), y luego:

    1. zypper up → me sigue listando los programas
    2. zypper dup → 116 packages to upgrade, 74 to downgrade, 23 new, 10 to reinstall, 26 to remove, 137 to change vendor.
    Overall download size: 83,6 MiB. Already cached: 0 B After the operation, additional 787,7 KiB will be used.
    ¿Desea continuar? [s/n/? mostrar todas las opciones] (s): n

    ¿Qué debería hacer? se supone que el repositorio Multimedia entra en el que he puesto de Packman.

  5. #5
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.871
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    El añadir los repositorios no implica que tengas instalado los programas codecs etc.

    Te voy a poner un ejemplo (no si la comparación pueda valer) : el añadir repositorios es como añadir un acceso directo a una carpeta, si buscas los programas codecs multimedia , los encontraras porque tienes ese acceso creado, si no lo tuviese no los encontraría; eso no implica que los tengas instalados, tienes que instalarlos tu, es mas un mismo programa se puede encontrar en distintas carpetas pero unos pueden ser versiones superiores y otros no,también unos pueden reproducir todo tipo de formato multimedia y otros por razones legales no lo pueden hacer.

    El añadir packman es porque tiene esos codecs y puede reproducir todo, de ahí la necesidad de aumentar la prioridad a ese repositorio (o carpeta, como en el ejemplo), para que sea de ahí donde te descargues el programa y no de la otra carpeta (vamos tienes que ir a repositorios de Yast, te sitúas con el ratón donde pone packman y donde está prioridad le bajas el número, por ejemplo a 70.

    Con esto garantizas que ese sea él el proveedor de los programas multimedia y no de otro proveedor y no mezcle versiones al actualizar o cree conflictos o cambios de versión etc.

    Ejemplo del reproductor vlc :

    Código:
    X79-PRO:~ # zypper se -s vlc
    Loading repository data...
    Reading installed packages...
    
    S | Name                               | Type       | Version                  | Arch   | Repository            
    --+------------------------------------+------------+--------------------------+--------+-----------------------
    i | vlc-noX                            | package    | 2.1.5-241.1              | x86_64 | packman               
    v | vlc-noX                            | package    | 2.1.5-241.1              | i586   | packman               
    v | vlc-noX                            | package    | 2.1.5-8.1                | x86_64 | repo-oss              
    v | vlc-noX                            | package    | 2.1.5-8.1                | i586   | repo-oss              
      | npapi-vlc-beta                     | package    | 2.2.0_git20150209-1.1    | x86_64 | packman               
      | npapi-vlc-beta                     | package    | 2.2.0_git20150209-1.1    | i586   | packman               
      | phonon-backend-vlc-debugsource     | package    | 0.8.2-16.1               | x86_64 | packman               
      | phonon-backend-vlc-debugsource     | package    | 0.8.2-16.1               | i586   | packman               
      | phonon-backend-vlc-debugsource     | package    | 0.8.0-2.2                | x86_64 | repo-debug            
      | phonon-backend-vlc-debugsource     | package    | 0.8.0-2.2                | x86_64 | tumbleweed/repo/debug/
      | phonon-backend-vlc-debugsource     | package    | 0.8.0-2.2                | i586   | repo-debug            
      | phonon-backend-vlc-debugsource     | package    | 0.8.0-2.2                | i586   | tumbleweed/repo/debug/
      | vlc-gnome                          | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-gnome                          | package    | 2.1.5-241.1              | i586   | packman               
      | vlc-gnome                          | package    | 2.1.5-8.1                | x86_64 | repo-oss              
      | vlc-gnome                          | package    | 2.1.5-8.1                | i586   | repo-oss              
      | libvlc-qt-devel                    | package    | 0.8.0-1.119              | x86_64 | packman               
      | libvlc-qt-devel                    | package    | 0.8.0-1.119              | i586   | packman               
      | vlc-gnome-debuginfo                | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-gnome-debuginfo                | package    | 2.1.5-241.1              | i586   | packman               
      | vlc-gnome-debuginfo                | package    | 2.1.5-8.1                | x86_64 | repo-debug            
      | vlc-gnome-debuginfo                | package    | 2.1.5-8.1                | x86_64 | tumbleweed/repo/debug/
      | vlc-gnome-debuginfo                | package    | 2.1.5-8.1                | i586   | repo-debug            
      | vlc-gnome-debuginfo                | package    | 2.1.5-8.1                | i586   | tumbleweed/repo/debug/
      | vlc-beta-codecs-debuginfo          | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-codecs-debuginfo          | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-beta-debuginfo                 | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-debuginfo                 | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-beta-codecs                    | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-codecs                    | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
    i | vlc-codecs                         | package    | 2.1.5-241.1              | x86_64 | packman               
    v | vlc-codecs                         | package    | 2.1.5-241.1              | i586   | packman               
    i | libvlccore7                        | package    | 2.1.5-241.1              | x86_64 | packman               
    v | libvlccore7                        | package    | 2.1.5-241.1              | i586   | packman               
    v | libvlccore7                        | package    | 2.1.5-8.1                | x86_64 | repo-oss              
    v | libvlccore7                        | package    | 2.1.5-8.1                | i586   | repo-oss              
      | libvlccore9-debuginfo              | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | libvlccore9-debuginfo              | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-beta                           | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta                           | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | libvlc-qt0_8-debuginfo             | package    | 0.8.0-1.119              | x86_64 | packman               
      | libvlc-qt0_8-debuginfo             | package    | 0.8.0-1.119              | i586   | packman               
      | npapi-vlc-beta-debugsource         | package    | 2.2.0_git20150209-1.1    | x86_64 | packman               
      | npapi-vlc-beta-debugsource         | package    | 2.2.0_git20150209-1.1    | i586   | packman               
      | libvlc-qt-widgets0_8-debuginfo     | package    | 0.8.0-1.119              | x86_64 | packman               
      | libvlc-qt-widgets0_8-debuginfo     | package    | 0.8.0-1.119              | i586   | packman               
    i | vlc-qt                             | package    | 2.1.5-241.1              | x86_64 | packman               
    v | vlc-qt                             | package    | 2.1.5-241.1              | i586   | packman               
    v | vlc-qt                             | package    | 2.1.5-8.1                | x86_64 | repo-oss              
    v | vlc-qt                             | package    | 2.1.5-8.1                | i586   | repo-oss              
      | npapi-vlc                          | package    | 2.2.0_git20140911-2.4    | x86_64 | packman               
      | npapi-vlc                          | package    | 2.2.0_git20140911-2.4    | i586   | packman               
      | vlc-beta-gnome                     | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-gnome                     | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | phonon-backend-vlc                 | package    | 0.8.2-16.1               | x86_64 | packman               
      | phonon-backend-vlc                 | package    | 0.8.2-16.1               | i586   | packman               
      | phonon-backend-vlc                 | package    | 0.8.0-2.2                | x86_64 | repo-oss              
      | phonon-backend-vlc                 | package    | 0.8.0-2.2                | i586   | repo-oss              
      | npapi-vlc-debuginfo                | package    | 2.2.0_git20140911-2.4    | x86_64 | packman               
      | npapi-vlc-debuginfo                | package    | 2.2.0_git20140911-2.4    | i586   | packman               
      | libvlc6-debuginfo                  | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | libvlc6-debuginfo                  | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | phonon-backend-vlc-debuginfo       | package    | 0.8.2-16.1               | x86_64 | packman               
      | phonon-backend-vlc-debuginfo       | package    | 0.8.2-16.1               | i586   | packman               
      | phonon-backend-vlc-debuginfo       | package    | 0.8.0-2.2                | x86_64 | repo-debug            
      | phonon-backend-vlc-debuginfo       | package    | 0.8.0-2.2                | x86_64 | tumbleweed/repo/debug/
      | phonon-backend-vlc-debuginfo       | package    | 0.8.0-2.2                | i586   | repo-debug            
      | phonon-backend-vlc-debuginfo       | package    | 0.8.0-2.2                | i586   | tumbleweed/repo/debug/
      | libvlc5-debuginfo                  | package    | 2.1.5-241.1              | x86_64 | packman               
      | libvlc5-debuginfo                  | package    | 2.1.5-241.1              | i586   | packman               
      | libvlc5-debuginfo                  | package    | 2.1.5-8.1                | x86_64 | repo-debug            
      | libvlc5-debuginfo                  | package    | 2.1.5-8.1                | x86_64 | tumbleweed/repo/debug/
      | libvlc5-debuginfo                  | package    | 2.1.5-8.1                | i586   | repo-debug            
      | libvlc5-debuginfo                  | package    | 2.1.5-8.1                | i586   | tumbleweed/repo/debug/
      | vlc-beta-qt-debuginfo              | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-qt-debuginfo              | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-devel                          | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-devel                          | package    | 2.1.5-241.1              | i586   | packman               
      | vlc-devel                          | package    | 2.1.5-8.1                | x86_64 | repo-oss              
      | vlc-devel                          | package    | 2.1.5-8.1                | i586   | repo-oss              
      | libvlc6                            | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | libvlc6                            | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
    i | vlc                                | package    | 2.1.5-241.1              | x86_64 | packman               
    v | vlc                                | package    | 2.1.5-241.1              | i586   | packman               
    v | vlc                                | package    | 2.1.5-8.1                | x86_64 | repo-oss              
    v | vlc                                | package    | 2.1.5-8.1                | i586   | repo-oss              
      | libvlc-qt-widgets0_8               | package    | 0.8.0-1.119              | x86_64 | packman               
      | libvlc-qt-widgets0_8               | package    | 0.8.0-1.119              | i586   | packman               
      | vlc-beta-qt                        | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-qt                        | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-beta-devel                     | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-devel                     | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-beta-debugsource               | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-debugsource               | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-codecs-debuginfo               | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-codecs-debuginfo               | package    | 2.1.5-241.1              | i586   | packman               
      | libvlccore9                        | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | libvlccore9                        | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-beta-noX                       | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-noX                       | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | libvlccore7-debuginfo              | package    | 2.1.5-241.1              | x86_64 | packman               
      | libvlccore7-debuginfo              | package    | 2.1.5-241.1              | i586   | packman               
      | libvlccore7-debuginfo              | package    | 2.1.5-8.1                | x86_64 | repo-debug            
      | libvlccore7-debuginfo              | package    | 2.1.5-8.1                | x86_64 | tumbleweed/repo/debug/
      | libvlccore7-debuginfo              | package    | 2.1.5-8.1                | i586   | repo-debug            
      | libvlccore7-debuginfo              | package    | 2.1.5-8.1                | i586   | tumbleweed/repo/debug/
      | vlc-debuginfo                      | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-debuginfo                      | package    | 2.1.5-241.1              | i586   | packman               
      | vlc-debuginfo                      | package    | 2.1.5-8.1                | x86_64 | repo-debug            
      | vlc-debuginfo                      | package    | 2.1.5-8.1                | x86_64 | tumbleweed/repo/debug/
      | vlc-debuginfo                      | package    | 2.1.5-8.1                | i586   | repo-debug            
      | vlc-debuginfo                      | package    | 2.1.5-8.1                | i586   | tumbleweed/repo/debug/
      | vlc-debugsource                    | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-debugsource                    | package    | 2.1.5-241.1              | i586   | packman               
      | vlc-debugsource                    | package    | 2.1.5-8.1                | x86_64 | repo-debug            
      | vlc-debugsource                    | package    | 2.1.5-8.1                | x86_64 | tumbleweed/repo/debug/
      | vlc-debugsource                    | package    | 2.1.5-8.1                | i586   | repo-debug            
      | vlc-debugsource                    | package    | 2.1.5-8.1                | i586   | tumbleweed/repo/debug/
      | vlc-beta-gnome-debuginfo           | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-gnome-debuginfo           | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-beta-noX-debuginfo             | package    | 3.0.0_20150222001git-1.1 | x86_64 | packman               
      | vlc-beta-noX-debuginfo             | package    | 3.0.0_20150222001git-1.1 | i586   | packman               
      | vlc-noX-debuginfo                  | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-noX-debuginfo                  | package    | 2.1.5-241.1              | i586   | packman               
      | vlc-noX-debuginfo                  | package    | 2.1.5-8.1                | x86_64 | repo-debug            
      | vlc-noX-debuginfo                  | package    | 2.1.5-8.1                | x86_64 | tumbleweed/repo/debug/
      | vlc-noX-debuginfo                  | package    | 2.1.5-8.1                | i586   | repo-debug            
      | vlc-noX-debuginfo                  | package    | 2.1.5-8.1                | i586   | tumbleweed/repo/debug/
    i | libvlc5                            | package    | 2.1.5-241.1              | x86_64 | packman               
    v | libvlc5                            | package    | 2.1.5-241.1              | i586   | packman               
    v | libvlc5                            | package    | 2.1.5-8.1                | x86_64 | repo-oss              
    v | libvlc5                            | package    | 2.1.5-8.1                | i586   | repo-oss              
      | vlc-qt-debuginfo                   | package    | 2.1.5-241.1              | x86_64 | packman               
      | vlc-qt-debuginfo                   | package    | 2.1.5-241.1              | i586   | packman               
      | vlc-qt-debuginfo                   | package    | 2.1.5-8.1                | x86_64 | repo-debug            
      | vlc-qt-debuginfo                   | package    | 2.1.5-8.1                | x86_64 | tumbleweed/repo/debug/
      | vlc-qt-debuginfo                   | package    | 2.1.5-8.1                | i586   | repo-debug            
      | vlc-qt-debuginfo                   | package    | 2.1.5-8.1                | i586   | tumbleweed/repo/debug/
      | npapi-vlc-beta-debuginfo           | package    | 2.2.0_git20150209-1.1    | x86_64 | packman               
      | npapi-vlc-beta-debuginfo           | package    | 2.2.0_git20150209-1.1    | i586   | packman               
      | npapi-vlc-debugsource              | package    | 2.2.0_git20140911-2.4    | x86_64 | packman               
      | npapi-vlc-debugsource              | package    | 2.2.0_git20140911-2.4    | i586   | packman               
      | libvlc-qt0_8                       | package    | 0.8.0-1.119              | x86_64 | packman               
      | libvlc-qt0_8                       | package    | 0.8.0-1.119              | i586   | packman               
      | libvlc-qt-doc                      | package    | 0.8.0-1.119              | noarch | packman               
      | vlc-beta-noX-lang                  | package    | 3.0.0_20150222001git-1.1 | noarch | packman               
    i | vlc-noX-lang                       | package    | 2.1.5-241.1              | noarch | packman               
    v | vlc-noX-lang                       | package    | 2.1.5-8.1                | noarch | repo-oss              
      | npapi-vlc-beta                     | srcpackage | 2.2.0_git20150209-1.1    | noarch | packman               
      | npapi-vlc                          | srcpackage | 2.2.0_git20140911-2.4    | noarch | packman               
      | phonon-backend-vlc                 | srcpackage | 0.8.2-16.1               | noarch | packman               
      | libvlc-qt                          | srcpackage | 0.8.0-1.119              | noarch | packman               
      | vlc                                | srcpackage | 2.1.5-241.1              | noarch | packman               
      | vlc-beta                           | srcpackage | 3.0.0_20150222001git-1.1 | noarch | packman               
      | phonon4qt5-backend-vlc-debuginfo   | package    | 0.8.2-1.2                | x86_64 | repo-debug            
      | phonon4qt5-backend-vlc-debuginfo   | package    | 0.8.2-1.2                | x86_64 | tumbleweed/repo/debug/
      | phonon4qt5-backend-vlc-debuginfo   | package    | 0.8.2-1.2                | i586   | repo-debug            
      | phonon4qt5-backend-vlc-debuginfo   | package    | 0.8.2-1.2                | i586   | tumbleweed/repo/debug/
      | phonon4qt5-backend-vlc-debugsource | package    | 0.8.2-1.2                | x86_64 | repo-debug            
      | phonon4qt5-backend-vlc-debugsource | package    | 0.8.2-1.2                | x86_64 | tumbleweed/repo/debug/
      | phonon4qt5-backend-vlc-debugsource | package    | 0.8.2-1.2                | i586   | repo-debug            
      | phonon4qt5-backend-vlc-debugsource | package    | 0.8.2-1.2                | i586   | tumbleweed/repo/debug/
      | phonon4qt5-backend-vlc             | package    | 0.8.2-1.2                | x86_64 | repo-oss              
      | phonon4qt5-backend-vlc             | package    | 0.8.2-1.2                | i586   | repo-oss
    Código:
    X79-PRO:~ # zypper se -si vlc
    Loading repository data...
    Reading installed packages...
    
    S | Name         | Type    | Version     | Arch   | Repository
    --+--------------+---------+-------------+--------+-----------
    i | vlc-noX      | package | 2.1.5-241.1 | x86_64 | packman   
    i | vlc-codecs   | package | 2.1.5-241.1 | x86_64 | packman   
    i | libvlccore7  | package | 2.1.5-241.1 | x86_64 | packman   
    i | vlc-qt       | package | 2.1.5-241.1 | x86_64 | packman   
    i | vlc          | package | 2.1.5-241.1 | x86_64 | packman   
    i | libvlc5      | package | 2.1.5-241.1 | x86_64 | packman   
    i | vlc-noX-lang | package | 2.1.5-241.1 | noarch | packman
    Si hacemos una búsqueda, vemos que vlc se encuentra en packman y en el repositorio de repo-oss, pero para reproducir todo tipo de formatos necesitamos el vlc-codecs y ese solo se encuentra en packman .

    No te sirve de nada instalar el de repo-oss , por que no tienen los codecs, tampoco puede ser compatible porque puede ser distinta versión (de los log que puse donde está situado la S la ( i ) indica los que están instalados , el que no tiene nada es que están disponibles y los que tienen una (v) es que hay una versión superior ) ; de ahí cual elegirías tu ?, pues lógicamente el de packman.

    Que pasa si instalas los codecs, pues te va a decir que no es compatible con el vlc que tengas instalado (si es que lo habías hecho antes de añadir packman) y te dirá lo mas seguro que si quieres vlc-codecs tienes que cambiar vlc de distribuidor o sea a packman (normalmente suele ser la opción 1) .

    Pues eso mismo puede pasar con k3b (y sus codecs) , amarok etc (todos tiene que ser los de packman) .

    Creo que en la wiki de openSUSE, encontrarás amplia información al respeto.
    También hay script o programas que te descargan una serie de programas multimedia (vamos todo tipo de programas que te pudiesen hacer falta, y todo lo hace de packman) , creo que a eso le llaman un pack multimedia (en mi caso no me interesa instalar todos esos programas por que a lo mejor no voy a usar ni la mitad ) .

    Si tu haces un zypper up , y tienes todos los repositorios a 99, te instala las versiones superiores, pero de que te sirve tener una versión superior de repo-oss, si después no puedes reproducir por ejemplo mkv o mov etc (mas vale algo que funcione aunque sea inferior que otro que sea superior y no pueda hacerlo ) .

    Así que lo primero que tienes o podrías hacer es aumentar la prioridad a packman (ponerlo a 70 y no a 99 ) .
    Lo segundo un zypper ref y un zypper up .

    He visto que ha veces que tales programas no se van a instalar (están disponibles por que son versiones superiores) , pero no los instala o bien por que tienes problemas de dependencia o por que la versión que tienes instalada (aunque sea inferior) tiene mas prioridad .

    El que salga que no se instalaran no implica a veces que tengas un fallo si no mas bien es una información que da zypper (por lo que comente anteriormente, que creo que sea esa la causa), lo mismo que instalará paquetes nuevos , o desactualizara otros etc. (en caso de que hubiese un fallo en la actualización zypper lo mostraría, y me supongo que te diría que arregles ese problema o abortaría la actualización ) .

    Saludos cordiales

  6. #6
    Fecha de Ingreso
    08-septiembre-2005
    Ubicación
    ±43º21'N8º22'W
    Mensajes
    1.232
    Post Thanks / Like
    Poder de Credibilidad
    15
    Hay más multimedias, antes tenías este http://download.opensuse.org/reposit...timedia:/libs/ si no sabes porqué lo tenías, es muy probable que no te haga falta, pero también que tengas instalado un programa cuya versión necesite de él. Desde fuera no se puede saber.

    Pon el repositorio de Packman a prioridad 70
    zypper mr -p 70 número_o_nombre_repo-packman
    quita el debug
    zypper rr número_o_nombre_repo-debug
    Si tienes claro que no quieres repos como KDE-Extra ya puedes resetear el sistema con zypper dup: bajarás de versión x paquetes

    Yo no hago eso, prefiero "evolucionar" lo que tengo con zypper up: solo subirán aquellos más modernos y mostrará algunas excepciones que "will NOT installed" Pondré de ejemplo a amarok que teniendo la versión 2.8.0.3-29 en KDE-Extra no lo actualiza porque repo-Packman (2.8.0.3-27) es más prioritario
    Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
    Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

  7. #7
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.210
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por moshpirit Ver Mensaje
    He añadido el repo Pakman desde Yast a través de la URL http://packman.inode.at/suse/openSUSE_Tumbleweed/, después, he actualizado los repositorios (todos con 99 de prioridad), y luego:

    1. zypper up → me sigue listando los programas
    2. zypper dup → 116 packages to upgrade, 74 to downgrade, 23 new, 10 to reinstall, 26 to remove, 137 to change vendor.
    Overall download size: 83,6 MiB. Already cached: 0 B After the operation, additional 787,7 KiB will be used.
    ¿Desea continuar? [s/n/? mostrar todas las opciones] (s): n
    Haz caso a XisEme, no uses zypper dup ni harto de vino, causa muchos estropicios si tienes muchos repos. Lee esta guia mia y sabras porque

    Te asesoraremos mejor si nos das el listado de tus repos que incluya el enlace, usa el comando de abajo y danos su salida.
    zypper lr -u
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  8. #8
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.871
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    Tenia tu guía pero se me olvido de leerla, si no lo recuerdas no caigo en la cuenta.

    El zypper dup , como recomiendo el Zypper Cheat Sheet

    When doing a distribution update, the best is to work only with the repositories of distribution you want to install.
    Creo que mas o menos puede ser esto :

    Cuando se realiza una actualización de la distribución, lo mejor es trabajar sólo con los repositorios de la distribución que desea instalar.

    Aunque pensaba que eran con los repositorios que vienen por defecto, si añade otros , creo que el estropicio puede ser grande; ya lo probé y la verdad se me quitaron las ganas de usar el zypper dup .

    Así que me uno a lo que recomiendan XisEme y D.Rojo.

    Saludos cordiales.

    PD. me he guardado un enlace de la web de los comandos mas peligrosos de linux, creo que este podría ser uno de ellos . "http://blog.desdelinux.net/comandos-peligrosos-en-gnulinux/"

  9. #9
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.210
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por mikrios Ver Mensaje
    Creo que mas o menos puede ser esto :

    Cuando se realiza una actualización de la distribución, lo mejor es trabajar sólo con los repositorios de la distribución que desea instalar.
    El original de esa traducción viene a decir solo lo uses cuando cambies o actualices a una versión superior: eliminas y cambias a los repositorios básicos y zypper dup, ya tienes la nueva versión en tu computadora.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  10. #10
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.871
    Post Thanks / Like
    Poder de Credibilidad
    11
    Hola:

    Gracias cuanto mas claro lo tenga mejor (entiendo que es eliminar los repositorios de la versión instalada, añadir los repositorios de la nueva versión y hacer zypper dup ) .

    Mejor me leo tu tutorial (y aclaro mejor las cosas )

    Saludos cordiales

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. problemas instalación Qt5
    By Juan Nahual in forum Instalación y Actualizaciones
    Respuestas: 6
    Último mensaje: 06-jul-2014, 23:24
  2. Problemas con los plugins de Mupen64plus
    By J_VM in forum Juegos en Linux
    Respuestas: 21
    Último mensaje: 24-mar-2014, 23:04
  3. ¿porque ubuntu es mas popular q suse?
    By goundzchecky in forum El Contubernio
    Respuestas: 161
    Último mensaje: 16-ago-2012, 15:01
  4. Review de openSUSE 11.0 y comparativa con Ubuntu.
    By Dux in forum El Contubernio
    Respuestas: 54
    Último mensaje: 20-feb-2010, 14:30
  5. Guía de Instalación de OpenSuSE 10.3
    By DiabloRojo in forum Instalación y Actualizaciones
    Respuestas: 5
    Último mensaje: 11-feb-2008, 11:41

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •